<!DOCTYPE html>
<html class="no-js mh-one-sb" lang="en-US">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="profile" href="https://gmpg.org/xfn/11" />
<link rel="pingback" href="https://www.mtairynews.com/xmlrpc.php" />
<title>&#8216;It&#8217;s been one heck of a year&#8217; | Mt. Airy News</title>

<!-- The SEO Framework by Sybre Waaijer -->
<meta name="description" content="RANDLEMAN &mdash; East Surry&rsquo;s baseball season came to an end Friday in a fourth-round playoff game against the defending 2A State Champion, Randleman." />
<meta property="og:image" content="https://s24476.pcdn.co/wp-content/uploads/2022/05/128540178_web1_DSC_0089.jpg" />
<meta property="og:image:width" content="640" />
<meta property="og:image:height" content="426" />
<meta property="og:image:alt" content="East Surry catcher Luke Bowman tries to throw a Randleman baserunner out at first.
                                 Cory Smith | The News" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="&#8216;It&#8217;s been one heck of a year&#8217; | Mt. Airy News" />
<meta property="og:description" content="RANDLEMAN &mdash; East Surry&rsquo;s baseball season came to an end Friday in a fourth-round playoff game against the defending 2A State Champion, Randleman." />
<meta property="og:url" content="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year" />
<meta property="og:site_name" content="Mt. Airy News" />
<meta property="og:updated_time" content="2022-05-24T21:58+00:00" />
<meta property="article:publisher" content="https://www.facebook.com/pages/The-Mount-Airy-News/120821418072" />
<meta property="article:published_time" content="2022-05-24T21:58+00:00" />
<meta property="article:modified_time" content="2022-05-24T21:58+00:00" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@mountairynews" />
<meta name="twitter:title" content="&#8216;It&#8217;s been one heck of a year&#8217; | Mt. Airy News" />
<meta name="twitter:description" content="RANDLEMAN &mdash; East Surry&rsquo;s baseball season came to an end Friday in a fourth-round playoff game against the defending 2A State Champion, Randleman." />
<meta name="twitter:image" content="https://s24476.pcdn.co/wp-content/uploads/2022/05/128540178_web1_DSC_0089.jpg" />
<meta name="twitter:image:width" content="640" />
<meta name="twitter:image:height" content="426" />
<meta name="twitter:image:alt" content="East Surry catcher Luke Bowman tries to throw a Randleman baserunner out at first.
                                 Cory Smith | The News" />
<link rel="canonical" href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year" />
<script type="application/ld+json">{"@context":"https://schema.org","@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"item":{"@id":"https://www.mtairynews.com/","name":"Mt. Airy News"}},{"@type":"ListItem","position":2,"item":{"@id":"https://www.mtairynews.com/category/sports","name":"Sports"}},{"@type":"ListItem","position":3,"item":{"@id":"https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year","name":"&#8216;It&#8217;s been one heck of a year&#8217;"}}]}</script>
<!-- / The SEO Framework by Sybre Waaijer | 3.27ms meta | 0.51ms boot -->

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Mt. Airy News &raquo; Feed" href="https://www.mtairynews.com/feed" />
<link rel="alternate" type="application/rss+xml" title="Mt. Airy News &raquo; Comments Feed" href="https://www.mtairynews.com/comments/feed" />
<link rel="alternate" type="application/rss+xml" title="Mt. Airy News &raquo; &#8216;It&#8217;s been one heck of a year&#8217; Comments Feed" href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/feed" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/s24476.pcdn.co\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3.12"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://s24476.pcdn.co/wp-includes/css/dist/block-library/style.min.css?ver=5.3.12' type='text/css' media='all' />
<link rel='stylesheet' id='simple-staff-list-css'  href='https://s24476.pcdn.co/wp-content/plugins/simple-staff-list/public/css/simple-staff-list-public.css?ver=2.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='staff-list-custom-css-css'  href='https://s24476.pcdn.co/wp-content/themes/mh-magazine/simple-staff-list-custom.css?ver=5.3.12' type='text/css' media='all' />
<link rel='stylesheet' id='vfb-pro-css'  href='https://s24476.pcdn.co/wp-content/plugins/vfb-pro/public/assets/css/vfb-style.min.css?ver=2019.05.10' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://s24476.pcdn.co/wp-includes/css/dashicons.min.css?ver=5.3.12' type='text/css' media='all' />
<link rel='stylesheet' id='mh-magazine-css'  href='https://s24476.pcdn.co/wp-content/themes/mh-magazine/style.css?ver=3.8.3' type='text/css' media='all' />
<link rel='stylesheet' id='mh-font-awesome-css'  href='https://s24476.pcdn.co/wp-content/themes/mh-magazine/includes/font-awesome.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='mh-google-fonts-css'  href='https://fonts.googleapis.com/css?family=PT+Sans:300,400,400italic,600,700%7cMerriweather:300,400,400italic,600,700' type='text/css' media='all' />
<script type='text/javascript' src='https://s24476.pcdn.co/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://s24476.pcdn.co/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://s24476.pcdn.co/wp-content/themes/mh-magazine/js/scripts.js?ver=3.8.3'></script>
<link rel='https://api.w.org/' href='https://www.mtairynews.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.mtairynews.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://s24476.pcdn.co/wp-includes/wlwmanifest.xml" /> 
<link rel="alternate" type="application/json+oembed" href="https://www.mtairynews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.mtairynews.com%2Fsports%2F110096%2Fits-been-one-heck-of-a-year" />
<link rel="alternate" type="text/xml+oembed" href="https://www.mtairynews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.mtairynews.com%2Fsports%2F110096%2Fits-been-one-heck-of-a-year&#038;format=xml" />
<style type="text/css">
.mh-header { background: #022452; }
.mh-widget-layout4 .mh-widget-title { background: #022452; background: rgba(2, 36, 82, 0.6); }
.mh-preheader, .mh-wide-layout .mh-subheader, .mh-ticker-title, .mh-main-nav li:hover, .mh-footer-nav, .slicknav_menu, .slicknav_btn, .slicknav_nav .slicknav_item:hover, .slicknav_nav a:hover, .mh-back-to-top, .mh-subheading, .entry-tags .fa, .entry-tags li:hover, .mh-widget-layout2 .mh-widget-title, .mh-widget-layout4 .mh-widget-title-inner, .mh-widget-layout4 .mh-footer-widget-title, .mh-widget-layout5 .mh-widget-title-inner, .mh-widget-layout6 .mh-widget-title, #mh-mobile .flex-control-paging li a.flex-active, .mh-image-caption, .mh-carousel-layout1 .mh-carousel-caption, .mh-tab-button.active, .mh-tab-button.active:hover, .mh-footer-widget .mh-tab-button.active, .mh-social-widget li:hover a, .mh-footer-widget .mh-social-widget li a, .mh-footer-widget .mh-author-bio-widget, .tagcloud a:hover, .mh-widget .tagcloud a:hover, .mh-footer-widget .tagcloud a:hover, .mh-posts-stacked-item .mh-meta, .page-numbers:hover, .mh-loop-pagination .current, .mh-comments-pagination .current, .pagelink, a:hover .pagelink, input[type=submit], #infinite-handle span { background: #022452; }
.mh-main-nav-wrap .slicknav_nav ul, blockquote, .mh-widget-layout1 .mh-widget-title, .mh-widget-layout3 .mh-widget-title, .mh-widget-layout5 .mh-widget-title, .mh-widget-layout8 .mh-widget-title:after, #mh-mobile .mh-slider-caption, .mh-carousel-layout1, .mh-spotlight-widget, .mh-author-bio-widget, .mh-author-bio-title, .mh-author-bio-image-frame, .mh-video-widget, .mh-tab-buttons, textarea:hover, input[type=text]:hover, input[type=email]:hover, input[type=tel]:hover, input[type=url]:hover { border-color: #022452; }
.mh-dropcap, .mh-carousel-layout1 .flex-direction-nav a, .mh-carousel-layout2 .mh-carousel-caption, .mh-posts-digest-small-category, .mh-posts-lineup-more, .bypostauthor .fn:after, .mh-comment-list .comment-reply-link:before, #respond #cancel-comment-reply-link:before { color: #022452; }
</style>
<!--[if lt IE 9]>
<script src="https://s24476.pcdn.co/wp-content/themes/mh-magazine/js/css3-mediaqueries.js"></script>
<![endif]-->
<style type="text/css">
h1, h2, h3, h4, h5, h6, .mh-custom-posts-small-title { font-family: "Merriweather", serif; }
body { font-family: "PT Sans", sans-serif; }
</style>
<style type="text/css" id="custom-background-css">
body.custom-background { background-color: #e0e0e0; }
</style>
	<link rel="icon" href="https://s24476.pcdn.co/wp-content/uploads/2018/09/cropped-unnamed-32x32.png" sizes="32x32" />
<link rel="icon" href="https://s24476.pcdn.co/wp-content/uploads/2018/09/cropped-unnamed-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://s24476.pcdn.co/wp-content/uploads/2018/09/cropped-unnamed-180x180.png" />
<meta name="msapplication-TileImage" content="https://s24476.pcdn.co/wp-content/uploads/2018/09/cropped-unnamed-270x270.png" />
		<style type="text/css" id="wp-custom-css">
			.mh-widget-title {
	background-color: #022452 !important;
}

.mh-header-nav li a {
    padding: 0 19px !important;
}

.attachment-mh-magazine-slider{
height: 300px !important;
width: auto !important;
}
.metaInfo{
	display:none;
}

.class1 img {
	display: block;
	margin: auto;
	float: none !important;
}

@media screen and (min-width: 1125px) {

.mh-col-1-3 {
    width: 27% !important;
}

.mh-col-2-3 {
    width: 70% !important;
}

}

@media screen and (max-width: 1124px) {

.mh-col-1-3 {
    width: 30%;
		min-width: 300px;
		margin: auto !important;
		float: none;
}

.mh-col-2-3 {
    width: 100%;
		margin: auto !important;
}

}

.mh-googleplus{
	display:none;
}
.mh-posts-large-thumb{
	background-color:black;
}
.mh-posts-large-thumb img{
	width:auto !important;
}
.mh-main-nav li a {
    padding: 10px 18px;
}

.google-auto-placed {
	display: none;
}
		</style>
		<style type="text/css"></style>
<script async="async" src="//zdwidget3-bs.sphereup.com/zoomd/SearchUi/Script?clientId=05916537"></script>
</head>
<body data-rsssl=1 id="mh-mobile" class="post-template-default single single-post postid-110096 single-format-standard custom-background wp-custom-logo mh-boxed-layout mh-right-sb mh-loop-layout1 mh-widget-layout5" itemscope="itemscope" itemtype="http://schema.org/WebPage">
<aside class="mh-container mh-header-widget-1">
<div id="custom_html-11" class="widget_text mh-widget mh-header-1 widget_custom_html"><div class="textwidget custom-html-widget"><script> (function(){var l=function(){if (document.readyState && /loading/.test(document.readyState)){return setTimeout(l, 10);} if (!top._liqwid_loaded){top._liqwid_loaded=true; return setTimeout(l, 10);} var s=document.createElement("script"), x=top.document.getElementsByTagName('script')[0]; s.setAttribute('async', 'true'); s.setAttribute('src','https://liqwid.net/?key=2B69-A3AA-AFFC-D516&u='+encodeURIComponent(top.location.href)+'&d='+Date.now()+'&v='+('; '+document.cookie).split('; liqwid=').pop().split(';').shift()); x.parentNode.insertBefore(s,x);};l();})(); </script></div></div></aside>
<div class="mh-container mh-container-outer">
<div class="mh-header-nav-mobile clearfix"></div>
	<div class="mh-preheader">
    	<div class="mh-container mh-container-inner mh-row clearfix">
							<div class="mh-header-bar-content mh-header-bar-top-left mh-col-2-3 clearfix">
											<nav class="mh-navigation mh-header-nav mh-header-nav-top clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
							<div class="menu-header-menu-container"><ul id="menu-header-menu" class="menu"><li id="menu-item-65282" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-65282"><a href="http://yourjobmatchnc.thejobnetwork.com/">Jobs</a></li>
<li id="menu-item-65270" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-65270"><a href="https://www.mtairynews.com/e-edition">E-Edition</a></li>
<li id="menu-item-65271" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-65271"><a href="https://www.mtairynews.com/classifieds">Classifieds</a></li>
<li id="menu-item-91817" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-91817"><a href="https://apg01.newzware.com/ss70v2/adams/common/template.jsp?init=start">Subscribe</a>
<ul class="sub-menu">
	<li id="menu-item-91819" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-91819"><a href="https://apg01.newzware.com/ss70v2/adams/common/template.jsp">Manage My Subscription</a></li>
</ul>
</li>
<li id="menu-item-65273" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-65273"><a href="https://www.mtairynews.com/sign-up-for-notices">Sign Up For Notices</a></li>
<li id="menu-item-65285" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-65285"><a href="https://play.google.com/store/apps/details?id=com.vervewireless.droid.mtairynews&#038;hl=en">Android App</a></li>
<li id="menu-item-65286" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-65286"><a href="https://itunes.apple.com/us/app/the-mount-airy-news/id1378553829?ls=1&#038;mt=8">iOS App</a></li>
</ul></div>						</nav>
									</div>
										<div class="mh-header-bar-content mh-header-bar-top-right mh-col-1-3 clearfix">
											<nav class="mh-social-icons mh-social-nav mh-social-nav-top clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
							<div class="menu-social-container"><ul id="menu-social" class="menu"><li id="menu-item-65280" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-65280"><a href="https://www.facebook.com/pages/The-Mount-Airy-News/120821418072"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Facebook</span></a></li>
<li id="menu-item-65281" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-65281"><a href="https://twitter.com/mountairynews"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Twitter</span></a></li>
</ul></div>						</nav>
									</div>
					</div>
	</div>
<header class="mh-header" itemscope="itemscope" itemtype="http://schema.org/WPHeader">
	<div class="mh-container mh-container-inner clearfix">
		<div class="mh-custom-header clearfix">
<div class="mh-header-columns mh-row clearfix">
<div class="mh-col-1-3 mh-site-identity">
<div class="mh-site-logo" role="banner" itemscope="itemscope" itemtype="http://schema.org/Brand">
<a href="https://www.mtairynews.com/" class="custom-logo-link" rel="home"><img width="374" height="36" src="https://s24476.pcdn.co/wp-content/uploads/2018/09/cropped-mtairynews.png" class="custom-logo" alt="Mt. Airy News" srcset="https://s24476.pcdn.co/wp-content/uploads/2018/09/cropped-mtairynews.png 374w, https://s24476.pcdn.co/wp-content/uploads/2018/09/cropped-mtairynews-300x29.png 300w" sizes="(max-width: 374px) 100vw, 374px" /></a></div>
</div>
<aside class="mh-col-2-3 mh-header-widget-2">
<div id="custom_html-10" class="widget_text mh-widget mh-header-2 widget_custom_html"><div class="textwidget custom-html-widget"><!---<ins data-revive-zoneid="5" data-revive-id="7704ed944ed7863d36a61d5fccf7693e"></ins><script src="//adamsads.midtc.com/www/delivery/asyncjs.php"></script>--->
</div></div></aside>
</div>
</div>
	</div>
	<div class="mh-main-nav-wrap">
		<nav class="mh-navigation mh-main-nav mh-container mh-container-inner clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
			<div class="menu-main-menu-container"><ul id="menu-main-menu" class="menu"><li id="menu-item-37973" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-has-children menu-item-37973"><a href="https://www.mtairynews.com">Home</a>
<ul class="sub-menu">
	<li id="menu-item-38363" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38363"><a href="https://www.mtairynews.com/contact-us">Contact Us</a></li>
	<li id="menu-item-38364" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38364"><a href="https://www.mtairynews.com/about-us">About Us</a></li>
	<li id="menu-item-38368" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38368"><a href="https://www.mtairynews.com/advertise">Advertise</a></li>
	<li id="menu-item-38412" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38412"><a href="http://www.facebook.com/pages/The-Mount-Airy-News/120821418072">Mount Airy News on Facebook</a></li>
	<li id="menu-item-40794" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-40794"><a href="https://twitter.com/mountairynews">Mount Airy News on Twitter</a></li>
	<li id="menu-item-38414" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38414"><a href="https://www.mtairynews.com/sign-up-for-notices">Sign Up For Notices</a></li>
	<li id="menu-item-91816" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-91816"><a href="https://apg01.newzware.com/ss70v2/adams/common/template.jsp?init=start">Subscribe</a></li>
	<li id="menu-item-91820" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-91820"><a href="https://apg01.newzware.com/ss70v2/adams/common/template.jsp">Manage My Subscription</a></li>
	<li id="menu-item-77699" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-77699"><a href="https://www.mtairynews.com/terms-of-use">Terms Of Use</a></li>
</ul>
</li>
<li id="menu-item-37963" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-37963"><a href="https://www.mtairynews.com/category/news">News</a>
<ul class="sub-menu">
	<li id="menu-item-100016" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-100016"><a href="https://mtairynews.newsbank.com">Archive</a></li>
	<li id="menu-item-56100" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56100"><a href="https://www.mtairynews.com/category/special-sections">Special Sections</a></li>
	<li id="menu-item-38371" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38371"><a href="https://www.mtairynews.com/online-community">Online Community</a></li>
	<li id="menu-item-38375" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38375"><a href="https://www.mtairynews.com/formnewstip">Submit News Tip</a></li>
	<li id="menu-item-38376" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38376"><a href="https://www.mtairynews.com/onlineforms">Online Forms</a></li>
	<li id="menu-item-38416" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38416"><a href="https://www.mtairynews.com/feed">All Articles Feed</a></li>
</ul>
</li>
<li id="menu-item-37965" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-37965"><a href="https://www.mtairynews.com/category/sports">Sports</a>
<ul class="sub-menu">
	<li id="menu-item-38377" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38377"><a href="https://www.mtairynews.com/formscores">Submit Scores</a></li>
	<li id="menu-item-38378" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38378"><a href="https://www.mtairynews.com/formsportsnews">Submit Sports News</a></li>
	<li id="menu-item-43456" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43456"><a href="http://pro32.ap.org/mtairynews">Pro32</a></li>
	<li id="menu-item-43458" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43458"><a href="http://racing.ap.org/mtairynews">Auto Racing</a></li>
	<li id="menu-item-43459" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43459"><a href="http://collegebasketball.ap.org/mtairynews">College Basketball</a></li>
	<li id="menu-item-43460" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43460"><a href="http://collegefootball.ap.org/mtairynews">College Football</a></li>
</ul>
</li>
<li id="menu-item-37967" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-37967"><a href="http://www.legacy.com/obituaries/mtairynews">Obituaries</a></li>
<li id="menu-item-37964" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-37964"><a href="https://www.mtairynews.com/category/opinion">Opinion</a>
<ul class="sub-menu">
	<li id="menu-item-38379" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38379"><a href="https://www.mtairynews.com/formeditor">Send A Letter To The Editor</a></li>
</ul>
</li>
<li id="menu-item-37966" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-37966"><a href="https://www.mtairynews.com/category/features">Features</a>
<ul class="sub-menu">
	<li id="menu-item-38380" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38380"><a href="https://www.mtairynews.com/contests">Contests</a></li>
	<li id="menu-item-38382" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38382"><a href="https://www.mtairynews.com/comics">Comics</a></li>
	<li id="menu-item-38383" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38383"><a href="https://www.mtairynews.com/horoscopes">Horoscopes</a></li>
	<li id="menu-item-63246" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-63246"><a href="https://www.mtairynews.com/category/special-sections">Special Sections</a></li>
	<li id="menu-item-38385" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38385"><a href="https://www.mtairynews.com/formanniversary">Submit Anniversary</a></li>
	<li id="menu-item-38386" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38386"><a href="https://www.mtairynews.com/formbirth">Submit Birth</a></li>
	<li id="menu-item-38387" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38387"><a href="https://www.mtairynews.com/formbirthday">Submit Birthday</a></li>
	<li id="menu-item-38388" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38388"><a href="https://www.mtairynews.com/formengagement">Submit Engagement</a></li>
	<li id="menu-item-38389" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38389"><a href="https://www.mtairynews.com/formwedding">Submit Wedding</a></li>
</ul>
</li>
<li id="menu-item-37969" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-37969"><a href="https://www.mtairynews.com/entertainment">TV/Games</a>
<ul class="sub-menu">
	<li id="menu-item-82825" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-82825"><a href="https://www.mtairynews.com/games">Games</a></li>
	<li id="menu-item-38434" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38434"><a href="https://www.mtairynews.com/tvsoaps">Soaps</a></li>
	<li id="menu-item-39181" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-39181"><a href="https://www.mtairynews.com/tvbestbets">TV Best Bets</a></li>
	<li id="menu-item-38390" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38390"><a href="https://www.mtairynews.com/tvbestbets">TV Best Bets</a></li>
	<li id="menu-item-38436" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38436"><a href="https://www.mtairynews.com/tvmovies">Movies</a></li>
	<li id="menu-item-38391" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38391"><a href="https://www.mtairynews.com/tvlistings">TV Listings</a></li>
	<li id="menu-item-38392" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38392"><a href="https://www.mtairynews.com/tvnews">TV News</a></li>
	<li id="menu-item-38433" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38433"><a href="https://www.mtairynews.com/tvqa">Q &#038; A</a></li>
	<li id="menu-item-38437" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38437"><a href="https://www.mtairynews.com/tvnews">TV News</a></li>
	<li id="menu-item-38393" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38393"><a href="https://www.mtairynews.com/tvsearch">TV Search</a></li>
	<li id="menu-item-38394" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38394"><a href="https://www.mtairynews.com/tvsports">TV Sports</a></li>
	<li id="menu-item-38395" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38395"><a href="https://www.mtairynews.com/tvtalk">TV Talk</a></li>
	<li id="menu-item-38396" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38396"><a href="https://www.mtairynews.com/tvvideo">TV Video</a></li>
</ul>
</li>
<li id="menu-item-99553" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-99553"><a href="https://www.mtairynews.com/local-events">Events</a></li>
<li id="menu-item-39252" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-39252"><a href="http://shoplocal.yadkinvalley.com/mtairynews/">Shop Local</a>
<ul class="sub-menu">
	<li id="menu-item-86887" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-86887"><a href="https://shoplocal.yadkinvalley.com/mtairynews/">Local Businesses</a></li>
</ul>
</li>
<li id="menu-item-64582" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-64582"><a href="http://www.ncpress.com/ncnotices/">Public Notices</a></li>
<li id="menu-item-88298" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-88298"><a href="https://site1.midtcweb.com/flipcore/mountairy/MOU052522final/">Wednesday/Friday</a></li>
</ul></div>		</nav>
	</div>
	</header>
	<div class="mh-subheader">
		<div class="mh-container mh-container-inner mh-row clearfix">
							<div class="mh-header-bar-content mh-header-bar-bottom-left mh-col-2-3 clearfix">
											<div class="mh-header-date mh-header-date-bottom">
							May 24, 2022						</div>
									</div>
										<div class="mh-header-bar-content mh-header-bar-bottom-right mh-col-1-3 clearfix">
											<aside zoomdSearch='{"trigger":"OnClick"}' class="mh-header-search mh-header-search-bottom">
							<form role="search" method="get" class="search-form" action="https://www.mtairynews.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form>						</aside>
									</div>
					</div>
	</div>
<div class="mh-wrapper clearfix">
	<div class="mh-main clearfix">
		<div id="main-content" class="mh-content" role="main" itemprop="mainContentOfPage"><nav class="mh-breadcrumb"><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a href="https://www.mtairynews.com" itemprop="url"><span itemprop="title">Home</span></a></span><span class="mh-breadcrumb-delimiter"><i class="fa fa-angle-right"></i></span><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a href="https://www.mtairynews.com/category/sports" itemprop="url"><span itemprop="title">Sports</span></a></span><span class="mh-breadcrumb-delimiter"><i class="fa fa-angle-right"></i></span>&#8216;It&#8217;s been one heck of a year&#8217;</nav>


<script type="application/ld+json">
{
  "@context": "http://schema.org",
  "@type": "NewsArticle",
  "mainEntityOfPage": {
    "@type": "WebPage",
    "@id": "https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year"
  },
  "headline": "&#8216;It&#8217;s been one heck of a year&#8217;",
        "image": "https://s24476.pcdn.co/wp-content/uploads/2022/05/128540178_web1_DSC_0089.jpg",
     "datePublished": "2022-05-24T17:58:00-04:00",
  "dateModified": "2022-05-24T17:58:00-04:00",
  "author": {
    "@type": "Person",
	    "name": "By Cory Smith csmith@mtairynews.com"
	  },
   "publisher": {
    "@type": "Organization",
    "name": "Mt. Airy News",
    "logo": {
      "@type": "ImageObject",
      "url": "https://s24476.pcdn.co/wp-content/uploads/2015/07/mtairynews.png"
    }
  },
  "description": "
				RANDLEMAN &mdash; East Surry&rsquo;s baseball season came to an end Friday in a fourth-round playoff game against the defending 2A State Champion, Randleman.
			 [...]"
}
</script>
<style>
.neFileBlock{
	display:none;
}
.metaInfo{
	display:none;
}
.entry-thumbnail img {
width: auto !important;
max-height: 400px;
}
.factbox{ 
	float:left; 
	width:190px; 
	margin:7px; 
	background-color:#f5f5f5; 
	padding:5px; 
	box-shadow: 0 10px 16px 0 rgba(0,0,0,0.2),0 6px 20px 0 rgba(0,0,0,0.19);
}
.map{ 
	float:left; 
	width:200px; 
	margin:7px; 
}
.kicker{
	font-style:italic;
}
.pullquote {
    float: left;
    width: 190px;
    background: #f5f5f5;
    font-weight: bold;
    padding: 5px;
    margin: 0 5px 5px 0;
	font-size:18px;
}
.extraBox{
	float:left; 
	width:200px;  
	margin-right:20px;
}
.breakout{
border-radius: 25px;
  border: 2px solid #c00c00;
  padding: 20px;
}

</style>
<article id="post-110096" class="post-110096 post type-post status-publish format-standard has-post-thumbnail hentry category-sports">
		<header class="entry-header clearfix"><h1 class="entry-title">&#8216;It&#8217;s been one heck of a year&#8217;</h1><div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.mtairynews.com/date/2022/05">May 24, 2022</a></span>
<span class="entry-meta-author author vcard"><i class="fa fa-user"></i><a class="fn" href="https://www.mtairynews.com/author/csmith">Cory Smith</a></span>
<span class="entry-meta-categories"><i class="fa fa-folder-open-o"></i><a href="https://www.mtairynews.com/category/sports" rel="category tag">Sports</a></span>
<span class="entry-meta-comments"><i class="fa fa-comment-o"></i><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year#respond" class="mh-comment-count-link" ><span class="dsq-postid" data-dsqidentifier="110096 https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year">0</span></a></span>
</div>
				<h4 class="subhead"> <p>Cards fall to defending champs in fourth round</p></h4>
				
				<div id="byline" style="margin-left: 5px; margin-top: 5px;"><b> By Cory Smith csmith@mtairynews.com</b></div>
			</header>
		<div class="entry-content clearfix">
																						<figure class="entry-thumbnail">
			<img src="https://s24476.pcdn.co/wp-content/uploads/2022/05/128540178_web1_DSC_0089.jpg">
			<figcaption class="wp-caption-text"><p>East Surry catcher Luke Bowman tries to throw a Randleman baserunner out at first.</p>
                                 <p>Cory Smith | The News</p></figcaption>		</figure>
			
		<div class="mh-social-top">
<div class="mh-share-buttons clearfix">
	<a class="mh-facebook" href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.mtairynews.com%2Fsports%2F110096%2Fits-been-one-heck-of-a-year&t=%E2%80%98It%E2%80%99s+been+one+heck+of+a+year%E2%80%99', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
		<span class="mh-share-button"><i class="fa fa-facebook"></i></span>
	</a>
	<a class="mh-twitter" href="#" onclick="window.open('https://twitter.com/share?text=%E2%80%98It%E2%80%99s+been+one+heck+of+a+year%E2%80%99:&url=https%3A%2F%2Fwww.mtairynews.com%2Fsports%2F110096%2Fits-been-one-heck-of-a-year', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
		<span class="mh-share-button"><i class="fa fa-twitter"></i></span>
	</a>
	<a class="mh-pinterest" href="#" onclick="window.open('https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.mtairynews.com%2Fsports%2F110096%2Fits-been-one-heck-of-a-year&media=https://www.mtairynews.com/wp-content/uploads/2022/05/128540178_web1_DSC_0089.jpg&description=%E2%80%98It%E2%80%99s+been+one+heck+of+a+year%E2%80%99', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
		<span class="mh-share-button"><i class="fa fa-pinterest"></i></span>
	</a>
	<a class="mh-googleplus" href="#" onclick="window.open('https://plusone.google.com/_/+1/confirm?hl=en-US&url=https%3A%2F%2Fwww.mtairynews.com%2Fsports%2F110096%2Fits-been-one-heck-of-a-year', 'googleShare', 'width=626,height=436'); return false;" title="Share on Google+" target="_blank">
		<span class="mh-share-button"><i class="fa fa-google-plus"></i></span>
	</a>
	<a class="mh-email" href="mailto:?subject=%E2%80%98It%E2%80%99s%20been%20one%20heck%20of%20a%20year%E2%80%99&amp;body=https%3A%2F%2Fwww.mtairynews.com%2Fsports%2F110096%2Fits-been-one-heck-of-a-year" title="Send this article to a friend" target="_blank">
		<span class="mh-share-button"><i class="fa fa-envelope-o"></i></span>
	</a>
</div></div>
																		
																						<div class="extraBox">
											<a href="#" onclick="window.open('https://s24476.pcdn.co/wp-content/uploads/2022/05/128540178_web1_DSC_0062.jpg','Photo','width=600,height=400')"><img src="https://s24476.pcdn.co/wp-content/uploads/2022/05/128540178_web1_DSC_0062.jpg" alt="<p>Cardinal Luke Brown releases a pitch during the second inning of Friday&rsquo;s playoff game at Randleman.</p>
                                 <p>Cory Smith | The News</p>" style="float:left; width:200px; margin-top:3px; margin-bottom:3px"></a>
				<p>Cardinal Luke Brown releases a pitch during the second inning of Friday&rsquo;s playoff game at Randleman.</p>
                                 <p>Cory Smith | The News</p>								<a href="#" onclick="window.open('https://s24476.pcdn.co/wp-content/uploads/2022/05/128540178_web1_DSC_0152.jpg','Photo','width=600,height=400')"><img src="https://s24476.pcdn.co/wp-content/uploads/2022/05/128540178_web1_DSC_0152.jpg" alt="<p>East Surry&rsquo;s Trey Armstrong attempts to throw a Randleman player out at first base.</p>
                                 <p>Cory Smith | The News</p>" style="float:left; width:200px; margin-top:3px; margin-bottom:3px"></a>
				<p>East Surry&rsquo;s Trey Armstrong attempts to throw a Randleman player out at first base.</p>
                                 <p>Cory Smith | The News</p>								<a href="#" onclick="window.open('https://s24476.pcdn.co/wp-content/uploads/2022/05/128540178_web1_DSC_0246.jpg','Photo','width=600,height=400')"><img src="https://s24476.pcdn.co/wp-content/uploads/2022/05/128540178_web1_DSC_0246.jpg" alt="<p>Cardinal first baseman Folger Boaz lines up to catch a fly ball in foul territory.</p>
                                 <p>Cory Smith | The News</p>" style="float:left; width:200px; margin-top:3px; margin-bottom:3px"></a>
				<p>Cardinal first baseman Folger Boaz lines up to catch a fly ball in foul territory.</p>
                                 <p>Cory Smith | The News</p>								<a href="#" onclick="window.open('https://s24476.pcdn.co/wp-content/uploads/2022/05/128540178_web1_DSC_0436.jpg','Photo','width=600,height=400')"><img src="https://s24476.pcdn.co/wp-content/uploads/2022/05/128540178_web1_DSC_0436.jpg" alt="<p>East Surry&rsquo;s Anthony Ayers rotates 180 degrees to try and catch a Randleman player cheating off second base.</p>
                                 <p>Cory Smith | The News</p>" style="float:left; width:200px; margin-top:3px; margin-bottom:3px"></a>
				<p>East Surry&rsquo;s Anthony Ayers rotates 180 degrees to try and catch a Randleman player cheating off second base.</p>
                                 <p>Cory Smith | The News</p>								<a href="#" onclick="window.open('https://s24476.pcdn.co/wp-content/uploads/2022/05/128540178_web1_DSC_0200.jpg','Photo','width=600,height=400')"><img src="https://s24476.pcdn.co/wp-content/uploads/2022/05/128540178_web1_DSC_0200.jpg" alt="<p>East Surry&rsquo;s Tristen Mason swings at a Randleman pitch during Friday&rsquo;s West Regional Semifinal game.</p>
                                 <p>Cory Smith | The News</p>" style="float:left; width:200px; margin-top:3px; margin-bottom:3px"></a>
				<p>East Surry&rsquo;s Tristen Mason swings at a Randleman pitch during Friday&rsquo;s West Regional Semifinal game.</p>
                                 <p>Cory Smith | The News</p>																	</div>
										<p>RANDLEMAN &mdash; East Surry&rsquo;s baseball season came to an end Friday in a fourth-round playoff game against the defending 2A State Champion, Randleman.</p>
<p>The Cardinals were held to just two hits in their first true playoff road game in six years, while the home Tigers had 10 hits &#8211; including a trio of home runs. East couldn&rsquo;t convert when it chances to put runs on the board, and Randleman made the Cards pay for any mistakes.</p>
<p>Randleman advances to the Regional Championship for the third-straight postseason with a 10-0 win.</p>
<p>&ldquo;I told the kids that we had to play just about a perfect game to have a chance. We didn&rsquo;t, and they made us pay,&rdquo; said East Surry coach Chad Freeman. &ldquo;You tip your hat because they are the better team. There&rsquo;s nothing else you can say about it really.&rdquo;</p>
<p>Friday&rsquo;s game marked East Surry&rsquo;s fourth-consecutive appearance in the fourth round of the state playoffs, which is the second-longest active streak in the state among all classifications. The only team with more consecutive fourth-round appearances is Randleman, who competed in its 11th-straight in 2022. Since 2011, the Tigers have won two 2A State Titles and finished 2A State Runner-up three times.</p>
<p>&ldquo;They&rsquo;re so good and just relentless,&rdquo; Freeman said. &ldquo;One through nine, every single kid that they&rsquo;ve got in the lineup takes great approaches and they don&rsquo;t get fooled very often at the plate.&rdquo;</p>
<p>Luke Brown and Anthony Ayers served as the Cards&rsquo; two pitchers against the Tigers (29-1). Brown faced 25 batters in 3.2 innings on the mound, allowing nine runs &#8211; including four earned runs &#8211; on eight hits, with five strikeouts and three walks. Ayers faced three batters to close the fourth inning and open the fifth, allowing one run on two hits.</p>
<p>&ldquo;The score won&rsquo;t show it, but Luke didn&rsquo;t throw a bad game,&rdquo; Freeman said, referencing costly fielding errors by the Cardinals that contributed to the five unearned runs. Freeman also mentioned the shallow outfield fence on the lines of Joe Brookshire field.</p>
<p>&ldquo;With those first two home runs that put them up 4-0&#8230;I mean, they hit them well, but if we&rsquo;re at our field or many other fields it&rsquo;s at most a 1-0 lead,&rdquo; Freeman said. [Luke] pitched well, it&rsquo;s just that playing in this environment, at this field against this team was a different animal. They&rsquo;re defending state champs for a reason, and they&rsquo;re going to win states again.&rdquo;</p>
<p>East Surry (24-2) put runners on base in the first, third and fifth innings. Leadoff Luke Bowman singled to start the game and was sacrificed over to second base, but was left on after a strikeout and a flyout.</p>
<p>In the third inning, Trey Armstrong was hit by a pitch and Folger Boaz rocked a double to move Armstrong to third with no outs. The Tigers met at the mound to regroup and it worked, as pitcher Drake Purvis struck the next three batters out.</p>
<p>Purvis, a sophomore left-handed pitcher committed to N.C. State, finished with nine strikeouts in five innings.</p>
<p>&ldquo;Gotta give credit to Purvis,&rdquo; Freeman said. &ldquo;He buckled down when runners got on base, and we didn&rsquo;t do what we needed to and execute in good situational approaches. That&rsquo;s the difference between being in a game and still having a shot, to getting beat 10-0.&rdquo;</p>
<p>Another Cardinal, Brett Clayton, was hit by a pitch in the fifth inning with one out. Randleman forced a double play to end the inning by catching a fly ball and getting the out at first.</p>
<p>East Surry finishes the year 24-2, and Freeman said the players have a lot to be proud of looking back on the season.</p>
<p>&ldquo;The feeling right now stinks because you&rsquo;re coming off of a loss, but I told the guys after the game not to let this game diminish what all we accomplished this season,&rdquo; Freeman said. &ldquo;I told them: &lsquo;you bumped up to a new classification even though we&rsquo;re still 1A size. We went 24-2. We made it to the fourth round against the defending 2A State Champions. It&rsquo;s been one heck of a year.&rsquo;</p>
<p>&ldquo;I&rsquo;m so thankful for the kids that I&rsquo;ve got. They&rsquo;re wonderful young men, competitive players and most importantly they&rsquo;re good people. That makes it even easier and even better as a coach when you&rsquo;ve got players that will play hard and love each other. It was a special season with a special group, and I wouldn&rsquo;t trade it for anything.&rdquo;</p>
<p>East Surry had to come ready to play night in and night out, Freeman said, and added that was what pushed the team to get even better. He spoke of the &ldquo;tremendous talent&rdquo; in and around Surry County, and said it was evident by the close games the Cardinals had against the likes of North Surry, Forbush, Surry Central and West Stokes.</p>
<p>Following Friday&rsquo;s game, Freeman gave a final salute to the Cardinal seniors: Bowman, Ayers, Armstrong, Peyton Inscore, Tristen Mason and Anthony Ward.</p>
<p>&ldquo;You look back and these kids were sophomores when COVID hit, and several of them would&rsquo;ve been part of a big run with that strong group that never got to play their senior season,&rdquo; he said. &ldquo;They took us on an amazing journey last year to a state championship appearance and played two tight games in the state finals.</p>
<p>&ldquo;Then, they took us to a 24-2 season this year with a conference championship, a conference tournament championship and a fourth-round appearance &#8211; again, all while we are still pretty dang small and going against some pretty big and very good 2A teams. It&rsquo;s a great group of kids, and I&rsquo;m blessed to be their coach.</p>
<p>No. 1 Randleman faces No. 15 Community School of Davidson (17-6) in the West Regional Championship. The winner of the best 2-of-3 series in the West advances to the 2A State Championship Series to face the winner of the East&rsquo;s No. 4 Whiteville (21-3) and No. 15 North Lenoir (19-8).</p>
<p>Scoring</p>
<p>East Surry &#8211; 0, 0, 0, 0, 0, X, X = 0</p>
<p>Randleman &#8211; 0, 4, 2, 3, 1, X, X = 10</p>
<p><em>Reach Cory on Twitter @MaNewsSports</em></p>
										<em><p>Reach Cory on Twitter @MaNewsSports</p></em>
				<div class="mh-social-bottom">
<div class="mh-share-buttons clearfix">
	<a class="mh-facebook" href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.mtairynews.com%2Fsports%2F110096%2Fits-been-one-heck-of-a-year&t=%E2%80%98It%E2%80%99s+been+one+heck+of+a+year%E2%80%99', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
		<span class="mh-share-button"><i class="fa fa-facebook"></i></span>
	</a>
	<a class="mh-twitter" href="#" onclick="window.open('https://twitter.com/share?text=%E2%80%98It%E2%80%99s+been+one+heck+of+a+year%E2%80%99:&url=https%3A%2F%2Fwww.mtairynews.com%2Fsports%2F110096%2Fits-been-one-heck-of-a-year', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
		<span class="mh-share-button"><i class="fa fa-twitter"></i></span>
	</a>
	<a class="mh-pinterest" href="#" onclick="window.open('https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.mtairynews.com%2Fsports%2F110096%2Fits-been-one-heck-of-a-year&media=https://www.mtairynews.com/wp-content/uploads/2022/05/128540178_web1_DSC_0089.jpg&description=%E2%80%98It%E2%80%99s+been+one+heck+of+a+year%E2%80%99', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
		<span class="mh-share-button"><i class="fa fa-pinterest"></i></span>
	</a>
	<a class="mh-googleplus" href="#" onclick="window.open('https://plusone.google.com/_/+1/confirm?hl=en-US&url=https%3A%2F%2Fwww.mtairynews.com%2Fsports%2F110096%2Fits-been-one-heck-of-a-year', 'googleShare', 'width=626,height=436'); return false;" title="Share on Google+" target="_blank">
		<span class="mh-share-button"><i class="fa fa-google-plus"></i></span>
	</a>
	<a class="mh-email" href="mailto:?subject=%E2%80%98It%E2%80%99s%20been%20one%20heck%20of%20a%20year%E2%80%99&amp;body=https%3A%2F%2Fwww.mtairynews.com%2Fsports%2F110096%2Fits-been-one-heck-of-a-year" title="Send this article to a friend" target="_blank">
		<span class="mh-share-button"><i class="fa fa-envelope-o"></i></span>
	</a>
</div></div>

	</div></article>
								<div id="rc-widget-7301ab" data-rc-widget data-widget-host="habitat" data-endpoint="//trends.revcontent.com" data-widget-id="166979"></div>
				<script type="text/javascript" src="https://assets.revcontent.com/master/delivery.js" defer="defer"></script>
				
				
<div id="disqus_thread"></div>
<nav class="mh-post-nav mh-row clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
<div class="mh-col-1-2 mh-post-nav-item mh-post-nav-prev">
<a href="https://www.mtairynews.com/news/110087/city-schools-honored-for-pilot-bus-program" rel="prev"><img width="40" height="60" src="https://s24476.pcdn.co/wp-content/uploads/2022/05/128539077_web1_thumbnail_IMG_5961-40x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Mount Airy City Schools Superintendent Dr. Kim Morrison and Transportation Coordinator Jon Doss pose for a photo with the Tyler Technologies 2022 Tyler Excellence Award." srcset="https://s24476.pcdn.co/wp-content/uploads/2022/05/128539077_web1_thumbnail_IMG_5961-40x60.jpg 40w, https://s24476.pcdn.co/wp-content/uploads/2022/05/128539077_web1_thumbnail_IMG_5961-202x300.jpg 202w, https://s24476.pcdn.co/wp-content/uploads/2022/05/128539077_web1_thumbnail_IMG_5961-295x438.jpg 295w, https://s24476.pcdn.co/wp-content/uploads/2022/05/128539077_web1_thumbnail_IMG_5961-257x381.jpg 257w, https://s24476.pcdn.co/wp-content/uploads/2022/05/128539077_web1_thumbnail_IMG_5961-343x509.jpg 343w, https://s24476.pcdn.co/wp-content/uploads/2022/05/128539077_web1_thumbnail_IMG_5961-165x245.jpg 165w, https://s24476.pcdn.co/wp-content/uploads/2022/05/128539077_web1_thumbnail_IMG_5961.jpg 431w" sizes="(max-width: 40px) 100vw, 40px" /><span>Previous</span><p>City schools honored for pilot bus program</p></a></div>
</nav>
				<a id="comments"></a>
							<ins data-revive-zoneid="153" data-revive-id="7704ed944ed7863d36a61d5fccf7693e"></ins>
			<script async src="//adamsads.midtc.com/www/delivery/asyncjs.php"></script>
			  <style type="text/css">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</style><div id="ajax-load-more" class="ajax-load-more-wrap infinite fading-blocks"  data-alm-id="" data-canonical-url="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year" data-slug="its-been-one-heck-of-a-year" data-post-id="110096"  data-localized="ajax_load_more_vars"><ul aria-live="polite" aria-atomic="true" class="alm-listing alm-ajax" data-seo="true" data-seo-start-page="1" data-seo-scroll="true" data-seo-scrolltop="30" data-seo-controls="1" data-seo-permalink="pretty" data-seo-pageview="true" data-container-type="ul" data-loading-style="infinite fading-blocks" data-repeater="template_1" data-post-type="post" data-category="Sports" data-order="DESC" data-orderby="date" data-offset="1" data-posts-per-page="50" data-scroll="true" data-scroll-distance="100" data-max-pages="0" data-pause-override="false" data-pause="false" data-button-label="Next Article" data-transition="none"></ul><noscript><ul class="alm-listing alm-noscript"><div class="alm-reveal"><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/sports/110052/mount-airy-mca-compete-in-1a-state-meet" title="Mount Airy, MCA compete in 1A State Meet" style="color:black">Mount Airy, MCA compete in 1A State Meet</a></h1>

            <a href="https://www.mtairynews.com/sports/110052/mount-airy-mca-compete-in-1a-state-meet" title="Mount Airy, MCA compete in 1A State Meet">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/05/128539632_web1_283688338_5565224346829407_6412571382250230680_n.jpg" alt="Mount Airy, MCA compete in 1A State Meet">
            </a>
   <p class="entry-meta">May 23, 2022</p>
   <p>GREENSBORO &mdash; Millennium Charter and Mount Airy took part in the 1A State Championship Track and Field Meet on May 21.</p>
<p>The meet, held at N.C. A&#038;T University&rsquo;s Marcus T. Johnson Track inside Truist Stadium, featured four three individuals and one relay team from local 1A schools. Another local relay team qualified for the state meet, but was unable to compete.</p>
<p>Results are listed below by school.</p>
<p>Team points were accumulated for each school&rsquo;s top-8 individual finish: 10 points for first place, 8 for second, 6 for third, 5 for fourth and one point fewer through eighth place.</p>
<p><strong>Millennium Charter</strong></p>
<p>Millennium&rsquo;s 4&#215;800-meter relay team was the school&rsquo;s second-ever state qualifier in outdoor track. One of the relay team members, junior Ava Utt, was the school&rsquo;s first state qualifier in 2021. She was also the school&rsquo;s first medalist by taking bronze in high jump last year.</p>
<p>Utt was part of girls 4&#215;800 relay team that also featured Lion sophomore Clara Minix, as well as freshmen River Edge and Ruby Hoerter. The girls finished No. 11 in the race with a time of 12:00.42.</p>
<p><strong>Mount Airy</strong></p>
<p>The Granite Bears had four state qualifiers in the boys competition: three individuals and one relay team.</p>
<p>Mount Airy&rsquo;s 4&#215;100 relay team of Mario Revels, Connor Burrell, Caleb Reid and Tyler Mason qualified by finishing fourth in the 1A West Regional Championship, but wasn&rsquo;t able to compete at states due to an injury.</p>
<p>The three individual state qualifiers all finished just off the podium in their respective events.</p>
<p>Sophomore Deric Dandy competed in his first state championship meet and took fifth in the discus throw. Dandy&rsquo;s best mark was 134-04.</p>
<p>Sophomores Blake Hawks and Caden Ratcliff also finished fifth in their respective events. Hawks competed in the triple jump as a freshman and finished No. 6 with a mark of 40-03.25. He improved to 41-02.00 in 2022 to finished fifth.</p>
<p>Ratcliff competed in the 800 meters as both a freshman and a sophomore. He took the No. 15 spot in 2021 with a time of 2:22.70, and improved to No. 5 with a time of 2:05.53 in 2022. The top-5 finishes in this year&rsquo;s race were separated by less than six seconds.</p>
<p>Mount Airy&rsquo;s boys were tied for No. 20 as a team with 12 points.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/sports/110090/four-runnin-patriots-headed-to-east-west-all-star-game" title="Four Runnin&#8217; Patriots headed to East-West All-Star Game" style="color:black">Four Runnin&#8217; Patriots headed to East-West All-Star Game</a></h1>

            <a href="https://www.mtairynews.com/sports/110090/four-runnin-patriots-headed-to-east-west-all-star-game" title="Four Runnin&#8217; Patriots headed to East-West All-Star Game">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/05/128539312_web1_Photo-May-04-10-29-24-PM.jpg" alt="Four Runnin&amp;#8217; Patriots headed to East-West All-Star Game">
            </a>
   <p class="entry-meta">May 23, 2022</p>
   <p>Members of the Surry Homeschool Basketball program are set to compete in North Carolina&rsquo;s 2022 Home Educators All-Star Game.</p>
<p>Both the Surry Runnin&rsquo; Patriots boys and girls teams compete in the North Carolinians for Home Education Athletic Commission (NCHEAC). The NCHEAC East-West All-Star Game is scheduled for May 27 and will take place at Salem Baptist Christian School in Winston-Salem.</p>
<p>Four members of the Runnin&rsquo; Patriots will compete in the all-star game: Joshua Bunke will represent the boys team, and the trio of Faith McClary, Lindsay Cooper and Karlie Effler will represent the girls.</p>
<p>The Runnin&rsquo; Pats will team with other players from the NCHEAC&rsquo;s Western Conference, which includes teams from Forsyth, South Guilford, Cabarrus and South Charlotte. The NCHEAC East features teams from Wilmington, North Wake, Rocky Mount/Wilson, South Wake and Wake Forest.</p>
<p><strong>Bunke</strong></p>
<p>Joshua Bunke was named All-Conference for the third year in a row in 2022. He was also named to the All-Tournament team at the Triad Baptist Christmas Tournament.</p>
<p>For the season, Bunke averaged 17.9 points, 7.4 rebounds, and 4.0 assists per game. He shot 83% from the free throw line and led the Patriots&rsquo; attack with leadership on and off the court.</p>
<p>Josh achieved the 1,000 point milestone last year, and finished his career with 1,905 points.</p>
<p><strong>McClary </strong></p>
<p>Faith McClary, an excellent shooter herself, changed roles this year and became primarily a distributor as she repeated on the All-Conference team.</p>
<p>McClary ran the Lady Pats&rsquo; offense and worked constantly to get other players involved. She scored 204 points on the year while also dishing out 86 assists.</p>
<p>Defensively, McClary grabbed 51 steals.</p>
<p>Faith will continue her basketball career at Bob Jones University in the fall.</p>
<p><strong>Cooper </strong></p>
<p>In addition to being a repeat All-Conference selection, Lindsay was selected as conference&rsquo;s Defensive Player of the Year in 2022.</p>
<p>Cooper usually drew the toughest defensive assignment and led the team in steals with 111. As good defense often turns into offense, Cooper also scored 314 points, assisted on 101 baskets and had five double-doubles.</p>
<p><strong>Effler </strong></p>
<p>Another repeat All-Conference selection, Effler is a versatile and creative scorer that can also get teammates involved.</p>
<p>She finished the year with 465 points and 113 assists. Often drawing the other team&rsquo;s best defender, Karlie still managed to score consistently as an excellent outside shooter who can also drive to the basket, score in close and draw fouls.</p>
<p>Karlie is a 1,000 point scorer, having achieved this feat during last season.</p>
<p>She is also a lockdown defender who also surpassed 100 steals during the 2022 season.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/sports/110058/four-locals-win-state-track-titles" title="Four locals win State Track Titles" style="color:black">Four locals win State Track Titles</a></h1>

            <a href="https://www.mtairynews.com/sports/110058/four-locals-win-state-track-titles" title="Four locals win State Track Titles">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/05/128538237_web1_My-Post--10-.jpg" alt="Four locals win State Track Titles">
            </a>
   <p class="entry-meta">May 23, 2022</p>
   <p>GREENSBORO &mdash; Four local student-athletes won gold medals at the 2A State Championship Track and Field Meet.</p>
<p>East Surry, North Surry and Surry Central competed in the 2A Championship Meet on May 20 hosted at N.C. A&#038;T University&rsquo;s Marcus T. Johnson Track inside Truist Stadium.</p>
<p>Two of the local state champs hail from East Surry, while North Surry and Surry Central and each had one. The three schools combined to have 12 state qualifiers.</p>
<p>Results are listed below by school.</p>
<p>Team points were accumulated for each school&rsquo;s top-8 individual finish: 10 points for first place, 8 for second, 6 for third, 5 for fourth and one point fewer through eighth place.</p>
<p><strong>East Surry</strong></p>
<p>Senior Clara Willard and sophomore Isaac Vaden swept the 2A Discus Throw Championships.</p>
<p>Willard competed in the 2021 1A Discus Championship and finished No. 11 with a mark of 79-01 feet. She jumped to the top 2A spot in 2022 with a championship throw of 118-09 feet. Willard tied Camden County&rsquo;s Kennedy Lighty for the No. 1 spot, but won the tiebreaker with her second-longest throw.</p>
<p>Clara is just the third female state champion in outdoor track in East Surry history. She joins Suzanne Shelton, who won the 1A 1,600-meter Run Title in 1994, and Maya Bennett, who won the 1A High Jump Title in 2003.</p>
<p>Willard&rsquo;s 10 championship points put East Surry tied for No. 25 in the team standings.</p>
<p>Like Willard, Vaden had a huge leap from last year&rsquo;s 1A championship to this year&rsquo;s 2A meet. Vaden finished No. 15 of 16 competitors in 2021 with a throw of 95-01. He left no doubts this season by throwing a championship distance of 145-01 &#8211; which won the 2A title by more than eight feet.</p>
<p>Vaden is the first male outdoor track state champion in East Surry history.</p>
<p>Also competing in the state championship for East Surry was senior Cooper Motsinger. Motsinger finished No. 6 in the 3,200 meters with a time of 10:27.20.</p>
<p>Vaden and Motsinger&rsquo;s 13 points helped East Surry finish tied for No. 17 in the team competition.</p>
<p><strong>North Surry</strong></p>
<p>Ella Riggs competed in her first outdoor track championship this year as a freshman.</p>
<p>Riggs took part in shot put and finished just off the podium in fifth place. Her throw of 34-08.50 was less than two feet behind the fourth-place finish, and she was the only freshman to finish in the top-8.</p>
<p>Riggs&rsquo; four points helped the Lady Greyhounds finish tied for No. 41 as a team.</p>
<p>Junior Jared Hiatt was the only local male competitor to compete in two different events at the state championship. He competed in long jump at the 2021 2A State Championship, but competed in both long jump and high jump at this year&rsquo;s meet.</p>
<p>Hiatt captured the Long Jump State Championship with a final mark of 22-10.75. He narrowly defeated the defending 2A State Champion and the highest seed coming into this year&rsquo;s championship, Terry Hayes of Wilkes Central, by 1.5 inches.</p>
<p>Hiatt wins his second overall state championship and first in outdoor track; he previously won the 2021-22 Indoor Track State Championship for long jump.</p>
<p>Jared is the second outdoor track state champion in North Surry history, joining 2018 2A Shot Put Champion Ryan Eldridge.</p>
<p>In addition to his gold medal in long jump, Hiatt won a bronze medal in high jump with a leap of 6-04. There was a three-way tie for second place in the event, and the final order was decided based on number of attempts needed to clear a mark.</p>
<p>Hiatt&rsquo;s 15 points helped the Greyhound boys finish No. 15 as a team.</p>
<p><strong>Surry Central</strong></p>
<p>Golden Eagle senior Mia McMillen was one of only two local competitors, male or female, to compete in four events at the state championship level. She was also the only local athlete competing in their third outdoor track state championship meet.</p>
<p>McMillen had two finishes on the podium on Friday, including a gold-medal performance in the 300 hurdles with a time of 45.08 seconds. Her championship win comes after two second-place finishes in the event as a freshman and a junior (no state championship was held in 2020).</p>
<p>Surry Central girls have now won a total of 25 outdoor track state championships since 1990; 20 individual titles and five relay titles. Mia wins the school&rsquo;s first outdoor track championship since Sarah Brown won the pole vault title in 2019.</p>
<p>Like Hiatt at North Surry, McMillen added a bronze medal to go with her gold. Mia took third in the 100 hurdles with a time of 15.16, which was .09 seconds behind second place.</p>
<p>McMillen had two other finishes just outside the top-4. She finished fifth in long jump with a mark of 17-06.50, actually tying for fourth in distance but dropping to fifth due to number of attempts, and sixth in the 4&#215;200 relay at 1:48.48 with teammates Aylin Rodriguez, Ella Priddy and Ivy Toney.</p>
<p>Toney, a sophomore, joined McMillen as the only other local competitor to compete in four events at the state meet. Also making multiple appearances at the state meet were Lady Eagle teammates: Priddy with three, Rodriguez with two, Madelyn Wilmoth with two and Yeira Munoz with two.</p>
<p>Toney, Munoz and Cassie Snead competed in individual events for the Lady Eagles. Snead was No. 9 in discus with a mark of 100-01.00, Toney took the No. 10 spot in pole vault with a mark of 7-06 and Munoz was No. 13 in the 3,200 meters with a time of 14:30.13.</p>
<p>Central&rsquo;s 4&#215;400 and 4&#215;800 relay teams each finished sixth.</p>
<p>Wilmoth, Rodriguez, Toney and Priddy finished the 4&#215;400 in 4:23.35, and the team of Wilmoth, Toney, Munoz and Priddy finished the 4&#215;800 in 10:45.63.</p>
<p>Surry Central&rsquo;s girls had the highest team finish of any local school. The Lady Eagles racked up 29 points to finish No. 8 of more than 50 teams.</p>
<p>Two Surry Central boys competed at the state championship as well: sophomore Ignacio Morales and freshman Allen Huffman. Both boys were competing in the outdoor track championship for the first time.</p>
<p>Morales took part in the 3,200 meters and finished third with a time of 10:05.43. He was the only sophomore to finish in the top-8.</p>
<p>Huffman competed in the 300 hurdles and finished No. 15 with a time of 44.82.</p>
<p>Surry Central&rsquo;s boys tied for No. 31 in the team standings with six points.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/sports/109951/mount-airys-historic-baseball-season-ends-in-sweet-16" title="Mount Airy&#8217;s historic baseball season ends in Sweet 16" style="color:black">Mount Airy&#8217;s historic baseball season ends in Sweet 16</a></h1>

            <a href="https://www.mtairynews.com/sports/109951/mount-airys-historic-baseball-season-ends-in-sweet-16" title="Mount Airy&#8217;s historic baseball season ends in Sweet 16">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/05/128526748_web1_281867430_1660415061004532_8400490854320086893_n.jpg" alt="Mount Airy&amp;#8217;s historic baseball season ends in Sweet 16">
            </a>
   <p class="entry-meta">May 20, 2022</p>
   <p>WALNUT COVE &mdash; Mount Airy&rsquo;s storybook baseball season came to an end Tuesday in the Sweet 16 of the 1A State Playoffs.</p>
<p>Mount Airy and South Stokes were tied 1-1 through the third inning, then South added a trio of runs in the bottom of the fourth. The Bears put runners on base in the fifth and seventh innings but failed to score again.</p>
<p>No. 1-seeded South Stokes advanced to the Elite Eight with the 4-1 win.</p>
<p>Mount Airy finishes the season 19-9 overall. The 2022 team&rsquo;s 19 victories are the second-most in school history according to Mount Airy sports historian Doug McDaniel, trailing only the 1939 team that finished 20-0.</p>
<p>This year&rsquo;s team also won seven consecutive games at one point &#8211; a feat last accomplished by the 1958 Bears who won 10 consecutive games.</p>
<p>Mount Airy was the only 1A team during the regular season to defeat South Stokes. The Sauras (18-6) defeated the Bears 5-4 in the Granite City on March 22, then Mount Airy turned around and topped South 6-1 in Walnut Cove on March 28.</p>
<p>The Bears quickly loaded the bases to begin the rubber match. Rylan Venable led off with a single, then Ian Gallimore was walked and Kamden Hawks reached first on an error. Reece Deaton looked to score the opening run with a hit to second base, but South turned a 4-6-3 double play to hold Mount Airy scoreless.</p>
<p>Mount Airy turned a double play of its own in the bottom of the opening inning to keep the game scoreless. The Bears then took a lead thanks to three hits in the top of the second.</p>
<p>Mount Airy&rsquo;s first two batters, Cameryn Wilson and Landon Cox, singled to start the inning. Josh Penn reached first on a fielder&rsquo;s choice that also sent Wilson to third, then a Brison George single sent Wilson to the plate.</p>
<p>South quickly put two runners on in the bottom of the inning after Nolan Coe and Maddox Nelson drew back-to-back walks with just one out on the board. The runners advanced a base on a groundout, then Coe scored on a single from Ethan Nelson.</p>
<p>The Granite Bears were able to put runners on base in 5-of-7 innings, but struggled to get them back home.</p>
<p>Logan Dowell and Kamden Hawks singled to begin the third inning. South turned another double play to get Hawks and Deaton out, but Dowell advanced all the way to third. The Bears&rsquo; senior was stranded after a flyout.</p>
<p>South scored the decisive trio of runs in the bottom of the fourth. Coe led off by reaching first on an error before being moved to second on a sacrifice by Nelson. Jordan Buck was hit by a pitch to put two runners on base, then both were scored on a Blake Hughes triple.</p>
<p>Hughes added run No. 4 when he crossed the plate after a wild pitch.</p>
<p>Mount Airy went three up, three down in the fourth and sixth innings, and fell victim to another double play in the fifth. South had a chance to extend its lead by loading the bases in the bottom of the sixth, but the Bears left all three runners stranded by forcing a pair of flyouts.</p>
<p>South picked up two quick outs in the top of the seventh before Brison George singled to keep the game alive. Venable followed his teammate with a double, but George got out trying to go home on the hit.</p>
<p>Six Bears recorded at least one hit in the game: Venable, George, Wilson, Dowell, Hawks and Cox. Wilson had the Bears&rsquo; only run, and George hit the lone RBI.</p>
<p>Mount Airy and South Stokes only combined to throw two strikeouts in the game. </p>
<p>Rylan Venable spent 5.0 innings on the mound for the Bears, throwing one strikeout, two walks and allowing four runs on five hits. Ashton Gwyn threw 1.0 inning and had two walks.</p>
<p>South&rsquo;s Connor Young tossed a complete game with one strikeout, two walks, and allowed one run on six hits.</p>
<p>Scoring</p>
<p>Mount Airy &#8211; 0, 1, 0, 0, 0, 0, 0 = 1</p>
<p>South Stokes &#8211; 0, 1, 0, 3, 0, 0, X = 4</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/sports/109926/surry-softball-earns-national-coaching-honor" title="Surry Softball earns national coaching honor" style="color:black">Surry Softball earns national coaching honor</a></h1>

            <a href="https://www.mtairynews.com/sports/109926/surry-softball-earns-national-coaching-honor" title="Surry Softball earns national coaching honor">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/05/128531171_web1_2022SurrySBCoaches.jpg" alt="Surry Softball earns national coaching honor">
            </a>
   <p class="entry-meta">May 20, 2022</p>
   <p>LOUISVILLE &mdash; Surry Community College&rsquo;s trio of softball coaches was voted one of the top coaching staffs in the National Junior College Athletic Association (NJCAA).</p>
<p>Surry&rsquo;s coaching staff, made up of head coach Blaine Bullington and assistant coaches Joel Jones and Gary Stone, was voted an NJCAA Regional Coaching Staff of the Year for 2022 by the National Fastpitch Coaches Association (NFCA).</p>
<p>According to an NFCA press release, the organization is currently made up of nearly 6,000 coaches. Known for its high regarded coaching awards, the NFCA also educates and supports softball coaches on a variety of different levels from webinars to legal counsel, in-person events and the National Convention.</p>
<p>Surry was chosen as the NJCAA Division II recipient from the East Region. Joining SCC was Des Moines Area Community College (Iowa) for the Midwest Region, Murray State College (Oklahoma) in the South Region.</p>
<p>In the national press release, the NFCA says the following of Surry&rsquo;s coaching staff:</p>
<p>&ldquo;Head coach Blaine Bullington, along with assistant coaches Joel Jones and Gary Stone, led Surry to a 35-11 overall record, 22-6 mark in conference play and a No. 18 ranking in the most recent NJCAA DII national rankings.</p>
<p>&ldquo;Behind the tutelage of Bullington and his staff, the Knights are one of the top offensive teams in NJCAA DII, ranking in the top five in several categories, including second in home runs (48), extra-base hits (156) and slugging (.593), and third in batting average (.375), doubles (104), total bases (696) and RBI (302).&rdquo;</p>
<p>The Lady Knights&rsquo; 35 overall wins set a program record. The team also had four players named to Region 10 All-Region teams in addition to an All-Tournament selection.</p>
<p>&ldquo;Coach Bullington and his staff are incredible both in working with our student-athletes,&rdquo; said Surry athletic director Mark Tucker. &ldquo;They work to develop our student-athletes with a comprehensive approach placing emphasis on academics, personal growth, and community service while continuously developing their skills on the softball field. Surry is extremely blessed to have Coach Bullington and his staff leading our program.&rdquo;</p>
<p>The National Fastpitch Coaches Association NJCAA Division I and II National Coaching Staff of the Year will be announced on June 6.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/sports/109931/bears-fall-3-1-to-uwharrie-charter" title="Bears fall 3-1 to Uwharrie Charter" style="color:black">Bears fall 3-1 to Uwharrie Charter</a></h1>

            <a href="https://www.mtairynews.com/sports/109931/bears-fall-3-1-to-uwharrie-charter" title="Bears fall 3-1 to Uwharrie Charter">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/05/128530341_web1_DSC_0542.jpg" alt="Bears fall 3-1 to Uwharrie Charter">
            </a>
   <p class="entry-meta">May 20, 2022</p>
   <p>ASHEBORO &mdash; The Lady Bears&rsquo; soccer team fell 3-1 to Uwharrie Charter in the second round of the 1A State Playoffs.</p>
<p>Hot off the team&rsquo;s first playoff victory since 2019, Mount Airy struck first against Uwharrie with a Karyme Bueno goal nearly an hour into Thursday&rsquo;s playoff match. The No. 7-seeded Eagles netted the equalizer eight minutes later on a free kick, then scored the go-ahead goal with just six minutes left on the clock.</p>
<p>Uwharrie Charter added an insurance goal with two minutes left in regulation to secure the playoff win.</p>
<p>&rdquo;I thought we did a really good job early on then scoring that first goal,&rdquo; said Bears coach Will Hurley. &ldquo;I thought we could&rsquo;ve had them when we got that 1-0 lead. I knew we needed to rest some of the girls, but having seven players out with injuries really hurt us. Uwharrie stayed in the fight and made some good plays down the stretch.&rdquo;</p>
<p>Tuesday&rsquo;s game was given a 5:00 kickoff time since Uwharrie Charter&rsquo;s field didn&rsquo;t have lights, meaning it was 91-degrees when the game began. Despite the heat, Hurley felt the Lady Bears were able to keep their stamina up through the first half and part of the second.</p>
<p>&ldquo;Everything really came together at one point, &ldquo;Hurley said. &ldquo;I thought some of passing was really, really good, and we were able to move the ball up the field efficiently on a field that wasn&rsquo;t easy to play on. Ashley [Escamilla] came in off the bench and played significant minutes in the midfield when Paola [Ramirez] went down.&rdquo;</p>
<p>Ramirez left the game with an injury in the 25th minute. She and Morgan Hiatt advanced up the right sideline with 1-2 passes that put Ramirez in a 1-on-1 situation with Uwharrie&rsquo;s keeper. Ramirez&rsquo;s shot was deflected out of bounds by the charging keeper, and the ensuing collision took the Lady Bear sophomore out of the game.</p>
<p>The injury led to Hurley adapting his lineup once again. Mount Airy already had its striker shifted back to defensive mid, a center midfielder moved up to striker, and a defender moved up to midfielder to compensate for the cornucopia of injuries.</p>
<p>Defensively, Mount Airy&rsquo;s back line of Kinlee Reece, Kylie James, Aubrey Wilmoth and Aliyah Flores held Uwharrie to just four shots in the first half. The Bears caught the Eagles&rsquo; speedy forwards offside, and any chances Uwharrie had after getting through the defense were stopped by keeper Mackenzie Hudson.</p>
<p>Mount Airy broke the scoreless tie in the 56th minute. Kate Deaton attacked up the left sideline and crossed to Karyme Bueno in the box, and Bueno finished to put Mount Airy up 1-0.</p>
<p>The Bears shifted into a defensive mindset after scoring. This deterred all of Uwharrie&rsquo;s goal-scoring opportunities until the 64th minute, when the Eagles&rsquo; converted on a 35-yard free kick.</p>
<p>Hiatt&rsquo;s long throw ins had Mount Airy back into Uwharrie&rsquo;s 18-yard box, but the Bears&rsquo; shots couldn&rsquo;t find the back of the net. The teams were knotted up at 1-1 until Uwharrie floated a cross from the left sideline into the side-netting of the far post in the 74th minute.</p>
<p>The Eagles shifted their formation into a defensive 4-3-3 after the second goal. With the center of the field more crowded, Mount Airy pushed for more attacks up the sidelines which set Hiatt up for more long throw ins. Deaton had a pair of good looks in the final four minutes as a result, but both shots went off frame in an attempt to bypass the crowded 18-yard box. Grey Moore added a shot on goal that saved by Uwharrie&rsquo;s keeper.</p>
<p>With Mount Airy&rsquo;s team now in an offensive formation, Uwharrie took advantage and added its third goal. The Bears moved into Eagle territory with less than a minute to play, but it was too little too late as the final whistle signaled the end of Mount Airy&rsquo;s historic season.</p>
<p>&ldquo;One thing I have to say about Uwharrie is that their girls were really respectful and really good to our girls,&rdquo; Hurley said. &ldquo;They battled for 80 minutes, then brought over freeze pops for our girls and talked with them after the game. There was a lot of great sportsmanship, and it was a pleasure to see.&rdquo;</p>
<p>The Lady Bears finish the season 17-3-4. Mount Airy captured its first-ever conference championship this season while setting school records for single-season wins (17), fewest goals allowed (20), most shutouts (14) and the most consecutive matches without a loss (17).</p>
<p>Hurley knew early on this team was capable of great things, but said none of it would be possible if the girls hadn&rsquo;t put in the work.</p>
<p>&ldquo;I&rsquo;d have to say there really wasn&rsquo;t a single player that I&rsquo;d consider most improved, because that honor would go to the entire team,&rdquo; Hurley said. &ldquo;Everyone really bought in and worked incredibly hard to be successful.</p>
<p>&ldquo;We probably started out as an offensive team, then injuries really hit home and we became more of a defensive team in the end. Had we not had those injuries, I think we would&rsquo;ve gotten better defensively and been great at both. It just says a lot about the girls&rsquo; character to keep fighting all year long. I&rsquo;m just thankful I got to be a part of it.&rdquo;</p>
<p>Hurley credited his three senior players &#8211; Hiatt, Hudson and Moore &#8211; for really setting the tone for the team to be successful.</p>
<p>&ldquo;They treated everybody across the board equally,&rdquo; Hurley said. &ldquo;These three seniors did not get senioritis like most teams either. This has been the best team I&rsquo;ve ever had as far as everyone getting along, and those three seniors made all the difference.</p>
<p>&ldquo;Everybody was pretty upset after the game. When Morgan walked off the field I could see she was crying, so I ran over to her and told her it was alright. She said, &lsquo;It&rsquo;s just the greatest team I&rsquo;ve ever been a part of.&rsquo; I think she was less upset about the actual loss and more that the season was over. She didn&rsquo;t want to leave this crew.</p>
<p>&ldquo;They really have been a pleasure to coach.&rdquo;</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/sports/109900/lions-bears-compete-in-1a-regional-meets-2" title="Lions, Bears compete in 1A Regional Meets" style="color:black">Lions, Bears compete in 1A Regional Meets</a></h1>

            <a href="https://www.mtairynews.com/sports/109900/lions-bears-compete-in-1a-regional-meets-2" title="Lions, Bears compete in 1A Regional Meets">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/05/128525129_web1_MCA-Regional-Track-Field-man-5858.jpg" alt="Lions, Bears compete in 1A Regional Meets">
            </a>
   <p class="entry-meta">May 18, 2022</p>
   <p>Mount Airy and Millennium Charter Academy competed in 1A Regional Track Championships over the weekend.</p>
<p>Mount Airy took part in the 1A West Regional hosted by East Burke High School, and Millennium competed in the 1A Midwest Regional that was hosted by Davie County High School.</p>
<p>Millennium had one girls relay team qualify for the 1A State Championship Meet, and Mount Airy had one relay team and three boys qualify as individuals. The 1A State Championship Meet is scheduled for May 21 at North Carolina A&#038;T University.</p>
<p>Full 1A Midwest Regional results can be found at <a href="https://bit.ly/38xflWi" target="_blank" rel="noopener noreferrer">bit.ly/38xflWi</a>, and 1A West Regional results can be found at <a href="https://bit.ly/3aabSxg" target="_blank" rel="noopener noreferrer">bit.ly/3aabSxg</a></p>
<p><strong>Millennium Charter Lions</strong></p>
<p>Millennium had nine student-athletes compete in the 1A Midwest Regionals.</p>
<p>Ava Hiatt, Ava Utt, Clara Minix, Ruby Hoerter and River Edge took part in the girls competition, and Calvin Devore, Hartley Devore, Brody Krakenberg and Isaac Shipley competed in the boys. Utt, Minix, Calvin Devore and Hartley Devore were the only members of the 2022 Lions team that had experience in the Regional Championship.</p>
<p>The duo of Utt and Minix teamed with Hoerter and Edge to finish fourth in the girls 4&#215;800 relay. The relay team finished the race in 11:44.97 minutes. Utt returns to the N.C. High School Athletic Association 1A State Championship, while Minix, Hoerter and Edge will make their first appearances.</p>
<p>Utt and Hoerter finished just outside the top-4 in individual events. Utt took fifth in high jump with a leap of 4-06.00 feet, and Hoerter was fifth in the 3,200-meter run at 14:37.94.</p>
<p>Hiatt and Minix also competed as individuals for the Lady Lions. Hiatt finished seventh in discus throw with a mark of 71-03.00, and Minix finished eighth in the 800 meters at 2:49.02.</p>
<p>The Lions&rsquo; 4&#215;800 boys relay team finished just outside the state qualifying mark by taking fifth. The team of Calvin Devore, Hartley Devore, Brody Krakenberg and Isaac Shipley finished the race in 9:18.16.</p>
<p>Calvin Devore and Krakenberg had the boys&rsquo; two individual performances by competing in the 800 and 3,200 meters, respectively. Calvin finished seventh in the 800 with a time of 2:08.84, and Krakenberg was 14th in the 3,200 meters with a time of 13:08.90.</p>
<p><strong>Mount Airy Granite Bears</strong></p>
<p>Mount Airy sent 11 student-athletes to the 1A West Regional Championship.</p>
<p>Sydney Seagraves took part in the girls competition, while Deric Dandy, Blake Hawks, Mario Revels, Connor Burrell, Caleb Reid, Tyler Mason, Caden Ratcliff, Declan Conner, Ware Viers and Noah Khuri competed for the boys.</p>
<p>Ratcliff and Hawks, both sophomores, qualified for the state championship for a second consecutive year. Ratcliff did so by finishing second in the 800 meters with a time of 2:05.40, and Hawks finished second in triple jump with a mark of 41-00.00.</p>
<p>Five other Granite Bears qualified for their first 1A State Championship thanks to top-4 finishes at regionals. Dandy finished third in discus throw with a mark of 146-03.00, and the 4&#215;100 relay team of Revels, Burrell, Reid and Mason finished fourth with a time of 46.22 seconds.</p>
<p>Hawks nearly qualified in long jump as well, finishing sixth with a mark of 20-08.50. Hawks was just an inch behind the fourth-place finisher, and 2.5 inches behind the third-place finisher.</p>
<p>Seagraves added two top-10 finishes in the girls competition. The senior placed eighth in shot put with a mark of 29 feet, and finished No. 10 in discus throw with a mark of 85-10.00.</p>
<p>Also competing at regionals for Mount Airy: Conner finished 10th in the 3,200 meters with a time of 11:36.65; Revels was No. 12 in high jump with a height of 5-04.00; the 4&#215;200 relay team of Revels, Burrell, Reid and Hawks finished No. 13 with a time of 1:42.99; and the 4&#215;400 relay team of Ratcliff, Viers, Dandy and Khuri finished No. 15 with a time of 4:00.40.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/sports/109885/east-surry-elevates-to-elite-eight" title="East Surry elevates to Elite Eight" style="color:black">East Surry elevates to Elite Eight</a></h1>

            <a href="https://www.mtairynews.com/sports/109885/east-surry-elevates-to-elite-eight" title="East Surry elevates to Elite Eight">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/05/128522295_web1_DSC_0152.jpg" alt="East Surry elevates to Elite Eight">
            </a>
   <p class="entry-meta">May 18, 2022</p>
   <p>A 2-1 win over East Rutherford booked East Surry&rsquo;s ticket to the fourth round of the state playoffs for the fourth-consecutive postseason.</p>
<p>Junior Brett Clayton had two of East Surry&rsquo;s seven hits and both of the team&rsquo;s RBIs. Fellow junior Folger Boaz threw a complete game on the mound, striking out 12 batters and allowing just two hits.</p>
<p>&ldquo;Words can&rsquo;t do justice to how much I love this group of guys and how blessed I am to be their coach,&rdquo; Cardinal coach Chad Freeman said following Tuesday&rsquo;s win. &ldquo;Top to bottom they play hard, play for each other, have fun doing it, but most importantly they represent our program and community well.&rdquo;</p>
<p>East Surry&rsquo;s first postseason since being promoted to the 2A division ran directly through the Mountain Foothills Seven Conference (MFSC). The Cardinals (24-1) defeated the MFSC&rsquo;s No. 6 seed Hendersonville 8-2 in the opening round, bested MFSC Co-Champion R-S Central 3-2 in the round of 32, then topped the conference&rsquo;s other Co-Champion, East Rutherford, 2-1 on Tuesday.</p>
<p>Additionally, East Surry defeated the team that would finish fourth in the MFSC standings, Polk County, 8-6 back on March 5.</p>
<p>The Cardinals recorded seven hits against the visiting Cavaliers (21-6). Avery Strange threw a complete game for East Rutherford, striking out seven batters and walking two in six innings.</p>
<p>East Surry only had two hits heading into the bottom of the third inning, then opened things up when Clayton &#8211; called Hercules by his teammates &#8211; crushed a solo home run that hit the top of the scoreboard at Barry Hall Field. The homer was Clayton&rsquo;s first of the season.</p>
<p>&ldquo;Brett is just a wonderful teammate, &rdquo; Freeman said. &ldquo;All the boys love him; he is selfless, he works hard and you can&rsquo;t ask for a better kid than Brett Clayton. He plays a tremendous defensive center field, and his hitting has gotten better and better and better. He&rsquo;s had several doubles and triples this year. He&rsquo;s strong as an ox; we&rsquo;ve just been waiting for him to connect on one this year and, dang, he did tonight.&rdquo;</p>
<p>Clayton also came up clutch in the field with a pair of big catches in center field, one in the top of the fourth and then another in the top of the fifth.</p>
<p>&ldquo;He doesn&rsquo;t move like you&rsquo;d think a big boy would,&rdquo; Freeman said. &ldquo;He&rsquo;s got pretty good speed.&rdquo;</p>
<p>East Rutherford scored its only run off one of the team&rsquo;s two hits. Boaz threw his seventh strikeout to begin the fourth inning, but followed with his only base on balls. The Cavaliers&rsquo; Marshall McGowan advanced to second on a wild pitch, then scored on a hit by teammate Isaac Lee.</p>
<p>Following the Cavs&rsquo; run in the fourth, East Rutherford had one player get on base for the remainder of the game &#8211; and didn&rsquo;t get a ton of chances. Boaz finished with 12 strikeouts, including three innings of multiple strikeouts and two innings with three strikeouts in each.</p>
<p>&ldquo;You can&rsquo;t ask for a better performance than that,&rdquo; Freeman said. &ldquo;Folger was lights out on the mound. He gave us every opportunity to hold them, and the guys did what they needed to scratch across a couple runs and pull out the win. They also played great defense across the board.</p>
<p>&ldquo;The ball that got through, which allowed them to score their run, had top spin and it hit the lip. It just squirted past Trey (Armstrong) because of the top spin. There was absolutely nothing he could&rsquo;ve done about that.&rdquo;</p>
<p>East Surry regained the lead in the bottom of the fourth. Anthony Ayers was walked to start the inning, then Caden Lasley laid down a sacrifice bunt to move Ayers to second. Matthew Keener hit a blooper to right field to put Ayers on third, and Clayton followed with his own hit to right to bring the run in.</p>
<p>Following the run, players in the dugout told Lasley, &ldquo;That assist goes to you, Chuck. Great work.&rdquo;</p>
<p>While East Rutherford failed to get past first base in the final three innings, East Surry put multiple runners on in the sixth in a situation almost identical to the fourth inning. Ayers led with a single to right and was moved to second on a bunt from Lasley. Keener singled, but Ayers stayed on second as the hit went to the Cavaliers&rsquo; shortstop.</p>
<p>Both players were left on after Strange threw his sixth and seventh strikeouts.</p>
<p>East Surry held East Rutherford to just three batters in the top of the seventh: McGowan grounded out to Tristen Mason at second, Lee struck out after facing a full count then Caleb Crain grounded out. The game ended when Armstrong fielded Crain&rsquo;s grounder and made the throw to Luke Brown at first base.</p>
<p>&ldquo;We&rsquo;re excited to be moving on to the fourth round,&rdquo; Freeman said. &ldquo;2018 and 2019 we were one game away from the Western Finals, then last year the fourth round was the Western Finals because of COVID, and we were able to advance and make the state finals.</p>
<p>&ldquo;Now, we get to go against the juggernaut that is Randleman.&rdquo;</p>
<p>East Surry travels to Randleman (28-1), the No. 1 seed in the 2A West and defending 2A State Champion, on May 20. This is East Surry&rsquo;s first true road game in the playoffs since 2016. The 2021 State Championship was held at a neutral site.</p>
<p>Only two teams in North Carolina &#8211; among all public school classifications &#8211; have made it to at least the fourth round of the state playoffs in each of the past four postseasons: East Surry and Randleman.</p>
<p>Scoring</p>
<p>East Rutherford &#8211; 0, 0, 0, 1, 0, 0, 0 = 1</p>
<p>East Surry &#8211; 0, 0, 1, 1, 0, 0, 0 = 2</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/sports/109803/lady-bears-win-first-ever-conference-title" title="Lady Bears win first-ever conference title" style="color:black">Lady Bears win first-ever conference title</a></h1>

            <a href="https://www.mtairynews.com/sports/109803/lady-bears-win-first-ever-conference-title" title="Lady Bears win first-ever conference title">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/05/128509378_web1_DSC_0120--2-.jpg" alt="Lady Bears win first-ever conference title">
            </a>
   <p class="entry-meta">May 16, 2022</p>
   <p>For the first time in Mount Airy girls soccer history, the Lady Bears are conference champions.</p>
<p>Despite falling 2-1 (OT) to South Stokes in the regular season finale on May 12, the Bears&rsquo; still earned a share of the Northwest 1A Conference Title. In fact, Mount Airy clinched part of the NW1A Title three days earlier with a 4-0 win over East Wilkes.</p>
<p>The Lady Bears&rsquo; first conference title adds to the team&rsquo;s already impressive list of accomplishments for the 2022 season. This year&rsquo;s team set the school record for the best start in program history by beginning 13-0-4. Mount Airy also set the program record for most wins in a season, surpassing the previous school record of 15 set in 2017 and tied again in 2019.</p>
<p>Prior to this season, Mount Airy&rsquo;s best conference finish was third: behind Bishop McGuinness and East Surry 2014-17, then behind Bishop McGuinness and South Stokes in 2018, 2019 and 2021. The Bears previous school record for conference wins was six, which this year&rsquo;s team shattered by going 10-2.</p>
<p>Mount Airy, Elkin and South Stokes shared the 2022 NW1A Title with identical conference records; Mount Airy defeated Elkin twice, Elkin defeated South Stokes twice and South Stokes defeated Mount Airy twice.</p>
<p>The N.C. High School Athletic Association&rsquo;s final RPI rankings for the regular season ranked the NW1A&rsquo;s top three teams No. 5, No. 6 and No. 7. South Stokes earned the top playoff spot, followed by Mount Airy and then Elkin.</p>
<p>Mount Airy (16-2-4) earned the No. 10 seed in the 1A West and will host No. 23 Alleghany (5-9). The winner of that game will face the winner of No. 7 Uwharrie Charter (7-6-1) and No. 26 Piedmont Community Charter (7-5-1).</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/sports/109831/mount-airy-shuts-out-alleghany-in-playoff-victory" title="Mount Airy shuts out Alleghany in playoff victory" style="color:black">Mount Airy shuts out Alleghany in playoff victory</a></h1>

            <a href="https://www.mtairynews.com/sports/109831/mount-airy-shuts-out-alleghany-in-playoff-victory" title="Mount Airy shuts out Alleghany in playoff victory">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/05/128517054_web1_DSC_0452.jpg" alt="Mount Airy shuts out Alleghany in playoff victory">
            </a>
   <p class="entry-meta">May 16, 2022</p>
   <p>Mount Airy extended its most successful soccer season on record with a 5-0 playoff win over Alleghany.</p>
<p>For 17 of the 20 players on Mount Airy&rsquo;s roster, Monday&rsquo;s win served as their first playoff victory. The remaining three &#8211; seniors Mackenzie Hudson, Morgan Hiatt and Grey Moore &#8211; competed in their only playoff victory as freshmen when the Bears defeated North Stanly 3-0 on May 7, 2019.</p>
<p>No postseason was held in 2020 due to the coronavirus pandemic, and the 2021 playoffs only let in 16 teams in the 1A West.</p>
<p>The Granite Bears, who improve to 17-2-4 with the win, got after it early when Kate Deaton scored in just the fourth minute. Deaton added another goal four minutes later, then Paola Ramirez made it 3-0 at halftime with a goal in the 38th minute.</p>
<p>Goals from Kinlee Reece and Emilee Corn in the second half led No. 10 Mount Airy to its first playoff victory in three years.</p>
<p>&ldquo;Our goal in this game was &lsquo;we don&rsquo;t give up goals like we did at their place,&rsquo; and we did really good with that,&rdquo; said Bears coach Will Hurley. Mount Airy has only surrendered 17 goals in 2022, and five of those were scored by Alleghany (5-10).</p>
<p>&ldquo;It does hurt your offense a little bit, but I just think that&rsquo;s our game; we&rsquo;re more of a defensive team now. We shifted when we started getting injuries, but that&rsquo;s okay. We can come out of that once we get healthy so we can play well on both sides.&rdquo;</p>
<p>The win serves as Hudson&rsquo;s 14th shutout as the Bears&rsquo; keeper this season, and was the first time this season Alleghany was held scoreless.</p>
<p>Mount Airy, meanwhile, fired 20 shots at the visiting Trojans while allowing just two.</p>
<p>Despite dealing with injuries for most of the year, the Lady Bears came into the playoffs hot off a historic regular season. Mount Airy has already set new school records for most wins in a season, most consecutive matches without a loss, most shutouts and fewest goals allowed in the regular season.</p>
<p>The 2022 Bears also put their names in the history books as the school&rsquo;s first to win a conference championship. Hurley said he knew at the beginning of the season that the team was in for an uphill battle having to play strong conference opponents in Elkin and South Stokes &#8211; the latter of which was led by nine seniors.</p>
<p>&ldquo;I thought it was big when we beat Elkin at Elkin. That was huge,&rdquo; Hurley said. &ldquo;I knew we had an outside chance, but I didn&rsquo;t know if we could pull it off when we kept getting injury after injury. I think they really started believing in themselves, though. We kept telling them not to worry about rankings or what happened in the past, just play the game.</p>
<p>&ldquo;I&rsquo;m happy for them, because they&rsquo;ve done really well as a team. We don&rsquo;t have a true superstar.&rdquo;</p>
<p>Hurley added that Mount Airy approached to the postseason is the exact same as the regular season: take things one game at a time. When members of the team pointed out the Bears would likely run into No. 2 Bishop McGuinness, who shared a conference with Mount Airy from 2009-2021, in the third round.</p>
<p>&ldquo;We practiced Saturday morning at 7 a.m. and they said, &lsquo;coach, we&rsquo;ve got to play Bishop,&rsquo; and I said, &lsquo;no, you don&rsquo;t. You have to play Alleghany, and right now that&rsquo;s all that matters&rsquo;&rdquo; Hurley said. &ldquo;Sometimes it&rsquo;s tough to beat a team three times in the same season, and Alleghany&rsquo;s got a great group that always fights.</p>
<p>&ldquo;This is a home game, and there&rsquo;s a lot of teams out there that aren&rsquo;t playing at home. We can enjoy the moment, but we have to play hard and just worry about now. We can worry about the next round if and when we get there.&rdquo;</p>
<p>By defeating No. 23 Alleghany, Mount Airy advances to the round of 32 and will travel to No. 7 Uwharrie Charter.</p>
<p>Uwharrie finished third overall and first out of the 1A teams in the Piedmont Athletic 1A/2A Conference. Uwharrie Charter (8-6-1) defeated No. 26 Piedmont Community Charter 7-0 in the opening round of the playoffs.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/sports/109794/2a-midwest-regional-track-results" title="2A Midwest Regional Track results" style="color:black">2A Midwest Regional Track results</a></h1>

            <a href="https://www.mtairynews.com/sports/109794/2a-midwest-regional-track-results" title="2A Midwest Regional Track results">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/05/128506413_web1_My-Post--9-.jpg" alt="2A Midwest Regional Track results">
            </a>
   <p class="entry-meta">May 16, 2022</p>
   <p>HIGH POINT &mdash; Strong performances from Surry County&rsquo;s three 2A schools led to 14 local athletes qualifying for the State Championship Meet.</p>
<p>The 2A Midwest Regional Championship was held May 13 at the High Point Athletic Complex Track.</p>
<p>East Surry, North Surry and Surry Central combined to win seven Regional Championships. Central led the way with four, followed by East with two and North with one. Any competitor or relay team that finished in the top four at Regionals qualified for the 2A State Championship.</p>
<p>Team points were accumulated for each school&rsquo;s top-8 finish: 10 points for first place, 8 for second, 6 for third, 5 for fourth and one fewer point through eighth place.</p>
<p>Surry Central&rsquo;s girls won the 2A Midwest Regional Runner-up Trophy with a total of 76 points, which was 22 points behind Regional Champion West Stanly. East Surry&rsquo;s girls finished No. 18 with 10 points, followed by North Surry&rsquo;s girls at No. 26 with five points.</p>
<p>East Surry had the highest finish of any local team in the boys competition at No. 11 with 20 points. North Surry wasn&rsquo;t far behind at No. 13 with 18 points, then Surry Central was up next in No. 14 with 17 points.</p>
<p>Full events results can be found at bit.ly/3yCBZHi</p>
<p>Three Surry County individual performances met the MileSplit U.S. Second Team Standard: Surry Central&rsquo;s Mia McMillen in long jump, East Surry&rsquo;s Isaac Vaden in discus throw and North Surry&rsquo;s Jared Hiatt in long jump.</p>
<p>The full list of Elite Performances can be found at bit.ly/3LlxjYS</p>
<p><strong>Girls Results</strong></p>
<p>EAST SURRY</p>
<p>Clara Willard was East Surry&rsquo;s lone female state qualifier and regional champion.</p>
<p>The Cardinal senior finished first in the discus throw with a mark of 115-06 feet, more than seven feet farther than the second-place finisher. Willard and the event&rsquo;s silver medalist &#8211; Cassie Sneed of Surry Central &#8211; were the only two competitors to throw farther than 97 feet.</p>
<p>Willard also competed in the shot put, where she finished No. 14.</p>
<p>Also competing in the regional meet for East Surry: the relay team of Grace Strader, Arianna Liberatore, Kate McCraw and Ember Midkiff finished No. 13 in the 4&#215;200 and No. 15 in the 4&#215;100; Madeline Dayton and Arianna Liberator competed in triple jump but did not place.</p>
<p>NORTH SURRY</p>
<p>Ella Riggs was the Lady Greyhounds&rsquo; only regional qualifier.</p>
<p>Riggs took fourth in shot put with a mark of 33-10.10. Riggs, a freshman, qualifies for the outdoor track state championship after being one of two North Surry girls to qualify for the indoor track championship during the winter.</p>
<p>SURRY CENTRAL</p>
<p>All seven of Surry Central&rsquo;s regional qualifiers finished in the top four of at least one event at the regional championship: Madelyn Wilmoth, Ella Priddy, Yeira Munoz, Mia McMillen, Ivy Toney, Cassie Sneed and Aylin Soto.</p>
<p>McMillen qualified for the state championship in four events, which included two regional championship victories in 300 hurdles and the 4&#215;200 relay. She won the 300 hurdles with a time of 46.15, nearly two seconds faster than the second-place finisher, and teamed with Soto, Priddy and Toney to win the 4&#215;200 by more than two seconds.</p>
<p>Central&rsquo;s 4&#215;200 time of 1:47.10 set a new school record for the Golden Eagles.</p>
<p>McMillen&rsquo;s two second-place finishes came in 100 hurdles, with a time of 15.70, and long jump, with a mark of 18-01.25 feet. McMillen and West Stanly&rsquo;s Onii Bivens, who won long jump with a mark of 18-01.75, both met the MileSplit US Second Team standard for the event.</p>
<p>Also winning a regional championship for Surry Central was the 4&#215;800 relay team of Wilmoth, Toney, Munoz and Priddy. The four Eagles cruised to a victory with a time of 10:46.00, better than the silver medalists by six seconds.</p>
<p>Munoz and Snead added individual second-place finishes in the 3,200 meters and discus throw, respectively. Munoz finished in 13:33.45, while Snead had a mark of 108-02.00. The Eagles&rsquo; 4&#215;400 team of Wilmoth, Soto, Toney and Priddy also finished second with a time of 4:27.15.</p>
<p>Toney added an additional state qualification in pole vault with a third-place finish at 7-06.00.</p>
<p>In addition to the state qualifiers, Soto also competed in the 200 meters and finished No. 10 at 28.56.</p>
<p><strong>Boys results</strong></p>
<p>EAST SURRY</p>
<p>Isaac Vaden and Cooper Motsinger were the two state qualifiers for East Surry&rsquo;s boys.</p>
<p>Vaden won the 2A Midwest Regional Championship in discus throw with a mark of 156-08.00, which met the MileSplit US Second Team standard. Vaden&rsquo;s throw was one inch shy of being 15 feet better than the second-place finish.</p>
<p>Vaden also competed in the shot put, where he finished sixth overall.</p>
<p>Motsinger finished fourth in the 3,200-meter run with a time of 10:40.14.</p>
<p>Also competing in the regional meet for East Surry: Sam Whitt finished No. 7 in shot put; Eli Becker finished No. 10 in shot put; the relay team of Layton Allen, Colby Johnson, Lindann Fleming and Kyle Zinn finished No. 11 in the 4&#215;200 and No. 12 in the 4&#215;100.</p>
<p>NORTH SURRY</p>
<p>Like Jared Hiatt qualified for the 2A State Championship in two events: high jump and long jump.</p>
<p>Hiatt battled his Foothills 2A Conference nemesis, Terry Hayes of Wilkes Central, in every jumping event at the regional championship. Hiatt won the regional title in high jump with a height of 6-02.00, while Hayes finished second. Hayes finished first in the long jump with a mark of 23-00.00, and Hiatt finished second at 22-07.00 &#8211; both of which met the MileSplit US Second Team standard.</p>
<p>Hiatt also competed in the triple jump, where he finished No. 10 with a mark of 39-07.00.</p>
<p>SURRY CENTRAL</p>
<p>Golden Eagles. Allen Huffman and Ignacio Morales qualified for the state championship.</p>
<p>Morales won the 3,200 meters to capture the 2A Midwest Regional Title, doing so with a time of 10:08.16. Morales finished more than eight seconds before the silver medalist.</p>
<p>Huffman finished third in the 300 hurdles with a time of 43.07, and was less than 1.5 seconds out of first.</p>
<p>Central also had three relay teams compete at the regional championship: the 4&#215;800 team of Chris Nava, Jonathan Avila, Brangly Mazariegos and Sebastian Sanchez finished No. 11, the 4&#215;200 team of Huffman, Nava, Isaac Eller and Sony Orozco finished No. 13, and the 4&#215;400 of Eller, Nava, Huffman and Charlie Hernandez finished No. 14.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/sports/109742/lions-compete-in-nwpc-track-championship" title="Lions compete in NWPC Track Championship" style="color:black">Lions compete in NWPC Track Championship</a></h1>

            <a href="https://www.mtairynews.com/sports/109742/lions-compete-in-nwpc-track-championship" title="Lions compete in NWPC Track Championship">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/05/128506415_web1_MCA-HS-Track-Field-4957.jpg" alt="Lions compete in NWPC Track Championship">
            </a>
   <p class="entry-meta">May 13, 2022</p>
   <p>KERNERSVILLE &mdash; The Northwest Piedmont 1A Conference held its Track and Field Championship on May 4 at Bishop McGuinness Catholic High School.</p>
<p>Bishop McGuinness&rsquo; girls and Cornerstone Charter Academy&rsquo;s boys came away with the team conference championships. Points were awarded for each top-6 finish: 10 points for first place, 8 for second, 6 for third, 4 for fourth, 2 for fifth and 1 for sixth.</p>
<p>Millennium Charter Academy finished fourth in the girls standings and sixth in the boys. The Lions won one individual conference championship, and finished second in four events.</p>
<p>Ruby Hoerter finished first in girls pole vault by clearing a height of 5-06.00 feet. Hoerter also earned All-Conference Honors &#8211; given to competitors that finished in the top two of an event &#8211; in the 3,200-meter run, and as a member of MCA&rsquo;s 4&#215;400 and 4&#215;800 relay teams.</p>
<p>Hoerter completed the 3,200 meters in 14:36.70.</p>
<p>She was joined by teammates River Edge, Clara Minix and Ava Utt on both the 4&#215;400 and 4&#215;800 teams. Millennium&rsquo;s 4&#215;400 team finished the race in 5:17.48, and the 4&#215;800 team finished in 12:22.51.</p>
<p>Minix and Utt added All-Conference performances in high jump and the 800 meters. Minix was less than five seconds out of first place in the 800 meters by finishing in 2:46.88, and Utt was two inches from tying the conference champion in high jump with a mark of 4-08.00.</p>
<p>Hiatt also competed in the discus throw and shot put for Millennium, taking fourth in both. Palak Patel competed in both throwing events as well, finishing seventh in shot put and eighth in discus throw.</p>
<p>Seven Millennium boys competed in the NWPC Conference Championship: Liam Allred, Calvin Devore, Isaac Shipley, Diego Gomez, Ford Holmes, Hartley Devore and Brody Krakenberg.</p>
<p>The closest All-Conference performance for the MCA&rsquo;s boys came in the 4&#215;800 relay; Shipley, Krakenberg, Hartley and Calvin Devore took third at 9:50.93.</p>
<p>Calvin Devore also came close in the 800 meters by finishing fourth. His time of 2:11.43 was less than three seconds behind the race-winning time, and was exactly two seconds behind the second-place finisher.</p>
<p>Also competing for Millennium&rsquo;s boys: Hartley Devore, Holmes and Krakenberg finishes sixth, seventh and eighth, respectively, in the 3,200 meters; Shiply finished 10th in the 800 meters, followed by Gomez at 11; Holmes and Gomez took 10th and 13th in the 1,600 meters, respectively; and Allred finished 15th in the 400 meters and 16th in the 200 meters.</p>
<p>The following Lions qualified for the Midwest 1A Regional Championship in the corresponding events:</p>
<p>Ava Hiatt: discus throw</p>
<p>Ava Utt: high jump</p>
<p>Clara Minix: 800 meters</p>
<p>Ruby Hoerter: 3,200 meters</p>
<p>River Edge, Ruby Hoerter, Clara Minix, Ava Utt, Palak Patel (alternate): 4&#215;800</p>
<p>Brody Krakenberg: 3,200 meters</p>
<p>Calvin Devore: 800 meters</p>
<p>Calvin Devore, Hartley Devore, Brody Krakenberg, Isaac Shipley: 4&#215;800</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/sports/109723/surry-central-recognizes-baseball-seniors" title="Surry Central recognizes baseball seniors" style="color:black">Surry Central recognizes baseball seniors</a></h1>

            <a href="https://www.mtairynews.com/sports/109723/surry-central-recognizes-baseball-seniors" title="Surry Central recognizes baseball seniors">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/05/128506392_web1_279554395_10229142680416384_7013713684623598080_n.jpg" alt="Surry Central recognizes baseball seniors">
            </a>
   <p class="entry-meta">May 13, 2022</p>
   <p>Surry Central recognized seven baseball seniors before an April 29 home game against East Surry.</p>
<p>Spencer LeClair, Dakota Mills, Kade Norman, Austin Cave, Kayden Gage, Brady Edmonds and Kendall White were honored for their contributions to the Golden Eagles&rsquo; program, with many being with the team throughout their entire high school careers.</p>
<p>In the Senior Night game, Central held East Surry to its second-lowest scoring total of the season at three runs. However, the Eagles struggled to score and came up short 3-0 in the regular season finale.</p>
<p>The Golden Eagles entered the Foothills 2A Conference Tournament as the No. 5 seed and dropped their quarterfinal game to No. 4 West Wilkes 7-3.</p>
<p>Surry Central qualified for the 2A State Playoffs as the No. 26 seed and opened the tournament at No. 7 Lincoln Charter. The Golden Eagles rallied late in the game when faced a big deficit, but four seventh-inning runs weren&rsquo;t enough to bring Central back.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/sports/109713/cardinals-walk-off-to-reach-sweet-16" title="Cardinals walk-off to reach Sweet 16" style="color:black">Cardinals walk-off to reach Sweet 16</a></h1>

            <a href="https://www.mtairynews.com/sports/109713/cardinals-walk-off-to-reach-sweet-16" title="Cardinals walk-off to reach Sweet 16">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/05/128506337_web1_DSC_0375e.jpg" alt="Cardinals walk-off to reach Sweet 16">
            </a>
   <p class="entry-meta">May 13, 2022</p>
   <p>PILOT MOUNTAIN &mdash; A walk-off hit by Folger Boaz lifted East Surry to a 3-2 playoff win over R-S Central on Thursday.</p>
<p>The Cardinals initially took a 2-1 lead in the third inning. East held the visiting Hilltoppers from scoring additional runs through the sixth, then R-S Central tied things up in the top of the seventh. Strong defense from East kept the visitors from taking the lead, and hits from Luke Bowman and Boaz sealed the win for the Cards.</p>
<p>&ldquo;It&rsquo;s a mixture of emotions for us,&rdquo; said East Surry coach Chad Freeman. &ldquo;There&rsquo;s nervousness, even though the game is over and we know the outcome. There&rsquo;s excitement. There&rsquo;s joy for our guys. Honestly, there&rsquo;s heartbreak for their team. R-S has a quality coaching staff, their kids battled, they&rsquo;ve got good kids; that&rsquo;s the type of team you want to go up against.</p>
<p>&ldquo;At the end of the day, it was two solid teams going after each other and we were fortunate to come away with the win.&rdquo;</p>
<p>East Surry (23-1) put runners on base in each of the first two innings, but couldn&rsquo;t score to match R-S Central&rsquo;s run from the top of the first. This changed in the third inning when Bowman reached first on a fielder&rsquo;s choice then moved to second on an error by the Hilltoppers. Boaz was intentionally walked with two outs, and a passed ball allowed Bowman to score.</p>
<p>The score was now tied 1-1 with the rain picking up. Luke Brown was walked, and Anthony Ayers singled to load the bases. Another passed ball sent Boaz home to give East Surry its second run.</p>
<p>R-S Central (19-7) took Drew Yelton off the mound after East Surry&rsquo;s second run. Yelton threw 2.2 innings, allowed two runs on three hits and walked three batters. Hayden Wheeler took over on the mound and ended the inning with a strikeout</p>
<p>The Cardinals struggled against Wheeler through the sixth inning. The Hilltopper junior struck out eight of the first 11 batters he faced; one East Surry player grounded out, another flied out and only one &#8211; Boaz in the fifth &#8211; got on base via error.</p>
<p>&ldquo;The first kid was a little bit craftier and more off-speed oriented, and [Wheeler] threw a little harder. We tried to get our guys to make an adjustment and be ready for the fastball, and we didn&rsquo;t do a good job of that the first few innings he was on the mound. Finally that last inning, when we swung up to the top of our lineup, we did a little bit better job of it.&rdquo;</p>
<p>The Hilltoppers also had chances to build a lead, leaving runners on base in each of the first six innings. Trey Shearer opened the fourth with a double, and Audrey Scruggs bunted for a single that moved Shearer to third as well.</p>
<p>Brown, who spent five innings on the mound for East Surry, struck out the next batter, then Ayers checked the runner on third before throwing a runner out at first. R-S Central sent a hit to left field that would&rsquo;ve scored at least one run had it not been caught by Gabriel Harpe.</p>
<p>One inning later, R-S Central&rsquo;s Tanner Boone singled and teammate Caleb White was walked. A balk put the runners on second and third with two outs, but Brown struck out his final batter to leave the runners stranded.</p>
<p>&ldquo;Luke may not have had his best stuff today, but he battled and came up big,&rdquo; Freeman said. &ldquo;Part of it is a credit to R-S: they took phenomenal approaches, and their two-strike approaches were on point.&rdquo;</p>
<p>Ayers took over on the bump in the sixth inning and East continued to stave off R-S Central&rsquo;s comeback attempts. Even when the visitors managed to score the game-tying run in the top of the seventh, Freeman said his guys were able to stay calm due to their experience in high-pressure games.</p>
<p>One such game Freeman referenced was East Surry&rsquo;s 2021 playoff opener against Community School of Davidson. The Cards, who went on to win the 1A West Regional Championship, were nearly upset in the first round by that CSD team.</p>
<p>&ldquo;I think last year&rsquo;s CSD game gave them the composure to not get rattled against Hendersonville, and even tonight when we had the shot to get the tying run at the plate and didn&rsquo;t execute there,&rdquo; Freeman said. &ldquo;We&rsquo;ve been through it enough that we&rsquo;ve come back before. We&rsquo;ve been in tight situations before and our guys didn&rsquo;t panic, so that&rsquo;s a credit to them.&rdquo;</p>
<p>The Cards got out of the top of the seventh by forcing two fly outs, including one chased down by Harpe in left field, and got the third out when Bowman threw to Trey Armstrong at second to catch a runner stealing.</p>
<p>Bowman then went up to bat and picked up the first East Surry hit against Wheeler. The Cards already had one out on the board in the bottom of the seventh, then the second came on a fly out. Boaz approached the plate with two outs and hit right over the left fielder&rsquo;s head. Bowman sped around the bases and reached the plate just as the ball made its way back into the infield.</p>
<p>As the celebration settled, Freeman praised the Cardinals for the resilience shown against a very good R-S Central team. East Surry&rsquo;s goal is to survive and advance, and he said that&rsquo;s exactly what they did.</p>
<p>East Surry will host the winner of No. 5 East Rutherford (20-5) and No. 12 Morehead (19-5) in the Sweet 16.</p>
<p>Scoring</p>
<p>R-S Central &#8211; 1, 0, 0, 0, 0, 0, 1 = 2</p>
<p>East Surry &#8211; 0, 0, 2, 0, 0, 0, 1 = 3</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/sports/107525/east-surry-recognizes-soccer-seniors" title="East Surry recognizes soccer seniors" style="color:black">East Surry recognizes soccer seniors</a></h1>

            <a href="https://www.mtairynews.com/sports/107525/east-surry-recognizes-soccer-seniors" title="East Surry recognizes soccer seniors">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/05/128501688_web1_DSC_0424.jpg" alt="East Surry recognizes soccer seniors">
            </a>
   <p class="entry-meta">May 11, 2022</p>
   <p>East Surry recognized five soccer seniors during halftime of a May 4 home match against Alleghany.</p>
<p>The Cardinals held a 2-1 lead after 40 minutes when four players and one manager paraded onto the field with members of their families: Brianna Whitaker, Liannette Chavez, Samantha Blose, Jamariah Lowery and manager Nick Lowery.</p>
<p>The Lady Cardinals went on to win the match 3-1. Blose scored both goals in the first half, with the second being assisted by Chavez. Morgan Bryant added an insurance goal in the 56th minute.</p>
<p>East Surry out-shot Alleghany 16-5 in the match. Cardinal keeper Katie Collins saved three of the Trojans&rsquo; shots, and one went off frame.</p>
<p>The win over Alleghany was East Surry&rsquo;s fifth consecutive win, marking the Cards&rsquo; longest winning streak of the season. It is also East&rsquo;s longest winning streak since the 2017 team won nine straight games.</p>
<p>The Lady Cards sit at 11-5-2 on the season, marking the program&rsquo;s first season of double-digit wins since the aforementioned 2017 team finished 13-8. East Surry also finished third in the Foothills 2A Conference at 8-4.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/sports/107501/kings-of-the-diamond-best-queens-grant-11-1" title="Kings of the diamond best Queen&#8217;s Grant 11-1" style="color:black">Kings of the diamond best Queen&#8217;s Grant 11-1</a></h1>

            <a href="https://www.mtairynews.com/sports/107501/kings-of-the-diamond-best-queens-grant-11-1" title="Kings of the diamond best Queen&#8217;s Grant 11-1">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/05/128499297_web1_DSC_0634.jpg" alt="Kings of the diamond best Queen&amp;#8217;s Grant 11-1">
            </a>
   <p class="entry-meta">May 11, 2022</p>
   <p>When asked about his expectations for his senior season, Mount Airy senior Reece McDuffie said the following at his college signing in November 2021:</p>
<p>&ldquo;I don&rsquo;t know the last time we had a home playoff game, so that&rsquo;s a huge goal. I think it&rsquo;s very possible with the team we have.&rdquo;</p>
<p>McDuffie&rsquo;s words came to fruition nearly six months later as Mount Airy hosted Queen&rsquo;s Grant High School on May 10. The Granite Bears put on a show against the Stallions, winning 11-1 in five innings to advance to the second round of the 1A State Playoffs.</p>
<p>Mount Airy&rsquo;s most recent home playoff game &#8211; prior to Tuesday &#8211; was nearly a decade ago on May 14, 2013. The 2013 Bears dropped that game 4-2 to visiting Albemarle.</p>
<p>The 2022 Granite Bears kept their historic season alive by shutting the Stallions down. After scoring one run on two hits in the top of the first inning, Mount Airy held Queen&rsquo;s Grant (9-8) to one hit for the remainder of the game.</p>
<p>Rylan Venable and Ashton Gwyn split time on the mound for the Bears (18-8). The duo allowed just three hits, walked one player and struck out 10 batters.</p>
<p>Mount Airy finished with 12 total hits, including a team-high four hits from Logan Dowell. Venable and Reece Deaton each had two hits, while Kamden Hawks, Cameryn Wilson, Landon Cox and Brison George each had one.</p>
<p>Hawks and George each hit doubles, and Venable had a 2-run home run.</p>
<p>Ian Gallimore scored Mount Airy&rsquo;s first run in the bottom of the first inning. The sophomore was walked, moved to third on a Dowell single then scored on a ground out hit by Hawks.</p>
<p>Wilson and John Penn added runs No. 2 and No. 3 in the next inning. Wilson led the inning with a single, and Penn was walked. An error on a George hit brought Wilson in, then Penn scored on a hit from Venable.</p>
<p>Dowell crossed the plate for run No. 4 in the bottom of the third thanks a bomb hit to the center field fence by Hawks.</p>
<p>After slowly building a lead through three innings, Mount Airy exploded for six runs in the fourth. George, who was the first of 12 batters for the Bears in the inning, led with a double, then Venable smashed a homer to increase Mount Airy&rsquo;s lead to 6-1.</p>
<p>Gallimore was walked to prompt a pitching change for the visitors. The substitution didn&rsquo;t pay off, though, as Gallimore stole second then scored on a Dowell single.</p>
<p>Dowell advanced to third on a wild pitch, then Hawks was walked to put runners on the corners. Cash Hemric, running for Hawks, took a lead off of first and Queen&rsquo;s Grant attempted to pick him off. An errant throw sent Hemric to second and scored Dowell to increase the lead again to 8-1.</p>
<p>Deaton scored Hemric with an RBI single, then Deaton scored on a hit from Landon Cox to make it 10-1.</p>
<p>The Stallions last chance to put runs up ended after three batters after Gwyn struck out three-in-a-row in the top of the fifth. Dowell had his fourth single in the bottom of the inning and stole his way around the bases before scoring on a Deaton hit.</p>
<p>No. 8 Mount Airy advances to the Round of 32 and will host No. 9 Bethany on May 13. Bethany (18-9) finished second in the Northwest Piedmont 1A Conference and defeated No. 24 Mitchell 8-3 in the opening round.</p>
<p>Scoring</p>
<p>Queen&rsquo;s Grant &#8211; 1, 0, 0, 0, 0, X, X = 1</p>
<p>Mount Airy &#8211; 1, 2, 1, 6, 1, X, X = 11</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/sports/107515/east-surry-golf-wins-2a-state-championship" title="East Surry Golf wins 2A State Championship" style="color:black">East Surry Golf wins 2A State Championship</a></h1>

            <a href="https://www.mtairynews.com/sports/107515/east-surry-golf-wins-2a-state-championship" title="East Surry Golf wins 2A State Championship">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/05/128501545_web1_IMG_4654.jpg" alt="East Surry Golf wins 2A State Championship">
            </a>
   <p class="entry-meta">May 11, 2022</p>
   <p>PINEHURST &mdash; After finishing State Runner-Up in 2019 and 2021, East Surry&rsquo;s golf team finally won the ultimate prize in 2022.</p>
<p>The Cardinals dominated the second day of competition at Foxfire Resort&rsquo;s Red Fox Course to secure the 2A State Championship. The title is East Surry&rsquo;s seventh in school history, and the program&rsquo;s first since winning four consecutive titles from 2005-2008.</p>
<p>&ldquo;I&rsquo;m so proud and excited for those young men who worked so hard to get here,&rdquo; said East Surry coach Darrin Haywood. &ldquo;I would probably say that it was more of a feeling of relief than anything else. We have been so close and right there on the cusp so many times. Me and the boys were waiting for all scores to be counted, saying &lsquo;We&rsquo;re not believing it until it&rsquo;s up on the board.&rsquo; Then they called me up there and it was just surreal.&rdquo;</p>
<p>Haywood called the entire second day of competition a &ldquo;very exciting but nerve-wracking five hours.&rdquo;</p>
<p>East Surry finished the first day of competition tied for top overall spot with Midway High School. Though the Cards were in a prime position to win the state title, the team felt it hadn&rsquo;t performed up to its potential through the first 18 holes.</p>
<p>&ldquo;Monday, when we posted our score we knew that was not our best golf,&rdquo; Haywood said. &ldquo;We didn&rsquo;t feel great being the first ones to post, but when we saw we were even with [Midway] it kind of relaxed our guys. Our kids knew that we had a lot left in us, and even though we didn&rsquo;t play to East Surry&rsquo;s standard of golf we were still tied for first.</p>
<p>&ldquo;We weren&rsquo;t behind anyone and it was ours for the taking. The kids showed a lot of confidence, saying &lsquo;we&rsquo;ve been here before. We&rsquo;ve done as bad as we&rsquo;ve done all year and are still in the perfect position to win.&rdquo;</p>
<p>After combining to shoot 328 after the first day, East Surry bested Midway&rsquo;s foursome by eleven strokes, 326 to 337, on the second 18 holes.</p>
<p>The Cardinals were led both days by Bradley Davis Jr. Davis shot 75 (+3) on the first 18 holes, which was just one shot in back of the overnight leader, Drew O&rsquo;Neal from Beddingfield.</p>
<p>Davis matched his +3 round from the first day on the final day to put up a superb 6+ total for the tournament. Midway&rsquo;s Logan Atkins posted the only even-par round of the tournament in the Final Round to pair with his opening round 76 (+4), winning the individual title by two shots over his counterpart from East Surry.</p>
<p>Atkins won the individual championship with a two-day total of 148, and Davis finished as State Runner-up with a total score of 150</p>
<p>&ldquo;The thing about Bradley is that he&rsquo;s just so consistent,&rdquo; Haywood said. &ldquo;He stays even keel and never gets rattled, and those are just some of the qualities that make him a very good golfer. He knew he was in the running for the top spot this week, and never got worried even when he didn&rsquo;t play his best &#8211; which was still very good &#8211; in the first round.</p>
<p>&ldquo;Brad might hit a rough shot then look at me and ask how everybody else was doing. It says a lot about him as a young man to care first about the team accolades. These guys love each other and wanted each other to succeed. It was always team-first with them.&rdquo;</p>
<p>Following Davis, East Surry also got outstanding rounds from the rest of their scoring foursome to solidify the victory on the final day of the event. Chase Harris shot 78 (+6) thanks to a pair of matching 39&rsquo;s on the front and back nine. Connor Key and Anderson Badgett contributed an 86 and an 87, respectively.</p>
<p>Also contributing to the Cards&rsquo; success was what Haywood called a &lsquo;caravan of fans&rsquo; supporting the team.</p>
<p>&ldquo;So much of the community was there and I was so surprised,&rdquo; Haywood said. &ldquo;There were people I never thought I&rsquo;d see there just because they didn&rsquo;t have a family member playing. It was incredible to see.</p>
<p>&ldquo;Those kids see that everybody is there supporting them; not to make them nervous or add pressure, but to offer genuine support and see good golf. It helped the kids relax and feel like home. They were surrounded by people they grew up around and saw their entire life there to cheer them on. I think that really helped.&rdquo;</p>
<p>East Surry added another piece of hardware when the N.C. High School Athletic Association presented the 2A Men&rsquo;s Golf Championship Sportsmanship Award to Jordan Davis.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/sports/107466/bears-fall-in-regional-semifinal" title="Bears fall in Regional Semifinal" style="color:black">Bears fall in Regional Semifinal</a></h1>

            <a href="https://www.mtairynews.com/sports/107466/bears-fall-in-regional-semifinal" title="Bears fall in Regional Semifinal">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/05/128493427_web1_DSC_0231--2-.jpg" alt="Bears fall in Regional Semifinal">
            </a>
   <p class="entry-meta">May 09, 2022</p>
   <p>The third time was the charm for Elkin in its dual team series against Mount Airy.</p>
<p>After both regular season meetings went to the Granite Bears, the Buckin&rsquo; Elks went on the road Monday to face Mount Airy in the third round of the 1A State Playoffs. Mount Airy first defeated Elkin 6-3 on March 24, then secured the Northwest 1A Conference Championship by defeating the Elks 5-4 on April 12.</p>
<p>Another close match went the way of the Elks this time. Elkin defeated Mount Airy 5-4 on May 9 to advance to the 1A West Regional Championship. The Buckin&rsquo; Elks set up another third meeting in the regional final, as Elkin is set to face Bishop McGuinness for a shot at the 1A State Championship.</p>
<p>The May 9 edition of the Bears-Elks rivalry saw Elkin win three singles matches for the first time; Mount Airy held a 4-2 advantage after singles in each of the previous two meetings. Similar to the teams&rsquo; two regular season matches, Mount Airy won the top three singles matches: No. 1 Georgie Kriek defeated Owen Jennings 6-1, 6-4, No. 2 Carson Hill defeated Thomas McComb 6-1, 6-2, and No. 3 John Juno defeated Jack Zamudio 6-0, 6-3.</p>
<p>In addition to the top three spots, Mount Airy won No. 6 singles in its first meeting with Elkin and No. 5 singles in the second meeting. This time, however, Elkin swept courts No. 4-No. 6: Luke McComb topped Connor Sechrist 6-4, 6-1, Clay Sebastian bested Kieran Slate 6-1, 6-1, and Addison Blackwelder defeated Martin Cooke 6-1, 3-6, 1-0 (10-4).</p>
<p>Just as Mount Airy won the top three singles matches in all three meetings against Elkin, the Bears also won No. 1 doubles in all three. Kriek and Hill were the victors each time, defeating Jennings and Luke McComb in the first two meetings and topping Thomas McComb and Zamudio in round three, 8-2.</p>
<p>Elkin slid its top singles player, Jennings, to No. 2 doubles for the playoff match. Jennings teamed with Blackwelder to defeat Juno and Dylan Tilley 8-1.</p>
<p>This left all eyes on No. 3 doubles where Luke McComb and Sebastian took on Cooke and Jared Pinto. Elkin took a 1-0 lead before Mount Airy won back-to-back games. Luke McComb and Sebastian responded with two-straight wins, then Mount Airy tied the game score at 3-3 behind Pinto&rsquo;s serve.</p>
<p>Elkin won three-straight to make it 6-3. The Bears won on Pinto&rsquo;s serve again to cut the lead to 6-4, but Elkin won the next two games to seal the victory.</p>
<p>Mount Airy&rsquo;s season ends at 15-5 overall. Monday&rsquo;s loss was the Bears&rsquo; only defeat at the hands of a fellow 1A team.</p>
<p>Elkin improves to 14-5 with the playoff victory. The Elks will need another strong performance to get past Bishop McGuinness (15-1), who previously defeated Elkin 7-2 on March 30.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/sports/107452/cardinal-baseball-honors-six-seniors" title="Cardinal baseball honors six seniors" style="color:black">Cardinal baseball honors six seniors</a></h1>

            <a href="https://www.mtairynews.com/sports/107452/cardinal-baseball-honors-six-seniors" title="Cardinal baseball honors six seniors">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/05/128492581_web1_IMG_4416.jpg" alt="Cardinal baseball honors six seniors">
            </a>
   <p class="entry-meta">May 09, 2022</p>
   <p>East Surry recognized six seniors prior to an April 28 home game against Surry Central.</p>
<p>The Cardinals honored Peyton Inscore, Tristen Mason, Anthony Ward, Trey Armstrong, Luke Bowman and Anthony Ayers ahead of the team&rsquo;s final regular season home game at Barry Hall Field. East Surry went on to win the game 8-1.</p>
<p>East won the Foothills 2A Conference Regular Season Championship with a 12-0 conference record, then went on to defeat West Wilkes and North Surry to win the FH2A Tournament Championship.</p>
<p>The Cardinals (21-1) earned the No. 4 seed in the 2A West and will host No. 29 Hendersonville (9-13) on May 10.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/sports/107446/lady-cards-honor-softball-seniors" title="Lady Cards honor softball seniors" style="color:black">Lady Cards honor softball seniors</a></h1>

            <a href="https://www.mtairynews.com/sports/107446/lady-cards-honor-softball-seniors" title="Lady Cards honor softball seniors">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/05/128492427_web1_DSC_0961_2.jpg" alt="Lady Cards honor softball seniors">
            </a>
   <p class="entry-meta">May 09, 2022</p>
   <p>PILOT MOUNTAIN &mdash; East Surry softball recognized four senior softball players ahead of an April 27 home game against West Stokes.</p>
<p>The four seniors &#8211; Rosie Craven, Maegan Banks, Haley Chilton and Clara Willard &#8211; were all four-year members of the varsity softball team. The Lady Cards dropped their Senior Night game 9-1, but turned around and won the regular-season finale the next night by defeating Surry Central 8-3.</p>
<p>East Surry finished the 2022 season 5-14 overall and 4-8 in the Foothills 2A Conference.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/sports/107437/greyhounds-honor-soccer-seniors" title="Greyhounds honor soccer seniors" style="color:black">Greyhounds honor soccer seniors</a></h1>

            <a href="https://www.mtairynews.com/sports/107437/greyhounds-honor-soccer-seniors" title="Greyhounds honor soccer seniors">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/05/128492282_web1_NSHS-Seniors.jpg" alt="Greyhounds honor soccer seniors">
            </a>
   <p class="entry-meta">May 09, 2022</p>
   <p>North Surry recognized seven senior student-athletes during an April 29 home match against North Wilkes.</p>
<p>The seven Greyhound seniors are: Savannah Seal, Camila Flores, Isabel Delfin, Weatherly Reeves, Nydia Cabrera, Callie Allen and Eve Bodnar.</p>
<p>North Surry defeated North Wilkes 6-0 to win its second Foothills 2A Conference match. The Greyhounds finished 2-10 in the FH2A Conference.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/sports/107428/mount-airy-softball-ends-playoff-drought" title="Mount Airy softball ends playoff drought" style="color:black">Mount Airy softball ends playoff drought</a></h1>

            <a href="https://www.mtairynews.com/sports/107428/mount-airy-softball-ends-playoff-drought" title="Mount Airy softball ends playoff drought">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/05/128485483_web1_FRjsb2jWYAElQic-382x509.jpg" alt="Mount Airy softball ends playoff drought">
            </a>
   <p class="entry-meta">May 09, 2022</p>
   <p>Mount Airy softball&rsquo;s four senior players helped the team end a seven-year playoff drought.</p>
<p>Skylar Partin, Sofia Stafford, Sydney Seagraves and Savannah Horne were in the fifth grade the last time the Granite Bears made the playoffs. The 2015 team finished the regular season 6-11 overall and was named the No. 26 seed in the 1A West, where the Bears faced No. 7 Avery County in the opening round and lost 13-3.</p>
<p>Mount Airy finished just outside the playoff picture in 2016 and 2017, then wasn&rsquo;t able to field a varsity team in 2018 &#8211; the class of 2022&rsquo;s eighth-grade year.</p>
<p>This senior class has faced tough odds during its four years. The 2019 Bears had just two upperclassmen and played a brutal conference schedule that included four games against the eventual 1A State Champion North Stokes.</p>
<p>Things were looking up for the 2020 Bears after picking up a program-defining road win against East Wilkes, but then the season was shut down just days later due to COVID-19. The 2021 season was also an anomaly as teams were only allowed to play a maximum of 14 games, but the team showed improvement by starting the season 4-1.</p>
<p>The 2022 Bears lost some key pieces from the year before, but that didn&rsquo;t stop them from competing. This year&rsquo;s team finished the regular season 4-15 overall and 4-8 in the Northwest 1A Conference.</p>
<p>Seagraves was selected for the NW1A All-Conference squad, while Stafford and Partin were named All-Conference Honorable Mentions.</p>
<p>Mount Airy, seeded No. 27 in the 1A West, travels to No. 6 Cornerstone Charter on May 10. Cornerstone finished the regular season 14-2 overall and finished first in the Northwest Piedmont 1A Conference.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/sports/107423/kriek-motsinger-reach-state-semifinals" title="Kriek, Motsinger reach state semifinals" style="color:black">Kriek, Motsinger reach state semifinals</a></h1>

            <a href="https://www.mtairynews.com/sports/107423/kriek-motsinger-reach-state-semifinals" title="Kriek, Motsinger reach state semifinals">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/05/128491569_web1_My-project--3-.jpg" alt="Kriek, Motsinger reach state semifinals">
            </a>
   <p class="entry-meta">May 09, 2022</p>
   <p>Local tennis players competed in the NCHSAA Individual State Championship Tournaments on May 6-7.</p>
<p>Three singles athletes and two doubles teams from local schools qualified for their respective state tournaments. One singles player from Mount Airy competed in the 1A State Tournament held at Cary State Park, while two singles players from East Surry and two doubles duos from Surry Central competed in the 2A State Tournament at Ting Park in Holly Springs.</p>
<p>The 1A Tournaments featured eight entries per bracket, and the 2A Tournaments had 16 entries per bracket.</p>
<p><strong>1A Singles</strong></p>
<p>Mount Airy junior Georgie Kriek reached the 1A State Tournament for a second consecutive season. In 2021, Kriek was one of eight state qualifiers and fell to Raleigh Charter&rsquo;s Ryan Hill in a three-set thriller in the opening round.</p>
<p>Kriek had little trouble advancing to the state semifinals in 2022 after finishing second in the 1A Midwest Regional Tournament. The Granite Bear defeated Clover Garden&rsquo;s Will Oldham 6-0, 6-0 in the opening round.</p>
<p>Kriek ran into Langtree Charter&rsquo;s Nikhil Deshpande in the semifinals and fell 6-1, 6-2. Deshpande went on to win the 1A Singles Championship with a 6-1, 6-0 win in the finals.</p>
<p>Kriek&rsquo;s season will continue as Mount Airy still stands in the 1A Dual Team State Playoffs.</p>
<p><strong>2A Singles</strong></p>
<p>East Surry&rsquo;s No. 1 and No. 2 seeds this season both competed in the 2A State Singles Tournament. Both were first-time state qualifiers.</p>
<p>Top-seeded Cooper Motsinger, a senior, entered as the 2A Midwest Regional Champion. His Cardinal teammate Levi Watson, a sophomore, qualified as the fourth-place finisher at regionals.</p>
<p>Watson had the unfortunate draw of facing Pine Lake Prep&rsquo;s Tyler Ramanata in the opening round. Ramanata, who won the 1A Singles Championship in 2021, defeated Watson 6-0, 6-1.</p>
<p>Motsinger defeated Lincoln Charter&rsquo;s Connor Milligan 6-4, 6-4 in the opening round, then topped Franklin Academy&rsquo;s Lance Keller 6-1, 6-1 in the quarterfinals.</p>
<p>Motsinger ran into Ramanata in the semifinals and fell 6-0, 6-0. Like Kriek&rsquo;s semifinal opponent, Ramanata went on to win the 2A Singles Championship. Ramanata only lost a combined three games in his four matches at the state tournament.</p>
<p><strong>2A Doubles</strong></p>
<p>All four of Surry Central&rsquo;s state qualifiers competed in their first state tournaments.</p>
<p>Central&rsquo;s top-ranked doubles team of senior Jacob Edmonds and junior Josh Pardue entered the tournament as the 2A Midwest Regional Runners-up, and the team of junior Michael Tucker and freshman Tripp McMillen were the No. 4 seed from the 2A Midwest.</p>
<p>Pardue and Edmonds dropped their first-round match to Community School of Davidson&rsquo;s Luke Breen and Julian Rizo 6-1, 6-3. Breen and Rizo won their quarterfinal match in straight sets, then lost to the eventual state champions in the semifinals.</p>
<p>Tucker and McMillen fell to Lincolnton&rsquo;s Zach Zagorkski and Piero Ravolino 6-3, 6-4 in the opening round. Zagorkski and Ravolino lost in the quarterfinals.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/sports/107346/east-surry-tops-north-to-win-fh2a-tourney" title="East Surry tops North to win FH2A Tourney" style="color:black">East Surry tops North to win FH2A Tourney</a></h1>

            <a href="https://www.mtairynews.com/sports/107346/east-surry-tops-north-to-win-fh2a-tourney" title="East Surry tops North to win FH2A Tourney">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/05/128482762_web1_DSC_0710.jpg" alt="East Surry tops North to win FH2A Tourney">
            </a>
   <p class="entry-meta">May 06, 2022</p>
   <p>MORAVIAN FALLS &mdash; East Surry pulled away from North Surry on Thursday to win the Foothills 2A Conference Tournament Championship.</p>
<p>The game was closely contested until the No. 1-seeded Cards nearly doubled their number of hits and runs in an explosive sixth inning. The No. 3 Greyhounds continued to battle and scored again in the top of the seventh, and even had two players on base when the final strikeout was thrown.</p>
<p>A 9-4 win over its county foe gave East Surry its 14th conference tournament championship in the program&rsquo;s history.</p>
<p>&ldquo;We have a lot of respect for the North Surry baseball program, and Coach [Daryll] Johnson always has them well-prepared,&rdquo; said East Surry coach Chad Freeman. &ldquo;They won 10-of-11 coming into the championship so we knew they were a scrappy bunch. We made some mistakes, but came up with key hits at some key times.</p>
<p>&ldquo;A lot of guys stepped up for us, so hopefully this will give us some momentum as we prepare for state playoffs.&rdquo;</p>
<p>East and North Surry are two programs very familiar with conference tournament championship games. East won the Northwest 1A Conference Tournament Championship in 2013-15, 2017 and 2018, then finished tournament runner-up in 2019. North won the Western Piedmont 2A Conference Tournament Championship in 2019, and was runner-up in 2017 and 2018.</p>
<p>No conference tournaments were held in 2020 or 2021.</p>
<p>&ldquo;I&rsquo;m incredibly proud of the guys for fighting to get here and putting us in a position to compete for a championship,&rdquo; Johnson said. &ldquo;The box scores were almost identical, but East Surry was able to get his when they needed them and they made some big plays. They have a culture they live by and they&rsquo;ve been very successful. We have culture too, and we want to be successful every time we go out there. Success is measured a lot of different ways, and I don&rsquo;t always judge on what the scoreboard says.</p>
<p>&ldquo;We&rsquo;re not done. We&rsquo;re gonna get ready for wherever we have to go if we&rsquo;re blessed with a playoff berth.&rdquo;</p>
<p>The road to the FH2A Championship</p>
<p>North felt it had unfinished business with top-seeded East Surry after the most recent meeting between the teams. The Cardinals came away with the 2-1 win despite not advancing past second base past the third inning. The Greyhounds loaded the bases three times after scoring their only run, but couldn&rsquo;t convert a run.</p>
<p>&ldquo;Honestly, I thought they outplayed us in that game at our place,&rdquo; Freeman said. &ldquo;We weren&rsquo;t as sharp as we should&rsquo;ve been, we were just fortunate to make the plays needed to pick up the win. As a whole, they were better prepared for game two even though we won the game.&rdquo;</p>
<p>Knowing his team had shown they could compete with East, the top-ranked team in the FH2A Conference, served as extra motivation for Johnson and the Greyhounds.</p>
<p>&ldquo;It was a bad feeling coming out of that game, and we took that game and grew from it,&rdquo; Johnson said. &ldquo;If the ball had bounced our way a few times when it didn&rsquo;t, things might&rsquo;ve ended differently. That game, like the ones against Forbush and the game at West Wilkes, was a wake-up call for us.&rdquo;</p>
<p>North Surry&rsquo;s 17-11 loss at West Wilkes on April 4 was a turning point for the team. The Greyhounds, who fell to 6-7 overall following the loss, committed a season-high nine errors against the Blackhawks.</p>
<p>&ldquo;We had a team meeting and discussed some things that will stay between us as a team,&rdquo; Johnson said. &ldquo;They agreed it was unacceptable. We weren&rsquo;t mentally tough at the beginning of the season and, while we&rsquo;re not completely where we want to be, we&rsquo;ve come a long way since then.&rdquo;</p>
<p>The Greyhounds proceeded to win 10 of their next 11 games, including a 3-0 win over No. 2-seeded Forbush to reach the conference championship game. Forbush defeated North Surry 8-2 and 9-1 in their two regular season meetings.</p>
<p>&ldquo;It&rsquo;s been a long season, but it&rsquo;s been a good season,&rdquo; Johnson said. &ldquo;I&rsquo;ve watched other teams and seen how they respond to adversity, then take a look at mine. I wouldn&rsquo;t trade my guys for anything&#8230;there&rsquo;s a lot of respect in that dugout for the people inside our circle. That&rsquo;s got us to where we&rsquo;re at.&rdquo;</p>
<p>East Surry, meanwhile, had to grind out wins in multiple close games to keep its undefeated conference campaign alive. This included two close games against Forbush, the aforementioned win over North Surry, a come-from-behind win at West Wilkes and a victory at Surry Central to close the regular season.</p>
<p>The No. 1 Cardinals defeated No. 4 West Wilkes 10-1 to reach the conference tournament championship.</p>
<p>&ldquo;We made sure to emphasize in practice that we couldn&rsquo;t take North Surry lightly, and the guys knew that,&rdquo; Freeman said. &ldquo;We talked about it and no one on our team has been part of a conference tournament championship team. It&rsquo;s something special, and North is playing for the same prize.&rdquo;</p>
<p>&ldquo;Another wildcard is that we never faced Cam Taylor in the regular season either. He threw great for them the second half of the conference season, and we really weren&rsquo;t sure what to expect.&rdquo;</p>
<p>Trading Haymakers</p>
<p>Freeman likened the tournament championship to a heavyweight boxing match.</p>
<p>&ldquo;It was like two good boxers going back-and-forth with each other,&rdquo; Freeman said. &ldquo;One side would get on a run with a few quality punches, then the other would fight back and gain momentum. It was a great quality game, and that&rsquo;s what you expect for a championship.&rdquo;</p>
<p>North Surry (16-9) was first on the board with a run in the top of the first inning. Leadoff Ethan Edwards reached first on a Cardinal fielding error, moved to second and then third on a pair of wild pitches. James McCreary scored Edwards with a blooper over the third baseman&rsquo;s head.</p>
<p>The Cardinals (21-1) mirrored the Hounds and put their leadoff on first after a fielding error. Trey Armstrong was hit by a pitch and then Folger Boaz was walked to load the bases with no outs. After picking up a strikeout, North Surry pitcher Cam Taylor walked Anthony Ayers to bring Luke Bowman across the plate to tie the game.</p>
<p>North faced another set of loaded bases after the walk, but turned a double play to end the inning. Caden Lasley hit a grounder to Edwards and first, and Edwards rifled a throw to Brodie Robertson at home for the force out. Robertson quickly threw back to Edwards at first for the third out of the inning.</p>
<p>East Surry added three runs in the bottom of the second to take its first lead of the evening. Matthew Keener and Bowman each singled, and Tristen Mason was walked to load the bases similar to the first inning. Armstrong, who was named Most Outstanding Player of the FH2A Tournament, hit a 2RBI single to Keener and Mason.</p>
<p>&ldquo;Trey was just phenomenal all tournament; he really played out of his mind,&rdquo; Freeman said. &ldquo;He played great in the field and had that spectacular diving save. Throughout the entire tournament, he only got out once at the plate.&rdquo;</p>
<p>A sacrifice fly hit by Boaz brought Bowman in to make it a 4-1 game.</p>
<p>North Surry returned fire in the top of the third when Edwards and Kolby Watson hit singles. A Cardinal error on Watson&rsquo;s hit allowed the runners to advance to second and third, then Robertson joined his teammates after being hit by a Luke Brown pitch.</p>
<p>Myles Draughn scored Edwards with a single to make it 4-2. The Cardinals got Watson out when he attempted to go home, but a ground out hit by McCreary allowed Trevor Isaacs &#8211; running for Robertson &#8211; to score and make it 4-3.</p>
<p>The Cardinals added an insurance run in the bottom of the fourth inning when Boaz grounded out to score Bowman. North Surry had chances to retaliate in the fifth and sixth, but left two runners on base each time.</p>
<p>The Hounds caught some bad luck in the sixth inning with runners on the corners. Edwards was up to bat and faced a 2-2 count. Edwards attempted to dodge a pitch thrown his way, but his bat inadvertently made contact with the ball. Taylor never got the chance to run home on the wild pitch since it was ruled a foul ball, and it made the count stay at 2-2 instead of going to 3-2. Brown struck Edwards out on the next pitch.</p>
<p>East Surry went to the top of the lineup in the bottom of the sixth and erupted for back-to-back doubles, put a runner on base with an intentional walk and then rattled off two more doubles to increase their lead to 9-3. North Surry led the hit-count 7-6 prior to the bottom of the sixth.</p>
<p>&ldquo;We just took good approaches, and when we got pitches to hit we took advantage of it,&rdquo; Freeman said. &ldquo;We also had strong baserunning throughout the game.&rdquo;</p>
<p>The Greyhounds continued to battle and added a run in the top of the seventh. The Cards committed two fielding errors that opened the door for Watson to score, but North once again left two runners on base.</p>
<p>&ldquo;I&rsquo;m proud of them, and I&rsquo;ve been sure to tell them that,&rdquo; Johnson said. &ldquo;It&rsquo;s been tough to get where we are, and it&rsquo;s definitely not been easy. But, we don&rsquo;t want it to be easy. That&rsquo;s how you get better.</p>
<p>&ldquo;Hopefully we get a good draw in playoffs. We played some bad games and had some bad performances, so we put ourselves here and now we&rsquo;ve got to do something about it.&rdquo;</p>
<p>Taylor spent 5.1 innings on the mound for North Surry. He threw two strikeouts, hit batters, walked three and allowed eight runs on eight hits. McCreary threw the final .2 innings and allowed one run on two hits.</p>
<p>Brown got the win on the mound for East by throwing six strikeouts, two walks, and giving up three runs on seven hits in 6.0 innings. Anthony Ayers pitched the final inning and had one strikeout, one walk and allowed one run.</p>
<p>Scoring</p>
<p>North Surry &#8211; 1, 0, 2, 0, 0, 0, 1 = 4</p>
<p>East Surry &#8211; 1, 3, 0, 1, 0, 4, X = 9</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/sports/107354/eagles-honor-softball-seniors" title="Eagles honor softball seniors" style="color:black">Eagles honor softball seniors</a></h1>

            <a href="https://www.mtairynews.com/sports/107354/eagles-honor-softball-seniors" title="Eagles honor softball seniors">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/05/128485228_web1_279392066_10224320669097506_3740942825284923333_n.jpg" alt="Eagles honor softball seniors">
            </a>
   <p class="entry-meta">May 06, 2022</p>
   <p>The Surry Central softball team recognized its four senior athletes prior to an April 28 home game against East Surry.</p>
<p>Arial Holt, Alyssa Woods, Carlee Jones and Emma Gentry rode onto the field in style on the back of motorcycles. Each senior was presented gifts by the team and recognized before the start of the game. East Surry won the regular season finale 8-3.</p>
<p>Surry Central was given the No. 6 seed in the Foothills 2A Conference Tournament and traveled to No. 3 Wilkes Central on May 2. Surry Central broke a winning drought by upsetting Wilkes Central 15-4. Wilkes Central came into the conference tournament having won nine of its past 11 games, and its only two losses came against eventual conference champion and conference tournament champion Forbush.</p>
<p>The Golden Eagles faced No. 2 West Wilkes in the FH2A semifinals. West Wilkes jumped out to a 4-0 lead, but couldn&rsquo;t put Surry Central away. The Eagles cut the lead to 4-2 with a 2RBI single hit by Kailea Zurita in the top of the fifth inning, then tied the game on a 2RBI double hit by Woods in the top of the sixth inning.</p>
<p>West Wilkes rallied and put up five runs in the bottom of the sixth, then held Surry Central scoreless in the top of the seventh.</p>
<p>Surry Central sits at 4-14 as it waits for a potential postseason bid to the 2A State Playoffs.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/sports/107311/fh2a-track-championship-results-2" title="FH2A Track Championship Results" style="color:black">FH2A Track Championship Results</a></h1>

            <a href="https://www.mtairynews.com/sports/107311/fh2a-track-championship-results-2" title="FH2A Track Championship Results">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/05/128470657_web1_279088677_2091046074395924_2884272993167393041_n.jpg" alt="FH2A Track Championship Results">
            </a>
   <p class="entry-meta">May 04, 2022</p>
   <p>DOBSON &mdash; Surry Central hosted the 2022 Foothills 2A Conference Track and Field Championship on April 28.</p>
<p>Surry Central&rsquo;s girls and Wilkes Central&rsquo;s boys came away with the team conference championships. Points were awarded for each top-8 finish: 10 points for first place, 8 for second, 6 for third, 5 for fourth and one fewer point through eighth place.</p>
<p>Surry Central senior Mia McMillen was named FH2A Female Athlete of the Year, and Golden Eagle coach Kevin Pack was named Girls Coach of the Year.</p>
<p>Wilkes Central senior Terry Hayes was named Male Athlete of the Year, and his coach Anthony Smith was named Coach of the Year.</p>
<p>Team results and individual breakdowns are included below for each Surry County school. Full meet results can be found at <a href="https://bit.ly/3MMXWqY" target="_blank" rel="noopener noreferrer">bit.ly/3MMXWqY</a></p>
<p><strong>Girls team scores</strong></p>
<p>1 Surry Central 145</p>
<p>2 Forbush 143</p>
<p>3 West Wilkes 109</p>
<p>4 East Surry 103</p>
<p>5 North Wilkes 69.5</p>
<p>6 Wilkes Central 69</p>
<p>7 North Surry 35.5</p>
<p>SURRY CENTRAL</p>
<p>Four of Surry Central&rsquo;s eight gold medals were won by McMillen, who repeats as female athlete of the year.</p>
<p>McMillen was the only athlete at the conference championship &#8211; in boys or girls &#8211; that won four gold medals in individual events. McMillen took first in the long jump, 100-meter hurdles, 300-meter hurdles and 100-meter dash.</p>
<p>Yeira Munoz had Surry Central&rsquo;s remaining gold in track events by winning the 3,200 meters, and Ivy Toney added a gold from a field event by winning pole vault.</p>
<p>Toney and Munoz helped the Lady Golden Eagles win gold in two relays. Toney, Andrea Gonzalez, Ella Priddy and Madelyn Wilmoth won the 4&#215;400, and Munoz, Priddy, Toney and Wilmoth won the 4&#215;800.</p>
<p>Surry Central had two second-place finishes and three third-place finishes.</p>
<p>Priddy finished second in the 400 meters, while Cassie Sneed took silver in the discus throw.</p>
<p>Toney finished just behind Priddy in the 400 meters, Munoz took third in the 1,600 meters and Lanie Fitzgerald was third in pole vault.</p>
<p>EAST SURRY</p>
<p>East Surry finished first in two events: discus throw and the 4&#215;100 relay.</p>
<p>Clara Willard won discus for the Cardinals, and also took third in shot put. The team of Faith Braithwaite, Madeline Dayton, Ember Midkiff and Arianna Liberatore won the 4&#215;100 relay.</p>
<p>East&rsquo;s 4&#215;100 team also finished second in the 4&#215;200. Two of those relay members helped the Lady Cards win three other medals: Dayton finished second in triple jump, and Braithwaite finished second in the 200 meters and third in the 100 meters.</p>
<p>The Cards&rsquo; remaining top-3 finish came from Chloe Anne Tew, who finished second in high jump.</p>
<p>NORTH SURRY</p>
<p>Greyhound freshman Ella Riggs had both of North Surry&rsquo;s top-3 finishes. Riggs won gold in shot put, then took third in discus throw.</p>
<p>North Surry had two girls finish just outside the top-3: Isabel Delfin finished fourth in the 400 meters, and Anna Escobar was fourth in shot put.</p>
<p><strong>Boys team scores</strong></p>
<p>1 Wilkes Central 217</p>
<p>2 Forbush 101.5</p>
<p>3 Surry Central 93</p>
<p>4 West Wilkes 91</p>
<p>5 East Surry 83.5</p>
<p>6 North Surry 51</p>
<p>7 North Wilkes 46</p>
<p>SURRY CENTRAL</p>
<p>Ignacio Morales and Allen Huffman each won four medals for the Golden Eagles.</p>
<p>Morales finished first in the 1,600 meters and 3,200 meters, while also finishing second in the 800 meters and third as part of Surry Central&rsquo;s 4&#215;800 relay team. Morales was joined in the 4&#215;800 by Brangly Mazariegos, Jonathan Avila and Sebastian Sanchez.</p>
<p>Huffman had the Golden Eagles&rsquo; other gold medal finish by winning the 300 hurdles. He joined Isaac Eller, Josue Rodriguez and Chris Nava on the 4&#215;400 team that finished second, and was part of two relay teams that finished third. The team of Huffman, Ayden Wilmoth, Brian Williams and Evan Wall won bronze in the 4&#215;100, and Huffman, Wilmoth, Wall and Rhylee Anderson finished third in the 4&#215;200.</p>
<p>Mazariegos had Central&rsquo;s remaining medal performance by taking third in the 1,600 meters.</p>
<p>EAST SURRY</p>
<p>Cardinal sophomore Isaac Vaden swept the throwing events by winning discus throw and shot put. Vaden&rsquo;s wins were the Cardinals&rsquo; only gold medals.</p>
<p>Cooper Motsinger added a silver medal by taking second in the 3,200 meters, and the relay team of Layton Allen, Kyle Zinn, Colby Johnson and Lindann Fleming finished second in the 4&#215;100.</p>
<p>Colby Johnson and Eli Becker each added a third-place finish. Johnson won bronze in triple jump, and Becker finished third in shot put.</p>
<p>NORTH SURRY</p>
<p>North Surry&rsquo;s three medal-winning performances were all achieved by junior Jared Hiatt. Hiatt won the FH2A Championship in long jump and triple jump, while finishing second in high jump.</p>
<p>Hiatt and Hayes had the only two performances in the meet that met the MileSplit US Second Team <a href="https://nc.milesplit.com/meets/478080-foothills-2a-conference-championship-2022/elites#.YnCXSNrMI2w" target="_blank" rel="noopener noreferrer">Standard</a>. Hiatt did so by leaping 22-11.50 feet in the long jump, and Hayes was only 3.50 inches behind him. No other athlete jumped within 3.80 feet of either Hayes or Hiatt.</p>
<p>Aaron Mauck finished just outside the top-3 with a fourth-place finish in discus throw. North Surry also had two relay teams finish fourth: Hiatt, Chuck Powers, Jake Simmons and Matthew Senter did so in the 4&#215;100, and Powers, Simmons, Senter and Elijah Shelton were fourth in the 4&#215;200.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/sports/107306/lions-end-regular-season-with-winning-streak" title="Lions end regular season with winning streak" style="color:black">Lions end regular season with winning streak</a></h1>

            <a href="https://www.mtairynews.com/sports/107306/lions-end-regular-season-with-winning-streak" title="Lions end regular season with winning streak">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/05/128478013_web1_MCA-HS-Baseball-man-9111.jpg" alt="Lions end regular season with winning streak">
            </a>
   <p class="entry-meta">May 04, 2022</p>
   <p>Millennium Charter baseball closed its regular season with the program&rsquo;s longest winning streak.</p>
<p>The Lions (6-12, 3-7 Northwest Piedmont) won back-to-back <a href="https://www.mtairynews.com/sports/107054/lions-walk-off-to-win-second-straight" target="_blank" rel="noopener noreferrer">games </a>on April 21 and 22 for their first winning streak since joining the N.C. High School Athletic Association. Following a 5-4 walk-off win over rival N.C. Leadership Academy, Millennium went on a hot streak and scored 51 runs over its next three games.</p>
<p>MCA&rsquo;s first obstacle as the season was winding down was Oak Ridge Military Academy. Millennium trailed 2-1 in the April 27 game, then exploded for six runs in the bottom of the second inning. ORMA scored one run in the top of the fourth, then the Lions responded with a 10-run inning.</p>
<p>Millennium went on to defeat Oak Ridge 17-4.</p>
<p>The Lions hammered 16 hits against ORMA. Tristan Shockley, Zeke Harrison, Calvin Devore, Hartley Devore, Ethan Holladay and Phillip Byrd each recorded two hits in the victory, while Aryan Hira, Landon Martin, Landon Jarrell and Evan Key recorded one hit each.</p>
<p>Byrd led the Lions with four RBIs, and Shockley had three.</p>
<p>Byrd, Martin and the Devore&rsquo;s split time on the mound, combining to throw five strikeouts, four walks and allow three hits.</p>
<p>Millennium closed the regular season with a Senior Night double-header against Carver. The Lions&rsquo; six senior players were recognized before the start of game No. 1: Key, Harrison, Jarrell, Shockley, Calvin and Hartley Devore.</p>
<p>The seniors went home happy with wins of 16-1 and 18-0.</p>
<p>Byrd pitched one game and nine strikeouts while allowing no hits. Hartley Devore and Holladay threw the other game, combing to strike out three batters.</p>
<p>Across two games: Byrd and Hartley Devore each had six hits; Shockley, Holladay and Key each had three hits; Martin had two hits; and Harrison, Jarrell and Calvin Devore each had one hit.</p>
<p>Millennium and N.C. Leadership Academy tied for fourth in the NWPC and played each other in the first round of the conference tournament. NCLA won that game 7-1 to advance to the tournament semifinals.</p>
<p>Millennium now waits to see if it will receive a bid for the 1A State Playoffs.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/sports/107295/lady-bears-drop-first-match-in-ot" title="Lady Bears drop first match in OT" style="color:black">Lady Bears drop first match in OT</a></h1>

            <a href="https://www.mtairynews.com/sports/107295/lady-bears-drop-first-match-in-ot" title="Lady Bears drop first match in OT">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/05/128477896_web1_DSC_1745--1-.jpg" alt="Lady Bears drop first match in OT">
            </a>
   <p class="entry-meta">May 04, 2022</p>
   <p>WALNUT COVE &mdash; No. 5 ranked South Stokes handed No. 4 Mount Airy its first loss of the season on Friday with a 3-2 come-from-behind overtime win in the Northwest 1A Conference.</p>
<p>With the win, the Sauras tied the Bears atop the conference with one loss each.</p>
<p>&ldquo;The girls played as a team, and we kept our composure in a very physical game,&rdquo; said Sauras&rsquo; coach Danny Bowman. &ldquo;We maintained during the first half, but we also allowed them to control too much of the game. In the second half, we slowed down a little and played our game. We stepped up in the overtime period and scored our third goal early. It gave us the confidence we needed to hold on and get the win.&rdquo;</p>
<p>The Bears&rsquo; Grey Moore gave her team an early 1-0 lead at the 31:14 mark of the first half. The senior scored on a header with the help of a pass from Karyme Bueno off a corner kick.</p>
<p>Mount Airy was able to take advantage of the physicality between both teams with 22 minutes left in the first half. The Sauras were called for a foul so Moore lined up for a free kick from 25 yards out. Moore&rsquo;s kick bounced over the Sauras&rsquo; initial front line and then took a spinning bounce past goalie Alicia Rangel for a 2-0 advantage into the half.</p>
<p>Both teams had moments of control in the first 10 minutes of the second half until South&rsquo;s Ella Carroll closed the gap with a goal with 29:49 left in the contest.</p>
<p>Mount Airy controlled the next 20-plus minutes of play, keeping the ball on the Sauras&rsquo; defensive side of the field. Rangel continue to make saves in the goal to keep her team within striking distance.</p>
<p>With 8:57 left in the match, senior Jenna Shotton, who committed to play for Guilford College earlier in the day, took an unexpected shot from 40 yards out on the right hash. The senior&rsquo;s kick sailed over multiple Bear defenders and found the back of the net, tying the contest and eventually sending the game into overtime.</p>
<p>The teams played two 10-minute overtime periods, with the Sauras scoring with 5:45 left in the first 10 minutes on of a corner kick by Shotton. Her kick found Abby Tilley in the middle of the field, and she placed the ball over the out-stretched hands of the Bears&rsquo; goalie Mackenzie Hudson giving the home team&rsquo;s its first lead of the game.</p>
<p>The Sauras held strong and were able to withstand a fury of kicks by the Bears in the last minute of the game to get the win and draw even in the standings.</p>
<p>Rangel finished the game with 14 saves on 22 shots from the Bears. Hydson recorded 13 saves on 20 South Stokes&rsquo; shots.</p>
<p>South Stokes improved to 14-3 overall and 8-1 in league play after its 7-0 win over county-rival North Stokes on Tuesday. Shotton scored her conference leading 29th and 30th goals of the season in the win.</p>
<p>Mount Airy dropped to 14-1-4 overall and 8-1 in league play.</p>
<p>The Sauras travel to Elkin (11-3-1, 7-2) on Thursday and the Bears go to Alleghany (5-6, 5-5). The Elks gave South its only loss in league play with a 3-2 overtime victory in Walnut-Cove two weeks ago.</p>
<p>Robert Money can be reached at 336-749-1193.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/sports/107299/cards-capture-regional-golf-championship" title="Cards capture Regional Golf Championship" style="color:black">Cards capture Regional Golf Championship</a></h1>

            <a href="https://www.mtairynews.com/sports/107299/cards-capture-regional-golf-championship" title="Cards capture Regional Golf Championship">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/05/128472291_web1_ESgolf.jpg" alt="Cards capture Regional Golf Championship">
            </a>
   <p class="entry-meta">May 04, 2022</p>
   <p>LEXINGTON &mdash; New classification, same result.</p>
<p>East Surry captured its second consecutive regional golf championship on Monday by winning the 2022 2A Midwest Regional Championship. The tournament was held at the Sapona Country Club in Lexington on May 2.</p>
<p>The Cardinals won the 1A Midwest Regional Title in 2021, then secured the 2A Midwest Regional Title this season.</p>
<p>&ldquo;Winning the regional is one goal that we set before the season started,&rdquo; said East Surry coach Darrin Haywood. &ldquo;It was great to watch the guys compete on a tough course that demanded accuracy. I also am proud of our individual scores from Monday.&rdquo;</p>
<p>The Cardinals won the regional championship by 19 strokes, with East&rsquo;s top four golfers all finishing in the top-10. The top three teams automatically qualified for the 2A State Championship Meet.</p>
<p>Team scores</p>
<p>1. East Surry 314</p>
<p>2. Salisbury 333</p>
<p>3. West Davidson 337</p>
<p>4. Wheatmore 349</p>
<p>5. Forbush 357</p>
<p>6. West Stokes 360</p>
<p>7. Surry Central 374</p>
<p>8. Morehead 382</p>
<p>9. North Stanly 388</p>
<p>10. Providence Grove 397</p>
<p>11. West Stanly 408</p>
<p>A total of 79 golfers competed in the 2A Midwest Regional. East Surry junior Anderson Badgett was the medalist at the event with a low score of 74.</p>
<p>Badgett&rsquo;s Cardinal teammates Chase Harris, Connor Key and Bradley Davis also finished in the top 10. Harris was fifth at 78, Key was sixth at 79 and Davis was 10th at 83.</p>
<p>The top nine individuals that weren&rsquo;t part of the three state-qualifying teams will compete as individuals at the 2A State Championship. Six local golfers fall into this category, and are listed below along with East Surry&rsquo;s individual scores</p>
<p>1. Anderson Badgett (East Surry) 74</p>
<p>2. Brandon Bowman (West Stokes) 76</p>
<p>5. Chase Harris (East Surry) 78</p>
<p>6. Connor Key (East Surry) 79</p>
<p>9. Ethan Hutchens (Forbush) 81</p>
<p>10. Bradley Davis (East Surry) 83</p>
<p>12. Carter Huffman (North Wilkes) 84</p>
<p>14. Adam Hege (Surry Central) 84</p>
<p>16. Joshua Fulk (West Stokes) 86</p>
<p>19. Aiden Lyon (Forbush) 86</p>
<p>The 2A State Championship will be held May 9-10 at the Foxfire Golf Club (Red) in Pinehurst. East Surry looks to win its first state title since 2008, which was also the last time the Cards had an individual state champion (John Welden).</p>
<p>Since winning it all in 2008, the Cardinals finished second in the state three times &#8211; 2014, 2019 and 2021 &#8211; and third three times &#8211; 2011, 2012 and 2013.</p>
<p>&ldquo;In order to win the state title as a team we have a few things to improve in our game,&rdquo; Haywood said. &ldquo;We are at the point of tweaking a few things to continue to bring our scores down. I am so excited for next week and the challenge that lies ahead at Foxfire. We are approaching the tournament one hole at a time.&rdquo;</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/sports/107271/granite-bears-rewriting-the-history-books" title="Granite Bears rewriting the history books" style="color:black">Granite Bears rewriting the history books</a></h1>

            <a href="https://www.mtairynews.com/sports/107271/granite-bears-rewriting-the-history-books" title="Granite Bears rewriting the history books">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/05/128474229_web1_FRjkQi5XEAEoLIk.jpg" alt="Granite Bears rewriting the history books">
            </a>
   <p class="entry-meta">May 03, 2022</p>
   <p>Though they may have lost a few members along the way, Mount Airy baseball&rsquo;s class of 2022 is experiencing success that the program hasn&rsquo;t seen in more than 50 years.</p>
<p>The Granite Bears defeated Elkin 5-2 in the opening round of the Northwest 1A Conference Tournament. With the May 2 victory, the Bears win their seventh consecutive game and improve to 17-7 overall. According to Mount Airy historian Doug McDaniel, Mount Airy last won eight games in a row in 1958 and most recently won at least 16 games in a season in 1939.</p>
<p>Mount Airy (17-7, 10-2 NW1A) began its current win streak on April 13. Since then, the Bears have defeated Surry Central twice, Alleghany twice and Elkin three times. The Bears have outscored opponents 75-23 during this run, which includes four games scoring in double figures.</p>
<p>The Bears, ranked No. 1 in the 1A West by MaxPreps, closed the season with a Senior Night game against Alleghany. Mount Airy&rsquo;s four senior team members are: Josh Penn, Logan Dowell, Reece McDuffie and Reece Deaton.</p>
<p>Ashton Gwyn got the win on the mound, while Dowell and Gallimore also spent time on the bump. Gwyn tossed six strikeouts, and Dowell and Landon Gallimore each had three.</p>
<p>Deaton and Rylan Venable each had two hits against the Trojans, and Brison George, Cameryn Wilson and Kamden Hawks each had one. Nine different Bears scored in the 12-2 victory.</p>
<p>The Alleghany win helped Mount Airy secure the No. 2 seed in the NW1A Tournament, allowing the Bears to host Elkin on May 2.</p>
<p>Dowell pitched five innings for Mount Airy and threw five strikeouts, one walk and allowed one run on three hits. Gwyn pitched the remainder of the game and had three strikeouts, two walks and allowed one run on three hits.</p>
<p>Deaton and Landon Cox racked up two hits each, and George, Wilson, Penn, Dowell and Hawks each had one.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/sports/107263/lady-hounds-hitting-their-stride" title="Lady Hounds hitting their stride" style="color:black">Lady Hounds hitting their stride</a></h1>

            <a href="https://www.mtairynews.com/sports/107263/lady-hounds-hitting-their-stride" title="Lady Hounds hitting their stride">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/05/128473082_web1_278795251_493641519099284_4459803561902924052_n.jpg" alt="Lady Hounds hitting their stride">
            </a>
   <p class="entry-meta">May 03, 2022</p>
   <p>Successful teams aim to peak at the right time in a season, and it appears North Surry softball is doing just that.</p>
<p>North Surry is riding a four-game winning streak in which the Hounds have outscored opponents 41-6. These four wins include: a 9-1 road victory against Surry Central, a 9-1 win over West Wilkes, an 11-0 Senior Night victory over North Wilkes and a 12-4 win over East Surry.</p>
<p>All four wins are significant as the Greyhounds (11-10, 7-5 Foothills 2A) battle for a playoff berth.</p>
<p>The win over Surry Central broke a three-game losing streak for North Surry; two of those losses were by one run to the teams that would finish first and third in the FH2A Conference. The remaining loss came against one of the top-ranked 1A teams in the state.</p>
<p>After beating Surry Central, North Surry posted possibly its biggest win of the year by upsetting West Wilkes. The Blackhawks had won eight-straight games and 13-of-14 prior to the game against North Surry. The Hounds&rsquo; 9-1 win handed West Wilkes its largest defeat of the season.</p>
<p>North Surry recognized seven senior players as part of the team&rsquo;s Senior Night game against North Wilkes: Marissa Casstevens, Trista Berrier, Sara Bledsoe, Micah Felts, Kadie Fulk, Carley Puckett and Bella Aparicio.</p>
<p>Berrier was perfect in the five-inning shutout victory. The senior pitcher threw eight strikeouts while walking zero batters and allowing zero hits.</p>
<p>Offensively, North Surry scored all 11 of its runs in the third inning. Berrier led the way with three hits, including two doubles, while Aparicio had two hits, and Puckett and Sarah Mauldin each had one hit.</p>
<p>Like the North Wilkes game, North Surry scored all of its runs against East Surry in one inning. The May 2 FH2A Tournament game marked North and East Surry&rsquo;s third meeting, with the first two going the way of the Hounds. East Surry took a 1-0 lead before North exploded for 12 runs in the fourth inning.</p>
<p>Aparicio and Fulk each had three hits and three RBIs in the win over the Cardinals. Jordan Snow had a pair of hits, and Mauldin, Felts, Puckett and Sadie Montgomery each had one hit. Snow had one double, and Aparicio had a triple.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/sports/107253/greyhounds-riding-win-streak" title="Greyhounds riding win streak" style="color:black">Greyhounds riding win streak</a></h1>

            <a href="https://www.mtairynews.com/sports/107253/greyhounds-riding-win-streak" title="Greyhounds riding win streak">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/05/128468747_web1_279048269_319288380348144_5181554660432247778_n.jpg" alt="Greyhounds riding win streak">
            </a>
   <p class="entry-meta">May 02, 2022</p>
   <p>The North Surry Greyhounds baseball team is running at full speed entering the postseason.</p>
<p>North Surry was 6-7 overall after dropping a home game to West Wilkes on April 4. Four days later, the Greyhounds beat West Wilkes on the road to begin a 5-game winning streak.</p>
<p>As of May 3, North Surry has won nine of its past 10 games to improve to 15-8 overall.</p>
<p>The Hounds have scored double-digit runs in seven of those nine victories. This includes a Senior Night victory over North Wilkes on April 29, as well as a 10-6 win over Wilkes Central in the Foothills 2A Conference Tournament.</p>
<p>North Surry&rsquo;s five seniors &#8211; Alec Singleton, Trevor Isaacs, Keaton Hudson, Ethan Edwards and Caleb Collins &#8211; ended the regular season with an 11-1 victory to finish 7-5 in conference play. This set the No. 3 Greyhounds up against the No. 6 Wilkes Central Eagles in the opening round of the FH2A Tourney.</p>
<p>North Surry started with a 6-2 lead through three innings, but found itself in a tough spot when Wilkes Central battled back to tie the game at 6-6 in the fifth.</p>
<p>Myles Draughn led off in the bottom of the fifth with a ground rule double that bounced over the fence in left-center field. A wild pitch moved Draughn&rsquo;s courtesy runner, Jay Eades, to third, then a sacrifice fly from Cam Taylor allowed Eades to score.</p>
<p>Wilkes Central put the potential game-tying run on first in the top of the sixth after being walked. North had just one out on the board, but kept the plate clean with a classic 6-4-3 double play.</p>
<p>Jackson Smith was up first in the bottom of the sixth and smashed a double down the right field line. Jake Beamer bunted to move Smith to third, and an overthrow at first base allowed Smith to score and Beamer to reach second.</p>
<p>Edwards kept the bats moving with a hit to left field. Wilkes Central&rsquo;s throw home was off the mark, which allowed Beamer to score run No. 9 and put Edwards on third. North Surry added their final run when Edwards scored off a wild pitch.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/sports/107218/regional-tennis-championship-results" title="Regional Tennis Championship Results" style="color:black">Regional Tennis Championship Results</a></h1>

            <a href="https://www.mtairynews.com/sports/107218/regional-tennis-championship-results" title="Regional Tennis Championship Results">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/05/128468423_web1_My-Post--8-.jpg" alt="Regional Tennis Championship Results">
            </a>
   <p class="entry-meta">May 02, 2022</p>
   <p>Seven local tennis stars are headed to the Individual State Championship Tournaments.</p>
<p>One athlete from Mount Airy, Georgie Kriek, will compete in the 1A State Tournament as a singles competitor. The remaining six athletes will compete in the 2A State Tournament: East Surry&rsquo;s Cooper Motsinger and Levi Watson qualified for the singles championship, while the Surry Central teams of Josh Pardue/Jacob Edmonds and Michael Tucker/Tripp McMillen will compete in the doubles championship.</p>
<p>Kriek reached the 1A West Regional Singles Championship before finishing second in the bracket.</p>
<p>Motsinger won the 2A Midwest Regional Singles Championship, while Pardue/ Edmonds were runners-up in the 2A Midwest Doubles Championship.</p>
<p>Watson finished fourth in the 2A Singles Tournament, and Tucker/McMillen finished fourth in the 2A Doubles Tournament.</p>
<p><strong>1A West</strong></p>
<p>Two Northwest 1A Conference rivals entered the 1A West Regional Championship on opposite sides of the singles bracket: Mount Airy&rsquo;s Kriek and Elkin&rsquo;s Owen Jennings. Kriek defeated Jennings twice during the regular season, and Jennings topped Kriek in the NW1A Singles Championship.</p>
<p>Kriek breezed through the first two rounds of regionals to qualify for the state tournament. The Granite Bear topped Cornerstone Charter&rsquo;s Jacob Stanfield 6-3, 6-0 in the opening round, then beat Draughn&rsquo;s Corey Powell 6-0, 6-1.</p>
<p>Kriek reached the championship round by defeating Thomas Jefferson Classical Academy&rsquo;s Charlie Schweppe 6-2, 6-4. Schweppe went on to finish third in the bracket.</p>
<p>Jennings defeated Kriek 6-2, 6-2 in the finals.</p>
<p>Mount Airy also had a doubles team qualify for regionals: Martin Cooke/Jared Pinto. The duo of Cooke/Pinto fell to Bishop McGuinness&rsquo; Joshua Hanflink/Evan Sturgill in the opening round, while the Bishop team went on to finish third.</p>
<p><strong>2A Midwest</strong></p>
<p>Motsinger and Watson were seeded No. 2 and No. 5, respectively, in the singles bracket.</p>
<p>Motsinger won without ever surrendering more than three total games in a match. Through four rounds of the tournament, he only lost a total of six games.</p>
<p>Motsinger defeated the No. 15 seed, West Davidson&rsquo;s Ethan Ullring, 6-0, 6-0 in the opening round, then topped the No. 7 seed, North Wilkes&rsquo; Mitch Adams, 6-0, 6-1 in the quarterfinals. </p>
<p>Like the 1A singles and 2A doubles bracket, a Surry County team occupied half of the semifinal spots. East Surry&rsquo;s Watson reached the semis by beating the No. 12 seed, West Stanly&rsquo;s Nate Barringer, 6-3, 6-4, before topping the No. 4 seed, West Davidson&rsquo;s Bain Bennett, 5-7, 6-3, 6-3.</p>
<p>Motsinger advanced to the championship match by defeating Wheatmore&rsquo;s Jagur Williams, seeded No. 3, 6-1, 6-1 in the semifinals. Watson fell to Salisbury&rsquo;s Will Koontz in the semifinals. Koontz was the top-seeded player in the bracket and defeated Watson 6-0, 6-1.</p>
<p>Koontz was undefeated on the year coming into the regional finals. Motsinger defeated Koontz 6-1, 6-2 to win the 2A Midwest Singles Championship.</p>
<p>Both Motsinger and Watson advance to the State Championship Tournament in hopes of becoming East Surry&rsquo;s first-ever Singles State Champion.</p>
<p>East Surry&rsquo;s lone doubles team in the Regional Tournament was the duo of Kade Talton/Nick Lowery. The team, seeded No. 10, defeated Walkertown&rsquo;s No. 7 team of Kooper Bray/James Brown 6-2, 6-2 in the opening round, but fell to Mount Pleasant&rsquo;s No. 2-seeded duo of Jadon Carnes/Gonzalo Gomez in the quarterfinals.</p>
<p>Surry Central&rsquo;s Pardue/Edmonds entered as the No. 1 seed in the 2A Midwest Doubles Tournament. The duo defeated Forest Hill&rsquo;s No. 16 team of Stephen Herrera/Keith Evan in the opening round, then beat North Stanly&rsquo;s No. 8 team of Kaleb Burrage/Judson Busch 6-4, 6-3 in the quarterfinals.</p>
<p>Pardue/Edmonds won a marathon semifinal match over Salisbury&rsquo;s No. 4-ranked team of Colin Donaldson/Gray Davis. The pair of undefeated teams went to two set-tiebreakers before a winner could be crowned.</p>
<p>Pardue/Edmonds won the first set of the semifinal 7-6, (7-5), and Donaldson/Davis won the second set 6-2. The tiebreaking set was also decided with a tiebreaker, which went the way of the Golden Eagles 7-6 (7-4).</p>
<p>Now 19-0 as a doubles team this season, Pardue/Edmonds faced yet another undefeated squad: Mount Pleasant&rsquo;s Carnes/Gomez.</p>
<p>Carnes/Gomez defeated Pardue/Edmonds 6-1, 6-2 to win the Regional Championship.</p>
<p>Pardue/Edmonds aren&rsquo;t the only Golden Eagles with a chance to become Surry Central&rsquo;s first-ever Doubles State Champions. Tucker/McMillen entered as the No. 3 seeded team and posted back-to-back wins to qualify for the state tournament.</p>
<p>Tucker/McMillen defeated No. 14 Collin Burgess/Jacob Youngs of Wheatmore 6-3, 6-2 in the opening round, then topped Forbush&rsquo;s No. 6-ranked team of Calvin Norman/Cooper Hennings 6-4, 6-4 in the quarterfinals.</p>
<p>Tucker/McMillen fell to Mount Pleasant&rsquo;s Carves/Gomez in the semifinals, then lost to Salisbury&rsquo;s Donaldson/Davis in the consolation finals.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/sports/107171/gonzalez-signs-nli-with-pfeiffer" title="Gonzalez signs NLI with Pfeiffer" style="color:black">Gonzalez signs NLI with Pfeiffer</a></h1>

            <a href="https://www.mtairynews.com/sports/107171/gonzalez-signs-nli-with-pfeiffer" title="Gonzalez signs NLI with Pfeiffer">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/04/128452642_web1_DSC_0971.jpg" alt="Gonzalez signs NLI with Pfeiffer">
            </a>
   <p class="entry-meta">April 29, 2022</p>
   <p>North Surry High School senior Jair Gonzalez officially signed his NCAA National Letter of Intent and will continue his academic and soccer careers at Pfeiffer University.</p>
<p>&ldquo;It feels unreal, but amazing,&rdquo; Gonzalez said. &ldquo;It&rsquo;s everything I&rsquo;ve been pursuing since I was little. At first I had my doubts because of the way I started out playing in high school. It was a completely different environment than middle school, but as time went on things clicked together for me.&rdquo;</p>
<p>Jair has been a cornerstone of the Greyhounds soccer team for four years. He walked into Charlie Atkins Stadium and became a starter his freshman year, then went on to become an All-Conference and All-Region player that garnered the attention of college scouts.</p>
<p>&ldquo;I never doubted him because I&rsquo;ve seen how hard of a worker he is and what he&rsquo;s willing to do to accomplish something,&rdquo; said Eric Jessup, who served as North Surry head soccer coach from 2017-21 before swapping to an assistant role ahead of the 2021-22 season. &ldquo;He puts a lot of time into the sport and plays year round. You could see him each year getting a little better, little better, little better&#8230; to the point where you thought &lsquo;hey, this kid could definitely play at the next level.&rsquo;&rdquo;</p>
<p>Another coach that was present for Gonzalez&rsquo;s development as both a player and a young man was Kevin Shore. Shore served as Jessup&rsquo;s assistant coach during Gonzalez&rsquo;s first three years, then took over as head coach for Jair&rsquo;s senior year.</p>
<p>&ldquo;When he came in as a freshman, a lot of times he just needed a little bit of guidance and maybe some parameters,&rdquo; Shore said. &ldquo;You could see him develop as a team player and as the leader of the team. This year, all the team members looked up to Jair.</p>
<p>&ldquo;If there was some backbiting going on, you could look at Jair and he would end it. He&rsquo;d say &lsquo;This is what we&rsquo;re going to do and this is how we&rsquo;re going to go about things,&rsquo; and everything would get better. You need that leadership to be successful.&rdquo;</p>
<p>Gonzalez&rsquo;s soccer experience and natural abilities led to success on the field. He picked up the sport at a young age and played a lot of indoor soccer. As he entered middle school, Jair started getting more serious about playing in college and decided to play travel soccer. He later joined Northern Triad Soccer Club coached by Sam Lowe.</p>
<p>Gonzalez wasn&rsquo;t the crucial piece of the puzzle just because he was a talented player at one or two positions. Rather, according to Shore, he was a talented player wherever the team needed him to play.</p>
<p>He said his natural position is in the midfield, which is where he started when he first came to North. But as older players graduated and holes opened up, Jair was moved to defense where he found his fit for the Greyhounds.</p>
<p>&ldquo;Jair is one of the kids that we&rsquo;d do a starting lineup and say &lsquo;hey, what do you think,&rsquo;&rdquo; Shore said. &ldquo; He was one of the few players on the field that, of the 11, he had the green light if he needed to go from defense to striker and we would back his play. He was an asset all the way around.&rdquo;</p>
<p>&ldquo;If you really think about it,&rdquo; Jessup added, &ldquo;I don&rsquo;t think we really took you out of a game this year. We&rsquo;d just shift you somewhere else on the field if someone needed a break.&rdquo;</p>
<p>After some discussion, the trio of Shore, Jessup and Gonzalez could only think of one instance throughout the entire 2021-22 season in which Jair was subbed out by the coaches excluding injuries and cards. The game in question was North Surry&rsquo;s playoff game at Trinity, which marked the school&rsquo;s first playoff appearance since 2018.</p>
<p>&ldquo;That was just giving direction, making sure he had his mind right to go back out there and make an impact,&rdquo; Shore said. &ldquo;But what makes Jair so unique was that if he did take the freedom to push up to striker and there was a turnover, he would undoubtedly sprint back. He gave as much effort going up to the offensive end as he would coming back on defense. You can&rsquo;t say that about everybody all the time; they weren&rsquo;t that excited about it. But at the same time, he knew he was necessary to get those stops.&rdquo;</p>
<p>&ldquo;I just tried to play the best I could every game,&rdquo; Gonzalez said. &ldquo;I try not to get off the field unless it&rsquo;s completely necessary for me to. I&rsquo;ve always tried to bring everyone up as much as I could. We&rsquo;ve always had our arguments, our differences, but we&rsquo;ve always tried to work through them together.&rdquo;</p>
<p>Even after his final high school season, Jair&rsquo;s impact on North Surry soccer is still being felt.</p>
<p>&ldquo;I think Jair set the standard for what it takes to lead on the team,&rdquo; Shore said. &ldquo;Even today in April, I&rsquo;ve got kids talking about summer workouts and they&rsquo;re saying &lsquo;I want to take Jair&rsquo;s spot. I want to be like Jair.&rsquo; It&rsquo;s good to hear those comments because it shows his teammates realize what he brought to the table.&rdquo;</p>
<p>Shore and Jessup spoke of how Jair&rsquo;s college recruitment would serve as a shining example for upcoming North Surry soccer players. The coaches expressed their gratitude to Gonzalez for his dedication to the program and to his teammates over the years, and Gonzalez gave it right back.</p>
<p>&ldquo;I really want to thank Coach Shore and Coach Jessup,&rdquo; he said. &ldquo;I honestly don&rsquo;t think I would be at this point I&rsquo;m at today without their help throughout these four years.&rdquo;</p>
<p>Jair also extended thanks to his family for their unwavering support. Gonzalez mentioned wanting to succeed in the sport to have the experience that his dad earned but couldn&rsquo;t experience.</p>
<p>&ldquo;My dad&rsquo;s been my main inspiration,&rdquo; Jair said. &ldquo;Back when he was younger he had the opportunity to possibly go pro, but did not because he was too young to leave home.&rdquo;</p>
<p>With his parting words at Gonzalez&rsquo;s signing, Jessup wanted to let Pfeiffer know what kind of person they were getting this fall.</p>
<p>&ldquo;Jair is a winner, just all the way around,&rdquo; Jessup said. &ldquo;He&rsquo;s going to be a winner in life, he&rsquo;s gonna do great in college &#8211; whether hitting the books or playing on the field &#8211; and he&rsquo;s going to do great with whatever he decides to do after.&rdquo;</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/sports/107119/central-surges-in-comeback-win-over-north" title="Central surges in comeback win over North" style="color:black">Central surges in comeback win over North</a></h1>

            <a href="https://www.mtairynews.com/sports/107119/central-surges-in-comeback-win-over-north" title="Central surges in comeback win over North">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/04/128456652_web1_DSC_0092e.jpg" alt="Central surges in comeback win over North">
            </a>
   <p class="entry-meta">April 28, 2022</p>
   <p>DOBSON &mdash; Each half of Wednesday&rsquo;s soccer match between Surry Central and North Surry was like an entirely different game.</p>
<p>The first 40 minutes saw North Surry strike early and hold on to a hold halftime lead for the first time in more than three weeks. North&rsquo;s defense took a major hit in the final minutes of the first half, which proved doubly brutal for the Greyhounds when the Golden Eagles played with new energy in the second half.</p>
<p>A trio of quick goals by Central turned the tides of the game, and a fourth goal later in the half put the exclamation point on the 4-1 win.</p>
<p>&ldquo;We just came out completely different in the second half,&rdquo; said Central coach Adan Garcia. &ldquo;We played a little sloppy at the start and felt the effects. We didn&rsquo;t have much luck against their defense in the first half either, but we were able to adjust and I&rsquo;m proud of the girls for making the necessary changes.</p>
<p>&ldquo;They (North) gave us a tough battle, regardless of the score line. That was a tough, tough win.&rdquo;</p>
<p>Garcia said the Eagles completely changed their formation during halftime. As someone that traditionally plays a more conservative 4-4-2, Garcia decided to play risky and change to a 3-4-3.</p>
<p>&ldquo;We thought we could contain them enough to keep them from outscoring us in the second half, but knew we wouldn&rsquo;t have a chance if we didn&rsquo;t put the ball in the net,&rdquo; Garcia said. &ldquo;We wanted to try and get around [Kim] Elias in the back so we tried to get to our outside mids, drag her out and find the wings.&rdquo;</p>
<p>Central&rsquo;s plan worked, and within five minutes had evened the game at 1-1.</p>
<p>North Surry&rsquo;s defense was locked in during the first half. The Greyhound limited shots on the goal, and forced Central to try and fire from distance.</p>
<p>&ldquo;Our defense hasn&rsquo;t given up a many goals since we moved Weatherly Reeves and Kim Elias both back there,&rdquo; said Greyhound coach Eric Jessup. &ldquo;Those two work so well together and it&rsquo;s fun to watch. Sometimes we&rsquo;ll run a diamond in the back with both of them in the center, and then other times we&rsquo;ll have three in the back with a sweeper.&rdquo;</p>
<p>Elias also scored North&rsquo;s lightning-fast goal early in the game. Central gave up a foul five yards outside the 18-yard box, and Elias sent an absolute firecracker into the net with the wind on her side.</p>
<p>North Surry&rsquo;s defense had to call an audible after Reeves was injured late in the first half. She left the game and did not return.</p>
<p>&ldquo;That was such a big loss for our team,&rdquo; Jessup said. &ldquo;She&rsquo;s our team leader. Does a lot of the talking from the back, takes all the throw-ins, she knows where to be and what to do and helps others on the field as well. She&rsquo;s really hard to replace.&rdquo;</p>
<p>Jessup said he had to pull a midfielder back to Reeves&rsquo; spot on defense, then plug another player into the midfield spot. The sudden change led the team to a troublesome start to the second half, which, paired with Central&rsquo;s offensive explosion, changed the entire dynamic of the game.</p>
<p>&ldquo;That was a big loss for our defense, but I&rsquo;m definitely not taking anything away from Coach Garcia,&rdquo; Jessup said. &ldquo;They played a great second half and were able to finish really well. They came out in the second half and scored three quick goals, so I know he drew up a great gameplan.</p>
<p>&ldquo;Most of all I hate it for her (Reeves). I know not being able to play really hurts her.&rdquo;</p>
<p>Lillian Orozco scored Central&rsquo;s game-tying goal that sparked the strong second half. Estefany Avila sent a hard pass on the ground to Orozco in the middle to finish in the 45th minute. A few minutes later, Orozco took another shot that was blocked down by North&rsquo;s keeper. Miranda Calderon swooped in and poked the ball in to give the Eagles a 2-1 lead.</p>
<p>In the 57th minute, Central&rsquo;s Dafne Salgado-Perez took a pass from Orozco up the sideline to set up a deep cross. Avila crashed from the left wing and redirected the cross with her knee into the goal.</p>
<p>The fourth and final goal for the Eagles came on an Orozco shot at the edge of the 18. Her shot was low and hard, and sailed over the line near the post.</p>
<p>&ldquo;All we worked on this week was long-range shooting,&rdquo; Garcia said. &ldquo;It&rsquo;s going to give us a little boost in the East Surry game and for the rest of the season.&rdquo;</p>
<p>&ldquo;Our girls played hard and we had some really good stretches, especially in that first half,&rdquo; Jessup said. &ldquo;Sometimes this is just how things go. We need to rebound and come out fighting again when we get back on the field.&rdquo;</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/sports/107104/northwest-1a-conference-golf-championship-results" title="Northwest 1A Conference Golf Championship Results" style="color:black">Northwest 1A Conference Golf Championship Results</a></h1>

            <a href="https://www.mtairynews.com/sports/107104/northwest-1a-conference-golf-championship-results" title="Northwest 1A Conference Golf Championship Results">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/04/128453549_web1_MAgolf.jpg" alt="Northwest 1A Conference Golf Championship Results">
            </a>
   <p class="entry-meta">April 27, 2022</p>
   <p>ROARING GAP &mdash; The Mount Airy golf team finished second at the Northwest 1A Conference Championship meet on Tuesday.</p>
<p>The meet was hosted at held at the Roaring Gap Club in Alleghany County and featured golfers from all seven NW1Aschools: Mount Airy, Elkin, North Stokes, South Stokes, East Wilkes, Starmount and Alleghany.</p>
<p>Elkin won the NW1A Tournament Title in a close three-man race against South Stokes and Mount Airy. The Buckin&rsquo; Elks won with an 18-hole team score of 332 despite not having the lowest score on either the front or back 9.</p>
<p>Elkin&rsquo;s James Owings was the medalist at the conference championship with a final score of 77 strokes. Owings tied South Stokes&rsquo; Keelan Robertson for first, then won a one-hole playoff for the victory. Robertson went on to be named NW1A Golfer of the Year.</p>
<p>Mount Airy had the lowest score on the front 9, and South Stokes had the lowest score on the back 9. The Granite Bears and Sauras tied for second at the NW1A tournament at 334 strokes.</p>
<p>The trio of Mount Airy, South Stokes and Elkin also made up the top three of the regular season standings. South Stokes won the regular season championship, Mount Airy finished second and Elkin was third.</p>
<p>South Stokes coach Kent Mendenhall was named NW1A Coach of the Year. </p>
<p>TOP INDIVIDUAL SCORERS</p>
<p>T-1. James Owings (EK) 40+37=77</p>
<p>T-1. Keelan Robertson (SS) 40+37=77</p>
<p>3. Noah Sparks (SS) 43+36=79</p>
<p>T-4. Brooks Sizemore (MA) 42+40=82</p>
<p>T-4. Avery Poindexter (MA) 37+45=82</p>
<p>T-4. Larsen Gallimore (SS) 46+36=82</p>
<p>7. Judah Christian (EK) 40+43=83</p>
<p>T-8. Eli Morrison (MA) 41+44=85</p>
<p>T-8. Mason Varney (MA) 45+40=85</p>
<p>T-8. Brady Hall (EW) 45+40=85</p>
<p>TEAM RESULTS</p>
<p>*The top four individual performances contribute to team score. Scores are formatted as: front 9 score + back 9 score = total score</p>
<p><strong>1. Elkin Buckin&rsquo; Elks 166+166=332 </strong></p>
<p>James Owings 40+37=77*</p>
<p>Judah Christian 40+43=83*</p>
<p>Matthew Pelkey 40+46=86*</p>
<p>Paul Brinegar 49+42=92</p>
<p>Wesley Nations 46+44=90*</p>
<p><strong>T-2. Mount Airy Granite Bears 165+169=334</strong></p>
<p>Brooks Sizemore 42+40=82*</p>
<p>Avery Poindexter 37+45=82*</p>
<p>Eli Morrison 41+44=85*</p>
<p>Mason Varney 45+40=85*</p>
<p>Chapman Utt 45+48=93</p>
<p><strong>T-2. South Stokes Sauras 178+156=334</strong></p>
<p>Larsen Gallimore 46+36=82*</p>
<p>Keelan Robertson 40+37=77*</p>
<p>Noah Sparks 43+36=79*</p>
<p>Cohen Jennings 49+47=96*</p>
<p>Bryson Snow 49+52=101</p>
<p><strong>4. East Wilkes Cardinals 183+171=354</strong></p>
<p>Tucker Settle 49+37=86*</p>
<p>Brady Hall 45+40=85*</p>
<p>Ryan Sanders 46+44=90*</p>
<p>Chase Mastin 43+50=93*</p>
<p>Zachary Harrold 50+51=101</p>
<p><strong>5. Starmount Rams 204+188=392</strong></p>
<p>Jacob Groce 50+50=100*</p>
<p>Eli Wingler 53+42=95*</p>
<p>Jake Shoemaker 53+54=107</p>
<p>Weston Stiles 49+45=94*</p>
<p>Alex Garza 52+51=103*</p>
<p><strong>6. North Stokes </strong><strong>Vikings 210+192=402</strong></p>
<p>Amos Stanberry 46+42=88*</p>
<p>Will Greer 59+51=110*</p>
<p>Brandon Mabe 52+50=102*</p>
<p>Jacob Dowell 53+49=102*</p>
<p><strong>7. Alleghany Trojans 229+232=461</strong></p>
<p>Elliott Church 55+50=105*</p>
<p>Austin Maines 52+58=110*</p>
<p>Grayson Poole 59+61=120*</p>
<p>Koda Blythe 63+63=126*</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/sports/107102/nchsaa-approves-womens-wrestlings-more-at-spring-meeting" title="NCHSAA approves womens wrestlings, more at spring meeting" style="color:black">NCHSAA approves womens wrestlings, more at spring meeting</a></h1>

            <a href="https://www.mtairynews.com/sports/107102/nchsaa-approves-womens-wrestlings-more-at-spring-meeting" title="NCHSAA approves womens wrestlings, more at spring meeting">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/04/128455499_web1_NCHSAA-logo-509x509.jpg" alt="NCHSAA approves womens wrestlings, more at spring meeting">
            </a>
   <p class="entry-meta">April 27, 2022</p>
   <p>The N.C. High School Athletic Association Board of Directors completed its annual Spring Meeting on April 27.</p>
<p>According to a press release from the NCHSAA, Board members were hard at work addressing changes necessitated by the Association&rsquo;s agreement (MOU) with the State Board of Education.</p>
<p>The Board took action on many items during its meeting. Highlights are as follows:</p>
<p>&#183; Sanctioned the addition of Women&rsquo;s Wrestling for the 2023-2024 athletic year.</p>
<p>&#183; Sanctioned the addition of a 4A Classification State Championship in Women&rsquo;s Lacrosse, effective 2022-2023.</p>
<p>&#183; Approved a Five Quarter Rule for basketball allowing students to participate in five quarters of play in a single day. This was done to promote and sustain junior varsity programs across the state.</p>
<p>&#183; Approved a 5% distribution from interest earned on the Association&rsquo;s General Endowment Fund to member schools, including a 5.05% distribution from the Education/Health and Safety Endowment Fund.</p>
<p>&#183; Approved Membership Fees remaining at $1.00 per pupil for 2022-2023. Board eliminated the $100 administrative fee for all member schools, effective 2022-2023.</p>
<p>&#183; Revised NCHSAA revenue share to 20% for all Fourth Round contests in all team and bracketed sports. As a reminder, as a result of the MOU, the Association will receive its share in all rounds from the net revenues of all playoff and championships, rather than the gross receipts.</p>
<p>Commissioner Que Tucker said, &ldquo;Today has been a landmark meeting for the NCHSAA, on many fronts. As we celebrate the 50th year since the passage of Title IX, our Board was able to sanction a new women&rsquo;s sport, Women&rsquo;s Wrestling, and add a new championship classification in Women&rsquo;s Lacrosse.</p>
<p>We are proud to provide new opportunities for women to participate in education-based athletic programs and are excited to see the many ways that these new programs will benefit the student experience in our state.&rdquo;</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/sports/107080/hounds-rebound-with-win-over-eagles" title="Hounds rebound with win over Eagles" style="color:black">Hounds rebound with win over Eagles</a></h1>

            <a href="https://www.mtairynews.com/sports/107080/hounds-rebound-with-win-over-eagles" title="Hounds rebound with win over Eagles">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/04/128448262_web1_DSC_0308.jpg" alt="Hounds rebound with win over Eagles">
            </a>
   <p class="entry-meta">April 26, 2022</p>
   <p>DOBSON &mdash; North Surry bounced back from a three-game skid with a 9-1 road win over Surry Central.</p>
<p>Both teams looked to build momentum for the Foothills 2A Conference tournament as the final week of the regular season began. Eleven hits by the Greyhounds led to multiple runs being scored in three separate innings during a four-inning stretch at Central. North Surry (8-10, 5-5 FH2A) also took advantage of six Surry Central errors to get back to .500 in conference play.</p>
<p>The Lady Greyhounds came into Monday&rsquo;s game having just endured what was arguably their toughest three-game stretch of the season. In the span of six days, North Surry played two of the top three teams in FH2A conference &#8211; Wilkes Central (11-5) and Forbush (15-6) &#8211; as well as the No. 5-ranked team in the 1A West, South Stokes (14-4).</p>
<p>Surry Central (3-12, 2-9 FH2A), meanwhile, looked to pick up its first win in more than a month. The Golden Eagles&rsquo; previous three games saw the team come up just short in a close matchup against East Surry (4-12), then fall to the No. 6-ranked team in the 2A West, West Wilkes (17-2), as well as the No. 21 4A West team, West Forsyth (16-5).</p>
<p>Both teams put runners on third in the first inning, Sarah Mauldin for North and Alyssa Woods for Central, but both were left on base.</p>
<p>Once North Surry connected for a hit in the second inning the Hounds couldn&rsquo;t seem to miss. Following a leadoff ground out, Micah Felts singled for North and went to second on an Eagle fielding error. Sadie Montgomery hit an RBI to score Felts, but was called out going to second.</p>
<p>Kadie Fulk and Carley Puckett repopulated the bases with a single and double, respectively. Bella Aparicio doubled to score both runners, then advanced to third on the throw home.</p>
<p>A fly out, strikeout and ground out in the bottom of the second put North Surry back up to bat. Trista Berrier led off by reaching first on a fielding error. The Eagles committed an error when attempting to get Berrier out at second on a Marissa Casstevens hit, so Berrier went to third to put runners on the corners. This set Berrier up to score on an error committed by Central when attempting to pick her off.</p>
<p>Jordan Snow joined Casstevens&rsquo; courtesy runner, Lexie Allen, on base with a grounder to third. The duo started on base with no outs, but would not advance any further in the inning.</p>
<p>Central&rsquo;s Woods got on base for the second time in the bottom of the third, but another quick inning left the Eagles scoreless.</p>
<p>North had its second multi-run inning in the fourth. Puckett picked up her second hit of the game with a single, then moved to second on a ground out and third on a passed ball. Berrier doubled with two outs to score Puckett, then Berrier scored on a Casstevens hit that was overthrown.</p>
<p>The Eagles finally broke through in the bottom of the fourth thanks to a well-timed double. Kaylin Moody led off with a single to center field, advanced to second on a passed ball and went to third on a ground out. Kailea Zurita crushed a fly ball to right-center to score Moody and reach second herself.</p>
<p>Zurita advanced to third on a ground out as the Eagles threatened to score again, but North&rsquo;s Berrier tossed a strikeout to end the inning and prevent further damage. Berrier threw a complete game for the Hounds, striking out seven, walking one, and allowing one run on four hits.</p>
<p>Carlee Jones threw all seven innings for Surry Central. The Golden Eagle senior struck out three batters, walked one, and allowed nine runs on 11 hits.</p>
<p>North Surry&rsquo;s leadoff batter got on base for the third consecutive inning in the fifth thanks to a Felts single. Central got outs on the next two batters and didn&rsquo;t allow Felts to advance past second, hoping the Hounds&rsquo; scoring fest was coming to an end. Puckett played spoiler by hitting a line drive to center to score Felts, then moving to second on the throw home to make it 7-1.</p>
<p>Aparicio was up next and hammered a line to drive to score Puckett. An error in the outfield provided all the time Aparicio needed to circle the diamond and slide into home plate for run No. 9.</p>
<p>After the exciting four-inning stretch for North Surry, neither squad recorded a hit in the final 2.5 innings. The Hounds did have one batter walked during this stretch, and the Eagles put one player on base via error.</p>
<p>Scoring</p>
<p>North Surry &#8211; 0, 3, 1, 2, 3, 0, 0 = 9</p>
<p>Surry Central &#8211; 0, 0, 0, 1, 0, 0, 0 = 1</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/sports/107073/foothills-2a-golf-championship-results" title="Foothills 2A Golf Championship Results" style="color:black">Foothills 2A Golf Championship Results</a></h1>

            <a href="https://www.mtairynews.com/sports/107073/foothills-2a-golf-championship-results" title="Foothills 2A Golf Championship Results">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/04/128448370_web1_IMG_4068.jpg" alt="Foothills 2A Golf Championship Results">
            </a>
   <p class="entry-meta">April 26, 2022</p>
   <p>STATE ROAD &mdash; The East Surry Cardinals swept the Foothills 2A Conference&rsquo;s top honors at Monday&rsquo;s conference championship meet.</p>
<p>The meet, held at Cedarbrook Country Club, featured golfers from all seven FH2A schools: East Surry, North Surry, Surry Central, Forbush, West Wilkes, North Wilkes and Wilkes Central.</p>
<p>East Surry&rsquo;s Connor Key was the medalist of the conference tournament with an 18-hole score of 74 strokes. Key was the only one of 38 golfers to shoot fewer than 40 strokes on both the front and back nine.</p>
<p>Key was followed by three Cardinal teammates in the individual standings to help East win the teams fourth consecutive conference championship. The Cards won conference titles in 2018, 2019, 2021 and 2022. The 2020 season was cancelled due to the COVID-19 pandemic.</p>
<p>East Surry finished with a team score of 314, followed by Forbush at 345, North Surry at 348, Surry Central at 370, North Wilkes at 419, West Wilkes at 425 and Wilkes Central at 426.</p>
<p>East Surry senior Bradley Davis was named FH2A Player of the Year, and the Cardinals&rsquo; Darrin Haywood was named FH2A Conference Coach of the Year.</p>
<p>TOP INDIVIDUAL SCORERS</p>
<p>1. Connor Key (ES) 36+38=74</p>
<p>2. Anderson Badgett (ES) 40+36=76</p>
<p>3. Bradley Davis (ES) 38+40=78</p>
<p>T-4. Chase Harris (ES) 42+38=80</p>
<p>T-4. Ethan Hutchens (FB) 41+39=80</p>
<p>6. Brody York (NS) 41+41=82</p>
<p>T-7. Adam Hege (SC) 41+44=85</p>
<p>T-7. Eli Sloan (FB) 40+45=85</p>
<p>9. Nic Grey (NS) 43+43=86</p>
<p>10. Jace Goldbach (ES) 42+45=87</p>
<p>TEAM RESULTS</p>
<p>*The top four individual performances contribute to team score. Scores are formatted as: front 9 score + back 9 score = total score</p>
<p><strong>1. East Surry Cardinals 156+158=314</strong></p>
<p>Bradley Davis 38+40=78*</p>
<p>Chase Harris 42+38=80*</p>
<p>Connor Key 36+38=74*</p>
<p>Jace Goldbach 42+45=87</p>
<p>Anderson Badgett 40+36=76*</p>
<p>Jordan Davis 50+48=98</p>
<p><strong>2. Forbush Falcons 173+172=345</strong></p>
<p>Ethan Hutchens 41+39=80*</p>
<p>Eli Sloan 40+45=85*</p>
<p>Joe Hennings 46+48=94</p>
<p>Aiden Lyon 47+44=91*</p>
<p>Hunter Hall 46+44=90*</p>
<p>Noah Mathis 49+45=94</p>
<p><strong>3. North Surry Greyhounds 179+169=348</strong></p>
<p>Brody York 41+41=82*</p>
<p>Aiden Oakley 54+51=105</p>
<p>Nic Grey 43+43=86*</p>
<p>Jansen Huff 49+43=92*</p>
<p>Alex Rios 56+56=112</p>
<p>Carson Stanley 46+42=88*</p>
<p><strong>4. Surry Central Golden Eagles 181+189=370</strong></p>
<p>Adam Hege 41+44=85*</p>
<p>Reece Hanson 49+50=99*</p>
<p>Nathan Narehood 43+45=88*</p>
<p>Wesley Whitaker 48+50=98*</p>
<p>Colby Cruise 57+55=112</p>
<p>Kinley White 51+52=103</p>
<p><strong>5. North Wilkes Vikings 204+215=419</strong></p>
<p>Carter Huffman 43+49=92*</p>
<p>Briley Wyatt 57+56=113*</p>
<p>Will Harold 48+56=104*</p>
<p>Hunter Brown 56+54=110*</p>
<p><strong>6. West Wilkes Blackhawks 219+206=425</strong></p>
<p>Taner Estes 48+47=95*</p>
<p>Andrew Barlow 51+48=99*</p>
<p>Jacob Bray 61+61=122</p>
<p>Leo Resendiz 59+55=114*</p>
<p>Dalton Lahargoue 63+63=126</p>
<p>Bryson Patterson 62+56=118*</p>
<p><strong>7. Wilkes Central Eagles 215+211=426</strong></p>
<p>Blake Hayes 47+41=88*</p>
<p>Brody Mathis 52+50=102*</p>
<p>Andrew Hincher 53+57=110*</p>
<p>N/A 63+63=126*</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/sports/107046/cards-raise-the-standard-with-5th-straight-conference-title" title="Cards raise the standard with 5th straight conference title" style="color:black">Cards raise the standard with 5th straight conference title</a></h1>

            <a href="https://www.mtairynews.com/sports/107046/cards-raise-the-standard-with-5th-straight-conference-title" title="Cards raise the standard with 5th straight conference title">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/04/128445899_web1_277542333_1113287339522171_3728846243366387423_n.jpg" alt="Cards raise the standard with 5th straight conference title">
            </a>
   <p class="entry-meta">April 25, 2022</p>
   <p>MILLERS CREEK &mdash; With a road win over West Wilkes on Friday, East Surry clinches the Foothills 2A Conference Championship.</p>
<p>East Surry has won conference titles in seven of the past eight completed seasons (the 2020 season was cancelled), and the 2021-22 FH2A Title marks the team&rsquo;s 19th conference championship since 1976. Conference title No. 19 holds a special place in the Cardinals&rsquo; record book as it marks the program&rsquo;s first-ever &ldquo;five-peat.&rdquo;</p>
<p>East Surry first set the standard with the school&rsquo;s first-ever &ldquo;four-peat&rdquo; in 2020-21. Prior to that season, the Cardinals had won three consecutive conference titles on three other occasions: 1982-84, 1999-2001 and 2013-15.</p>
<p>From the start of the 2016-17 season through Friday&rsquo;s West Wilkes win, East Surry has a conference posted a total conference record of 49-3. The Cards were part of the Northwest 1A Conference in the 2017-21 seasons and had a 39-3 conference record. East is currently in its first season in the 2A division and sits at 10-0 with a week remaining in the regular season.</p>
<p>East Surry&rsquo;s conference-clinching win saw the team battle back from a 3-run deficit in the fifth inning. The Cards had loaded the bases in the second inning and left runners on in the third and fourth, but never could get back to the plate.</p>
<p>Tristen Mason was walked to begin the top of the fifth, then Luke Bowman crushed a 2-run home run to get the Cardinals on the board. East followed up by putting two runners on base in the sixth inning, but both were left on after a strikeout.</p>
<p>West Wilkes then scored in the bottom of the sixth to increase its lead to 4-2. The Blackhawks had bases loaded with just one out when Brett Clayton caught a pop fly in the outfield. West had a player run home, but Clayton rifled a throw to the infield to get the third out before the insurance run could cross the plate.</p>
<p>Trey Armstrong led off in the top of the seventh. The Cardinal senior hit a grounder between third base and shortstop, but was narrowly called out at first. Folger Boaz and Luke Bowman followed with singles, then Anthony Ayers hammered a hit to the outfield for a single of his own that scored Boaz. Ayers&rsquo; hit was mishandled in the outfield, allowing Brown to score and letting Ayers get all the way to third.</p>
<p>Caden Lasley was up next for the Cardinals, now tied 4-4. Lasley took a 1-1 count and hit a triple to that rolled to the fence in right-center field. Ayers scored to give East Surry its first lead of the game.</p>
<p>Matthew Keener hit an RBI to score Lasley and extend the lead to 6-4 with just one out. Clayton hit a hard line drive up the middle that was caught, then the Blackhawks flipped the ball to second for a double play.</p>
<p>West Wilkes&rsquo; first two batters grounded out in the bottom of the seventh. An error by the Cards put a runner on base, then a Blackhawk RBI double cut the visitor&rsquo;s advantage to one run at 6-5. East Surry forced a ground out to leave the game-tying run on base.</p>
<p>Brown and Ayers were the Cardinals&rsquo; two pitchers against the Blackhawks. Brown threw seven strikeouts, three walks and gave up four runs on nine hits in five innings. Ayers threw two innings, had one strikeout, one walk and allowed one run on two hits.</p>
<p>East Surry is now 16-1 overall entering the final week of the regular season. East will host back-to-back games against Surry Central and North Stokes on April 26 and 27, then will conclude the season at Surry Central on April 29.</p>
<p>Scoring</p>
<p>East Surry &#8211; 0, 0, 0, 0, 2, 0, 4 = 6</p>
<p>West Wilkes &#8211; 0, 2, 0, 1, 0, 1, 1 = 5</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/sports/107054/lions-walk-off-to-win-second-straight" title="Lions walk-off to win 2nd straight" style="color:black">Lions walk-off to win 2nd straight</a></h1>

            <a href="https://www.mtairynews.com/sports/107054/lions-walk-off-to-win-second-straight" title="Lions walk-off to win 2nd straight">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/04/128445881_web1_MCA-HS-Baseball-man-8060.jpg" alt="Lions walk-off to win 2nd straight">
            </a>
   <p class="entry-meta">April 25, 2022</p>
   <p>DOBSON &mdash; A walk-off hit by Phillip Byrd led Millennium Charter to a 5-4 win over N.C. Leadership Academy on Friday.</p>
<p>The April 22 victory not only served as Millennium&rsquo;s first win in the Northwest Piedmont 1A Conference, but it also gave the Lions their first winning streak since joining the N.C. High School Athletic Association. Less than 24 hours prior, MCA defeated another team out of Kernersville &#8211; Triad Baptist Christian Academy &#8211; by a score of 15-5.</p>
<p>In addition to his game-winning hit that scored Calvin Devore, Byrd earned the win on the bump against NCLA. The Lion freshman pitched four innings and had six strikeouts, three walks and allowed three runs on three hits. Hartley Devore threw the remaining three innings, recording three strikeouts, three walks and allowing one run on one hit.</p>
<p>NCLA (9-5, 3-5 NWPC) jumped out to a 3-0 lead before Millennium got on the board. Tristan Shockley and Aryan Hira each scored in the bottom of the third inning to cut the Falcons&rsquo; lead to 3-2, then Shockley and Calvin Devore each circled the diamond in the fifth inning to give the Lions a 4-3 advantage.</p>
<p>Leadership Academy tied things up in the top of the sixth inning. Zeke Harrison stole his way around the bases to reach third in the bottom of the inning, but a ground-out and fly-out by the Lions left Harrison stranded.</p>
<p>Millennium (3-11, 1-7 NWPC) held NCLA scoreless in the top of the seventh to keep the game at 4-4. Hira was walked to begin the inning, then Calvin Devore singled. Hira got out on a fielder&rsquo;s choice hit by Hartley Devore, but a single Ethan Holladay kept pressure on the Falcons by loading the bases.</p>
<p>A full-count strikeout put the second out on the board and put Byrd up to bat. Byrd, who went hitless through his first three plate appearances, brought Calvin Devore in for the game-winning run.</p>
<p>Holladay led the Lions with three hits and four RBIs in four at-bats. Harrison, Byrd and Calvin Devore each had one hit, and Byrd had Millennium&rsquo;s remaining RBI.</p>
<p>Shockley and Calvin Devore each scored twice, and Hira scored once.</p>
<p>Scoring</p>
<p>Leadership Academy &#8211; 1, 0, 2, 0, 0, 1, 0 = 4</p>
<p>Millennium Charter &#8211; 0, 0, 2, 0, 2, 0, 1 = 5</p>
<p>The Lions wasted little time establishing their dominance against TBCA on Thursday. Millennium put up seven runs in the first inning alone in the 15-5 win via mercy rule.</p>
<p>Eight different Lions recorded hits against the Titans. Harrison and Byrd led the way with four hits each, including a home run by Byrd, while Hartley Devore had three hits, Calvin Devore had two, and Shockley, Hira, Holladay and Landon Martin each had one.</p>
<p>Byrd hit an incredible seven RBIs in Thursday&rsquo;s win. Harrison added three RBIs, and the following Lions each had one: Shockley, Holladay, Martin, Hira and Hartley Devore.</p>
<p>Martin, Harrison, Calvin and Hartley Devore combined to pitch five innings. The quartet only gave up five hits, while striking out six and walking seven.</p>
<p>Millennium continues nonconference play against Oak Ridge Military Academy on April 27.</p>
<p>Scoring</p>
<p>Triad Baptist Christian &#8211; 0, 0, 2, 0, 3, X, X = 5</p>
<p>Millennium Charter &#8211; 7, 1, 2, 1, 4, X, X = 15</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/sports/107038/celebrating-soccer-moms" title="East Surry celebrates soccer moms" style="color:black">East Surry celebrates soccer moms</a></h1>

            <a href="https://www.mtairynews.com/sports/107038/celebrating-soccer-moms" title="East Surry celebrates soccer moms">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/04/128441186_web1_DSC_0685.jpg" alt="East Surry celebrates soccer moms">
            </a>
   <p class="entry-meta">April 25, 2022</p>
   <p>Mother&rsquo;s Day may not officially take place until May 8, but the East Surry&rsquo;s girls soccer team didn&rsquo;t want to wait to showcase the women that helped shape their lives.</p>
<p>The Cardinal soccer team recognized all the team moms &#8211; biological or not &#8211; as part of a Mothers Appreciation Night game. The game was held Thursday, April 21 when the Lady Cards hosted Surry Central.</p>
<p>&ldquo;We came up with this idea because moms are so important in our everyday life, and especially during our soccer season,&rdquo; said East Surry junior Katie Collins. &ldquo;Our moms always make sure we&rsquo;re fueled up for our games, make sure we&rsquo;re at practice and always make sure we&rsquo;re prepared to play our best.&rdquo;</p>
<p>Themed soccer matches aren&rsquo;t a new concept for East Surry soccer. Cardinal head coach William Hart has encouraged his players to host these theme nights for more than a decade, including his time as the boys soccer coach.</p>
<p>&ldquo;I want to give our juniors an opportunity to have some sort of awareness night because it promotes good citizenship and provides an opportunity for a service project,&rdquo; Hart said. &ldquo;The girls do 99% of the work, and I provide announcements. It&rsquo;s always a special night.&rdquo;</p>
<p>During Hart&rsquo;s tenure, players have elected to host games raising awareness for diseases that affected the families of team members, such as epilepsy, brain cancer and breast cancer, while also honoring causes such as military appreciation and mothers appreciation. The team has worn special jerseys in some of the past games as well.</p>
<p>Collins, Tara Martin, and Emory Taylor were the main juniors who organized this night.</p>
<p>&ldquo;Every player wrote their moms a thank you card and we decided to wear pink socks to represent our mothers,&rdquo; Collins said. &ldquo;This was very exciting for us because our moms will always be there for us &#8211; win or lose.&rdquo;</p>
<p>Each player was accompanied by a maternal figure of their choosing during Thursday&rsquo;s pregame. This ranged from biological mothers, step-moms, host moms or other representatives. All were announced by Hart and ran out to midfield for the starting lineups.</p>
<p>The team also wanted to recognize a maternal figure they all share.</p>
<p>&ldquo;Mothers Appreciation Night also included our team mom and assistant coach JoAnn Sutterby,&rdquo; Collins said. &ldquo;She always makes sure that our bodies are taken care of to play or practice&rdquo;</p>
<p>&ldquo;She definitely wears a lot of hats, serving as a coach, trainer, confidant, cheerleader and team mom,&rdquo; Hart said of Sutterby. &ldquo;We wouldn&rsquo;t be having the season we are without her.&rdquo;</p>
<p>East Surry <a href="https://www.mtairynews.com/sports/106970/bloses-late-goal-leads-to-1-0-cardinal-win-over-eagles" target="_blank" rel="noopener noreferrer">defeated </a>Surry Central 1-0 to improve to 8-5-2 on the season.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/sports/106979/mount-airy-soccer-honors-senior-trio" title="Mount Airy soccer honors senior trio" style="color:black">Mount Airy soccer honors senior trio</a></h1>

            <a href="https://www.mtairynews.com/sports/106979/mount-airy-soccer-honors-senior-trio" title="Mount Airy soccer honors senior trio">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/04/128440951_web1_278739351_10166453404930154_4780114053231934977_n.jpg" alt="Mount Airy soccer honors senior trio">
            </a>
   <p class="entry-meta">April 23, 2022</p>
   <p>Mount Airy soccer seniors Mackenzie Hudson, Grey Moore and Morgan Hiatt have seen the best and worst of times during their four years with the team.</p>
<p>The trio started their high school careers with a bang by helping the team tie a school record with 15 wins. The 2019 Bears also reached the second round of the 1A State Playoffs.</p>
<p>Then came the lows. A promising sophomore season only made it two weeks before being cancelled, then Mount Airy was only allowed to play 13 total matches the following year due to statewide limitations. Six of the Bears&rsquo; 2020-21 matches came against conference teams that were ranked among the state&rsquo;s best.</p>
<p>Playing their first full season since 2019, Hudson, Moore and Hiatt have made the most of their senior campaign in 2022. Following an April 21 win over Starmount, which also served as the Bears&rsquo; Senior Night, the team sits at 12-0-4 overall, 9-0-1 at home and 6-0 in the Northwest 1A Conference. </p>
<p>The Granite Bears, ranked No. 5 in the April 21 MaxPreps poll for the 1A West, have been on fire during the month of April. In six matches this month, Mount Airy: is 5-0-1, has five shutouts and has outscored opponents 25-1.</p>
<p>The undefeated Bears have scored 69 goals this season, including eight in the victory over Starmount, and only allowed nine. Starmount and Elkin are the only 1A teams to have scored on Mount Airy in 2022.</p>
<p>Hudson has 10 shutouts on the season as Mount Airy&rsquo;s keeper. The senior has more than 100 saves, including three penalty kick saves. East Surry and Starmount are the only teams to score more than one goal on Mount Airy in a single game.</p>
<p>Junior Alex Rose leads the team with 23 goals this season, tied with Union Academy&rsquo;s Shania Coppin for the most in the 1A West. Bear teammates Kate Deaton and Paola Ramirez have double-digit goals as well with 14 and 12, respectively. Mount Airy is the only school in the 1A West with three players ranked in the top-20 in goals.</p>
<p>Ramirez and Karyme Bueno each scored twice against Starmount, while Rose, Deaton, Moore and Hiatt each scored once. Hudson may not have scored against Starmount, but the keeper did leave the goal one week earlier to score a penalty kick against East Wilkes.</p>
<p>In addition to her two goals against Starmount, Bueno recorded her fourth game this season with multiple assists. She currently has 15 on the year, which ranks No. 3 in the 1A West.</p>
<p>Mount Airy sits atop the Northwest 1A Conference standings with a 6-0 record. The Bears have played every NW1A team once except for South Stokes, and have played Starmount twice.</p>
<p>South Stokes and Elkin sit in second place at 4-1; South lost to Elkin, and Elkin lost to Mount Airy. Starmount and Alleghany are next at 3-4, followed by East Wilkes at 1-5 and North Stokes at 0-6.</p>
<p>North and South Stokes are up next for Mount Airy. The Bears travel to Danbury on April 25, then go to Walnut Cove on April 29.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/sports/106970/bloses-late-goal-leads-to-1-0-cardinal-win-over-eagles" title="Blose&#8217;s late goal leads to 1-0 Cardinal win over Eagles" style="color:black">Blose&#8217;s late goal leads to 1-0 Cardinal win over Eagles</a></h1>

            <a href="https://www.mtairynews.com/sports/106970/bloses-late-goal-leads-to-1-0-cardinal-win-over-eagles" title="Blose&#8217;s late goal leads to 1-0 Cardinal win over Eagles">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/04/128437142_web1_DSC_0999.jpg" alt="Blose&amp;#8217;s late goal leads to 1-0 Cardinal win over Eagles">
            </a>
   <p class="entry-meta">April 23, 2022</p>
   <p>PILOT MOUNTAIN &mdash; East Surry outlasted Surry Central in a 1-0 war of attrition on Thursday.</p>
<p>The home Lady Cards and visiting Golden Eagles went scoreless for 71 minutes in the Foothills 2A Conference match, with each having opportunities to find the back of the net throughout.</p>
<p>A deflected East Surry shot in the final 10 minutes of the second half was cleared by Central, seemingly erasing the current threat. However, Cardinal senior Samantha Blose intercepted the clearance at the top of the 18-yard box and dealt the decisive blow.</p>
<p>&ldquo;Every person that stepped on the field tonight contributed,&rdquo; said East Surry coach William Hart. &ldquo;I&rsquo;m really proud of the girls for fighting all game long in a tough conference battle. They stuck with it for 80 minutes and came out on top against a talented Surry Central squad.&rdquo;</p>
<p>Despite the loss, Surry Central coach Adan Garcia felt his team played one of its strongest matches of the season.</p>
<p>&ldquo;That&rsquo;s one of those games that could&rsquo;ve easily gone either way,&rdquo; Garcia said. &ldquo;We held them as long as we could defensively, they just created that opportunity late and converted. The loss is unfortunate especially for our keeper, Fernanda Camacho, because she played such a great game and made a lot of crucial saves.</p>
<p>&ldquo;East Surry is a good team and they made a good shot. My girls have nothing to be ashamed of.&rdquo;</p>
<p>The goal-scoring drive, like most of the Cardinals&rsquo; offensive maneuvers in Thursday&rsquo;s game, saw the team progress up the sidelines. East Surry was already pressed into Central&rsquo;s half when Shirin Binder sent a through ball to Addison Goins in the corner. Goins cut into the 18 before firing a shot that was deflected down by Camacho.</p>
<p>Golden Eagle Anahi Duran swooped in to clear the deflection while the goal was unguarded. Blose was there to cut the clear off, then fired a shot to the far post.</p>
<p>&ldquo;That entire run started with Shirin,&rdquo; Hart said. &ldquo;We kept telling the girls to stay the course and good things would happen against that strong back line, and we eventually got our shot.&rdquo;</p>
<p>Persistence was key for the Cardinals. East Surry spent a lot of the first half on Central&rsquo;s half, but the Eagles&rsquo; defense held the Cards to distant shots. Golden Eagle sweeper Lillian Orozco was the last line of defense for the visitors and saved multiple one-on-one opportunities.</p>
<p>Many of East&rsquo;s shots never made it past Central&rsquo;s back line as they retreated back to the box. Blose and Morgan Bryant each made runs up the left sideline early in the first half that were stopped before they reached the goal, and Goins&rsquo; runs led to a series of corner kicks that were booted from the danger zone.</p>
<p>Bryant and Liannette Chavez combined to take six corners for East in the first alone, including two in the final four minutes of the first half, yet the score remained 0-0 going into halftime.</p>
<p>The Golden Eagles&rsquo; offense controlled the pace of the game for much of the second half. Midfielder Yuri Ramirez distributed to the forwards, while also passing back to the defense and resetting when the situation called for it.</p>
<p>The first foul of the game wasn&rsquo;t called until the 49th minute. Ramirez used the subsequent free kick to fire a shot on goal from 35 yards out, but it was saved by Cardinal keeper Katie Collins. Dafne Salgado-Perez picked up a steal in East&rsquo;s defensive third a few minutes later and put a shot on target, but it too was saved by Collins.</p>
<p>Within 60 seconds of Salgado-Perez&rsquo;s shot, Central&rsquo;s Wendy Cantor placed a shot on goal from the middle of the field. This too was wrapped up by Collins, who finished the night with seven saves.</p>
<p>The Cardinals&rsquo; offense was rejuvenated once the game entered its final 12 minutes. Chavez and Goins operated up the right sideline on an attack, and Goins&rsquo; attempt on the goal &#8211; which was just East&rsquo;s second shot of the second half &#8211; was deflected out for a corner kick. Chavez&rsquo;s corner soared across the six-yard box and was nearly poked in by Bryant at the far post.</p>
<p>East Surry&rsquo;s third shot was the charm when Blose scored with 9:30 on the clock. Central&rsquo;s Orozco, who spent much of the second half pushed up on offense while Cantor moved to sweeper, put a shot on goal less than a minute after the goal but it was saved by Collins.</p>
<p>East spent the final few minutes of the game pressed up in Central&rsquo;s half to hold on for the win.</p>
<p>The Cardinals (8-5-2) have won four of their past five matches, with their only loss in that time coming against one of the top-ranked teams in the state, Wilkes Central. All four wins have been shutouts, giving Collins a total of six for the season.</p>
<p>The Golden Eagles (5-9-3) came into April riding a three-match winning streak, but have dropped their past four matches. With the exception of a game at Wilkes Central, Surry Central has been competitive in each of those matches: a 2-1 overtime loss to West Wilkes, a 3-1 loss at Forbush and the 1-0 game against East Surry.</p>
<p>&ldquo;West Wilkes was like the East Surry game where we were close the entire time, but just came up short in the end,&rdquo; Garcia said. &ldquo;The Forbush game was huge because we were tied with them at halftime. Forbush is a very talented team and one of the best in the 2A division, and that&rsquo;s one of the most difficult places to play.</p>
<p>&ldquo;In the end it sucks to lose, but we are going out there and competing with great teams. Where we are now is night-and-day compared to where we started the season, and I know good things are coming our way if we keep working.&rdquo;</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/sports/106990/taylor-walk-off-lifts-hounds-over-eagles" title="Taylor walk-off lifts Hounds over Eagles" style="color:black">Taylor walk-off lifts Hounds over Eagles</a></h1>

            <a href="https://www.mtairynews.com/sports/106990/taylor-walk-off-lifts-hounds-over-eagles" title="Taylor walk-off lifts Hounds over Eagles">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/04/128441018_web1_DSC_0700--43-.jpg" alt="Taylor walk-off lifts Hounds over Eagles">
            </a>
   <p class="entry-meta">April 22, 2022</p>
   <p>The second part of an intense rivalry played out in Toast on Friday.</p>
<p>North Surry hosted Surry Central in a game with conference tournament &#8211; and potentially 2A State Playoff &#8211; implications.</p>
<p>In their first game against North earlier in the week, Surry Central&rsquo;s rally in the bottom of the seventh inning yielded one run but came up short as North won 4-3. Fast-forward three days to April 22 and all eyes were on the Greyhound batters.</p>
<p>With two men on base, the score tied 2-2 and a 2-2 count North Surry&rsquo;s Cam Taylor hit a line drive to right field to bring in Ethan Edwards for the game-winning run. The walk-off secured the season sweep for the Hounds.</p>
<p>North Surry led 2-1 after the first inning, and the same was true after the fifth inning. Both sides had chances to build a lead, with the Eagles and Hounds combining for 12 hits and 11 bases on balls. However, eight runners were left on base by each team.</p>
<p>In addition to hitting the walk-off to end the game, Taylor spent 5.2 innings on the mound for North Surry. The junior struck out four batters, walked three, and gave up two runs on seven hits. James McCreary threw the final 1.1 innings and struck out two batters.</p>
<p>Justin Reeves pitched 6.2 innings for Central and threw four strikeouts, seven walks and allowed three runs on four hits. Clay Whitaker also spent time on the mound, walking one batter and giving up one hit.</p>
<p>Most of the scoring action went down in the first 20 minutes of Friday&rsquo;s game. Central&rsquo;s Dakota Mills led off in the game with a single, then a Whitaker triple to right field scored Mills. Whitaker had a chance to score on a Brady Edmonds hit, but was tagged out at the plate. North turned a double play to minimize the damage.</p>
<p>Following a ground out by the leadoff batter, McCreary hit a single and Edwards reached first on a fielding error in the bottom of the first. Central forced the second out when Edmonds caught a pop fly in right field, then rifled a throw back to the infield to keep the runners on the corners.</p>
<p>Brodie Robertson was walked to load the bases, then Taylor was walked to bring McCreary across the plate to tie the game at 1-1. Myles Draughn singled to right-center field to score Edwards. Robertson&rsquo;s courtesy runner, Alec Singleton, rounded third and went home in hopes of scoring run No. 3, but Whitaker made the throw to Mills at the plate for the tag.</p>
<p>The Greyhounds only recorded two hits between Draughn&rsquo;s RBI in the bottom of the first and Taylor&rsquo;s walk-off in the bottom of the seventh: an Edwards double in the fifth inning, and an Edwards single in the bottom of the seventh. The Hounds did have six runners put on base via walks and another on a fielder&rsquo;s choice.</p>
<p>The Golden Eagles put runners on base in each inning but the seventh, but could only add one run the rest of the game.</p>
<p>Central&rsquo;s tying run came in the top of the sixth with two outs already on the board. Lucas Johnson, who singled twice on his earlier plate appearances, reached first on a Greyhound fielding error. Mason Jewell singled with a blooper to left-center field, and Spencer LeClair followed it up with a grounder to the same spot to load the bases.</p>
<p>Kendall White faced a 2-2 count with bases loaded when Taylor threw balls three and four to bring Johnson in for the tying run. The Hounds swapped McCreary onto the mound, and got out of the inning with a strikeout.</p>
<p>North went three up, three down in the bottom of the sixth, and Central did the same in the top of the seventh.</p>
<p>Reeves struck out two of the first three batters in the bottom of the seventh, with a single from Edwards sandwiched in-between. Whitaker took over on the mound with Reeves reaching his pitch count, and Robertson was walked to put runners on first and second. Taylor&rsquo;s subsequent hit to right field gave Edwards enough time to round third and score the game-winning run.</p>
<p>The FH2A Conference&rsquo;s top seed has already been decided since East Surry holds at least a four-game lead over the rest of the league. Second through fifth place will be determined during the final week of the regular season.</p>
<p>Surry Central and Forbush are tied at 6-4, West Wilkes&rsquo; conference season has already ended at 7-5, and North Surry is 5-5.</p>
<p>North Surry will compete in a series against North Wilkes (0-10 FH2A) to close the regular season, while Surry Central faces East Surry (10-0 FH2A).</p>
<p>Scoring</p>
<p>Surry Central &#8211; 1, 0, 0, 0, 0, 1, 0 = 2</p>
<p>North Surry &#8211; 2, 0, 0, 0, 0, 0, 1 = 3</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/sports/106944/foothills-2a-tennis-championship-results" title="Foothills 2A Tennis Championship Results" style="color:black">Foothills 2A Tennis Championship Results</a></h1>

            <a href="https://www.mtairynews.com/sports/106944/foothills-2a-tennis-championship-results" title="Foothills 2A Tennis Championship Results">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/04/128437171_web1_My-project--2-.jpg" alt="Foothills 2A Tennis Championship Results">
            </a>
   <p class="entry-meta">April 22, 2022</p>
   <p>North Surry High School played host to the 2021-22 Boys Tennis Foothills 2A Conference Championship on Thursday.</p>
<p>East Surry and Surry Central both had dominant performances, and each occupied both spaces in a championship round. The Singles Championship came down to East Surry vs. East Surry, and the Doubles Championship came down to Surry Central vs. Surry Central.</p>
<p>All four singles competitors and four doubles teams to reach the semifinal round automatically qualify for the 2A Midwest Regional Championship. East Surry earned three of the qualifying spots, Surry Central and North Wilkes each claimed two, and the final qualifying bid went to Forbush.</p>
<p>In singles: East Surry&rsquo;s Cooper Motsinger won first, East Surry&rsquo;s Levi Watson finished second, and North Wilkes&rsquo; Aiden Pennell and Mitch Adams reached the semifinals.</p>
<p>In doubles: Surry Central&rsquo;s team of Josh Pardue and Jacob Edmonds won first, the Surry Central duo of Tripp McMillen and Michael Tucker finished second, while East Surry&rsquo;s Kade Talton and Nick Lowery reached one semifinal and Forbush&rsquo;s Calvin Norman and Cooper Hennings reached the other.</p>
<p>Surry Central swept the conference&rsquo;s top regular season honors. Pardue was named FH2A Player of the Year for finishing the going 12-0 in singles and 12-0 in doubles against conference teams. Mason Midkiff was named FH2A Coach of the Year after guiding Surry Central to a 12-0 conference record and its first conference championship in at least 13 years.</p>
<p><strong>Singles</strong></p>
<p>Motsinger came into the FH2A as the No. 1 seed and earned a first-round BYE thanks to his 10-2 singles record against conference opponents.</p>
<p>The opening matches of each bracket played eight-game pro sets, while every subsequent round was contested in the standard 2-of-3 sets.</p>
<p>Forbush&rsquo;s Samuel Crews defeated North Surry&rsquo;s Colby Callaway 8-3 in the opening round, then Motsinger defeated Crews 6-0, 6-1. North Wilkes&rsquo; Adams defeated Surry Central&rsquo;s Isaac Eller 8-2 in the opening round, then advanced to the semifinals with a 6-0, 6-2 win over Wilkes Central&rsquo;s Gage York.</p>
<p>On the bottom half of the bracket, North Wilkes&rsquo; Pennell earned a first-round BYE as the No. 2 seed then defeated Forbush&rsquo;s Jacob St. John in the quarterfinals. No. 6 Watson defeated Maddox Martin of Surry Central 8-3, then upset No. 3 seeded Nick Hall of Wilkes Central 6-1, 6-1.</p>
<p>Motsinger defeated Adams 6-0, 6-1 in one semifinal. Watson won his first set 6-3 over Pennell, then led 4-0 when Pennell retired from the match.</p>
<p>Motsinger defeated his Cardinal teammate 6-2, 6-0 to win the FH2A Singles Championship.</p>
<p><strong>Doubles</strong></p>
<p>Pardue and Edmonds were the No. 1 seed in the doubles tournament thanks to a perfect 12-0 record as a doubles team in conference play.</p>
<p>North Surry&rsquo;s Jordan Inman and Ty Richardson defeated North Wilkes&rsquo; Caleb Parsons and Lucas Berrier 8-6 in the opening round. The Greyhound duo ran into Pardue and Edmonds in the quarterfinals and lost 6-1, 6-1.</p>
<p>East Surry&rsquo;s Talton and Lowery, seeded No. 4, defeated a team from West Wilkes 8-1 in the first round (West Wilkes doesn&rsquo;t have a roster available on MaxPreps), then the Cardinal pair beat Forbush&rsquo;s Wyatt Graham and Caden Funk 3-6, 6-4, 6-2 to advance to the semifinals.</p>
<p>On the bottom half of the bracket, Forbush&rsquo;s Norman and Hennings were the No. 2 seed. East Surry&rsquo;s Lupe Chavez and Noah Hopkins defeated North Wilkes&rsquo; Marshall Welborn and Evan Dubuque 8-0 in the opening round, then Norman and Hopkins defeated the Cardinal team 7-5, 4-6, 6-1.</p>
<p>The No. 6-ranked team of Surry Central&rsquo;s Tucker and McMillen defeated a team from West Wilkes 8-0 in the opening round, then topped North Surry&rsquo;s No. 3-seeded team of Holdin Hall and Nathan Lattimore 6-2, 6-2 to reach the semifinals.</p>
<p>Pardue and Edmonds beat Talton and Lowery 6-0, 6-3 in one semifinal, and the team of Tucker and McMillen defeated Forbush&rsquo;s Norman and Hennings 6-0, 6-2 in the other semifinal.</p>
<p>Pardue and Edmonds defeated their Golden Eagle teammates 6-2, 6-2 to capture the FH2A Doubles Championship.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/sports/106906/greyhounds-honor-senior-tennis-players" title="Greyhounds honor senior tennis players" style="color:black">Greyhounds honor senior tennis players</a></h1>

            <a href="https://www.mtairynews.com/sports/106906/greyhounds-honor-senior-tennis-players" title="Greyhounds honor senior tennis players">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/04/128435088_web1_277835903_523338549186612_6856292386257946305_n-560x509.jpg" alt="Greyhounds honor senior tennis players">
            </a>
   <p class="entry-meta">April 21, 2022</p>
   <p>North Surry High School recognized three senior tennis players prior to an April 19 match against North Wilkes.</p>
<p>The trio of Holdin Hall, Nathan Lattimore and Colby Callaway were honored as part of the school&rsquo;s Senior Night festivities. The three were also part of the Greyhounds&rsquo; season-closing 6-3 win over North Wilkes.</p>
<p>North Surry (4-10, 4-8 Foothills 2A) finished fifth in the conference standings with the win, and trailed Wilkes Central by just one match.</p>
<p>The Hounds won four singles matches, sweeping courts three through six.</p>
<p>Callaway defeated North Wilkes&rsquo; Marshall Welborn 6-0, 6-4 in No. 3 singles, Jordan Inman defeated Caleb Parsons 6-4, 6-4 in No. 4 singles, Ryan Woodruff defeated Lucas Berrier 6-2, 6-1 in No. 5 singles, and Ty Richardson defeated Evan Dubuque 6-0, 6-0 in No. 6 singles.</p>
<p>North Wilkes won the top two singles matches. The Vikings&rsquo; Aiden Pennell defeated Hall 6-0, 6-0 on court No. 1, and Mitch Adams defeated Lattimore 6-2, 6-0 on court No. 2.</p>
<p>North Wilkes&rsquo; third and final win of the afternoon came in No. 1 doubles, where the duo of Pennell and Adams topped Hall and Lattimore 8-1.</p>
<p>The remaining doubles matches went the way of the Greyhounds.</p>
<p>Callaway and Woodruff defeated Parsons and Berrier 8-2 in No. 2 doubles, and Inman and Richardson joined forces to beat Welborn and Dubuque 8-3 in No. 3 doubles.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/sports/106903/surry-community-softball-enters-national-rankings" title="Surry Community Softball enters national rankings" style="color:black">Surry Community Softball enters national rankings</a></h1>

            <a href="https://www.mtairynews.com/sports/106903/surry-community-softball-enters-national-rankings" title="Surry Community Softball enters national rankings">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/04/128432662_web1_DraughnAbbigailAction.jpg" alt="Surry Community Softball enters national rankings">
            </a>
   <p class="entry-meta">April 21, 2022</p>
   <p>CHARLOTTE &#8211; The Surry Community College softball team is ranked 20th in the latest National Junior College Athletic Association (NJCAA) Division II softball poll.</p>
<p>The Lady Knights are currently 29-8 overall and 17-5 in conference play.</p>
<p>Offensively, Surry ranks second among Region 10 colleges in slugging percentage (.604) and home runs (41), while ranking third in batting average (.373) and on-base percentage (. 425).</p>
<p>The Lady Knights have several offensive weapons including: Kelsey Craven (Eastern Randolph High School), who currently leads the team in batting average (.478), home runs (9) and RBIs with 48; Taylor Allen (Alleghany HS) with a .465 batting average, seven home runs and 34 RBIs to the lineup; Kaylee Snow (Surry Central HS) posts a .473 batting average along with two home runs and 19 RBIs.</p>
<p>Surry&rsquo;s Megan Atkins (Surry Central HS) is hitting at a .455 clip to go along with three home runs and 29 RBIs. Rachel Cooke (Maiden HS) has supplied power to the lineup with seven home runs and 36 RBIs, while teammates Abbigail Draughn (North Surry HS) and Makara Woodbury (North Surry HS) have added five and four home runs, respectively.</p>
<p>On the mound, Draughn leads the Lady Knights with a 13-4 record and 2.57 earned run average. The right-hander has pitched 106.1 innings, allowing 95 hits while striking out 71 batters. Atkins currently has a 6-3 record along with a 4.18 earned run average. In 70.1 innings pitched, Atkins has allowed 93 hits while striking out 56 batters.</p>
<p>Defensively, the Knights lead Region 10 with a .962 fielding percentage and have gotten stellar play from catcher K.G. White (Starmount HS) who has not committed an error, along with fellow catcher Allie Bruner (East Surry HS) with just one error on the season.</p>
<p>Region 10 was represented by three teams in the latest NJCAA National poll with Louisburg College (27-3) ranked fourth, Pitt Community College (25-7) ranked 17th and Surry ranked 20th.</p>
<p>Des Moines Area Community College from Iowa is currently ranked first with a 40-3 record.</p>
<p>The Lady Knights continue play on April 23 by hosting Cleveland Community College at 1:00 pm in a doubleheader.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/sports/106898/nw1a-conference-tennis-results" title="NW1A Conference Tennis results" style="color:black">NW1A Conference Tennis results</a></h1>

            <a href="https://www.mtairynews.com/sports/106898/nw1a-conference-tennis-results" title="NW1A Conference Tennis results">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/04/128434881_web1_278051313_1653958758291413_1840226840436974021_n.jpg" alt="NW1A Conference Tennis results">
            </a>
   <p class="entry-meta">April 21, 2022</p>
   <p>Singles and doubles champions were crowned at the 2021-22 Northwest 1A Conference Boys Tennis Tournament held April 19-20.</p>
<p>The Elkin Buckin&rsquo; Elks won both the singles and doubles titles, and also earned three of the conference&rsquo;s six qualifying spots for the 1A West Regional Championship Tournament; two doubles teams and one singles competitor. Mount Airy had two of the remaining three spots &#8211; consisting of one singles competitor and one doubles team &#8211; and the final qualifying spot went to a singles player from East Wilkes.</p>
<p>The top three finishers in each bracket qualified for regionals. This is a change from previous years when the top four of each bracket would advance to the regional competition.</p>
<p>In singles: Elkin&rsquo;s Owen Jennings finished first, Mount Airy&rsquo;s Georgie Kriek finished second and East Wilkes&rsquo; Braxton Long took third.</p>
<p>In doubles: Elkin&rsquo;s team of Luke McComb and Clay Sebastian finished first, Elkin&rsquo;s Thomas McComb and Jack Zamudio finished second, and Mount Airy&rsquo;s Martin Cooke and Jared Pinto finished third.</p>
<p>Mount Airy swept the conference&rsquo;s top regular season honors. Kriek was named NW1A Player of the Year for finishing the going 10-0 in singles and 10-0 in doubles against conference teams during the regular season. Luke Graham was named Coach of the Year after guiding the team to the NW1A Championship with an undefeated 10-0 record</p>
<p><strong>Singles</strong></p>
<p>Kriek and Jennings entered the singles tournament as the top two seeds. In the regular season, Kriek went 10-0 in the conference and Jennings went 8-2. Jennings&rsquo; only conference singles losses came against Kriek.</p>
<p>Kriek opened the tournament with a 6-0, 6-0 win over a Starmount player (no Starmount roster listed on MaxPreps), then reached the championship by defeating East Wilkes&rsquo; Long 6-0, 7-5.</p>
<p>On the bottom half of the bracket: Jennings defeated South Stokes&rsquo; Cohen Boak 6-0, 6-0, and Mount Airy&rsquo;s Carson Hill defeated East Wilkes&rsquo; Luke Macemore 6-1, 6-3. Jennings topped Hill 6-1, 6-3 to advance to the championship.</p>
<p>Jennings became the first NW1A player to defeat Kriek in singles by winning the championship 6-4, 6-1.</p>
<p>Hill and Long went three sets in the consolation finals. Long won the first set 6-2, Hill took the second set 6-3 and Long won the third set 6-2.</p>
<p><strong>Doubles</strong></p>
<p>Zamudio and Thomas McComb defeated East Wilkes&rsquo; James Cook and Weston Cook 6-3, 6-1 in the quarterfinals, then topped Mount Airy&rsquo;s John Juno and Dylan Tilley 7-6 (7-3), 6-3 in the semifinals. Juno and Tilley had reached the semifinal round by beating South Stokes&rsquo; Wyatt Simmons and Ian Clark 6-1, 1-6, 6-2 in the quarterfinal round.</p>
<p>The bottom half of the bracket also saw teams from Mount Airy and Elkin advance to the semifinal.</p>
<p>Cooke and Pinto defeated South Stokes&rsquo; Nick Leophard and Noah Leophard 6-0, 6-0 in the opening round, then beat East Wilkes&rsquo; Cole Macemore and Nathaniel Burchette 6-4, 6-0.</p>
<p>Elkin&rsquo;s Sebastian and Luke McComb beat a Starmount doubles team (no Starmount roster listed on MaxPreps) in the quarterfinals 6-1, 6-1, then topped Cooke and Pinto in the semis 6-1, 6-3.</p>
<p>Sebastian and Luke McComb defeated Elkin teammates Zamudio and Thomas McComb 5-7, 6-4, 6-4 to win the NW1A doubles title.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/sports/106886/bears-battle-back-to-best-eagles" title="Bears battle back to best Eagles" style="color:black">Bears battle back to best Eagles</a></h1>

            <a href="https://www.mtairynews.com/sports/106886/bears-battle-back-to-best-eagles" title="Bears battle back to best Eagles">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/04/128433488_web1_DSC_0549.jpg" alt="Bears battle back to best Eagles">
            </a>
   <p class="entry-meta">April 21, 2022</p>
   <p>Similar to the first meeting between the two teams seven days earlier, a third-inning momentum shift helped Mount Airy defeat Surry Central on April 20.</p>
<p>When the Granite Bears and Golden Eagles played in Dobson on April 13, Mount Airy&rsquo;s lead slowly grew with one or two runs per inning. On Wednesday, Mount Airy went from no runs to 13 runs in the span of two innings.</p>
<p>The Bears tacked on three runs as insurance in the sixth inning, going on to defeat their county foe 16-7.</p>
<p>Mount Airy (13-7, 7-2 Northwest 1A) racked up 15 hits in Wednesday&rsquo;s win. Ian Gallimore and Logan Dowell each had three hits, and Rylan Venable and Cameryn Wilson each had two. Venable led the way with five RBIs &#8211; including a 3-run home run that gave Mount Airy its first lead of the night &#8211; while Dowell and Landon Cox each had three RBIs.</p>
<p>Wilson threw six innings for the Granite Bears, and Ashton Gwyn pitched the final inning. Wilson struck out four batters, walked three and allowed seven runs on seven hits. Gwyn struck out all three of his batters in the seventh inning.</p>
<p>The Golden Eagles utilized four different pitchers in Wednesday&rsquo;s game. Max Lambert, Aiden Shropshire, Spencer LeClair and Lucas Johnson combined to throw seven strikeouts, walk five batters and allow 16 runs on 15 hits.</p>
<p>Lambert started on the mound for Central for the first time in more than a month. While the Bears did put five runners on base in the first two innings, Lambert&rsquo;s three strikeouts helped the Eagles hold Mount Airy scoreless during this time.</p>
<p>Central (11-8, 6-3 Foothills 2A), meanwhile, didn&rsquo;t want a repeat of the first Mount Airy game in which the Eagles left six runners on base through three innings.</p>
<p>Dakota Mills led the game off with a double before stealing third and scoring on a wild pitch. In the second inning, Kendall White hit a 2RBI single to score Johnson and Mason Jewell, then a fielding error on a Clay Whitaker hit allowed LeClair to score run No. 4.</p>
<p>The tides began to turn in the third inning. Jewell had a single for Central, but was the only Eagle to get on base in the inning&rsquo;s top half. Then in the bottom of the inning, the Bears&rsquo; first two batters &#8211; Dowell and Reece Deaton &#8211; each singled and moved to scoring position by stealing.</p>
<p>An error on a Wilson hit allowed Dowell to score, then an error on a Brison George hit scored Deaton. Central forced a ground out at first for the second out, but the score would soon be tied after Cox hit a 2RBI single. The leadoff Gallimore doubled to put Cox on third before Venable hammered a 3-run homer to make it 7-4 for the home team.</p>
<p>Surry Central didn&rsquo;t just roll over, though. Mills made his way around the diamond after being walked, going to second on a balk and stealing third. The inning could&rsquo;ve ended when Mills was caught in a pickle between second and third with two outs, but a miscue by the Bears kept the inning alive.</p>
<p>Mills was sent home soon after when Brady Edmonds crushed a double to the center field fence. Kade Norman scored Edmonds with a single, closing the gap to 7-6.</p>
<p>Similar to the bottom of the third inning, two singles and a walk for Mount Airy immediately put the Bears in position to score. Gwyn was hit by a pitch with loaded bases to score the eighth run, then a single by error hit by Cox made it 9-6. Central managed to pick up the second out, but it was followed by back-to-back 2RBI hits from Venable and Dowell to increase the lead to 13-6.</p>
<p>Neither side scored in the fifth inning. Mills scored for a third time by starting the top of the sixth inning with a solo home run, however, this would be Central&rsquo;s only hit of the last three innings.</p>
<p>Mount Airy put Gallimore and Venable on base in the sixth inning, then Dowell scored Gallimore with an RBI single. Kamden Hawks scored both Venable and Dowell later in the inning with a 2RBI double that made it 16-7.</p>
<p>Both the Bears and Golden Eagles will compete in key conference matchups on April 22.</p>
<p>Mount Airy is currently second in the NW1A Conference with a 7-2 record, trailing first-place South Stokes (9-5, 8-1 NW1A) by one game. The Bears need to win out and hope the Sauras lose to make the NW1A title picture interesting. Mount Airy travels to Elkin (6-10, 1-8 NW1A) on Friday.</p>
<p>Surry Central is in a similar situation in the FH2A Conference. The Golden Eagles sit at 6-3 and are the only team in the conference capable of tying East Surry (15-1, 9-0 FH2A) for first. In order to tie for first, all three of these must happen: Surry Central defeats North Surry (11-8, 4-5 FH2A) on Friday, East Surry loses to West Wilkes (11-8, 7-4 FH2A) on Friday and Surry Central beats East Surry twice next week.</p>
<p>Scoring</p>
<p>Surry Central &#8211; 1, 3, 0, 2, 0, 1, 0 = 7</p>
<p>Mount Airy &#8211; 0, 0, 7, 6, 0, 3, X = 16</p>
</article>

</div></div></ul><div class="alm-paging">Pages: <span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year">1</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/2">2</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/3">3</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/4">4</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/5">5</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/6">6</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/7">7</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/8">8</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/9">9</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/10">10</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/11">11</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/12">12</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/13">13</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/14">14</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/15">15</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/16">16</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/17">17</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/18">18</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/19">19</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/20">20</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/21">21</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/22">22</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/23">23</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/24">24</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/25">25</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/26">26</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/27">27</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/28">28</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/29">29</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/30">30</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/31">31</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/32">32</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/33">33</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/34">34</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/35">35</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/36">36</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/37">37</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/38">38</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/39">39</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/40">40</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/41">41</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/42">42</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/43">43</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/44">44</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/45">45</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/46">46</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/47">47</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/48">48</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/49">49</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/50">50</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/51">51</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/52">52</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/53">53</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/54">54</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/55">55</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/56">56</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/57">57</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/58">58</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/59">59</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/60">60</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/61">61</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/62">62</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/63">63</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/64">64</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/65">65</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/66">66</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/67">67</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/68">68</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/69">69</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/70">70</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/71">71</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/72">72</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/73">73</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/74">74</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/75">75</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/76">76</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/77">77</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/78">78</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/79">79</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/80">80</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/81">81</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/82">82</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/83">83</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/84">84</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/85">85</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/86">86</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/87">87</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/88">88</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/89">89</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/90">90</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/91">91</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/92">92</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/93">93</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/94">94</a></span><span class="page"><a href="https://www.mtairynews.com/sports/110096/its-been-one-heck-of-a-year/page/95">95</a></span></div></noscript><div class="alm-btn-wrap" style="visibility: hidden;"><button class="alm-load-more-btn more " rel="next" type="button">Next Article</button></div></div>	
		</div>

		 		<aside class="mh-widget-col-1 mh-sidebar" itemscope="itemscope" itemtype="http://schema.org/WPSideBar"><div id="custom_html-13" class="widget_text mh-widget widget_custom_html"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Weather</span></h4><div class="textwidget custom-html-widget"><div style="width: 300px;"><iframe style="display: block;" src="https://cdnres.willyweather.com/widget/loadView.html?id=100630" width="300" height="228" frameborder="0" scrolling="no"></iframe><a style="height: 20px;position: relative;margin: -20px 0 0 0;text-indent: -9999em;display: block;z-index: 1" href="https://mtairynews.com/weather" rel="nofollow">mount airy weekly forecast</a></div>

<ins data-revive-zoneid="10" data-revive-id="7704ed944ed7863d36a61d5fccf7693e"></ins>
</div></div><div id="custom_html-31" class="widget_text mh-widget widget_custom_html"><div class="textwidget custom-html-widget"><p>
<ins data-revive-zoneid="123" data-revive-id="7704ed944ed7863d36a61d5fccf7693e"></ins>

</p><p>
<ins data-revive-zoneid="124" data-revive-id="7704ed944ed7863d36a61d5fccf7693e"></ins>

</p><p>
<ins data-revive-zoneid="125" data-revive-id="7704ed944ed7863d36a61d5fccf7693e"></ins>

</p><p>
<ins data-revive-zoneid="126" data-revive-id="7704ed944ed7863d36a61d5fccf7693e"></ins>

</p></div></div><div id="custom_html-2" class="widget_text mh-widget widget_custom_html"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Advertisement</span></h4><div class="textwidget custom-html-widget"><!---<ins data-revive-zoneid="1" data-revive-id="7704ed944ed7863d36a61d5fccf7693e"></ins>--->
</div></div><div id="custom_html-39" class="widget_text mh-widget widget_custom_html"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Video</span></h4><div class="textwidget custom-html-widget"><ins data-revive-zoneid="152" data-revive-id="7704ed944ed7863d36a61d5fccf7693e"></ins>
<script async src="//adamsads.midtc.com/www/delivery/asyncjs.php"></script></div></div><div id="custom_html-4" class="widget_text mh-widget widget_custom_html"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Advertisement</span></h4><div class="textwidget custom-html-widget"><!---<ins data-revive-zoneid="2" data-revive-id="7704ed944ed7863d36a61d5fccf7693e"></ins>--->
</div></div><div id="custom_html-15" class="widget_text mh-widget widget_custom_html"><div class="textwidget custom-html-widget"><ins data-revive-zoneid="97" data-revive-id="7704ed944ed7863d36a61d5fccf7693e"></ins>
</div></div><div id="custom_html-17" class="widget_text mh-widget widget_custom_html"><div class="textwidget custom-html-widget"><ins data-revive-zoneid="112" data-revive-id="7704ed944ed7863d36a61d5fccf7693e"></ins>
</div></div><div id="custom_html-6" class="widget_text mh-widget widget_custom_html"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Advertisement</span></h4><div class="textwidget custom-html-widget"><!---<ins data-revive-zoneid="3" data-revive-id="7704ed944ed7863d36a61d5fccf7693e"></ins>--->
</div></div><div id="custom_html-24" class="widget_text mh-widget widget_custom_html"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Poll</span></h4><div class="textwidget custom-html-widget"><script type="text/javascript" src="https://www.civicscience.com/widget/jspoll/?elt=130efe3f-8872-9e24-3d0a-f08413db6479&amp;tgtid=0ea95aa6-abf0-e1a4-91f4-4a6b1d2e6b5e"></script>
<div id="130efe3f-8872-9e24-3d0a-f08413db6479"></div></div></div><div id="custom_html-40" class="widget_text mh-widget widget_custom_html"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Recipe of the Day</span></h4><div class="textwidget custom-html-widget"><!-- APG TN/NC/VA; Recipe Of The Day -->

<div id="ahm-rotd" class="ahm-rotd" style="display: inline-block; vertical-align: top;max-width:365px;width: calc( 100% - 310px ); min-width: 300px;"></div><div style="display: inline-block; margin: 0 auto; width: calc(100% - 375px); min-width: 300px;"><div style="margin: 0 auto; vertical-align: top;height: 250px; width: 300px; background: #666;width: 300px; min-height: 50px;" id="_snup-rtdx-ldgr1"></div></div>

<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':

new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],

j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=

'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);

})(window,document,'script','dataLayer','GTM-ML7VZQM');</script>
</div></div><div id="custom_html-8" class="widget_text mh-widget widget_custom_html"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Advertisement</span></h4><div class="textwidget custom-html-widget"><!---<ins data-revive-zoneid="4" data-revive-id="7704ed944ed7863d36a61d5fccf7693e"></ins>---></div></div>	</aside>

	</div>
    </div>
<footer class="mh-footer" itemscope="itemscope" itemtype="http://schema.org/WPFooter">
<div class="mh-container mh-container-inner mh-footer-widgets mh-row clearfix">
<div class="mh-col-1-2 mh-widget-col-2 mh-footer-2-cols  mh-footer-area mh-footer-1">
<div id="media_image-2" class="mh-footer-widget widget_media_image"><a href="https://mtairynews.com"><img width="300" height="29" src="https://s24476.pcdn.co/wp-content/uploads/2018/09/mtairynews-300x29.png" class="image wp-image-65276  attachment-medium size-medium" alt="" style="max-width: 100%; height: auto;" srcset="https://s24476.pcdn.co/wp-content/uploads/2018/09/mtairynews-300x29.png 300w, https://s24476.pcdn.co/wp-content/uploads/2018/09/mtairynews.png 374w" sizes="(max-width: 300px) 100vw, 300px" /></a></div></div>
<div class="mh-col-1-2 mh-widget-col-2 mh-footer-2-cols  mh-footer-area mh-footer-4">
<div id="custom_html-27" class="widget_text mh-footer-widget widget_custom_html"><h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner">Contact</span></h6><div class="textwidget custom-html-widget"><b>Phone:</b><br>
336-786-4141<br>
<b>Fax:</b><br>
336-789-2816<br>
<b>Address:</b><br>
319 N. Renfro Street,<br> 
Mount Airy NC, 27030</div></div><div id="custom_html-36" class="widget_text mh-footer-widget widget_custom_html"><div class="textwidget custom-html-widget"><script src="//adamsads.midtc.com/www/delivery/asyncjs.php"></script></div></div></div>
</div>
</footer>
	<div class="mh-footer-nav-mobile"></div>
	<nav class="mh-navigation mh-footer-nav" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
		<div class="mh-container mh-container-inner clearfix">
			<div class="menu-footer-container"><ul id="menu-footer" class="menu"><li id="menu-item-77700" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-77700"><a href="https://www.mtairynews.com/terms-of-use">Terms Of Use</a></li>
<li id="menu-item-87777" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87777"><a href="https://www.mtairynews.com/cookie-policy-us">Cookie Policy (US)</a></li>
<li id="menu-item-87778" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-87778"><a href="https://www.mtairynews.com/privacy-statement-us">Privacy statement (US)</a></li>
<li id="menu-item-87779" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87779"><a href="https://www.mtairynews.com/disclaimer">Disclaimer</a></li>
</ul></div>		</div>
	</nav>
<div class="mh-copyright-wrap">
	<div class="mh-container mh-container-inner clearfix">
		<p class="mh-copyright">
			&copy; 2018 The Mount Airy News		</p>
	</div>
</div>
<a href="#" class="mh-back-to-top"><i class="fa fa-chevron-up"></i></a>
</div><!-- .mh-container-outer -->
<!-- Google Tag Manager -->
	<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
	new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
	j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
	'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
	})(window,document,'script','dataLayer','GTM-WCB7NXP');</script>
	<!-- End Google Tag Manager --><script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"mtairynews"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s24476.pcdn.co/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.22'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.22"},"disqusIdentifier":"110096 https:\/\/www.mtairynews.com\/sports\/110096\/its-been-one-heck-of-a-year","disqusShortname":"mtairynews","disqusTitle":"\u2018It\u2019s been one heck of a year\u2019","disqusUrl":"https:\/\/www.mtairynews.com\/sports\/110096\/its-been-one-heck-of-a-year","postId":"110096"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s24476.pcdn.co/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.22'></script>
<script type='text/javascript' src='https://s24476.pcdn.co/wp-includes/js/comment-reply.min.js?ver=5.3.12'></script>
<script type='text/javascript' src='https://s24476.pcdn.co/wp-includes/js/hoverIntent.min.js?ver=1.8.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var megamenu = {"timeout":"300","interval":"100"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s24476.pcdn.co/wp-content/plugins/megamenu/js/maxmegamenu.js?ver=2.9.6'></script>
<script type='text/javascript' src='https://s24476.pcdn.co/wp-includes/js/wp-embed.min.js?ver=5.3.12'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var alm_localize = {"ajaxurl":"https:\/\/www.mtairynews.com\/wp-admin\/admin-ajax.php","alm_nonce":"977ce13ec2","rest_api":"https:\/\/www.mtairynews.com\/wp-json\/","rest_nonce":"830ae47710","pluginurl":"https:\/\/www.mtairynews.com\/wp-content\/plugins\/ajax-load-more","speed":"200","ga_debug":"false","results_text":"Viewing {post_count} of {total_posts} results.","no_results_text":"No results found.","alm_debug":"","a11y_focus":"1","site_title":"Mt. Airy News","site_tagline":"Mount Airy News, Obituaries, Classifieds, and Sports"};
var ajax_load_more_vars = {"id":"ajax-load-more"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s24476.pcdn.co/wp-content/plugins/ajax-load-more/core/dist/js/ajax-load-more.min.js?ver=5.5.2'></script>
<script type='text/javascript' src='https://s24476.pcdn.co/wp-content/plugins/ajax-load-more-seo/js/alm-seo.min.js?ver=1.9.3'></script>
</body>
</html>