<!DOCTYPE html>
<html class="no-js mh-one-sb" lang="en-US">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="profile" href="https://gmpg.org/xfn/11" />
<link rel="pingback" href="https://www.mtairynews.com/xmlrpc.php" />
<title>Police reports | Mt. Airy News</title>

<!-- The SEO Framework by Sybre Waaijer -->
<meta name="description" content="An area electrical provider was the victim of a theft discovered Monday in Mount Airy, according to city police reports." />
<meta property="og:image" content="https://s24476.pcdn.co/wp-content/uploads/2018/09/cropped-mtairynews.png" />
<meta property="og:image:width" content="374" />
<meta property="og:image:height" content="36" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Police reports | Mt. Airy News" />
<meta property="og:description" content="An area electrical provider was the victim of a theft discovered Monday in Mount Airy, according to city police reports." />
<meta property="og:url" content="https://www.mtairynews.com/news/111473/police-reports-593" />
<meta property="og:site_name" content="Mt. Airy News" />
<meta property="og:updated_time" content="2022-07-14T00:52+00:00" />
<meta property="article:publisher" content="https://www.facebook.com/pages/The-Mount-Airy-News/120821418072" />
<meta property="article:published_time" content="2022-07-14T00:52+00:00" />
<meta property="article:modified_time" content="2022-07-14T00:52+00:00" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@mountairynews" />
<meta name="twitter:title" content="Police reports | Mt. Airy News" />
<meta name="twitter:description" content="An area electrical provider was the victim of a theft discovered Monday in Mount Airy, according to city police reports." />
<meta name="twitter:image" content="https://s24476.pcdn.co/wp-content/uploads/2018/09/cropped-mtairynews.png" />
<meta name="twitter:image:width" content="374" />
<meta name="twitter:image:height" content="36" />
<link rel="canonical" href="https://www.mtairynews.com/news/111473/police-reports-593" />
<script type="application/ld+json">{"@context":"https://schema.org","@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"item":{"@id":"https://www.mtairynews.com/","name":"Mt. Airy News"}},{"@type":"ListItem","position":2,"item":{"@id":"https://www.mtairynews.com/category/news","name":"News"}},{"@type":"ListItem","position":3,"item":{"@id":"https://www.mtairynews.com/news/111473/police-reports-593","name":"Police reports"}}]}</script>
<!-- / The SEO Framework by Sybre Waaijer | 3.50ms meta | 0.45ms boot -->

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Mt. Airy News &raquo; Feed" href="https://www.mtairynews.com/feed" />
<link rel="alternate" type="application/rss+xml" title="Mt. Airy News &raquo; Comments Feed" href="https://www.mtairynews.com/comments/feed" />
<link rel="alternate" type="application/rss+xml" title="Mt. Airy News &raquo; Police reports Comments Feed" href="https://www.mtairynews.com/news/111473/police-reports-593/feed" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/s24476.pcdn.co\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3.12"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://s24476.pcdn.co/wp-includes/css/dist/block-library/style.min.css?ver=5.3.12' type='text/css' media='all' />
<link rel='stylesheet' id='simple-staff-list-css'  href='https://s24476.pcdn.co/wp-content/plugins/simple-staff-list/public/css/simple-staff-list-public.css?ver=2.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='staff-list-custom-css-css'  href='https://s24476.pcdn.co/wp-content/themes/mh-magazine/simple-staff-list-custom.css?ver=5.3.12' type='text/css' media='all' />
<link rel='stylesheet' id='vfb-pro-css'  href='https://s24476.pcdn.co/wp-content/plugins/vfb-pro/public/assets/css/vfb-style.min.css?ver=2019.05.10' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://s24476.pcdn.co/wp-includes/css/dashicons.min.css?ver=5.3.12' type='text/css' media='all' />
<link rel='stylesheet' id='mh-magazine-css'  href='https://s24476.pcdn.co/wp-content/themes/mh-magazine/style.css?ver=3.8.3' type='text/css' media='all' />
<link rel='stylesheet' id='mh-font-awesome-css'  href='https://s24476.pcdn.co/wp-content/themes/mh-magazine/includes/font-awesome.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='mh-google-fonts-css'  href='https://fonts.googleapis.com/css?family=PT+Sans:300,400,400italic,600,700%7cMerriweather:300,400,400italic,600,700' type='text/css' media='all' />
<script type='text/javascript' src='https://s24476.pcdn.co/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://s24476.pcdn.co/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://s24476.pcdn.co/wp-content/themes/mh-magazine/js/scripts.js?ver=3.8.3'></script>
<link rel='https://api.w.org/' href='https://www.mtairynews.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.mtairynews.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://s24476.pcdn.co/wp-includes/wlwmanifest.xml" /> 
<link rel="alternate" type="application/json+oembed" href="https://www.mtairynews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.mtairynews.com%2Fnews%2F111473%2Fpolice-reports-593" />
<link rel="alternate" type="text/xml+oembed" href="https://www.mtairynews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.mtairynews.com%2Fnews%2F111473%2Fpolice-reports-593&#038;format=xml" />
<style type="text/css">
.mh-header { background: #022452; }
.mh-widget-layout4 .mh-widget-title { background: #022452; background: rgba(2, 36, 82, 0.6); }
.mh-preheader, .mh-wide-layout .mh-subheader, .mh-ticker-title, .mh-main-nav li:hover, .mh-footer-nav, .slicknav_menu, .slicknav_btn, .slicknav_nav .slicknav_item:hover, .slicknav_nav a:hover, .mh-back-to-top, .mh-subheading, .entry-tags .fa, .entry-tags li:hover, .mh-widget-layout2 .mh-widget-title, .mh-widget-layout4 .mh-widget-title-inner, .mh-widget-layout4 .mh-footer-widget-title, .mh-widget-layout5 .mh-widget-title-inner, .mh-widget-layout6 .mh-widget-title, #mh-mobile .flex-control-paging li a.flex-active, .mh-image-caption, .mh-carousel-layout1 .mh-carousel-caption, .mh-tab-button.active, .mh-tab-button.active:hover, .mh-footer-widget .mh-tab-button.active, .mh-social-widget li:hover a, .mh-footer-widget .mh-social-widget li a, .mh-footer-widget .mh-author-bio-widget, .tagcloud a:hover, .mh-widget .tagcloud a:hover, .mh-footer-widget .tagcloud a:hover, .mh-posts-stacked-item .mh-meta, .page-numbers:hover, .mh-loop-pagination .current, .mh-comments-pagination .current, .pagelink, a:hover .pagelink, input[type=submit], #infinite-handle span { background: #022452; }
.mh-main-nav-wrap .slicknav_nav ul, blockquote, .mh-widget-layout1 .mh-widget-title, .mh-widget-layout3 .mh-widget-title, .mh-widget-layout5 .mh-widget-title, .mh-widget-layout8 .mh-widget-title:after, #mh-mobile .mh-slider-caption, .mh-carousel-layout1, .mh-spotlight-widget, .mh-author-bio-widget, .mh-author-bio-title, .mh-author-bio-image-frame, .mh-video-widget, .mh-tab-buttons, textarea:hover, input[type=text]:hover, input[type=email]:hover, input[type=tel]:hover, input[type=url]:hover { border-color: #022452; }
.mh-dropcap, .mh-carousel-layout1 .flex-direction-nav a, .mh-carousel-layout2 .mh-carousel-caption, .mh-posts-digest-small-category, .mh-posts-lineup-more, .bypostauthor .fn:after, .mh-comment-list .comment-reply-link:before, #respond #cancel-comment-reply-link:before { color: #022452; }
</style>
<!--[if lt IE 9]>
<script src="https://s24476.pcdn.co/wp-content/themes/mh-magazine/js/css3-mediaqueries.js"></script>
<![endif]-->
<style type="text/css">
h1, h2, h3, h4, h5, h6, .mh-custom-posts-small-title { font-family: "Merriweather", serif; }
body { font-family: "PT Sans", sans-serif; }
</style>
<style type="text/css" id="custom-background-css">
body.custom-background { background-color: #e0e0e0; }
</style>
	<link rel="icon" href="https://s24476.pcdn.co/wp-content/uploads/2018/09/cropped-unnamed-32x32.png" sizes="32x32" />
<link rel="icon" href="https://s24476.pcdn.co/wp-content/uploads/2018/09/cropped-unnamed-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://s24476.pcdn.co/wp-content/uploads/2018/09/cropped-unnamed-180x180.png" />
<meta name="msapplication-TileImage" content="https://s24476.pcdn.co/wp-content/uploads/2018/09/cropped-unnamed-270x270.png" />
		<style type="text/css" id="wp-custom-css">
			.mh-widget-title {
	background-color: #022452 !important;
}

.mh-header-nav li a {
    padding: 0 19px !important;
}

.attachment-mh-magazine-slider{
height: 300px !important;
width: auto !important;
}
.metaInfo{
	display:none;
}

.class1 img {
	display: block;
	margin: auto;
	float: none !important;
}

@media screen and (min-width: 1125px) {

.mh-col-1-3 {
    width: 27% !important;
}

.mh-col-2-3 {
    width: 70% !important;
}

}

@media screen and (max-width: 1124px) {

.mh-col-1-3 {
    width: 30%;
		min-width: 300px;
		margin: auto !important;
		float: none;
}

.mh-col-2-3 {
    width: 100%;
		margin: auto !important;
}

}

.mh-googleplus{
	display:none;
}
.mh-posts-large-thumb{
	background-color:black;
}
.mh-posts-large-thumb img{
	width:auto !important;
}
.mh-main-nav li a {
    padding: 10px 18px;
}

.google-auto-placed {
	display: none;
}
		</style>
		<style type="text/css"></style>
<script async="async" src="//zdwidget3-bs.sphereup.com/zoomd/SearchUi/Script?clientId=05916537"></script>
</head>
<body data-rsssl=1 id="mh-mobile" class="post-template-default single single-post postid-111473 single-format-standard custom-background wp-custom-logo mh-boxed-layout mh-right-sb mh-loop-layout1 mh-widget-layout5" itemscope="itemscope" itemtype="http://schema.org/WebPage">
<aside class="mh-container mh-header-widget-1">
<div id="custom_html-11" class="widget_text mh-widget mh-header-1 widget_custom_html"><div class="textwidget custom-html-widget"><script> (function(){var l=function(){if (document.readyState && /loading/.test(document.readyState)){return setTimeout(l, 10);} if (!top._liqwid_loaded){top._liqwid_loaded=true; return setTimeout(l, 10);} var s=document.createElement("script"), x=top.document.getElementsByTagName('script')[0]; s.setAttribute('async', 'true'); s.setAttribute('src','https://liqwid.net/?key=2B69-A3AA-AFFC-D516&u='+encodeURIComponent(top.location.href)+'&d='+Date.now()+'&v='+('; '+document.cookie).split('; liqwid=').pop().split(';').shift()); x.parentNode.insertBefore(s,x);};l();})(); </script></div></div></aside>
<div class="mh-container mh-container-outer">
<div class="mh-header-nav-mobile clearfix"></div>
	<div class="mh-preheader">
    	<div class="mh-container mh-container-inner mh-row clearfix">
							<div class="mh-header-bar-content mh-header-bar-top-left mh-col-2-3 clearfix">
											<nav class="mh-navigation mh-header-nav mh-header-nav-top clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
							<div class="menu-header-menu-container"><ul id="menu-header-menu" class="menu"><li id="menu-item-65282" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-65282"><a href="http://yourjobmatchnc.thejobnetwork.com/">Jobs</a></li>
<li id="menu-item-65270" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-65270"><a href="https://www.mtairynews.com/e-edition">E-Edition</a></li>
<li id="menu-item-65271" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-65271"><a href="https://www.mtairynews.com/classifieds">Classifieds</a></li>
<li id="menu-item-91817" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-91817"><a href="https://apg01.newzware.com/ss70v2/adams/common/template.jsp?init=start">Subscribe</a>
<ul class="sub-menu">
	<li id="menu-item-91819" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-91819"><a href="https://apg01.newzware.com/ss70v2/adams/common/template.jsp">Manage My Subscription</a></li>
</ul>
</li>
<li id="menu-item-65273" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-65273"><a href="https://www.mtairynews.com/sign-up-for-notices">Sign Up For Notices</a></li>
<li id="menu-item-65285" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-65285"><a href="https://play.google.com/store/apps/details?id=com.vervewireless.droid.mtairynews&#038;hl=en">Android App</a></li>
<li id="menu-item-65286" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-65286"><a href="https://itunes.apple.com/us/app/the-mount-airy-news/id1378553829?ls=1&#038;mt=8">iOS App</a></li>
</ul></div>						</nav>
									</div>
										<div class="mh-header-bar-content mh-header-bar-top-right mh-col-1-3 clearfix">
											<nav class="mh-social-icons mh-social-nav mh-social-nav-top clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
							<div class="menu-social-container"><ul id="menu-social" class="menu"><li id="menu-item-65280" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-65280"><a href="https://www.facebook.com/pages/The-Mount-Airy-News/120821418072"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Facebook</span></a></li>
<li id="menu-item-65281" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-65281"><a href="https://twitter.com/mountairynews"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Twitter</span></a></li>
</ul></div>						</nav>
									</div>
					</div>
	</div>
<header class="mh-header" itemscope="itemscope" itemtype="http://schema.org/WPHeader">
	<div class="mh-container mh-container-inner clearfix">
		<div class="mh-custom-header clearfix">
<div class="mh-header-columns mh-row clearfix">
<div class="mh-col-1-3 mh-site-identity">
<div class="mh-site-logo" role="banner" itemscope="itemscope" itemtype="http://schema.org/Brand">
<a href="https://www.mtairynews.com/" class="custom-logo-link" rel="home"><img width="374" height="36" src="https://s24476.pcdn.co/wp-content/uploads/2018/09/cropped-mtairynews.png" class="custom-logo" alt="Mt. Airy News" srcset="https://s24476.pcdn.co/wp-content/uploads/2018/09/cropped-mtairynews.png 374w, https://s24476.pcdn.co/wp-content/uploads/2018/09/cropped-mtairynews-300x29.png 300w" sizes="(max-width: 374px) 100vw, 374px" /></a></div>
</div>
<aside class="mh-col-2-3 mh-header-widget-2">
<div id="custom_html-10" class="widget_text mh-widget mh-header-2 widget_custom_html"><div class="textwidget custom-html-widget"><!---<ins data-revive-zoneid="5" data-revive-id="7704ed944ed7863d36a61d5fccf7693e"></ins><script src="//adamsads.midtc.com/www/delivery/asyncjs.php"></script>--->
</div></div></aside>
</div>
</div>
	</div>
	<div class="mh-main-nav-wrap">
		<nav class="mh-navigation mh-main-nav mh-container mh-container-inner clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
			<div class="menu-main-menu-container"><ul id="menu-main-menu" class="menu"><li id="menu-item-37973" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-has-children menu-item-37973"><a href="https://www.mtairynews.com">Home</a>
<ul class="sub-menu">
	<li id="menu-item-38363" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38363"><a href="https://www.mtairynews.com/contact-us">Contact Us</a></li>
	<li id="menu-item-38364" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38364"><a href="https://www.mtairynews.com/about-us">About Us</a></li>
	<li id="menu-item-38368" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38368"><a href="https://www.mtairynews.com/advertise">Advertise</a></li>
	<li id="menu-item-38412" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38412"><a href="http://www.facebook.com/pages/The-Mount-Airy-News/120821418072">Mount Airy News on Facebook</a></li>
	<li id="menu-item-40794" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-40794"><a href="https://twitter.com/mountairynews">Mount Airy News on Twitter</a></li>
	<li id="menu-item-38414" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38414"><a href="https://www.mtairynews.com/sign-up-for-notices">Sign Up For Notices</a></li>
	<li id="menu-item-91816" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-91816"><a href="https://apg01.newzware.com/ss70v2/adams/common/template.jsp?init=start">Subscribe</a></li>
	<li id="menu-item-91820" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-91820"><a href="https://apg01.newzware.com/ss70v2/adams/common/template.jsp">Manage My Subscription</a></li>
	<li id="menu-item-77699" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-77699"><a href="https://www.mtairynews.com/terms-of-use">Terms Of Use</a></li>
</ul>
</li>
<li id="menu-item-37963" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-37963"><a href="https://www.mtairynews.com/category/news">News</a>
<ul class="sub-menu">
	<li id="menu-item-100016" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-100016"><a href="https://mtairynews.newsbank.com">Archive</a></li>
	<li id="menu-item-56100" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56100"><a href="https://www.mtairynews.com/category/special-sections">Special Sections</a></li>
	<li id="menu-item-38371" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38371"><a href="https://www.mtairynews.com/online-community">Online Community</a></li>
	<li id="menu-item-38375" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38375"><a href="https://www.mtairynews.com/formnewstip">Submit News Tip</a></li>
	<li id="menu-item-38376" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38376"><a href="https://www.mtairynews.com/onlineforms">Online Forms</a></li>
	<li id="menu-item-38416" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38416"><a href="https://www.mtairynews.com/feed">All Articles Feed</a></li>
</ul>
</li>
<li id="menu-item-37965" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-37965"><a href="https://www.mtairynews.com/category/sports">Sports</a>
<ul class="sub-menu">
	<li id="menu-item-38377" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38377"><a href="https://www.mtairynews.com/formscores">Submit Scores</a></li>
	<li id="menu-item-38378" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38378"><a href="https://www.mtairynews.com/formsportsnews">Submit Sports News</a></li>
	<li id="menu-item-43456" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43456"><a href="http://pro32.ap.org/mtairynews">Pro32</a></li>
	<li id="menu-item-43458" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43458"><a href="http://racing.ap.org/mtairynews">Auto Racing</a></li>
	<li id="menu-item-43459" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43459"><a href="http://collegebasketball.ap.org/mtairynews">College Basketball</a></li>
	<li id="menu-item-43460" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43460"><a href="http://collegefootball.ap.org/mtairynews">College Football</a></li>
</ul>
</li>
<li id="menu-item-37967" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-37967"><a href="http://www.legacy.com/obituaries/mtairynews">Obituaries</a></li>
<li id="menu-item-37964" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-37964"><a href="https://www.mtairynews.com/category/opinion">Opinion</a>
<ul class="sub-menu">
	<li id="menu-item-38379" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38379"><a href="https://www.mtairynews.com/formeditor">Send A Letter To The Editor</a></li>
</ul>
</li>
<li id="menu-item-37966" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-37966"><a href="https://www.mtairynews.com/category/features">Features</a>
<ul class="sub-menu">
	<li id="menu-item-38380" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38380"><a href="https://www.mtairynews.com/contests">Contests</a></li>
	<li id="menu-item-38382" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38382"><a href="https://www.mtairynews.com/comics">Comics</a></li>
	<li id="menu-item-38383" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38383"><a href="https://www.mtairynews.com/horoscopes">Horoscopes</a></li>
	<li id="menu-item-63246" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-63246"><a href="https://www.mtairynews.com/category/special-sections">Special Sections</a></li>
	<li id="menu-item-38385" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38385"><a href="https://www.mtairynews.com/formanniversary">Submit Anniversary</a></li>
	<li id="menu-item-38386" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38386"><a href="https://www.mtairynews.com/formbirth">Submit Birth</a></li>
	<li id="menu-item-38387" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38387"><a href="https://www.mtairynews.com/formbirthday">Submit Birthday</a></li>
	<li id="menu-item-38388" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38388"><a href="https://www.mtairynews.com/formengagement">Submit Engagement</a></li>
	<li id="menu-item-38389" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38389"><a href="https://www.mtairynews.com/formwedding">Submit Wedding</a></li>
</ul>
</li>
<li id="menu-item-37969" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-37969"><a href="https://www.mtairynews.com/entertainment">TV/Games</a>
<ul class="sub-menu">
	<li id="menu-item-82825" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-82825"><a href="https://www.mtairynews.com/games">Games</a></li>
	<li id="menu-item-38434" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38434"><a href="https://www.mtairynews.com/tvsoaps">Soaps</a></li>
	<li id="menu-item-39181" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-39181"><a href="https://www.mtairynews.com/tvbestbets">TV Best Bets</a></li>
	<li id="menu-item-38390" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38390"><a href="https://www.mtairynews.com/tvbestbets">TV Best Bets</a></li>
	<li id="menu-item-38436" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38436"><a href="https://www.mtairynews.com/tvmovies">Movies</a></li>
	<li id="menu-item-38391" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38391"><a href="https://www.mtairynews.com/tvlistings">TV Listings</a></li>
	<li id="menu-item-38392" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38392"><a href="https://www.mtairynews.com/tvnews">TV News</a></li>
	<li id="menu-item-38433" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38433"><a href="https://www.mtairynews.com/tvqa">Q &#038; A</a></li>
	<li id="menu-item-38437" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38437"><a href="https://www.mtairynews.com/tvnews">TV News</a></li>
	<li id="menu-item-38393" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38393"><a href="https://www.mtairynews.com/tvsearch">TV Search</a></li>
	<li id="menu-item-38394" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38394"><a href="https://www.mtairynews.com/tvsports">TV Sports</a></li>
	<li id="menu-item-38395" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38395"><a href="https://www.mtairynews.com/tvtalk">TV Talk</a></li>
	<li id="menu-item-38396" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38396"><a href="https://www.mtairynews.com/tvvideo">TV Video</a></li>
</ul>
</li>
<li id="menu-item-99553" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-99553"><a href="https://www.mtairynews.com/local-events">Events</a></li>
<li id="menu-item-39252" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-39252"><a href="http://shoplocal.yadkinvalley.com/mtairynews/">Shop Local</a>
<ul class="sub-menu">
	<li id="menu-item-86887" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-86887"><a href="https://shoplocal.yadkinvalley.com/mtairynews/">Local Businesses</a></li>
</ul>
</li>
<li id="menu-item-64582" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-64582"><a href="http://www.ncpress.com/ncnotices/">Public Notices</a></li>
<li id="menu-item-88298" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-88298"><a href="https://site1.midtcweb.com/flipcore/mountairy/MOU070822final/">Wednesday/Friday</a></li>
</ul></div>		</nav>
	</div>
	</header>
	<div class="mh-subheader">
		<div class="mh-container mh-container-inner mh-row clearfix">
							<div class="mh-header-bar-content mh-header-bar-bottom-left mh-col-2-3 clearfix">
											<div class="mh-header-date mh-header-date-bottom">
							July 13, 2022						</div>
									</div>
										<div class="mh-header-bar-content mh-header-bar-bottom-right mh-col-1-3 clearfix">
											<aside zoomdSearch='{"trigger":"OnClick"}' class="mh-header-search mh-header-search-bottom">
							<form role="search" method="get" class="search-form" action="https://www.mtairynews.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form>						</aside>
									</div>
					</div>
	</div>
<div class="mh-wrapper clearfix">
	<div class="mh-main clearfix">
		<div id="main-content" class="mh-content" role="main" itemprop="mainContentOfPage"><nav class="mh-breadcrumb"><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a href="https://www.mtairynews.com" itemprop="url"><span itemprop="title">Home</span></a></span><span class="mh-breadcrumb-delimiter"><i class="fa fa-angle-right"></i></span><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a href="https://www.mtairynews.com/category/news" itemprop="url"><span itemprop="title">News</span></a></span><span class="mh-breadcrumb-delimiter"><i class="fa fa-angle-right"></i></span>Police reports</nav>


<script type="application/ld+json">
{
  "@context": "http://schema.org",
  "@type": "NewsArticle",
  "mainEntityOfPage": {
    "@type": "WebPage",
    "@id": "https://www.mtairynews.com/news/111473/police-reports-593"
  },
  "headline": "Police reports",
     "datePublished": "2022-07-13T20:52:00-04:00",
  "dateModified": "2022-07-13T20:52:00-04:00",
  "author": {
    "@type": "Person",
		"name": "Staff Reports"
	  },
   "publisher": {
    "@type": "Organization",
    "name": "Mt. Airy News",
    "logo": {
      "@type": "ImageObject",
      "url": "https://s24476.pcdn.co/wp-content/uploads/2015/07/mtairynews.png"
    }
  },
  "description": "
				&#8226; An area electrical provider was the victim of a theft discovered Monday in Mount Airy, according to city police reports.
			 [...]"
}
</script>
<style>
.neFileBlock{
	display:none;
}
.metaInfo{
	display:none;
}
.entry-thumbnail img {
width: auto !important;
max-height: 400px;
}
.factbox{ 
	float:left; 
	width:190px; 
	margin:7px; 
	background-color:#f5f5f5; 
	padding:5px; 
	box-shadow: 0 10px 16px 0 rgba(0,0,0,0.2),0 6px 20px 0 rgba(0,0,0,0.19);
}
.map{ 
	float:left; 
	width:200px; 
	margin:7px; 
}
.kicker{
	font-style:italic;
}
.pullquote {
    float: left;
    width: 190px;
    background: #f5f5f5;
    font-weight: bold;
    padding: 5px;
    margin: 0 5px 5px 0;
	font-size:18px;
}
.extraBox{
	float:left; 
	width:200px;  
	margin-right:20px;
}
.breakout{
border-radius: 25px;
  border: 2px solid #c00c00;
  padding: 20px;
}

</style>
<article id="post-111473" class="post-111473 post type-post status-publish format-standard hentry category-news">
		<header class="entry-header clearfix"><h1 class="entry-title">Police reports</h1><div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.mtairynews.com/date/2022/07">July 13, 2022</a></span>
<span class="entry-meta-author author vcard"><i class="fa fa-user"></i><a class="fn" href="https://www.mtairynews.com/author/tjoyce">Thomas Joyce</a></span>
<span class="entry-meta-categories"><i class="fa fa-folder-open-o"></i><a href="https://www.mtairynews.com/category/news" rel="category tag">News</a></span>
<span class="entry-meta-comments"><i class="fa fa-comment-o"></i><a href="https://www.mtairynews.com/news/111473/police-reports-593#respond" class="mh-comment-count-link" ><span class="dsq-postid" data-dsqidentifier="111473 https://www.mtairynews.com/news/111473/police-reports-593">0</span></a></span>
</div>
				
			</header>
		<div class="entry-content clearfix">
																					
		<div class="mh-social-top">
<div class="mh-share-buttons clearfix">
	<a class="mh-facebook" href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.mtairynews.com%2Fnews%2F111473%2Fpolice-reports-593&t=Police+reports', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
		<span class="mh-share-button"><i class="fa fa-facebook"></i></span>
	</a>
	<a class="mh-twitter" href="#" onclick="window.open('https://twitter.com/share?text=Police+reports:&url=https%3A%2F%2Fwww.mtairynews.com%2Fnews%2F111473%2Fpolice-reports-593', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
		<span class="mh-share-button"><i class="fa fa-twitter"></i></span>
	</a>
	<a class="mh-pinterest" href="#" onclick="window.open('https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.mtairynews.com%2Fnews%2F111473%2Fpolice-reports-593&media=&description=Police+reports', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
		<span class="mh-share-button"><i class="fa fa-pinterest"></i></span>
	</a>
	<a class="mh-googleplus" href="#" onclick="window.open('https://plusone.google.com/_/+1/confirm?hl=en-US&url=https%3A%2F%2Fwww.mtairynews.com%2Fnews%2F111473%2Fpolice-reports-593', 'googleShare', 'width=626,height=436'); return false;" title="Share on Google+" target="_blank">
		<span class="mh-share-button"><i class="fa fa-google-plus"></i></span>
	</a>
	<a class="mh-email" href="mailto:?subject=Police%20reports&amp;body=https%3A%2F%2Fwww.mtairynews.com%2Fnews%2F111473%2Fpolice-reports-593" title="Send this article to a friend" target="_blank">
		<span class="mh-share-button"><i class="fa fa-envelope-o"></i></span>
	</a>
</div></div>
																		
																						<div class="extraBox">
														</div>
										<p>&#8226; An area electrical provider was the victim of a theft discovered Monday in Mount Airy, according to city police reports.</p>
<p>This involved copper wire valued at $400 being stolen from a roadside site on Forrest Drive near Reeves Drive, off U.S. 601. The owner of the wire was listed as Duke Power, also known as Duke Energy, with a local employee of the company, Austin Chrissman of Beeswax Lane, reporting the incident to police.</p>
<p>&#8226; Police also learned Monday that property valued at more than $1,200 had been stolen from a local residence during a breaking and entering.</p>
<p>This occurred at the home of Ibarra Thomas Garcia and Amy Lynn Garcia on Galloway Street, where an LG 60-inch television set was taken along with another 42-inch TV set for which no brand name was specified. Also listed as missing were a speaker, miscellaneous alcohol and a wooden cross bearing a likeness of Jesus.</p>
<p>&#8226; Johnny Ray Gwyn, 53, of 143 Welch Road, was jailed under an $8,000 secured bond for a felonious larceny charge on July 1 after police encountered him during a traffic stop on South Franklin Road near Snowhill Drive.</p>
<p>A warrant for the theft case had been issued through the Surry County Sheriff&rsquo;s Office with no other details listed. Gwyn was scheduled to appear in District Court on Wednesday.</p>
<p>&#8226; Sixty dosage units of prescription medication and a tumbler cup were stolen on July 1 from the residence of Krystal Dale Whittington on South Gilmer Street, where an unknown suspect reached through an open window in order to effect the crime.</p>
<p>The loss totaled $87.</p>
										<div class="mh-social-bottom">
<div class="mh-share-buttons clearfix">
	<a class="mh-facebook" href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.mtairynews.com%2Fnews%2F111473%2Fpolice-reports-593&t=Police+reports', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
		<span class="mh-share-button"><i class="fa fa-facebook"></i></span>
	</a>
	<a class="mh-twitter" href="#" onclick="window.open('https://twitter.com/share?text=Police+reports:&url=https%3A%2F%2Fwww.mtairynews.com%2Fnews%2F111473%2Fpolice-reports-593', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
		<span class="mh-share-button"><i class="fa fa-twitter"></i></span>
	</a>
	<a class="mh-pinterest" href="#" onclick="window.open('https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.mtairynews.com%2Fnews%2F111473%2Fpolice-reports-593&media=&description=Police+reports', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
		<span class="mh-share-button"><i class="fa fa-pinterest"></i></span>
	</a>
	<a class="mh-googleplus" href="#" onclick="window.open('https://plusone.google.com/_/+1/confirm?hl=en-US&url=https%3A%2F%2Fwww.mtairynews.com%2Fnews%2F111473%2Fpolice-reports-593', 'googleShare', 'width=626,height=436'); return false;" title="Share on Google+" target="_blank">
		<span class="mh-share-button"><i class="fa fa-google-plus"></i></span>
	</a>
	<a class="mh-email" href="mailto:?subject=Police%20reports&amp;body=https%3A%2F%2Fwww.mtairynews.com%2Fnews%2F111473%2Fpolice-reports-593" title="Send this article to a friend" target="_blank">
		<span class="mh-share-button"><i class="fa fa-envelope-o"></i></span>
	</a>
</div></div>

	</div></article>
								<div id="rc-widget-7301ab" data-rc-widget data-widget-host="habitat" data-endpoint="//trends.revcontent.com" data-widget-id="166979"></div>
				<script type="text/javascript" src="https://assets.revcontent.com/master/delivery.js" defer="defer"></script>
				
				
<div id="disqus_thread"></div>
<nav class="mh-post-nav mh-row clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
<div class="mh-col-1-2 mh-post-nav-item mh-post-nav-prev">
<a href="https://www.mtairynews.com/news/111471/city-gets-2-million-for-further-spencers-work" rel="prev"><img width="68" height="60" src="https://s24476.pcdn.co/wp-content/uploads/2022/07/128698200_web1_Up-here-this-68x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="This is an aerial of the Cube Building portion of the former Spencer&#146;s textile mill property where the Mount Airy-Surry County Visitor Center and Conference Center is envisioned. An upper section already is being developed as a market center in conjunction with a new hotel coming to the Sparger Building, pictured at the top." srcset="https://s24476.pcdn.co/wp-content/uploads/2022/07/128698200_web1_Up-here-this-68x60.jpg 68w, https://s24476.pcdn.co/wp-content/uploads/2022/07/128698200_web1_Up-here-this-300x264.jpg 300w, https://s24476.pcdn.co/wp-content/uploads/2022/07/128698200_web1_Up-here-this-498x438.jpg 498w, https://s24476.pcdn.co/wp-content/uploads/2022/07/128698200_web1_Up-here-this-433x381.jpg 433w, https://s24476.pcdn.co/wp-content/uploads/2022/07/128698200_web1_Up-here-this-579x509.jpg 579w, https://s24476.pcdn.co/wp-content/uploads/2022/07/128698200_web1_Up-here-this-279x245.jpg 279w, https://s24476.pcdn.co/wp-content/uploads/2022/07/128698200_web1_Up-here-this.jpg 640w" sizes="(max-width: 68px) 100vw, 68px" /><span>Previous</span><p>City gets $2 million for further Spencer&#8217;s work</p></a></div>
</nav>
				<a id="comments"></a>
							<ins data-revive-zoneid="153" data-revive-id="7704ed944ed7863d36a61d5fccf7693e"></ins>
			<script async src="//adamsads.midtc.com/www/delivery/asyncjs.php"></script>
			  <style type="text/css">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</style><div id="ajax-load-more" class="ajax-load-more-wrap infinite fading-blocks"  data-alm-id="" data-canonical-url="https://www.mtairynews.com/news/111473/police-reports-593" data-slug="police-reports-593" data-post-id="111473"  data-localized="ajax_load_more_vars"><ul aria-live="polite" aria-atomic="true" class="alm-listing alm-ajax" data-seo="true" data-seo-start-page="1" data-seo-scroll="true" data-seo-scrolltop="30" data-seo-controls="1" data-seo-permalink="pretty" data-seo-pageview="true" data-container-type="ul" data-loading-style="infinite fading-blocks" data-repeater="template_1" data-post-type="post" data-category="News" data-order="DESC" data-orderby="date" data-offset="1" data-posts-per-page="50" data-scroll="true" data-scroll-distance="100" data-max-pages="0" data-pause-override="false" data-pause="false" data-button-label="Next Article" data-transition="none"></ul><noscript><ul class="alm-listing alm-noscript"><div class="alm-reveal"><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/111471/city-gets-2-million-for-further-spencers-work" title="City gets $2 million for further Spencer&#8217;s work" style="color:black">City gets $2 million for further Spencer&#8217;s work</a></h1>

            <a href="https://www.mtairynews.com/news/111471/city-gets-2-million-for-further-spencers-work" title="City gets $2 million for further Spencer&#8217;s work">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/07/128698200_web1_Up-here-this-579x509.jpg" alt="City gets $2 million for further Spencer&amp;#8217;s work">
            </a>
   <p class="entry-meta">July 13, 2022</p>
   <p>Mount Airy has been tapped to receive $2 million in state funding to aid further redevelopment of the former Spencer&rsquo;s textile property, which is tied to plans for establishing a large conference/visitors center there.</p>
<p>&ldquo;It&rsquo;s an exciting next step,&rdquo; Mayor Ron Niland said Tuesday in announcing the assistance for continued transformation of the downtown site where children&rsquo;s apparel production ceased in 2007, which the municipality bought in 2014 and has spearheaded two phases of development.</p>
<p>Phase 1 included the private developments of market-rate apartments and loft condominiums.</p>
<p>Much attention in recent months has been focused on Phase 2 plans for a hotel and market center by another private entity, Sunhouse Development Co. The lodging establishment, rumored to be a Marriott facility, is to utilize what are known as the Sparger Building and the Barrel Building, both fronting Willow Street.</p>
<p>The market center, meanwhile, is eyed for a section of the so-called Cube Building site located behind, or west, of the Sparger Building. It is to feature mini-convention meeting rooms, mezzanine amenities both for hotel guests and the public, a spa and a tap room/coffeehouse.</p>
<p>That leaves the rest of the large site open for additional redevelopment, including what are commonly referred to as The Cube and the Cube Annex.</p>
<p><strong>Plans for next phase</strong></p>
<p>The proposed Mount Airy-Surry County Visitor Center and Conference Center is now the focus for that property, which Mayor Niland said represents a third phase of the Spencer&rsquo;s redevelopment.</p>
<p>He added that the $2 million from Raleigh will be used for &ldquo;outside&rdquo; improvements there, rather than building work itself.</p>
<p>This will include providing infrastructure needed to support what Niland described as a convention center to host large gatherings and the adjacent visitor center, with amenities on the grounds also part of the mix.</p>
<p>While no plans have been forged so far, he said those amenities likely will include some type of green space, a farmers market and a splash pad facility.</p>
<p>&ldquo;There has been no final decision on exactly what,&rdquo; the mayor said, but the plan is to use the state funding to hire architects and engineers to chart a course for the third phase with such items in mind.</p>
<p>The funding is directed toward site planning, design, engineering, grading, utilities and additional infrastructure, stabilization and any other required pre-development activities surrounding The Cube property.</p>
<p>&ldquo;I&rsquo;ve been working on this with our state legislators,&rdquo; the mayor said of efforts to secure the funding, which included a request from the city government along with its partners Mount Airy Downtown Inc., the Greater Mount Airy Chamber of Commerce and the Mount Airy Tourism Development Authority.</p>
<p>&ldquo;We just heard about it yesterday (Monday),&rdquo; Niland said Tuesday of receiving notification that the $2 million was included in the state budget for the 2022-2023 fiscal year through the support of legislators serving this area in the North Carolina General Assembly.</p>
<p>&ldquo;And the first thing I want to do is thank Sarah Stevens, Sen. (Phil) Berger and Kyle Hall for their continued help in making our city stronger going forward,&rdquo; the mayor said. Stevens, of Mount Airy, and Hall, Stokes County, are members of the state House of Representatives.</p>
<p>&ldquo;They have been champions in the transformational projects going on in our town,&rdquo; Niland added regarding the state lawmakers involved.</p>
<p>City Manager Stan Farmer also reacted to the news of the state funding this week.</p>
<p>&ldquo;The city, along with local partners, sends our utmost appreciation to the state of North Carolina for supporting small-town economic development,&rdquo; Farmer said in a statement.</p>
<p>Bryan Grote, who is president of the governing board of Mount Airy Downtown Inc., offered similar comments affirming the impact of the initial investment by the state in the further reuse of the former textile mill complex.</p>
<p>&ldquo;The proposed Phase Three visitor center and conference center project is a capstone development that best leverages the $30 million of private investment already committed to the Phase One and Phase Two projects,&rdquo; Grote said in a statement. &ldquo;The Spencer&rsquo;s initiative is a transformational economic-development project with major long-term public benefits.&rdquo; </p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/111464/candidate-filing-pace-picks-up" title="Candidate filing pace picks up" style="color:black">Candidate filing pace picks up</a></h1>
   <p class="entry-meta">July 13, 2022</p>
   <p>DOBSON &mdash; More candidates have filed for elected offices in municipalities across Surry County this week, including a Dobson woman who wants to improve the quality of life for older residents in town.</p>
<p>&ldquo;We don&rsquo;t (have) anything for seniors,&rdquo; Sharon Gates-Hodges said in listing her reasons for seeking a seat on the Dobson Board of Commissioners in the 2022 municipal election. &ldquo;We don&rsquo;t even have bingo.&rdquo;</p>
<p>Gates-Hodges, 64, who resides on Freeman Street, has never sought public office before. And in addition to wanting to help provide more programs or activities to help prolong the lives of senior citizens, the candidate is interested in serving Dobson residents as a whole.</p>
<p>&ldquo;I guess my main motivation was, I&rsquo;m a lifetime resident and a retired engineer and I have time and I just want to make a positive difference in our town,&rdquo; Gates-Hodges said.</p>
<p>She seeks to work for the betterment of all Dobson residents, including listening to their concerns and needs and trying to respond to those.</p>
<p><strong>Citizens have choices</strong></p>
<p>The filing of Gates-Hodges as a candidate in Dobson was joined by others tossing their hats into the ring this week at the Surry County Board of Elections office.</p>
<p>Also doing so was a present member of the Dobson town board, Walter White, who took office last fall as the replacement for Commissioner John Lawson. Lawson had resigned in June 2021 after 13 years of service, for health and family reasons.</p>
<p>White is 58 and lives on Windsor Park Drive.</p>
<p>Filing last week were a longtime incumbent commissioner, J. Wayne Atkins, 78, a resident of Lewis Lane, and John Jonczak, who is a political newcomer along with Gates-Hodges.</p>
<p>There are only two seats available on the Dobson Board of Commissioners, now held by Atkins and White, and in addition to the four candidates already involved, more could enter the race by the filing deadline Friday at noon.</p>
<p>The two top vote-getters in the Nov. 8 election will win four-year terms on the board.</p>
<p>Dobson Mayor Ricky Draughn also has filed for his sixth term, with no challengers coming forward at last report.</p>
<p><strong>Pilot, Elkin filers</strong></p>
<p>At last report, the only candidates filing for the three offices at stake this year in the Pilot Mountain municipal election are the incumbents.</p>
<p>They include Mayor Evan Cockerham and commissioners Donna Kiger and Scott Needham. All are running for re-election to their second four-year terms.</p>
<p>The situation is much the same for the Elkin municipal election, which affects a trio of seats on the town council. All three have filed for re-election.</p>
<p>Cicely McCulloch, 58, a West Main Street resident, did so this week, joining the previous filings of fellow incumbent commissioners William Gwyn and Jeffrey C. Eidson.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/111446/scc-grad-now-teaching-in-college" title="SCC grad now teaching in college" style="color:black">SCC grad now teaching in college</a></h1>

            <a href="https://www.mtairynews.com/news/111446/scc-grad-now-teaching-in-college" title="SCC grad now teaching in college">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/07/128691040_web1_Jewel-Carrie-Parker_STREAM.jpg" alt="SCC grad now teaching in college">
            </a>
   <p class="entry-meta">July 13, 2022</p>
   <p>Jewel Carrie Parker of Greensboro, a graduate of Surry Community College, is taking on the role of a university-level instructor.</p>
<p>Parker graduated from Surry Community College in 2014 with an Associate in Arts degree, before transferring to Appalachian State University where she continued her educational career. She went on to earn a B.A. in history in 2016 and an M.A. in history in 2018.</p>
<p>&ldquo;I had a wonderful experience at SCC. Dr. Cory Stewart (division chair of social sciences) was my advisor, and he was a wonderful mentor,&rdquo; she said.</p>
<p>Parker was also a member of the Phi Theta Kappa honor organization&rsquo;s chapter at SCC and served as chapter president in her second year. She gave a presentation on campus with her fellow chapter members that was covered in local newspapers, and she attended PTK&rsquo;s national convention that was held in Orlando.</p>
<p>Parker got her first glimpse at helping students learn when she became a tutor during her last semester at SCC. She tutored students in American history, English, biology and political science courses. &ldquo;I think it&rsquo;s a great resource for students on campus,&rdquo; she says of the Academic Support Center&rsquo;s free tutoring services.</p>
<p>Since 2018, Parker has been in a Ph.D. program at University of North Carolina at Greensboro. She spent her first two years of the program working as a teaching assistant, and the following two years as an instructor of record. Classes she has taught as an instructor include: American History to 1865; Women and Gender in Early America; Human Rights in Modern World History; American Indian History to 1840; Women, Gender, and Power in the Premodern Atlantic World; and this summer, History of Christianity.</p>
<p>Starting in the fall 2022 semester, Parker will begin teaching as an adjunct history instructor at Appalachian State University. She aspires to become a history professor upon completing her doctoral degree.</p>
<p>Though she&rsquo;s gone on to earn additional degrees and teach a wide variety of courses in the field of history, Parker still looks back at her time at Surry Community College as a positive experience. She has also returned to the campus several times to give presentations to students. She was the guest speaker at the Edward M. Armfield Sr. Foundation College Scholarship Program in May. Parker was a 2015 Armfield Scholarship recipient.</p>
<p>&ldquo;Attending SCC is a great way for students to gain an affordable college education. The faculty and staff are extremely supportive and offer top-quality education,&rdquo; said Parker. </p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/111448/group-donates-books-to-library" title="Group donates books to library" style="color:black">Group donates books to library</a></h1>

            <a href="https://www.mtairynews.com/news/111448/group-donates-books-to-library" title="Group donates books to library">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/07/128694293_web1_Book-this-1.jpg" alt="Group donates books to library">
            </a>
   <p class="entry-meta">July 13, 2022</p>
   <p>It&rsquo;s been said that there is no better gift than a good book, and a local organization is fulfilling that sentiment through a recent gesture with kids in mind.</p>
<p>This involved the Mount Airy-Surry County Branch of the National Association of University Women (NAUW) donating eight children&rsquo;s books to the public library on Rockford Street.</p>
<p>This is part of the non-profit organization&rsquo;s mission including health and education, which has involved delivering meals to persons taking refuge in their homes at the height of the COVID crisis and recognition programs for veterans and others, among additional initiatives.</p>
<p>For the past six years, the NAUW &mdash; which was founded in early 2016 &mdash; has donated books with African-American subject matter for readers of all ages.</p>
<p>The Mount Airy Public Library was the 2022 recipient of the NAUW&rsquo;s annual book program.</p>
<p>&ldquo;We just have projects we do every year and donating books is one thing we like to do,&rdquo; Emma Jean Tucker of the group said Tuesday, along with other efforts on behalf of the city library.</p>
<p>&ldquo;We have a tradition of giving something to the library every year,&rdquo; added Tucker, who is the corresponding secretary for the local NAUW.</p>
<p>It also distributed free books to youngsters during a Juneteenth celebration at Mount Airy Museum of Regional History.</p>
<p>The latest book donation has a dual purpose, she said, including promoting literacy and exposing readers to material they might not have access to otherwise via regular library channels.</p>
<p>Among the titles of the volumes are &ldquo;I am Jackie Robinson&rdquo; by Brad Meltzer, about the first African-American player in Major League Baseball; &ldquo;Five Brave Explorers&rdquo; by Wade Hudson, detailing exploits of individuals such as Matthew Henson, the first African-American to reach the North Pole;</p>
<p>Also, one on famed composer and pianist Duke Ellington; books about Dr. Martin Luther King Jr. including &ldquo;My Daddy,&rdquo; authored by his son; and &ldquo;28 Days: Moments in Black History that Changed the World.&rdquo;</p>
<p>Tucker says providing books to a segment of society that can be considered underserved is another key element of the donation program.</p>
<p>&ldquo;It&rsquo;s important that children see themselves in books,&rdquo; she said of being able to identify with subjects of one&rsquo;s own race.</p>
<p>While growing up, Tucker said the availability of such material was an obstacle for her, yet she was able to read about agricultural scientist and inventor George Washington Carver &mdash; &ldquo;all those wonderful things he did with peanuts.&rdquo;</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/111431/city-schools-begin-new-leadership-program" title="City schools begin new leadership program" style="color:black">City schools begin new leadership program</a></h1>

            <a href="https://www.mtairynews.com/news/111431/city-schools-begin-new-leadership-program" title="City schools begin new leadership program">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/07/128690979_web1_Advanced-Teaching-Roles-407x509.jpg" alt="City schools begin new leadership program">
            </a>
   <p class="entry-meta">July 12, 2022</p>
   <p>Earlier this year, Mount Airy City Schools was awarded a grant for approximately $900,000 to help diminish the negative academic impacts of COVID. Since then, district leaders have been building the foundation of the school system&rsquo;s Professional, Innovative, Versatile, Open-minded, Talented yet Teachable (PIVOT) project.</p>
<p>Advanced Teaching Roles (ATR) have been integrated into this work. Each school within the district was allotted a certain number of ATRs based on enrollment. Interested individuals were interviewed and several were awarded these positions. They will continue to serve in their regular roles while lleading within the district&rsquo;s new PIVOT team.</p>
<p>Through creative scheduling and administrator support, these individuals will devote a portion of their time to co-teaching, modeling high-quality instructional practices, coaching, serving small groups of students, and working alongside others to increase their reach and build the efficacy of others.</p>
<p>This three-year grant funding will begin in August. The following teachers and staff members will become leaders in their content areas and grade levels.</p>
<p>BH Tharrington Primary School</p>
<p>&#8226; Beth Martin &#8211; Multi-Classroom Leader: first grade</p>
<p>&#8226; Brooke Ledford &#8211; Master Teacher Leader of Literacy</p>
<p>&#8226; Nicole Hooker &#8211; Master Teacher Leader of MTSS and Intervention</p>
<p>&#8226; Eve Trotter &#8211; Master Teacher Leader</p>
<p>JJ Jones Intermediate School</p>
<p>&#8226; Ginnie Deaton &#8211; Master Teacher Leader of MTSS and Differentiation</p>
<p>&#8226; Ben Pendleton &#8211; Master Teacher Leader of Exceptional Children</p>
<p>&#8226; Dalton Tedder &#8211; Master Teacher Leader</p>
<p>Mount Airy Middle School</p>
<p>&#8226; Katie McCrary &#8211; Master Teacher Leader of Math: third-fifth grades</p>
<p>&#8226; Tarona Hollingsworth- Master Teacher Leader of Literacy: third-eighth grades</p>
<p>&#8226; Marie Hauser &#8211; Master Teacher Leader of Math: sixth-eighth grades</p>
<p>Mount Airy High School</p>
<p>&#8226; Courtney Howlett &#8211; Master Teacher Leader of Math: ninth-twelfth grades</p>
<p>&#8226; Garrett Howlett- Master Teacher Leader of Career and Technical Education: ninth-twelfth grades</p>
<p>Community Central Office</p>
<p>&#8226; Nora Santillan- Master Teacher Leader of Dual Language Immersion</p>
<p>&ldquo;This is a unique and innovative opportunity for Mount Airy City Schools, which is multi-faceted because educators will be empowered with leadership opportunities without having to leave their classrooms,&rdquo; said Penny Willard, director of innovative programming. &ldquo;Our highly-skilled and newly formed PIVOT team will continue serving in their current capacities but have increased responsibilities to serve both students and other teachers. This will allow them to support their colleagues in a non-traditional, yet highly valuable manner that is projected to yield high results for student achievement. Building capacity within our own district allows us to foster meaningful relationships that revolve around professional growth that is centered around meeting both students and teachers at their individual point of need.&rdquo;</p>
<p>Superintendent Dr. Kim Morrison added, &ldquo;These teachers and administrators have demonstrated a desire to lead within our school buildings. Advanced teaching roles keep these strong leaders closely connected to students by collaboratively problem-solving solutions to ensure every child grows every day. This new paradigm leads a way for the future of education spreading expertise across classrooms and impacting all students.&rdquo;</p>
<p>During COVID, educators and staff members have gained and strengthened their skills in a multitude of areas. This grant will allow the district to capitalize on these skills with more attention to technology, remote learning, and intentional and consistent collaboration practices around highly effective teaching and learning.</p>
<p>The implementation of the Mount Airy City Shools PIVOT project will follow the Opportunity Culture Principles to allow the district to prioritize overall improvement in the following areas:</p>
<p>&#8211; superior teaching and learning for all learners</p>
<p>&#8211; recruitment and retainment of quality educators</p>
<p>&#8211; teacher efficacy (with a priority around teachers viewing themselves as leaders)</p>
<p>&#8211; professional learning communities (PLCs) with a focus on high-quality instructional planning times</p>
<p>&#8211; family and community engagement in the learning process</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/111429/annual-river-run-slated-saturday" title="Annual river run slated Saturday" style="color:black">Annual river run slated Saturday</a></h1>

            <a href="https://www.mtairynews.com/news/111429/annual-river-run-slated-saturday" title="Annual river run slated Saturday">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/07/128691000_web1_Paddle-thiss.jpg" alt="Annual river run slated Saturday">
            </a>
   <p class="entry-meta">July 12, 2022</p>
   <p>CLAUDVILLE, Va. &mdash; It doesn&rsquo;t involve the Mississippi, but an annual event that makes use of an area waterway continues to roll along in its own right.</p>
<p>The 2022 Kibler Valley River Run is scheduled Saturday, when canoeists and kayakers will invade the upper portion of the Dan River in Patrick County for a whitewater event now in its 39th year which benefits charitable causes.</p>
<p>Several hundred people tend to gather along the headwaters of the Dan for the run, both competitors and spectators who enjoy the mountain scenery of the valley along with sporting aspects of the downriver race course.</p>
<p>The event is sponsored by the Red Bank Ruritan Club in Claudville, which is expecting a good turnout this year on the heels of a successful river run in 2021 after being cancelled in 2020 due to the coronavirus.</p>
<p>&ldquo;Last year we had more than we&rsquo;ve ever had,&rdquo; Ruritan Club President Lottie Gammons said Monday.</p>
<p>&ldquo;And we were really surprised,&rdquo; she added of the event routinely penciled on the calendars of whitewater enthusiasts from a wide region. &ldquo;We get people from all over the place.&rdquo;</p>
<p>The run is enhanced by the presence of the Pinnacles Hydro Plant at the end of Kibler Valley Road in Claudville where the race course starts. The velocity of water released by it into the river is increased on Race Day to ensure good canoeing and kayaking conditions through a cooperative arrangement with the Ruritans and the company that owns the electricity-generating complex.</p>
<p>&ldquo;They&rsquo;re great,&rdquo; Gammons said of Northbrook Energy, an Arizona company that bought the plant in early 2021 from the city of Danville, the longtime owner of the facility since its construction in the 1930s.</p>
<p>The increased water flow results in Category III rapids, which are high, irregular waves and narrow passages that often require precise maneuvering. Category II waters also are part of the mix &mdash; easy rapids with smaller waves and clear channels that are obvious without scouting, but with some maneuvering possibly required.</p>
<p>Trophies are awarded to the fastest finishers of competition categories.</p>
<p>Registration starts at 8:30 a.m. Saturday at a cost of $25 per person, with the races to begin at noon. There is no charge just to watch. Rustic camping is offered for $20 per night, recognizing the fact that some attendees make the river run into a weekend outing.</p>
<p>The event relies on a shuttle system to transport canoes and kayaks as runs are completed.</p>
<p>&ldquo;It takes a lot of people to put it on,&rdquo; Gammons said.</p>
<p>Proceeds from the Kibler Valley River Run are used by the Red Bank Ruritans for an array of community projects that benefit schools along with aiding cancer patients and residents coping with deaths in their families.</p>
<p>The river run area can be accessed from Mount Airy by taking N.C. 103 to Claudville and turning left onto Route 773, also known as Ararat Highway, and then right on Kibler Valley Road and proceeding about four miles.</p>
<p>Concessions will be sold, with no pets permitted in the food preparation area. Service animals are allowed. </p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/111428/police-reports-592" title="Police reports" style="color:black">Police reports</a></h1>
   <p class="entry-meta">July 11, 2022</p>
   <p>&#8226; A Greensboro woman was arrested Saturday night in Mount Airy on a charge of possession of a stolen motor vehicle, according to city police reports.</p>
<p>Amy Virtudes Galindez, 36, was located by officers in the Walmart parking lot along with the 1997 Plymouth Voyager van that was found to have been stolen.</p>
<p>Galindez was confined in the Surry County Jail under a $2,500 secured bond and slated for an Aug. 8 District Court appearance in Dobson.</p>
<p>&#8226; April Dawn Bowman, 44, listed as homeless, was arrested Friday as a fugitive from justice as the result of a welfare check by police at 541 W. Pine St., the address for Mill Creek General Store.</p>
<p>Bowman&rsquo;s name was discovered to have been entered in a national crime database due to being wanted in Patrick County, Virginia, on an unspecified matter.</p>
<p>She was jailed under a $1,000 secured bond and was scheduled to be in Surry District Court on Monday.</p>
<p>&#8226; A break-in involving a larceny was discovered on July 3 at the residence of Anthony David Manley at Davis Rooms and Apartments on West Pine Street.</p>
<p>A brown wallet was taken, with the loss also including an undisclosed sum of money, a North Carolina driver&rsquo;s license and ID card, an insurance card, a Social Security card and a Sheetz reward card.</p>
<p>&#8226; Police learned on June 30 that a utility trailer valued at $2,209 had been stolen from a business on North Andy Griffith Parkway earlier in the month.</p>
<p>The property was described as a 5-foot by 8-foot black metallic high side utility trailer, which was taken after a security cable was disconnected on the premises of Leonard Aluminum Utility Buildings.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/111424/local-favorites-return-to-blackmon-amphitheatre" title="Local favorites return to Blackmon Amphitheatre" style="color:black">Local favorites return to Blackmon Amphitheatre</a></h1>

            <a href="https://www.mtairynews.com/news/111424/local-favorites-return-to-blackmon-amphitheatre" title="Local favorites return to Blackmon Amphitheatre">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/07/128691521_web1_embers2205166.jpg" alt="Local favorites return to Blackmon Amphitheatre">
            </a>
   <p class="entry-meta">July 11, 2022</p>
   <p>Three favorite bands among local music fans return to the Blackmon Amphitheatre this weekend. The Embers will play Thursday night. Legacy Motown Revue will take the stage on Friday night and Phatt City will perform on Saturday night. All three shows will be at 7:30 p.m.</p>
<p>The Embers are widely considered a musical marvel and have laid the groundwork for what has become known as &lsquo;Beach Music&rsquo; in the Carolinas, Virginias, the gulf coast region of North America, and every beach in between. They are a true musical tradition with which many Americans have listened to from childhood to adulthood. The Embers consider the genre of Beach Music as &ldquo;music with a memory&rdquo; and have been creating lasting memories since its inception in 1958. Simply put &#8211; heart and soul, rhythm and blues, feel good music.</p>
<p>The Legacy Motown Revue takes listeners back to the days of The Drifters, The Coasters, The Jacksons, Earth Wind &#038; Fire, The Temptations, and so many more legendary icons. Featuring talented performers that dance and sing, plus an amazing six-piece horn band, residents will be transported back in time to one of the most influential periods in American Musical History.</p>
<p>Phatt City is a nine-member band that plays the best of beach, R&#038;B, and dance music. Phatt City draws inspiration from the bands Chicago, Earth, Wind &#038; Fire as well as the energetic audiences that attend their concerts.</p>
<p>Each concert will begin at 7:30 p.m. on Thursday, Friday and Saturday. Admission to each show is $15 or a Surry Arts Council Annual Pass. Children 12 and younger are admitted free with an adult admission or Annual Pass. The Dairy Center, Whit&rsquo;s Custard, and Thirsty Souls Community Brewing will be at the concerts to provide food, snacks, drinks, beer, and wine for purchase. No outside alcohol or coolers are allowed to be brought into the Amphitheatre area. Those attending are asked to bring a lounge chair or blanket to sit on.</p>
<p>Tickets are available online at www.surryarts.org, via phone at 336-786-7998, or at the Surry Arts Council office at 218 Rockford Street. For additional information, contact Marianna Juliana at 336-786-7998 or marianna@surryarts.org</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/111423/chambers-lunch-learn-continues-friday" title="Chamber&#8217;s Lunch &#038; Learn continues Friday" style="color:black">Chamber&#8217;s Lunch &#038; Learn continues Friday</a></h1>
   <p class="entry-meta">July 11, 2022</p>
   <p>Area residents and leaders will have a chance to get an update on what at least one local business official is saying could be among the biggest economic development efforts in the history of Mount Airy.</p>
<p>The Greater Mount Airy Chamber of Commerce is sponsoring a Lunch and Learn on Friday at Cross Creek Country Club from 11:30 a.m. to 1 p.m. Lizzie Morrison with Mount Airy Downtown Inc. will be speaking, presenting a downtown economic development update centered round the Spencer&rsquo;s Mill Redevelopment project.</p>
<p>&ldquo;Mount Airy Downtown has done so much to bring a vibrant downtown to Mount Airy,&rdquo; said Chamber President and CEO Randy Collins. &ldquo;The Spencer&rsquo;s Project could very well be the largest economic development project in the history of the city.&rdquo;</p>
<p>The three-phased $55 million Spencer&rsquo;s Mill Redevelopment Project centers around a former complex of textile facilities downtown, preserving as many of the buildings as possible for their historic value, while converting the buildings and surrounding area into a commercially and residentially viable community.</p>
<p>The plan calls for a mix of residential and business development, including an upscale hotel, convention center, and other public uses.</p>
<p>In making her presentation, Morrison joins a long line of area leaders &mdash; including state officials, local school district heads, commissioners, and others who have taken part in the Lunch and Learn series sponsored by the chamber. Those are quarterly lunch meetings that give area leaders and those with expertise in a particular subject matter a chance to bring the public up to date on various projects, and is a way for residents to interact with and learn more from these leaders.</p>
<p>Collins said the series was started several years ago &ldquo;To help educate our members and the business community on the issues of the day. We felt it was time to give everyone an update on downtown Mount Airy economic development.&rdquo;</p>
<p>Friday, after Morrison&rsquo;s remarks, there will be a question and answer session on her presentation open to those in attendance.</p>
<p>Tickets to the event can be purchased at the chamber website www.mtairyncchamber.org. Sponsorship packages are still available for this event, which include tickets to the event. The gathering is open to both members and non-members of the chamber.</p>
<p>For more information on the event contact Jordon Edwards at the chamber, 336-786-6116 ext. 204 or via email at jordon@mtairyncchamber.org.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/111422/local-citizens-getting-bang-for-buck-on-taxes" title="Local citizens getting bang for buck on taxes" style="color:black">Local citizens getting bang for buck on taxes</a></h1>
   <p class="entry-meta">July 11, 2022</p>
   <p>DOBSON &mdash; No one enjoys being forced to dole out money, but at least Surry County residents are getting a good value for the property taxes they pay, according to a new report.</p>
<p>The recent study by an entity called SmartAsset shows that Surry ranks third among North Carolina&rsquo;s 100 counties in terms of citizens receiving the most value for what they spend in property taxes.</p>
<p>Mitchell and Avery counties rate first and second, respectively, in the report from SmartAsset, a 10-year-old financial technology company headquartered in New York City which publishes articles, guides, reviews, calculators and tools on various monetary matters.</p>
<p>To determine the rankings, the study measured the effective property tax paid in each county to determine a relative property tax burden, then incorporated data on school quality within each. It also assessed where home values have increased the most during a five year period, 2016 -2021, which was 52% in Surry County, to reach an overall index for purposes of the rankings.</p>
<p>The SmartAsset report points out that North Carolina property taxes are relatively low compared to other states, with Surry County&rsquo;s level of taxation below both that of both the state and national averages &mdash; nearly $1,000 less than the latter.</p>
<p>Based on a median home value of $121,000, Surry Countians have a median annual property tax payment of $892, according to the study.</p>
<p><strong>Local official responds</strong></p>
<p>&ldquo;I think that is indicative of several things,&rdquo; county Commissioner Eddie Harris said Monday in reacting to the new report and the financial stability it reflects.</p>
<p>Harris credits the people of Surry along with its businesses, industries and three public school systems &mdash; &ldquo;the fine job they do for the funds that they receive,&rdquo; he said of the educational component.</p>
<p>The local college also is a key part of that equation, added Harris, the longest-serving member of the Surry County Board of Commissioners who lives in the State Road community and represents the South District.</p>
<p>&ldquo;We&rsquo;re very fortunate to have a community college that&rsquo;s laser-focused on businesses and industries,&rdquo; he said of their training and other needs, which also has coincided with the county having a diverse manufacturing base.</p>
<p>Surry is well-positioned geographically with good highways, with Harris further mentioning how Mount Airy, Pilot Mountain and Elkin are centers of commerce located at corners of the county. This collectively allows them to draw consumers from neighboring localities and regions.</p>
<p>Meanwhile, the county continues to maintain strong farming and tourism communities, Harris said in listing factors that have helped create a forecast of financial stability for years to come.</p>
<p><strong>Historically low rate</strong></p>
<p>The longtime commissioner says Surry County leaders across the board traditionally have done a good job managing the financial and other resources available to them.</p>
<p>Coupled with that, overall revenue efforts have been undertaken to keep property taxes low &mdash; with that rate now 55 cents per $100 of assessed value.</p>
<p>&ldquo;I&rsquo;ve been on the board for 12 years and there hasn&rsquo;t been a tax increase since,&rdquo; said Harris.</p>
<p>&ldquo;Another thing is, our people pay their taxes,&rdquo; the county official mentioned. Surry&rsquo;s annual budget projects a 97% collection rate, but the actual figure is &ldquo;north of 99,&rdquo; he said.</p>
<p>Harris pointed out that one way in which officials has made wise use of those revenues is maintaining infrastructure and good services along with a generally fine quality of life &mdash; benefiting both present and future residents.</p>
<p>&ldquo;I think there&rsquo;s a wide range of things that make Surry County more attractive to move to,&rdquo; he observed.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/111420/group-seeking-to-change-outcomes-for-kids" title="Group seeking to change outcomes for kids" style="color:black">Group seeking to change outcomes for kids</a></h1>

            <a href="https://www.mtairynews.com/news/111420/group-seeking-to-change-outcomes-for-kids" title="Group seeking to change outcomes for kids">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/07/128679096_web1_ACEsCDC.jpg" alt="Group seeking to change outcomes for kids">
            </a>
   <p class="entry-meta">July 11, 2022</p>
   <p>Having been selected as the pilot county for Strengthening Systems for North Carolina Children (SYNC), the Surry County team has been working together since May to develop a plan of action.</p>
<p>The SYNC team has a goal to improve the lives of children in the county by finding ways to mitigate a variety of adverse childhood experiences (ACEs). Officials hope that doing so will reduce instances of childhood trauma the effects of which can have a life-long impact. Studies have shown these traumas may also be passed on to the next generation and have a cascading effect on families.</p>
<p>The CDC reports, &ldquo;A large and growing body of research indicates that toxic stress during childhood can harm the most basic levels of the nervous, endocrine, and immune systems, and that such exposures can even alter the physical structure of DNA.&rdquo;</p>
<p>With county staff, teachers, health care professionals, peer support counselors, and representatives from local non-profit groups across the spectrum coming together meetings have been something like an All-Star game of subject matter experts.</p>
<p>Community teams have completed a trio of workshops during which they were introduced to the use of tool called causal loop diagramming to create a map view of institutions and systems that may influence ACEs in their community. The map identifies two types of loops &mdash; one that reinforces patterns, and the ones that seek to balance out systems or bring them back into order.</p>
<p>The map they developed is a bulky crisscross of lines and arrows that run between varied concepts such as &ldquo;positive self-image&rdquo; and &ldquo;ability to meet needs&rdquo; to see where they intersect or may influence one another.</p>
<p>The map can show at times a path of progression that creates a loop like how substance abuse may lead to decreased decision-making capacity and then to more risky behavior including the possible progression to the justice system getting involved. An outside influence along the path can easily create a nudge toward a different way forward and a new outcome.</p>
<p>SYNC is trying to find ways that the community, not just experts from UNC Chapel Hill or Raleigh, can create that nudge to influence these loops or cyclical patterns. Determining a role for parents, faith groups, educators, or law enforcement to play on the prevention of trauma, as opposed to after the fact, will also prove one of the best tools to create positive outcomes for children.</p>
<p>Groups such as educators, counselors, and parents need to be brought up to speed on how to identify warning signs of potential trauma. When these signs are spotted there is a &lsquo;signal for need&rsquo; that may then be detected, and this is where loops can break free of reinforcing cycles.</p>
<p>This will require teaching people to know what these signs are, and to look for them in all children. That also means &ldquo;looking at prevention and detection in perceived healthy children,&rdquo; county parks and recreation director Danny White said. The pandemic and remote learning created more feelings of isolation for children and their families, he noted, and warning signs can be impossible to distinguish when focused on &ldquo;squeaky wheels.&rdquo;</p>
<p>Practice is an invaluable commodity, so the SYNC squad spread out to conduct interviews with members of the community. This was a chance to put what they learned to the test &#8211; at least a dry run &#8211; before the training is over. Their mission was to express the concept of loop diagramming to a community member and then pick their brain for input on what areas the all-star SYNC team had missed.</p>
<p>The public&rsquo;s input revealed places where they saw shortcomings such as the need to address a stigma around men&rsquo;s mental health. There was also concern expressed that minority representation needs to be considered. Juan Sanchez agreed and wanted to make those parties not seated at the table like people of color, LGBTQ, and immigrants were being taken into consideration while setting goals for SYNC.</p>
<p>After the diagrams and feedback from the community came together the team&rsquo;s next challenge was to take concepts and turn them into actionable ideas. Their concepts were weighed on their level of importance versus probability to create change.</p>
<p>Some ideas can have great potential impact to change many lives but the implementation of them is so far-fetched due to costs, logistics, or red tape that they just are not feasible. One could lump a wide-reaching county public transportation system in this category.</p>
<p>Other ideas such as having substance abuse education happening in the county jail seemed unlikely until Mark Willis chimed in to remind that just such a program is forthcoming in the new detention center. Having these voices and expertise from different elements of the community addressing the same problem is part of the hallmark of the SYNC design.</p>
<p>Surry County&rsquo;s leadership in this program may create a guide for further implementation of these concepts in other counties or states. To that end Jaime Edwards said he hopes the group can help create advocates for change in spaces of all sizes.</p>
<p>Facilitator Kristen Hassmiller Lich of UNC concurred saying that discussions such as these that the group is having may create the very changes needed to institutions and systems, &ldquo;If all of you reached into your organizational policies after having these conversations; that could be very powerful.&rdquo;</p>
<p>By design SYNC is meant to look at systems but the team made sure to bring their focus back to the human element and invested some time in a discussion on empathy and compassion. Charlotte Reeves reminded regarding empathy that it needs to be applied generously and to not forget to include yourself.</p>
<p>&ldquo;Once you have empathy for yourself you can start to forgive yourself and then you can start to come to terms with the traumatic event and the healing.&rdquo;</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/111408/scc-honor-society-receives-international-recognition" title="SCC Honor Society receives international recognition" style="color:black">SCC Honor Society receives international recognition</a></h1>

            <a href="https://www.mtairynews.com/news/111408/scc-honor-society-receives-international-recognition" title="SCC Honor Society receives international recognition">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/07/128673990_web1_scc.jpg" alt="SCC Honor Society receives international recognition">
            </a>
   <p class="entry-meta">July 11, 2022</p>
   <p>Co-advisor of Surry Community College&rsquo;s Phi Theta Kappa Honor Society Dr. Kathleen Fowler attended the organization&rsquo;s annual convention this spring Denver, Colorado, where she was recognized for her and her chapter&rsquo;s accomplishments.</p>
<p>Fowler won the Paragon Award for New Advisors and the Phi Theta Kappa Carolinas Region Horizon Award. Advisors who receive the Paragon Award are recognized for significant contributions to the growth of individual members, serve as the chapter&rsquo;s advocate on campus and encourage the chapter to be involved on the local, regional and international level of the organization. The Horizon Award is given to advisors who participate in regional and international programs, as well as attain new levels of achievement in PTK programs.</p>
<p>The additional award recognitions include: three International Hallmark Trophies for 2020, four International Hallmark Trophies for 2022, six Regional Trophies including the 2022 Most Distinguished Chapter, Distinguished Theme Award for Honors in Action, Distinguished Honors in Action Project, Distinguished Chapter and seventh finalist for Most Distinguished Chapter of 1,300 chapters.</p>
<p>&ldquo;I am so elated that Dr. Kathleen Fowler was chosen as a recipient of the 2022 Phi Theta Kappa Paragon Award for New Advisors,&rdquo; said SCC College President Dr. David Shockley. &ldquo;She continually leverages superior leadership qualities, advising, knowledge, and work-ethic to transform our Alpha Xi Tau Chapter of Phi Theta Kappa while always seeking to improve the lives of students.&rdquo;</p>
<p>Phi Theta Kappa is the premier honor society recognizing the academic achievement of students at associate degree granting colleges and helping them to grow as scholars and leaders. The society is made up of more than 3.5 million members and nearly 1,300 chapters in 11 nations.</p>
<p>For more information about Phi Theta Kappa and their projects, contact PTK&rsquo;s faculty co-advisors Fowler at 336-386-3560 or fowlerk@surry.edu or Kayla Forrest at 336-386-3315 or forrestkm@surry.edu or go to www.ptk.org. Follow the local chapter on Facebook @surryPhiThetaKappa.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/111405/two-charged-with-murder" title="Two charged with murder" style="color:black">Two charged with murder</a></h1>

            <a href="https://www.mtairynews.com/news/111405/two-charged-with-murder" title="Two charged with murder">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/07/128689715_web1_Chris-Wayne-Mosley.jpg" alt="Two charged with murder">
            </a>
   <p class="entry-meta">July 11, 2022</p>
   <p>A nine-month probe following a deadly Halloween overdose has led to two Mount Airy residents being charged with murder.</p>
<p>Surry County Sheriff Steve C. Hiatt said this morning that Chris Wayne Mosley, 50, of 219 William Penn Street, and Laken Nichole Mabe, 34, of 257 Tolbert Road, have both been arrested and charged with second degree murder in the Oct. 31 death of Jeremy Franklin Collins III, 34.</p>
<p>The sheriff said the case began on Halloween when deputies responded to a call of an unattended death at 137 Bobs Way, Ararat. Upon arrival, they found Collins, dead from an apparent drug overdose.</p>
<p>&ldquo;Detective Donald Blizard was contacted and started investigating the origin and supplier of the illegal narcotics that were provided to Mr. Collins,&rdquo; the sheriff said.</p>
<p>That probe led to the arrests of both Mosley and Mabe.</p>
<p>Mosley, who was already in custody of North Carolina Department of Adult Corrections on an unrelated matter, was served with the charges, remaining incarcerated under a $300,000 bond.</p>
<p>Mabe was arrested by the Surry County Sheriff&rsquo;s Office and the North Carolina Department of Probation and Parole. She is being held in the Surry County Sheriff&rsquo;s Office Detention Center under a $200,000.00 secured bond with a pending court date of July 18.</p>
<p>No other details on the case were available.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/111393/police-reports-591" title="Police reports" style="color:black">Police reports</a></h1>
   <p class="entry-meta">July 08, 2022</p>
   <p>&#8226; A Mount Airy man was jailed Wednesday after allegedly &ldquo;causing a problem&rdquo; at a demolition area downtown, according to city police reports.</p>
<p>Donald William Branson, 28, a Willow Street resident whose exact address was not listed, was encountered by police upon crossing a marked line in violation of street-closing restrictions implemented after the collapse of the Main-Oak Building on the corner of North Main and East Oak streets earlier in the week.</p>
<p>Branson was advised to leave the demolition area and responded by cursing and otherwise hindering the situation, arrest records state. He subsequently was taken into custody at the North Main-Virginia Street intersection nearby and charged with disorderly conduct.</p>
<p>The man was held in the Surry County Jail under a $300 secured bond and slated for an appearance in District Court on Monday.</p>
<p>&#8226; Property damage was discovered last Sunday at Grand Pup Resort Hotel and Spa on North Main Street, where a Mediterranean four-tier decorative water fountain was targeted by an unknown suspect. The damage was put at $1,600.</p>
<p>&#8226; Patrick Marquis Allen, 31, of 515 Linville Road, was jailed on three charges Sunday stemming from an incident at Dollar General on North Renfro Street: larceny; possession of stolen goods; and resisting, delaying or obstructing a public officer.</p>
<p>He is accused of stealing a four-pack of men&rsquo;s white T-shirts from the store, which were recovered with the arrest of Allen, who allegedly fled on foot from an officer arriving at that location.</p>
<p>The Linville Road resident was jailed under a $200 secured bond, with the case scheduled for the July 18 session of Surry District Court.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/111382/more-candidates-seek-town-seats-in-surry" title="More candidates seek town seats in Surry" style="color:black">More candidates seek town seats in Surry</a></h1>
   <p class="entry-meta">July 08, 2022</p>
   <p>DOBSON &mdash; A small business owner who lives in Dobson is among the latest candidates to toss their hats into the ring for elected offices there and elsewhere across Surry County, including both fresh and familiar faces.</p>
<p>Newcomer John Jonczak filed Thursday to run for a seat on the Dobson Board of Commissioners, with incumbent board member J. Wayne Atkins doing so Friday.</p>
<p>And on Wednesday, incumbent Commissioner William Gwyn filed for re-election to the Elkin town board, joined by another sitting commissioner, Jeffrey C. Eidson, on Friday.</p>
<p>As of Friday afternoon, eight candidates had officially declared their intentions to run for municipal seats in Dobson, Elkin and Pilot Mountain, where nine elected offices altogether &mdash; all non-partisan &mdash; are at stake in a general election on Nov. 8.</p>
<p>The deadline for others to do so is next Friday at noon at the Surry County Board of Elections in Dobson.</p>
<p>Jonczak said Friday that a motivation to help businesses in Dobson and otherwise aid the town&rsquo;s growth fueled his decision to seek a spot on its governing board.</p>
<p>&ldquo;My wife Jessica and I and our family have lived in Dobson for five years,&rdquo; he said, with ancestral ties going back much farther.</p>
<p>For six years, the Jonczaks have owned and operated The Barn at Heritage Farm, a family farm and event center just outside town.</p>
<p>The candidate says they are &ldquo;heavily invested&rdquo; in the Dobson community and he also wants to help other small businesses thrive in Dobson by sharing information and basically working for the betterment of all.</p>
<p>Pointing out that the town has good schools and other attributes, Jonczak, 37, of Saddle Brook Drive, seeks to play a role in taking Dobson to the next level and meeting needs of citizens overall.</p>
<p>&ldquo;I think the main thing is just listening,&rdquo; the candidate said of what he would bring to the table if elected as a commissioner.</p>
<p>Two seats on the Dobson town board, now held by Atkins and John Lawson, are up for grabs this year altogether.</p>
<p>Dobson Mayor Ricky Draughn signed up to seek his sixth four-year term on July 1, the opening day of the filing period.</p>
<p>Along with Draughn, Atkins and Jonczak in Dobson, all three incumbents in Pilot Mountain whose seats are affected in 2022 have filed to seek re-election: Mayor Evan Cockerham and commissioners Donna Kiger and Scott Needham.</p>
<p>As of Friday morning, no one had filed to challenge any of the three, who all are seeking their second four-year terms.</p>
<p>In Elkin, where three slots on the town council are involved, only Gwyn and Eidson had filed as of Friday afternoon, with the other seat affected held by Cicely McCulloch.</p>
<p>Gwyn is 58 and resides on West Main Street, while Eidson, 60, lives on Ivy Circle.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/111375/edwards-franklin-open-house-events-continuing" title="Edwards-Franklin open house events continuing" style="color:black">Edwards-Franklin open house events continuing</a></h1>
   <p class="entry-meta">July 08, 2022</p>
   <p>Organizers of two open house events this weekend hope area residents will take advantage of the opportunity to explore an important piece of local history.</p>
<p>This will involve the 1799 Edwards-Franklin House being open to the public today and Sunday from 1 to 5 p.m. both days. Admission is free.</p>
<p>The weekend events are part of a monthly Saturday-Sunday open house series that resumed in May after a two-year shutdown prompted by the coronavirus.</p>
<p>Attendance has been good for this year&rsquo;s sessions, according to Dr. Annette Ayers of the Surry County Historical Society, which owns the house and conducts various events there.</p>
<p>&ldquo;We are so pleased,&rdquo; Ayers advised. &ldquo;We have had visitors each of the days we have been open &mdash; we had about 25 one day.&rdquo;</p>
<p>The Edwards-Franklin House is considered the finest example of its architectural type in the Piedmont region.</p>
<p>The house was built by Gideon Edwards and later occupied by his son-in-law, Meshack Franklin, a member of Congress and brother of North Carolina Gov. Jesse Franklin, who served in the 1820s.</p>
<p>In 1972, the Edwards-Franklin House was bought by the Surry County Historical Society and restored to its former grandeur. The structure features many unique architectural components.</p>
<p>Concerning those who have stopped by the house during the events in recent months, it has tended to be their first visit, according to Ayers. &ldquo;We are pleased the visitors range from children to adults.&rdquo;</p>
<p>In addition to the house, they can view the log water pipes, slave cemetery and family cemetery on the grounds.</p>
<p>Ayers also encourages people who&rsquo;ve been there before to come by again during the open house hours and catch up on lost time posed by the pandemic.</p>
<p>&ldquo;It will be a wonderful tour for those who have visited the house previously,&rdquo; she assured. &ldquo;It is a chance to become reacquainted with the house, it&rsquo;s history and our efforts at preserving this historic structure.&rdquo;</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/111356/grief-camp-for-kids-coming-this-month" title="Grief camp for kids coming this month" style="color:black">Grief camp for kids coming this month</a></h1>
   <p class="entry-meta">July 08, 2022</p>
   <p>Mountain Valley Hospice &#038; Palliative Care is holding its annual grief camp for young people who have experienced a significant loss in their life.</p>
<p>The camp, set for July 22 and July 23, is an extension of Mountain Valley Hospice&rsquo;s Kids Path program. The two-day event is offered to children and teens, ages 5-18.</p>
<p>It uses a variety of games and activities to teach young people ways to cope with grief and build confidence.</p>
<p>&ldquo;Grief Camp is important, because it provides a relaxed, fun-filled environment where a child can express their sorrow while making connections with other children who have experienced similar loss,&rdquo; said Katie Moser, Kids Path counselor.</p>
<p>This summer camp will be located at First Baptist Church in Dobson, between 8 a.m. and 5 p.m. both days.</p>
<p>On the final day of camp, parents and families are invited to an evening memorial after camp. This program is free to all families with children and teens who have/are experiencing grief. Due to COVID-19, upon arrival to camp, parents and children will be briefed for COVID-19 exposure and symptoms. Temperature checks will be required prior to entry and each camp member will be required to wear a face covering for each other&rsquo;s safety.</p>
<p>Camp registration is open until July 16 on the Mountain Valley Hospice and Palliative Care website at https://www.mtnvalleyhospice.org/support/kids-path</p>
<p>In the meantime, the Kids Path program still offers support for young individuals who are grieving over the loss of a loved one. For more information on Kids Path, contact Moser at 1-888-789-2922</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/111373/lewis-supporting-cawley-for-mayor" title="Lewis supporting Cawley for mayor" style="color:black">Lewis supporting Cawley for mayor</a></h1>

            <a href="https://www.mtairynews.com/news/111373/lewis-supporting-cawley-for-mayor" title="Lewis supporting Cawley for mayor">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/07/128683398_web1_Teresa-mug-this-441x509.jpg" alt="Lewis supporting Cawley for mayor">
            </a>
   <p class="entry-meta">July 08, 2022</p>
   <p>Teresa Lewis lost a bid to become mayor of Mount Airy in a May 17 primary, but is still a player regarding the general election &mdash; for which she is swinging her support to Jon Cawley.</p>
<p>&ldquo;I like both of them and I think they&rsquo;ve done a good job,&rdquo; Lewis said this week of Cawley, who is now a North Ward commissioner, and his opponent, Mayor Ron Niland. Niland was appointed to that position last year and is seeking his first four-year term.</p>
<p>Lewis finished third in a three-person race in the mayoral primary and thus was eliminated &mdash; although the votes she received exceed the winning margin captured by Niland against second-place finisher Cawley.</p>
<p>When three or more candidates file for a particular office, Mount Airy&rsquo;s non-partisan system requires a primary &mdash; after which only the two top vote-getters advance to the general election in a head-to-head matchup.</p>
<p>Lewis explained that her reasons for supporting Cawley are personal in nature &mdash; including ties to her family &mdash; rather than factors related to city government policy or job performance.</p>
<p>&ldquo;I like Ron a lot,&rdquo; she said. &ldquo;But Jon Cawley was our minister and also performed my marriage ceremony.&rdquo; Lewis added that Cawley further is scheduled to deliver a eulogy for her, which she hopes is a long time in the future.</p>
<p>Cawley also is well-liked by her children and was by her late father, Monroe Donathan, said the former mayoral candidate, a retired local businesswoman long associated with the WorkForce Unlimited staffing agency. In addition, Lewis is a former at-large commissioner in Mount Airy.</p>
<p>&ldquo;I&rsquo;m not sure what Jim&rsquo;s going to do,&rdquo; she said of husband Jim Lewis. &ldquo;He and Ron are good friends.&rdquo;</p>
<p>Based on updated totals from the May 17 primary compiled by the Surry County Board of Elections, Niland received 816 votes, while Cawley garnered an even 700 and Lewis, 289.</p>
<p>(Those figures include both Niland and Cawley each being credited with five more votes than they were initially, while Lewis&rsquo; final total is two votes fewer than earlier reported.)</p>
<p>&ldquo;I just appreciate all the people who did support me,&rdquo; she said of the primary.</p>
<p>The votes Lewis received would be more than enough to shift the election outcome in the two-man race unfolding between now and the fall, based on their primary showings. However, the dynamics can prove to be much different in a general election due to turnout and other factors.</p>
<p>The two remaining candidates for mayor are aware of Cawley&rsquo;s endorsement by Lewis.</p>
<p>&ldquo;I told Jon I would (support him),&rdquo; she said, &ldquo;for the reasons I listed,&rdquo; such as the church involvements.</p>
<p>&ldquo;And I think Ron understands.&rdquo;</p>
<p>If not for Cawley&rsquo;s presence on the ticket, Lewis says she would be firmly in the corner of Niland.</p>
<p>The upcoming general election also features a former mayor and commissioner, Deborah Cochran, squaring off against Commissioner Steve Yokeley for the at-large seat on the city council. Also, Gene Clark is facing Phil Thacker for a South Ward spot and it&rsquo;s Chad Hutchens vs. John Pritchard in the North Ward in a race to replace Cawley.</p>
<p>Yokeley now holds the South Ward post involved, but opted to seek the at-large seat in the 2022 municipal election.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/111362/here-we-grow-again" title="Opposition to new Dollar General in Sheltontown" style="color:black">Opposition to new Dollar General in Sheltontown</a></h1>

            <a href="https://www.mtairynews.com/news/111362/here-we-grow-again" title="Opposition to new Dollar General in Sheltontown">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/07/128683046_web1_DGSheltontown2.jpg" alt="Opposition to new Dollar General in Sheltontown">
            </a>
   <p class="entry-meta">July 08, 2022</p>
   <p>Concern over a proposed new Dollar General location at 2953 Westfield Road and the intersection of Quaker Road has gotten the attention of residents in Sheltontown who are worried about what the addition of one of the seemingly ubiquitous stores may mean to their community.</p>
<p>A sign sits on the corner of Quaker and Westfield announcing an upcoming rezoning hearing, but those opposed to the plan have said the sign is often obscured by a bush or facing the wrong way. They wonder if residents can see the sign and if they are even aware that a rezoning may be forthcoming.</p>
<p>Therefore, a community meeting has been organized to coordinate a response when they speak to the planning board Monday. They are meeting at 3 p.m. Sunday, July 10, at the Shelton Church of the Brethren, 1065 Quaker Road, Mount Airy, to discuss their plans.</p>
<p>Organizers say Sunday&rsquo;s meeting has been moved inside due to the weather.</p>
<p>&ldquo;Sunday&rsquo;s meeting will give us an opportunity to pool important information and develop a list of citizens willing to speak during the planning meeting,&rdquo; local resident Melissa Hiatt said of the meeting she and Heather Moore are planning.</p>
<p>Moore and her husband Heath Moore are the proprietors of Moore&rsquo;s General Store who operate their family-owned market just four tenths of a mile from the proposed new location. Within four miles from the planned location are also the Flat Rock, Main Street, and Airport Road locations of Dollar General.</p>
<p>In Surry County Dollar General is a retail force to be reckoned with, already boasting over a dozen stores within the county lines. The Surry County Board of County Commissioners have been told that there is an ongoing plan to grow the footprint of Dollar Generals in the county even further.</p>
<p>&ldquo;We built three new ones in the last three years, Beulah, Cook School Road, and the one at Zephyr, with (Mount View Drive) being the fourth,&rdquo; Joe Strickland of Teramore Development told the board of commissioners on June 6. He mentioned new store designs are now the norm with larger footprints that carry more variety of items.</p>
<p>Commissioner Larry Johnson remarked about the number of Dollar Generals in the county saying that he seems them all the time as he drives around, &ldquo;I don&rsquo;t have much else to do,&rdquo; he quipped. More seriously though he noted that the stores appear to be doing a brisk business, &ldquo;They seem to be doing well.&rdquo;</p>
<p>It may be the convenience factor of a quick pop in for bread, milk, and shampoo that makes the yellow sign of DG on the horizon a welcome sight to some. That bright yellow signage however makes others see red, and residents have signed a petition that Moore said as of Friday morning had over 850 signatures.</p>
<p>Opposition to land rezone requests are rare. Often when the planning board&rsquo;s recommendation reached the county commissioners the board will ask if there was any opposition; rarely has there been any.</p>
<p>The last Dollar General to come before the planning committee and reach the commissioners sailed through the approval process. Vice Chairman Eddie Harris asked development services director Marty Needham is the rezoning request for 120 Mount View Drive had met with any pushback. Rather than finding opposition to the new store, Needham informed the residents of the area were looking forward to having the additional options.</p>
<p>This is where Sheltontown differs from the past proposed locations.</p>
<p>Preserving the quality of life for the residents of Sheltontown is their number one concern, so too is protecting the land for the future. &ldquo;If we sell off rural America, what will be left for generations to come?&rdquo; Moore asked thinking about her four-year-old son. &ldquo;He&rsquo;ll grow up here. Even if we weren&rsquo;t business owners we would be against this plan.&rdquo;</p>
<p>Moore&rsquo;s General Store is their family business, she said. After time being horse trainers and cattle farmers, they settled in to running the store and making it an essential part of the community they serve.</p>
<p>She has stories aplenty of the difference having a small independent store like theirs can make, and how much their customer appreciate it. Being open 364 days a year for seven years, closed only on Christmas day, has established their general store as a place people can count on. Moore wonders if any box store can offer the same.</p>
<p>&ldquo;In winter of 2017 a snowstorm crippled our community, the roads hadn&rsquo;t been plowed. Heath drove our 4-wheel drive tractor from our farm to the store. We were the only store open in a 5-mile radius, the DOT drivers appreciated a warm coffee and snacks to keep them going.&rdquo;</p>
<p>The Sheltontown opposition group is not opposed Dollar General specifically but rather the growth of larger retailers in their rural community. The Moore&rsquo;s have had offers to sell their store, but they have no interest in that, &ldquo;We refuse to put a price on it because it is a part of this community. We didn&rsquo;t&rsquo; buy this to flip it.&rdquo;</p>
<p>A grander sense of community is what is driving the opposition and they are looking at increased traffic flow, property values, eyesore blight, and the possibility of increases in crime that may follow. Calls have been made to the Mount Airy Police Department and the Surry County Sheriff&rsquo;s Office to obtain crime stats for areas around DG locations.</p>
<p>BJ Elmore also has direct concerns involving the wildlife of the area, &ldquo;The bright lights will confuse nocturnal animals, therefore, disrupting their natural instincts. The paved parking lot will increase chances of pollution and runoff from so many vehicles.&rdquo;</p>
<p>Others wonder if the store is even needed with Hiatt suggesting a lack of need in that area, &ldquo;We have two very well rooted family run stores in the community, both stores are more than a gas station or a place to grab a snack. They are run by our own people who are part of our community family. They are always open and have yet to close one day due to lack of staff &#8211; that&rsquo;s impressive.&rdquo;</p>
<p>Moore concurs, &ldquo;We are the community store that has served the Sheltontown area for over 50 years. A store that many houses in the community have been built around. A store that takes a step back in time while providing modern day amenities.&rdquo;</p>
<p>For the 800+ residents of the area who signed on to the petition, the concerns outweigh the possible benefits of adding another Dollar General. Only time will tell if their pushback will be enough, but theirs is an example of a community deciding to coalesce to save the rural way of life so many of them desire.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/111346/middle-grader-takes-deep-diveinto-family-history" title="Middle grader takes deep diveinto family history" style="color:black">Middle grader takes deep diveinto family history</a></h1>

            <a href="https://www.mtairynews.com/news/111346/middle-grader-takes-deep-diveinto-family-history" title="Middle grader takes deep diveinto family history">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/07/128667825_web1_Elijah-Smith-12-years-old.-382x509.jpg" alt="Middle grader takes deep diveinto family history">
            </a>
   <p class="entry-meta">July 06, 2022</p>
   <p>The Surry County Genealogical Association members are accustomed to presentations during their meetings from folks who have a particular area of expertise in the field of genealogy. Sometimes it may be a historian there to discuss a certain period in local history; other times it might be explaining research techniques or tools; often it is simply a local resident giving a presentation on his or her family tree.</p>
<p>What they are not used to is a presentation by someone who is still in middle school.</p>
<p>That is exactly what is on tap for the planned July 11 meeting, when 12-year-old Elijah Smith is set to give a talk about his family tree &mdash; making him the youngest person to have ever made such a presentation, according to society president Esther Johnson.</p>
<p>&ldquo;Most of the time it&rsquo;s old people doing the family history,&rdquo; Johnson said with a laugh when discussing the upcoming meeting. &ldquo;I wish I had started loving genealogy at his age and was as smart as he is.&rdquo;</p>
<p>Elijah, the son of Chad and Leigh Ann Smith and a rising seventh grader at Mount Airy Middle School, said he became interested in genealogy years ago, when he was much younger.</p>
<p>&ldquo;My grandparents and great-grandparents and I would look at pictures and stuff,&rdquo; he said, recalling reviewing photos of his ancestors. &ldquo;When I got older, I started asking a lot of questions.&rdquo;</p>
<p>While he was able to fill in much of the recent information on his family from his grandparents and great-grandparents, it wasn&rsquo;t long before Elijah wanted to know more. He soon turned to ancestry.com, local courthouse and U.S. military records, and met Johnson.</p>
<p>&ldquo;I found out we were kin,&rdquo; he said. With encouragement from his newfound relative &mdash; a local authority on genealogy &mdash; he continued diving into his family&rsquo;s history.</p>
<p>&ldquo;I probably spend a lot of time on it&#8230;I get really involved in it, definitely,&rdquo; he said. &ldquo;I enjoy knowing where I came from, seeing photos of my kinfolk and thinking that&rsquo;s a part of me, in a sense. Sometimes I&rsquo;ll go to the courthouse and look at records occasionally. I have a bunch of records my grandparents have, photos with writing on the back, family Bibles.&rdquo;</p>
<p>He&rsquo;s managed to find military records of his ancestors from World War II, the Civil War, and other conflicts. It was while looking over military records that he had one of his biggest surprises.</p>
<p>&ldquo;My great-grandpa, he was in the army during the Korean War. I found out where he was stationed at, how long he had served through some papers and stuff. That was a surprise.&rdquo; He said his great-grandfather, Davis Smith, never once mentioned his time in the war.</p>
<p>&ldquo;I found one ancestor on grandma&rsquo;s side; he was in World War II. Most of his platoon got killed, but he made it back,&rdquo; he said of another startling discovery.</p>
<p>While Elijah has spent a great deal of time learning of the military history of his family, the research hardly stops there.</p>
<p>&ldquo;I&rsquo;ve made it back to Germany on my Smith side, they called it Schmidt, and that&rsquo;s in the 1600s,&rdquo; he said of his never-ending hunt for more family knowledge.</p>
<p>As to the upcoming presentation, Elijah said he&rsquo;s not nervous. &ldquo;I&rsquo;ll just take it easy until the day comes and then I&rsquo;ll just do it,&rdquo; he said. Truth is, he&rsquo;s putting in more advance work than it seems. He has had some help in putting together a slide presentation he will use to talk about his family tree, showing pictures of his ancestors along with records and other information, with a focus on those who served in Korea, both War Worlds, and the Civil War. He plans to touch on the Gates, Smith, Jarvis, Isaacs, Ray, Marion, and Johnson families.</p>
<p>&ldquo;Then I&rsquo;ll take questions at the end,&rdquo; he said. He is particularly looking forward to the question and answer session. Elijah said he has been to a few genealogy society meetings, and the Q&#038;A periods are always fun.</p>
<p>The meeting which includes Elijah&rsquo;s presentation will be at 6 p.m. on July 11 at the Mount Airy Public Library. For more information on the organization contact Johnson at EPDJ1@triad.rr.com The meeting is open and free to the public.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/111338/blue-bear-bus-visits-museum" title="Blue Bear Bus visits museum" style="color:black">Blue Bear Bus visits museum</a></h1>

            <a href="https://www.mtairynews.com/news/111338/blue-bear-bus-visits-museum" title="Blue Bear Bus visits museum">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/07/128664722_web1_289403774_448115163425978_7039974087992357449_n.jpg" alt="Blue Bear Bus visits museum">
            </a>
   <p class="entry-meta">July 06, 2022</p>
   <p>The Mount Airy City Schools Blue Bear Bus provides Summer Enrichment Programs and Family Engagement Sessions for underserved local communities throughout the summer with a unique weekly theme.</p>
<p>Last week, the Mount Airy Museum of Regional History was part of the bus&rsquo; tour, with the theme of Red, White, &#038; Blue. Cassandra Johnson, director of programs and education, met with the students at the Madoc Center on Monday and did a covered wagon craft with the children and taught them about pioneers who moved into the area from the North.</p>
<p>Later in the week, the museum had more than 30 of the students, along with several parents and educators at the museum location downtown. There, the children took part in a book reading, then learned about wood carving from local Denny Shelton, made their own soap from scratch, played with historic toys and games, saw Victorian-era artifacts in a game of bingo, and learned about NC aviation history while enjoying a parachute drop activity where they got to drop parachute &lsquo;rockets&rsquo; from the clock tower.</p>
<p>Several children and even many teachers and parents commented that they had never visited the museum before and were unaware that the town had all of the artifacts and resources offered at the museum.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/local/surry-scene/111334/edna-mounts" title="Edna Mounts" style="color:black">Edna Mounts</a></h1>
   <p class="entry-meta">July 06, 2022</p>
   <p>Edna Mae Toler Mounts, 82, of Mount Airy, passed away Tuesday, July 5, 2022, at Northern Regional Hospital in Mount Airy. She was born in Logan County, West Virginia, on Sept. 25, 1939, to the late William and Letha Toler. Mrs. Mounts was a loving homemaker who will be dearly missed by her family and all who knew her. She is survived by daughters and son-in-law, Kimberly Norman, Angela and Scott Hanks; sons and daughters-in-law, Charles Michael and Suzanne Mounts, Anthony &ldquo;Tony&rdquo; Mounts and Susan; grandchildren, Jeffrey Hanks, Eric Hanks, Jessica Mae Mounts, Yvonne Hodges, Nicole Norman; eleven great-grandchildren; one great-great-grandchild; numerous nieces and nephews extended family, includes Stephanie, Bethani, Jason, Leslie. In addition to her parents, Mrs. Mounts was preceded in death by her husband, French Charles Mounts; a son-in-law, Steven Norman; a sister, Nora Roberts, and brothers, Isaac, Noah, Roy, and Verlin Toler. A graveside service will be held Friday, July 8, at 2 p.m. at the Family Cemetery in Branchland, West Virginia. The family will receive friends Friday from 1 until 2 p.m. at Mildred Baptist Church. Moody Funeral Services in Mount Airy is serving the Mounts family. Online condolences may be made at www.moodyfuneralservices.com.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/111335/june-temperatures-locally-were-all-over-the-board" title="June temperatures locally were all over the board" style="color:black">June temperatures locally were all over the board</a></h1>
   <p class="entry-meta">July 06, 2022</p>
   <p>To say that June was a month of temperature extremes in Mount Airy would be a bit of an understatement, with temperatures in both the mid-90s and high 40s recorded which each threatened local records. </p>
<p>Even more interestingly, the wide disparity in mercury readings occurred just two days apart on a pair of occasions and represented a 47-degree swing during one three-day period.</p>
<p>The high for the month, 95 degrees, occurred on both June 18 and 23, according to a breakdown released earlier this week by personnel at F.G. Doggett Water Plant, the city&rsquo;s official weather-monitoring station.</p>
<p>That tied the all-time local high temperature record for both dates, with the first matching the mark first set in 2015 and the second 95-degree day tying a record initially established way back on June 23, 1933. Weather statistics have been kept in Mount Airy since 1924.</p>
<p>On June 20-21, a 48-degree temperature that was the monthly low tied a record for June 21 that had been set in 1944.</p>
<p>Last month&rsquo;s variations added up to a near-normal average reading for June of 72.4 degrees, slightly above the all-time figure for Mount Airy of 71.9.</p>
<p>This week&rsquo;s breakdown from the water plant was a two-month report that also showed some of the same temperature extremes during May, although no records were broken or tied.</p>
<p>That included the maximum reading for the month of 92 degrees, occurring on both May 21-22, and the month&rsquo;s low of 38 degrees logged on both June 10-11.</p>
<p>May&rsquo;s mercury readings averaged an even 65 degrees, slightly warmer than the all-time local average of 64.2.</p>
<p><strong>Slightly wetter for year</strong></p>
<p>Mount Airy finished the first six months of 2022 with precipitation totals a tad above normal, 24.78 to 24.16 inches. This is 0.62 inches, or 2.6 percent, above the local average for that period.</p>
<p>May&rsquo;s output of 6.24 inches topped the Mount Airy norm for that month of 4.70, while in June drier conditions prevailed with only 2.1 inches measured. That was well below the local average for June of 4.44 inches.</p>
<p>Much of last month&rsquo;s rain fell on a single day, June 9, when 1.32 inches occurred, with measurable amounts noted on just seven of its 30 days.</p>
<p>In stark contrast, May saw 18 days of rain topped by 2.17 inches on the 24th.</p>
<p>Fog was observed on 10 days during May and 11 in June.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/111309/main-oak-building-suffers-collapse" title="Main Oak Building suffers collapse" style="color:black">Main Oak Building suffers collapse</a></h1>

            <a href="https://www.mtairynews.com/news/111309/main-oak-building-suffers-collapse" title="Main Oak Building suffers collapse">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/07/128677488_web1_FallawWorkByHand-423x509.jpg" alt="Main Oak Building suffers collapse">
            </a>
   <p class="entry-meta">July 06, 2022</p>
   <p>On Wednesday morning Mount Airy Fire Marshal Chris Fallaw said that work at the historic Main Oak Building had resumed. The past 36 hours have been a flurry of dust, debris, and a little disbelief that the building that has been downtown for more than a century gave way.</p>
<p>During the morning hours of Wednesday much of the removal of debris was being done by hand, Fallaw said it would have been &ldquo;too tedious&rdquo; to try and use heavier equipment. Before lunchtime though, the heavy equipment was back in use bringing down small chunks of the exterior wall that had made the front fa&#231;ade of the Main Oak Building.</p>
<p>Engineers are coming to inspect the site &ldquo;once it is safe for them to go in&rdquo; he said. The building&rsquo;s integrity needs to be ensured before a more thorough inspection of the inside can be done. From there the determination will be made as to what can be salvaged and what cannot.</p>
<p>Care is being given to protect and preserve the buildings adjoining the Main Oak Building. He said the crews had done an excellent job overnight of preventing any further collapse but that additional barriers were being brought in to protect the public as roads reopen.</p>
<p>Some evacuations occurred Tuesday as the situation was developing out of an abundance of caution. &ldquo;Everything on this block is considered one building,&rdquo; he said, so the movement of the Main Oak Building could have affected other structures around it.</p>
<p>Steel beams connect the impacted building to its neighbors, so any movement of one means the rest will need to be looked at as well. To that end Moore and Associates Engineering Firm and Sasser Restoration Company along with city officials made their assessment before any demolition began.</p>
<p>&ldquo;If the building collapses, it very well could pull the other buildings apart or cause collapse on the other buildings so what we did is evacuate this whole block,&rdquo; Fallaw said.</p>
<p>Captain L. T. Whitaker with the Mount Airy Police Department said Wednesday morning that while the investigation is ongoing, there is no foul play suspected at this time. He said that city engineers and planning staff are &ldquo;working long hours&rdquo; to try and get the situation resolved.</p>
<p>The building was vacant at the time and there were no injuries in the incident.</p>
<p>Tim West of Clemmons made the drive up to Mount Airy Wednesday morning after seeing news coverage of the event last night. Like many residents of this area, he considers himself to be &ldquo;more than a bit of a history buff. When these old buildings go, sometimes that&rsquo;s it &#8211; ya know? I hope they can save as much as possible.&rdquo;</p>
<p>The saga of the Main Oak Building collapse started with little fanfare &#8211; a few bricks gave way and fell onto the roadway. Surry County Emergency Management Director Eric Southern reported that the fire department got the call at 4:26 a.m. Tuesday. Emergency personnel received a report of bricks falling from the building located at 248 N. Main Street.</p>
<p>Fallaw said first responders on scene heard &ldquo;weird noises, creaking, and cracking.&rdquo; These noises were just the initial warning signs of what was soon to follow.</p>
<p>The marshal explained, &ldquo;While emergency personnel were on scene the building experienced a partial collapse involving the roof and Oak Street side of the structure. Emergency personnel on scene quickly established a safety perimeter involving multiple businesses and streets in downtown.&rdquo;</p>
<p>Grant Welch of Mount Airy was downtown around 3 a.m. and did not see or hear a thing. When he heard emergency crews descending on downtown, he found his way over to the Mount Airy Museum of Regional History where he saw emergency services were on the scene.</p>
<p>Crews worked Tuesday evening to tear down part of the Main Oak Building which had partially collapsed in the morning hours assisted by D.H. Griffin.</p>
<p>D.H. Griffin Wrecking Company know a little something about demolition and they have a resume to back up any such claims. They arrived on scene Tuesday to tear down the facade of the building, in order to reopen streets and sidewalks as quickly as possible.</p>
<p>Storms that rolled through the area last night slowed down the process and no doubt introduced hundreds of gallons of water to freshly exposed surfaces.</p>
<p>Greg Bell, CEO of Grand Resorts, LLC, who is keeping animals at the Grand Pup Resort Hotel and Spa, said he was keeping abreast of the situation outside his business. Having staff on site 24 hours a day is part of the appeal for those boarding their pets with Bell.</p>
<p>Regular updates from the authorities have helped him be able to make the right decisions for the furry friends under his care. &ldquo;We have taken all precautions and all the hotel guests are safe. We are very thankful; this could have been a lot worse.&rdquo;</p>
<p>The timing of the overnight collapse of the building was fortunate, just twelve hours earlier could have yielded a vastly different result. As Tia Goins simply put it, &ldquo;So thankful no one was injured, and this did not happen during the parade yesterday.&rdquo;</p>
<p>&ldquo;Friends, we are shocked and saddened by the partial collapse of the pivotal and historic Main Oak Building,&rdquo; Mount Airy Downtown Inc. said in a statement Tuesday morning.</p>
<p>Lizzie Morrison, the Main Street coordinator for Mount Airy Downtown Inc. said, &ldquo;We are relieved to know there were no injuries reported and no loss of life occurred with the partial collapse of the Main Oak Building. We feel so fortunate that everyone is okay. At the same time, we are saddened by the sudden partial loss of a pivotal historic building in the Mount Airy National Register Historic District.&rdquo;</p>
<p>The Main Oak Building was built between 1905 and 1910 as the Midkiff Hardware Store, and Morrison referred to it as, &ldquo;An invaluable and irreplaceable part of our history here in Mount Airy. The community and visitors alike will be mourning a monumental loss if the front facade cannot be saved.&rdquo;</p>
<p>There were dozens of people on Main Street standing in small groups and looking at the building Tuesday morning as crews from Mount Airy Fire and the city were examining the building.</p>
<p>After the rain had passed Tuesday night, word spread that the demolition was resuming, and a new crowd formed. Television and movies have given a false impression of demolition as being massive implosions of old casinos, massive grain silos falling in unison just where they were meant to, or the basic image of a wrecking ball slamming into a building.</p>
<p>Instead, the crowd was treated to a modern ballet featuring multi-ton demolition equipment. Finesse and precision were the name of the game as the huge mouth-like bucket would scrape a dozen or so bricks from the top of the building sending them careening down the facade before crashing into the awning in a plume of dust.</p>
<p>The crowd spoke quietly to one another, as though watching golf and not a demolition. There remains a reverence for the past here in Surry County, and there was pain in the faces of some assembled on Main Street as another chunk of history fell to the ground with a distinctive and somewhat sickening &lsquo;clunk.&rsquo;</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/111333/candidate-list-grows-for-municipal-elections" title="Candidate list grows for municipal elections" style="color:black">Candidate list grows for municipal elections</a></h1>
   <p class="entry-meta">July 06, 2022</p>
   <p>DOBSON &mdash; This is a holiday week, but the democratic process is still moving along with the list of candidates for elected offices in local municipalities continuing to grow.</p>
<p>After a one-day break for Independence Day, the filing period resumed the next day for positions in Dobson, Pilot Mountain and Elkin, which are all non-partisan.</p>
<p>Tuesday&rsquo;s activity included Donna M. Kiger, a member of the Pilot Mountain Board of Commissioners, tossing her hat into the ring seeking re-election to a second term.</p>
<p>Kiger, 59, a resident of East Main Street, has long been interested in economic revitalization of Pilot Mountain&rsquo;s downtown area, among other betterment projects. Her background includes working as a Realtor.</p>
<p>She joined the only other incumbent Pilot Mountain commissioner whose seat is affected by the 2022 election process, Scott Needham, in seeking re-election. Needham filed for a second term Friday at the start of the candidate filing period, which ends at noon on July 15 at the Surry County Board of Elections office in Dobson.</p>
<p>The only other incumbent Pilot Mountain official whose seat is up for grabs this year, Evan Cockerham, also filed for re-election Friday.</p>
<p>Municipal offices in Surry County carry four-year terms.</p>
<p>So far, the only person filing for the Dobson election is Mayor Ricky Draughn, who did so Friday in seeking his sixth term.</p>
<p>Town commissioner seats now held by J. Wayne Atkins and John Lawson also are up for grabs this year in the county seat.</p>
<p>As of Wednesday afternoon, no one had filed for those slots, nor for three on the Elkin Board of Commissioners which are affected by the 2022 election process. Jeffrey Eidson, Cicely McCulloch and William Gwyn are the incumbents there.</p>
<p>The outcomes of municipal races will be decided in the general election on Nov. 8.</p>
<p><strong>Soil, conservation candidates</strong></p>
<p>While there is more than a week to go in the candidate filing period for Dobson, Pilot Mountain and Elkin, that for non-partisan Surry Soil and Water Conservation District supervisors has ended.</p>
<p>Incumbents Chad Keith Chilton of Ararat and Bradley Boyd of Mount Airy both filed along with Joe Zalescik, a member of the Mount Airy Board of Commissioners who lost his seat in a May 17 city primary and will step down from it later this year.</p>
<p>The three did so early in the filing period, which closed last Friday with no one else having come forward.</p>
<p>Soil and water conservation districts are set up in North Carolina counties to provide local direction for voluntary, incentive-based conservation programs to help landowners protect and conserve the state&rsquo;s natural resources. These include soil, water, wildlife, unique plant and animal habitats and others.</p>
<p>Surry has three soil and water supervisors in all, with the third, Glenn Pruitt, not up for re-election until 2024.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/111292/piano-students-perform-in-pilot-mountain" title="Piano students perform in Pilot Mountain" style="color:black">Piano students perform in Pilot Mountain</a></h1>

            <a href="https://www.mtairynews.com/news/111292/piano-students-perform-in-pilot-mountain" title="Piano students perform in Pilot Mountain">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/07/128664527_web1_received_1034274480563064.jpeg" alt="Piano students perform in Pilot Mountain">
            </a>
   <p class="entry-meta">July 06, 2022</p>
   <p>R. Wilson Smith, a piano teacher in Pilot Mountain, recently presented his students in an in-person recital at the First Presbyterian Church in Pilot Mountain. This was his first in person recital since 2019.</p>
<p>Besides his students, featured performers included his niece, Carrie Elizabeth Collins, also one of his former students; and his sister, Sherri S. Collins, retired as music specialist in the Surry County School System. She is the music director/keyboardist at First Presbyterian.</p>
<p>The recital opened with a meditation on the spiritual connections to music of various composers presented by Smith&rsquo;s brother-in-law, Paul S. Collins. He ended his presentation by leading the audience in a reading of the Psalm 150.</p>
<p>Students, who performed in a variety of solos and duets included: Harrison Jessup, who also played a duet with his mother, Maria Jessup; Joe Hauser, also performing a duet with his mother, Marie Hauser; Whitleigh McGee, who also performed in a duet with her mother, Jessie McGee; Nolan Key, Billy Pell, Alyssa Johnson.</p>
<p>Alyssa Johnson, as a graduating senior in the 2022 Class of East Surry High School, received a spray of roses and a gift from Smith.</p>
<p>Smith performed, lighting the memorial candelabra, honoring the memories of his parents Roland and Foy Cook Smith; his former teachers, Wilma Swanson and Dr. Kathryn Eskey (organ) of the School of Music, UNC-G. He lighted a special candle honoring his sister Sherri Collins for her talents and continuing inspiration. Collins and daughter Carrie sang a duet, &ldquo;Spring Wind,&rdquo; in a special performance.</p>
<p>A featured performer was a former student of both Collins and Smith, Jacob Smith, who performed his own piano composition &ldquo;Dance With Death.&rdquo; Jacob is a composition and musical technology major at Virgina Tech..</p>
<p>&ldquo;I would like to mention finally our sadness at the passing of Mr. Dean Palmer, who regularly covered and reported on our recitals before COVID,&rdquo; Smith said in reporting on his recital. &ldquo;He always asked me what were my final thoughts on our recitals I should say for this one: I was pleased with the work of all students, glad finally to be able to do a live recital. I would like to express my deepest appreciation for all of Dean&rsquo;s wonderful work, not only for his reporting of our recitals, his publicity on the Joyce Collins Music Camp/ Vacation Bible School at First Presbyterian Church; but for everything he meant to us in the community.&rdquo;</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/111278/three-concerts-on-tap-this-weekend" title="Three concerts on tap this weekend" style="color:black">Three concerts on tap this weekend</a></h1>

            <a href="https://www.mtairynews.com/news/111278/three-concerts-on-tap-this-weekend" title="Three concerts on tap this weekend">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/07/128664541_web1_jimquickcoastline22063.jpg" alt="Three concerts on tap this weekend">
            </a>
   <p class="entry-meta">July 05, 2022</p>
   <p>Jim Quick and Coastline return to the Blackmon Amphitheatre on Thursday followed by North Tower Band on Friday and The Extraordinaires on Saturday. All three bands are set to play at 7:30 p.m. each day.</p>
<p>Pulling from the threads of soul, blues, R&#038;B, and Americana, Jim Quick and Coastline weave together their own genre of music known as Swamp Soul. Delivered with precision by frontman Jim Quick and his band, this group captures the true, honest spirit of traditions born and bred in the small southern towns of America.</p>
<p>North Tower has been one of the South&rsquo;s party bands for more tha 35 years, providingTop 40, beach, funk, and oldies. Sizzling brass, super vocals, and a wide-ranging repertoire all contribute to making a night to remember.</p>
<p>The Extraordinaires are an interactive party band playing dance music from the &lsquo;70s, &lsquo;80s, and &lsquo;90s including Motown, rock, R&#038;B, beach, and Top 40. With four live horns, The Extraordinaires have the unique ability to bring the party atmosphere to any event.</p>
<p>Admission to each show is $15 or a Surry Arts Council Annual Pass. Children 12 and younger are admitted free with an adult admission or Annual Pass. The Dairy Center, Whit&rsquo;s Custard, and Thirsty Souls Community Brewing will be at the concerts to provide food, snacks, drinks, beer, and wine for purchase. No outside alcohol or coolers are allowed to be brought into the Amphitheatre area. Those attending are asked to bring a lounge chair or blanket to sit on.</p>
<p>Tickets are available online at www.surryarts.org, via phone at 336-786-7998, or at the Surry Arts Council office at 218 Rockford Street. For additional information, contact Marianna Juliana at 336-786-7998 or marianna@surryarts.org</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/111263/main-oak-building-collapses" title="Historic Main Oak Building collapses" style="color:black">Historic Main Oak Building collapses</a></h1>

            <a href="https://www.mtairynews.com/news/111263/main-oak-building-collapses" title="Historic Main Oak Building collapses">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/07/128670835_web1_DelicateTouch-382x509.jpg" alt="Historic Main Oak Building collapses">
            </a>
   <p class="entry-meta">July 05, 2022</p>
   <p>On Wednesday morning Fire Marshal Chris Fallaw said that work on the Main Oak Building site had resumed for the day.</p>
<p>Much of the work on removal of debris at the moment is being done by hand, Fallaw said it would be &ldquo;too tedious&rdquo; to try and use heavier equipment. Care is being given to protect and preserve the buildings adjoining the Main Oak Building.</p>
<p>Main Street from Marion&rsquo;s Jewelry to the Post Office has now reopened. Some businesses closer to the site like Olde Mill Music need to remain closed while they are inspected further.</p>
<p>Main Street remains closed from the Mount Airy Museum of Regional History/Oak Streeet to Moore Avenue.</p>
<p>Engineers are coming to inspect the site &ldquo;once it is safe for them to go in&rdquo; Fallaw said. The building&rsquo;s integrity needs to be ensured before a more thorough inspection of the inside can be done.</p>
<p>Captain L. T. Whitaker with the Mount Airy Police Department said Wednesday morning that while the investigation is ongoing, there is no foul play suspected at this time.</p>
<p>More updates will follow here and in Thursday&rsquo;s Mount Airy News print edition.</p>
<p>&#8211;</p>
<p>Crews are working this evening to tear down part of the Main Oak Building which partially collapsed in the early morning hours Tuesday. Main Street and the surrounding area will likely remain closed until at least noon Wednesday as crews continue working.</p>
<p>The Mount Airy Fire Department posted on its Facebook page Tuesday evening that D.H. Griffin Wrecking Company was on the scene to tear down the facade of the building, so that it would be safe to reopen streets and sidewalks there. However, storms passing through the area have created delays as crews wait out the rain.</p>
<p>Traffic has been diverted onto side streets and several sections of sidewalk along have been cordoned off since the collapse, which occurred shortly before dawn Tuesday.</p>
<p>The building was vacant at the time and there were no injuries in the incident.</p>
<p>Surry County Emergency Management Director Eric Southern reported that the Mount Airy Fire Department rolled on the call at 4:26 a.m. Tuesday. Emergency personnel received a report of bricks falling from the building located at 248 N. Main Street.</p>
<p>Mount Airy Fire Marshal Chris Fallaw said first responders on scene heard &ldquo;weird noises, creaking, and cracking.&rdquo; These noises were only the pronouncements of what was soon to follow.</p>
<p>&ldquo;While emergency personnel were on scene the building experienced a partial collapse involving the roof and Oak Street side of the structure. Emergency personnel on scene quickly established a safety perimeter involving multiple businesses and streets in downtown,&rdquo; he said.</p>
<p>Surry County Building Inspections and Mount Airy Code Enforcement were called to the scene to assist with scene evaluation. Southern said a drone was requested from emergency management to get some aerial footage for inspectors.</p>
<p>As Fallaw pointed out Tuesday afternoon, even though space is seen between the Main Oak Building and the Oak-Emporium building, &ldquo;Everything on this block is considered one building.&rdquo;</p>
<p>Steel beams connect the impacted building to its neighbors, so any movement of one means the rest will need to be looked at as well. To that end Moore and Associates Engineering Firm and Sasser Restoration Company along with city officials assessed the building to develop an action plan.</p>
<p>That plan, as of 2 p.m. Tuesday, was:</p>
<ul>
<li>Temporary construction fencing put in place for a more secure perimeter</li>
<li>Remove power, gas and other utilities from affected buildings</li>
<li>Remove traffic signals and streetlights poles to allow for mitigation</li>
<li>Bring in heavy duty demolition crew for incident stabilization</li>
<li>Bring front free-standing facade down to a safe level</li>
<li>Shore up remaining structure for safety and mitigation from further collapse</li>
</ul>
<p>The timing of the overnight collapse of the building was fortuitous, just twelve hours earlier could have yielded a vastly different result. As Tia Goins simply put it, &ldquo;So thankful no one was injured, and this did not happen during the parade yesterday.&rdquo;</p>
<p>&ldquo;Friends, we are shocked and saddened by the partial collapse of the pivotal and historic Main Oak Building. Please stay away from the corner of Oak St. and Main St. today as the area is secured. Thank you for your understanding,&rdquo; Mount Airy Downtown Inc. said in a statement Tuesday morning.</p>
<p>Lizzie Morrison is the Main Street coordinator for Mount Airy Downtown Inc. and found herself out of the area Tuesday when word of the collapse first broke. She said, &ldquo;We are relieved to know there were no injuries reported and no loss of life occurred with the partial collapse of the Main Oak Building. We feel so fortunate that everyone is okay. At the same time, we are saddened by the sudden partial loss of a pivotal historic building in the Mount Airy National Register Historic District.&rdquo;</p>
<p>&ldquo;The Main Oak Building was built between 1905 and 1910 as the Midkiff Hardware Store,&rdquo; she continued. &ldquo;It is an invaluable and irreplaceable part of our history here in Mount Airy. The community and visitors alike will be mourning a monumental loss if the front facade cannot be saved. Preservation of our historic structures is of utmost importance to retaining the character, charm, and history of Mount Airy.&rdquo;</p>
<p>The three-story structure, at the corner of Main and Oak Streets had changed hands last year, when long-time owner Burke Robertson sold the building to a Durham business known as Mt. Airy Once, LLC. At the time of the sale, Robertson said the new owners were planning to convert at least parts of the building into an AirBnB, supplying short-term rentals to tourists in town.</p>
<p>Two buildings next to one another that contain nearly 50,000 square feet between them were involved in the sale that took place in August. The Main Oak Building at the corner of North Main and East Oak streets is the building with the collapse in question today. At the corner of Oak and City Hall streets is Main Oak Emporium building that houses The Loaded Goat.</p>
<p>Construction crews had been working on the Main-Oak building in recent days.</p>
<p>There were dozens of people on Main Street standing in small groups and looking at the building Tuesday morning as crews from Mount Airy Fire and the city were examining the building. A crew was seen examining the building&rsquo;s exterior in the alleyway between the Main Oak Building and the building that homes The Loaded Goat; there was no damage visible to the latter structure.</p>
<p>Grant Welch was downtown early this morning, as is often the case, and he said at 3 a.m. it was all quiet on the Mayberry front. He said he heard nothing of the building collapse and only knew something was amiss upon hearing emergency scanner traffic. By the time he arrived at the building to take a look, fire engines &ldquo;were all over the place.&rdquo; He did not attempt to gain access to the scene saying it is best to allow emergency professionals space to operate.</p>
<p>Use caution when travelling around this site in downtown Mount Airy whether by car or on foot.</p>
<p>More information will be published as it becomes available.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/111260/thursday-council-meeting-cancelled" title="Thursday council meeting cancelled" style="color:black">Thursday council meeting cancelled</a></h1>
   <p class="entry-meta">July 04, 2022</p>
   <p>Normally, a meeting of the Mount Airy Board of Commissioners would be held on Thursday of this week, but it has been scrapped.</p>
<p>The commissioners decided last month to cancel that session due to its proximity to the July 4 holiday on Monday.</p>
<p>Cancellations of council meetings falling during the Fourth of July week have been a regular occurrence in Mount Airy, which acknowledges the fact that some people are out of town for the holiday period and unable to attend.</p>
<p>The Mount Airy of Commissioners regularly convenes on the first and third Thursdays of each month. The first meeting typically is held early in the day, at 2 p.m., and the third-Thursday session at 6 p.m.</p>
<p>City officials are next scheduled to meet on July 21.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/111323/annexation-rezoning-paves-way-for-development" title="Annexation/rezoning paves way for development" style="color:black">Annexation/rezoning paves way for development</a></h1>
   <p class="entry-meta">July 04, 2022</p>
   <p>A site near U.S. 601 in Mount Airy is now primed for business development after recent action by city officials.</p>
<p>The annexation and rezoning of property in the 1400 block of Edgewood Drive, located just off Rockford Street (U.S. 601), was among recent action taken by the Mount Airy Board of Commissioners before beginning what might be described as a &ldquo;summer recess.&rdquo;</p>
<p>Another move involved voting to sell two tracts of municipal-owned land to the same buyer.</p>
<p>The annexation and rezoning issue involves a two-parcel, 1.48-acre tract owned by Bill Juno, situated behind other property he has in the area where a Subway sandwich shop is located, not far from Walmart. Juno is the longtime owner of multiple Subways in Mount Airy.</p>
<p>At last check, the property owner, who voluntarily requested the annexation and rezoning of the Edgewood Drive section &mdash; through an entity known as Rockford Street, LLC, of which Juno is the principal &mdash; said he had no plans for developing the site.</p>
<p>But the commissioners&rsquo; action in June &mdash; when they also cancelled a meeting scheduled this Thursday, meaning they will go for more than a month without gathering again, until July 21 &mdash; paves the way for that in the bustling commercial vicinity involved.</p>
<p>It occurred after no one voiced opposition to the changes sought by Juno during a required public hearing.</p>
<p>The property had been zoned RL, a Surry County classification that stands for Residential Limited, and was approved by city officials for B-4, or Highway Business, zoning. It is now vacant, with single-family dwellings formerly existing at the site until recently being demolished.</p>
<p>Mount Airy&rsquo;s B-4 districts typically are located on major thoroughfares and collector streets, according to city government planning documents.</p>
<p>The area rezoned conforms to a high-intensity designation that applies to both residential and a wide variety of retail, service, office, institutional and civic uses along major arteries, documents state.</p>
<p>Annexation, meanwhile, aids the obtaining of municipal services such as water and sewer as a result of property being taken into the municipality.</p>
<p>The parcel on Edgewood Drive has direct access to public water and sewer lines would have to be extended by the developer about 175 feet down that road to serve the property.</p>
<p>In late May, The Mount Airy Planning Board, an advisory group to the commissioners on annexation/zoning matters, voted 7-0 in favor of both.</p>
<p><strong>Dual property purchase</strong></p>
<p>Also, at their last meeting before adjourning for five weeks, the commissioners voted to sell two parcels of city-owned property located in different parts of town to the same buyer.</p>
<p>Joshua Blake Aleva had sent letters to City Hall offering to buy a tract of about 0.72 acres on Circle Drive for $2,000 and one of around 0.75 acres at the corner of Lyn Avenue and Westlake Drive for $4,200.</p>
<p>When first discussing those offers during a meeting on May 19, Mount Airy officials opted to launch an upset bid process for the two &mdash; which has been the case with previous proposals to buy municipal property.</p>
<p>&ldquo;These are good offers,&rdquo; City Attorney Hugh Campbell said then, while also acknowledging that better ones could be achieved through the procedure in which property eyed for sale is advertised to the public to possibly produce a higher, or upset price.</p>
<p>The person originating the offer may then top that by a certain percentage and so on, until bid activity is exhausted.</p>
<p>No upset bids were received for either site, leading to the board&rsquo;s vote to sell both to Aleva, whose address was not available.</p>
<p>While agreeing the municipality has identified no public purposes for the tracts, some concern had arisen among city officials in May about the fact the Circle Drive property is located near the Ararat River Greenway. It is listed as a lot left over from what is described as the Grave Heights Development, which Aleva is eyeing for some type of unspecified development.</p>
<p>After discussion, the commissioners agreed that selling the property would not restrict any needed access to the trail by municipal personnel.</p>
<p>&ldquo;We wouldn&rsquo;t be selling the greenway,&rdquo; City Manager Stan Farmer assured.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/111268/protesting-conditions-inside-county-jail" title="Protesting conditions inside county jail" style="color:black">Protesting conditions inside county jail</a></h1>

            <a href="https://www.mtairynews.com/news/111268/protesting-conditions-inside-county-jail" title="Protesting conditions inside county jail">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/07/128548187_web1_across-street2.jpg" alt="Protesting conditions inside county jail">
            </a>
   <p class="entry-meta">July 04, 2022</p>
   <p>Clara Renfro drove eleven hours to get to Surry County on May 25 and she, along with other members of her family, are planning their next visit already. They are not interested in seeing the sights of Mayberry or hiking Pilot Mountain State Park, in fact their visit could not be any further from one of pleasure.</p>
<p>They are planning to protest again outside of the Surry County Detention Center regarding conditions of overcrowding, food safety, and sanitation. In late May they took to Main Street in Dobson with handwritten signs calling for better food and medical care for every inmate inside the jail.</p>
<p>Inside is someone they love, someone currently in the care of Sheriff Steve Hiatt and staff in the Surry County jail. Marquis Hatcher is waiting for court appearances on several charges, he is presumed innocent until proven guilty. During the family&rsquo;s protest his mother Christina Flippen was able to have a phone conversation with him on speakerphone about real time conditions.</p>
<p>Renfro, Flippen, and friends were in Dobson in May for a scheduled court appearance that never happened. Renfro is Hatcher&rsquo;s grandmother and said they had driven all this way in part to meet his new attorney Brandon York and were not able to do so. A call to York for comment was not returned.</p>
<p>Renfro said outside the courthouse in Dobson in May, &ldquo;I have a serious illness. I don&rsquo;t know how much longer I am going to be here.&rdquo; So, when her grandson did not appear, they asked if they may be able to see him and after several denials were told that due to COVID-19 they may not. &ldquo;Let&rsquo;s stop using COVID as an excuse for everything,&rdquo; a frustrated Renfro said as the protestors waved signs at the passing cars.</p>
<p>Interviews with former inmates show some similarity in the types of complaints, the most common was overcrowding. The jail is not meant to hold as many inmates as it does which is a problem the county and the Sheriff are well aware.</p>
<p>Captain Scott Hudson reported Friday the headcount inside the jail was 189; six inmates were being held out of county. The current detention center capacity is 125 &#8211; the new facility to be opened next year is designed to hold up to 360 inmates.</p>
<p>The solution for many issues at the jail, Commissioner Mark Marion said last month, was the construction of a new detention center. Many of the complaints on crowding and the physical state of the building will be addressed by the very virtue of opening the doors of the new facility.</p>
<p>Also, it will improve the ability to hire and retain detention, as the commissioners were told by detention center staff during the budgetary planning process.</p>
<p>Former inmate Billie Campbell said of the high number of people inside the jail, &ldquo;You&rsquo;re lucky to even get a cell. Last May when I was there, I recall 16-18 girls in one block. There only supposed to house 8 per block.&rdquo; She recounted a story of sleeping on a mat in the visitation room in her own waste while detoxing.</p>
<p>Of the men&rsquo;s facility John Gross added, &ldquo;It was very overcrowded; they would have 11 to 12 people in an 8-man cell.&rdquo;</p>
<p>Facilities complaints were made in interviews with the former inmates and current ones. Mold and mildew have been reported in the showers and on surfaces around the jail. Hatcher in his phone conversation with his mother in May said he was seeing black mold everywhere.</p>
<p>&ldquo;The black mold was covering the ceiling. Any time after I had left there, I was always sick in my lungs. I know this has to be an issue with the black mold being there. All the jail would ever do is just paint over it,&rdquo; Campbell said of her stay.</p>
<p>Renfro mentioned that the detention center has had two deaths this year already of inmates; she wonders if there may be a correlation between respiratory illness and mold. &ldquo;What about people with asthma, people with breathing issues, their own employees? What are you going to do about that?&rdquo;</p>
<p>In May, Timothy Norris Cox was pronounced dead after suffering a medical emergency. This followed the death of inmate Ashley Michelle Hicks was also found in a medical emergency in February.</p>
<p>Over the phone, Hatcher told his family of food that was molding or fruit that was beginning to rot. Renfro asked a simple question, &ldquo;Who is inspecting the food, and would they serve this food to their own family? We need state health inspectors to inspect the jail and we need food/kitchen inspection from state inspectors.&rdquo;</p>
<p>Hatcher said in May to his family, &ldquo;They are treating us wrong in here. They are not giving us cleaning supplies; they won&rsquo;t let us visit our families. Our blocks are overpopulated with people sleeping on the floor. There is mold and mildew all over the showers, I see black mold all over here.&rdquo;</p>
<p>&ldquo;Our food has been sitting out there for an hour and forty-five minutes, they won&rsquo;t feed us because they are mad that my family is downstairs,&rdquo; he explained the situation as he believed it. Other inmates could be heard calling out issues they wanted addressed inside like bedding, cleaning supplies, and problems making calls out of the jail. The meal was delivered to his part of the jail shortly after the phone call ended, he told his family.</p>
<p>Conditions like overcrowding Renfro knows have been an issue at the jail, and she has dealt with similar problems here in years past. How there continues to be problems of the same nature confuses her, &ldquo;Where is all the money going?&rdquo; she asked rhetorically but received an answer from fellow protester Mark Hatcher: &ldquo;Over there,&rdquo; he said gesturing to the location of the new jail.</p>
<p>&ldquo;The inmates really need help, they aren&rsquo;t getting the attention they need,&rdquo; Hatcher&rsquo;s mother Flippen expressed. She knows her son has needed eczema cream for his skin condition that he is not getting.</p>
<p>Gross said of his experience with medical care, &ldquo;If you are an addict, they treat you like dirt. Don&rsquo;t care about you. They don&rsquo;t try to help you when you are coming off drugs. They put you in the hole and leave you there and check on you after a couple days.&rdquo;</p>
<p>&ldquo;We&rsquo;re out here fighting for every inmate who is in there, for all the families who are not here to be a voice for their loved ones,&rdquo; Renfro said during the protest, noting it is not just her grandson about whom she is worried. &ldquo;We are trying to be the voice for everyone; we are out here for everyone.&rdquo;</p>
<p>The US Constitution prohibits &ldquo;cruel and unusual punishments,&rdquo; which includes inhumane treatment and conditions while confined. If an inmate is experiencing treatment or conditions that they believe to be unlawful, they must first file a grievance regarding the incident or conditions.</p>
<p>Campbell explained she tried to file a grievance during her time in the jail, &ldquo;I asked for (a grievance) this last time I was in because the guard wouldn&rsquo;t give me a washcloth and I had never gotten one coming in. She said I should have said something then. I told her I was in one of the little visitation rooms; I was so out of it, honestly, I didn&rsquo;t even know where I was at. I asked for a grievance, and they would say it&rsquo;s not possible.&rdquo;</p>
<p>Flippen said she got a call just last week, &ldquo;I had an inmate named John contact me last night to tell me that Marquis was sent to the hole for complaining about cold food being given to him. No inmate who speaks up about the conditions going on in that jail should be punished or treated differently because of the truth.&rdquo; She also advised she spoke to her son Thursday and he reported the same issues with cold food ongoing this week.</p>
<p>Catie Armstrong, press assistant for the North Carolina Department of Health and Human Services informed, &ldquo;The Complaint Intake Unit in NCDHHS&rsquo; Division of Health Service Regulation is available to receive complaints about care and services provided to residents in facilities, including jails. Complaints can be filed by anyone concerned with the care of their loved one; it does not have to be by the individual in a facility.&rdquo;</p>
<p>&ldquo;We cannot comment on investigations or possible investigations. If individuals have concerns about the care being provided at a facility, including a jail, they are strongly encouraged to file a complaint.&rdquo; To reach them, the phone number for with the Complaint Intake Unit is (919) 855-4500.</p>
<p>There are expectations of basic human rights for the inmates and the protesters noted they were seeking the ethical, humane treatment of all inmates. They felt that they were advocating for those inside the jail who do not have a voice, or who feel that their attempts to have a voice have been silenced. Protesters expressed concerns that grievances do not reach those higher in command at the jail, or as Campbell said, may not be allowed to be filed in the first place.</p>
<p>Lt. Randy Jenkins oversees the Surry County Jail and spoke to Hatcher&rsquo;s family in May. They got answers to some of their questions at that time like getting the answer that it was a COVID restriction that was preventing visitation.</p>
<p>Jenkins responded to questions on the food, &ldquo;Food services are provided by a contracted vendor. Food deliveries are received daily and inspected by the food service provider. Any complaints are immediately relayed to the food service provider for resolution.&rdquo;</p>
<p>He said he was not aware of any issues with the telephones and that cleaning supplies are provided daily for the cleaning of dorms. On medical care he said their &ldquo;medical provider makes the determinations regarding medicine dispersal and needs based on their protocols.&rdquo;</p>
<p>Renfro and her family are planning a return in the coming weeks to protest outside the jail in larger numbers. They are concerned that a lack of care is being shown by the jail staff and that their efforts to shine a light in the media and through direct contact with the Sheriff&rsquo;s Office have not brought resolution.</p>
<p>&ldquo;They need to really do something about what is actually going on in Surry County jail. There is too much stuff being put under the rug and people are being treated unfairly,&rdquo; Renfro said. &ldquo;Everybody should be treated equal.&rdquo;</p>
<p>&ldquo;We got to be more concerned about people than what we are now because everyone is human, and we can&rsquo;t have favorites. We got to do people right.&rdquo;</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/111253/fourth-festivities-draw-crowds-to-city" title="Fourth festivities draw crowds to city" style="color:black">Fourth festivities draw crowds to city</a></h1>

            <a href="https://www.mtairynews.com/news/111253/fourth-festivities-draw-crowds-to-city" title="Fourth festivities draw crowds to city">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/07/128668956_web1_Fourth-this-1.jpg" alt="Fourth festivities draw crowds to city">
            </a>
   <p class="entry-meta">July 04, 2022</p>
   <p>Despite what&rsquo;s occurring elsewhere in the country, no signs of a divided nation were visible Monday when crowds descended on downtown Mount Airy for July 4 festivities including a parade and reading of the Declaration of Independence.</p>
<p>&ldquo;I think we&rsquo;re looking for something to agree on,&rdquo; local community theater actor Brack Llewellyn said of this unified spirit just before reciting the historic document that on July 4, 1776 launched America&rsquo;s path to freedom.</p>
<p>The presentation of the Declaration of Independence by Llewellyn is a regular occurrence during the city&rsquo;s Fourth celebration, including him dressing in period attire topped by a three-cornered hat. An estimated 160 people squeezed into the courtyard at Mount Airy Museum of Regional History to hear its groundbreaking words.</p>
<p>&ldquo;It is the beginning of the beginning,&rdquo; Llewellyn had said beforehand in discussing the Declaration&rsquo;s importance in U.S. history. &ldquo;It&rsquo;s one of the fundamental documents of our nation.&rdquo;</p>
<p><strong>Parade participation plentiful</strong></p>
<p>Shortly after Llewellyn&rsquo;s program, the air downtown became filled with excitement as folks lined the entirety of North Main Street for the city&rsquo;s annual Independence Day Parade. Many waved flags or wore red, white and blue attire, the steady stream of their collective colors creating a river of patriotism that flowed through the entire area.</p>
<p>Nearly every choice vantage spot was taken by those awaiting the procession that left Veterans Memorial Park around 11 a.m. and meandered toward the central business district.</p>
<p>The parade showcased floats with patriotic themes featuring ones manned by local veterans organizations along with businesses, military-type transports including a convoy of jeeps, motorcycles, a large contingent of public safety vehicles from fire departments and other units and more.</p>
<p>&ldquo;Oh, it&rsquo;s wonderful,&rdquo; Jennie Lowry of the Downtown Business Association, which organizes the parade, said when surveying the large assemblage greeting its arrival.</p>
<p>Beforehand, the playing of the national anthem over a loudspeaker heard throughout the area set the stage for the patriotic occasion, as parade attendees stood solemnly with hands on chests and many sang along.</p>
<p>&ldquo;To watch all these people stand up and sing the national anthem was a nice touch,&rdquo; Lowry said. &ldquo;It was great to see all the folks do that.&rdquo;</p>
<p>Members of a family with long local roots, the Allens, served in a grand marshal role for the parade, which coincides with the family&rsquo;s annual reunion during the Fourth of July period.</p>
<p>The Allens have participated in the parade for many years as part of the reunion, and recently lost one of their members, Thelma Allen, who was associated with a downtown business, Mount Airy Tractor Toyland.</p>
<p><strong>Declaration delights celebrants</strong></p>
<p>The tone for Monday&rsquo;s procession had been set earlier in the day at about 10 a.m., when a pre-parade crowd listened solemnly from the museum courtyard during the Declaration of Independence reading.</p>
<p>Beforehand, Llewellyn stood on a nearby sidewalk and rang a hand-held bell to draw attention to the occasion.</p>
<p>He soon was transformed into the time of the Founding Fathers.</p>
<p>&ldquo;Heed now and listen to these words from Mr. Jefferson of Virginia and others in the Congress of Philadelphia,&rdquo; Llewellyn urged during his introduction.</p>
<p>Passages rendered from the Declaration condemned the &ldquo;tyranny&rdquo; of King George III and the British monarch&rsquo;s actions in taxing the colonists without their consent, burning their towns and terrorizing the seas.</p>
<p>The list of such grievances led to the declaration part of the document which was the key to charting a course of historical proportions: We basically ain&rsquo;t going to take it no more.</p>
<p>After finishing the roughly 20-minute recital, Llewellyn informed the crowd that King George was rumored to have kept a daily journal that recorded every detail of his life. And he is said to have penned this entry on July 4, 1776: &ldquo;Nothing of importance happened today.&rdquo;</p>
<p>&ldquo;Your majesty, I beg to differ,&rdquo; Llewellyn said with a smile.</p>
<p>When asked if he was surprised by the interest showed by so many people in attending Monday&rsquo;s reading, he replied, &ldquo;as a storyteller I can tell you that people will listen when it&rsquo;s important, I think &mdash; they don&rsquo;t mind gathering and listening.&rdquo;</p>
<p>The Declaration of Independence is also significant because it was the first time the words &ldquo;United States of America&rdquo; were mentioned, Llewellyn related. The undying ideals reflected in its text are manifested by Americans coming together on occasions such as July 4 for which the Declaration of Independence is a rallying point.</p>
<p>While acknowledging that it has become an overused statement, Llewellyn said there is definitely more connecting Americans than there are things separating them.</p>
<p>&ldquo;And you&rsquo;re more likely to see it in a small town rather than urban areas,&rdquo; he said of the spirit exhibited Monday in Mount Airy.</p>
<p>At the end of the day, most people just want to have a good safe place to raise their families and make a living, according to the holiday speaker.</p>
<p>Bryon Grohman, who attended the Declaration reading with his family including four home-schooled daughters, appreciated the educational nature of the program as part of their instruction in American history.</p>
<p>When asked what sticks out the most to him about its words, Grohman did not hesitate:</p>
<p>&ldquo;I think the thoughtfulness that went into the founding of the country.&rdquo;</p>
<p>Fireworks were scheduled Monday night at Veterans Memorial Park to cap off the holiday festivities locally.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/111209/author-pastor-to-speak-at-first-presbyterian" title="Author, pastor to speak at First Presbyterian" style="color:black">Author, pastor to speak at First Presbyterian</a></h1>

            <a href="https://www.mtairynews.com/news/111209/author-pastor-to-speak-at-first-presbyterian" title="Author, pastor to speak at First Presbyterian">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/07/128660755_web1_pastor-guy3-425x509.jpg" alt="Author, pastor to speak at First Presbyterian">
            </a>
   <p class="entry-meta">July 03, 2022</p>
   <p>First Presbyterian Church of Mount Airy will be welcoming Dr. David Docusen, founder and director of The Neighborliness Center, to their church on July 17.</p>
<p>Docusen has spent the past 20 years working as an author, speaker, pastor, and professor. He lives in Winston-Salem with his wife, Dara, and four teenage children. His new book, &ldquo;Neighborliness: Love Like Jesus. Cross Dividing Lines. Transform Your Community,&rdquo; is available at www.neighborliness.com and all major retailers.</p>
<p>Over the past 20 years he planted two churches in Charlotte, wrote an Amazon best selling book, Neighborliness, and was recently a guest on Good Morning America on May 20.</p>
<p>He will be speaking at the church on July 17 at 11 a.m. The church is located at 326 South Main Street</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/111207/wayne-farms-partners-with-shepherds-house" title="Wayne Farms partners with Shepherd&#8217;s House" style="color:black">Wayne Farms partners with Shepherd&#8217;s House</a></h1>

            <a href="https://www.mtairynews.com/news/111207/wayne-farms-partners-with-shepherds-house" title="Wayne Farms partners with Shepherd&#8217;s House">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/07/128660701_web1_IMG_5962-360x509.jpeg" alt="Wayne Farms partners with Shepherd&amp;#8217;s House">
            </a>
   <p class="entry-meta">July 03, 2022</p>
   <p>DOBSON &mdash; Wayne Farms Dobson recently presented a $5,000 check to the Shepherd&rsquo;s House to help underwrite the organization&rsquo;s homeless shelter operation.</p>
<p>&ldquo;But financial support is only one aspect of community partnership for the Dobson team,&rdquo; the firm said of its donation. &ldquo;The company has also signed on with Shepherd&rsquo;s House as a resource for the agency&rsquo;s Jobs First program, offering training and plant positions to homeless adults and even providing transportation to and from the job.&rdquo;</p>
<p>&ldquo;We wanted to help Shepherd&rsquo;s House give residents the opportunity to change their situation,&rdquo; said Dobson Complex Manager Matthew Wooten. &ldquo;Providing financial support is important, but helping people find employment is even more impactful,&rdquo; said Wooten, who noted that a number of former Shepherd&rsquo;s House residents have been able to get back on their feet and leave the facility thanks to gainful employment at the Dobson complex.</p>
<p>At any given time, seven to ten shelter residents are working with Wayne Farms through the Jobs First program, and as they graduate and move on to other opportunities, Wooten stressed that new positions at Wayne Farms are always available. &ldquo;Right now we&rsquo;re paying $17-20 an hour with signing bonuses and we can have people working the day they apply.&rdquo;</p>
<p>Wayne Farms has been a long-time supporter of Shepherd&rsquo;s House, which provides basic lodging and meals for homeless individuals and families, along with an array of therapeutic, educational, life skills and health education classes and social services assistance. The 64-bed facility just completed a major renovation and expansion.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/111204/northern-honored-by-american-heart-association" title="Northern honored by American Heart Association" style="color:black">Northern honored by American Heart Association</a></h1>

            <a href="https://www.mtairynews.com/news/111204/northern-honored-by-american-heart-association" title="Northern honored by American Heart Association">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/07/128662947_web1_Get-with-the-guidelines-2022-305x509.jpg" alt="Northern honored by American Heart Association">
            </a>
   <p class="entry-meta">July 03, 2022</p>
   <p>MOUNT AIRY &mdash; In addition to Northern Regional Hospital&rsquo;s recognition as an Advanced Primary Stroke Center by The Joint Commission earlier this year, the hospital has received the American Heart Association&rsquo;s GoldPlus Get With The Guidelines &#8211; Stroke quality achievement award.</p>
<p>The award, according to the hospital, is for &ldquo;for its commitment to ensuring that stroke patients receive the most appropriate treatment according to nationally recognized, research-based guidelines, ultimately leading to more lives saved and reduced disability.&rdquo;</p>
<p>Stroke is the No. 5 cause of death and a leading cause of disability in the U.S. A stroke occurs when a blood vessel that carries oxygen and nutrients to the brain is either blocked by a clot or bursts. When that happens, part of the brain cannot get the blood and oxygen it needs, so brain cells die. Early stroke detection and treatment are key to improving survival, minimizing disability, and accelerating recovery times.</p>
<p>Get With The Guidelines puts the expertise of the American Heart Association and American Stroke Association to work for hospitals nationwide, helping ensure patient care is aligned with the latest research and evidence-based guidelines. Get With The Guidelines &#8211; Stroke is an in-hospital program for improving stroke care by promoting consistent adherence to these guidelines, which can minimize the long-term effects of a stroke and even prevent death.</p>
<p>&ldquo;Obtaining Gold Plus recognition from the American Heart &#038; American Stroke Associations reflects the outstanding stroke care patients receive at Northern Regional Hospital. Our Northern Interdisciplinary Stroke Team is activated from the moment a possible stroke is identified, throughout the hospital stay, and into the post-discharge period to assure our patients are surrounded with treatments and resources they will need to achieve a robust recovery,&rdquo; said Emily Volk, transitional care nurse at Northern and one of the leaders of the project. &ldquo;This Get With The Guidelines award recognizes the success we have experienced as we collaborate not only among Northern clinical staff, but also with valued community partners such as EMS, rehab and therapy agencies, pharmacists, and primary care providers. We are honored to consistently provide exceptional stroke care to the members of our local community.&rdquo;</p>
<p>Each year, program participants qualify for the award by demonstrating how their organization has committed to providing quality care for stroke patients. In addition to following treatment guidelines, Get With The Guidelines participants also educate patients to help them manage their health and recovery at home.</p>
<p>&ldquo;We are incredibly pleased to recognize Northern Regional Hospital for its commitment to caring for patients with stroke,&rdquo; said Steven Messe, M.D., chairperson of the Stroke System of Care Advisory Group. &ldquo;Participation in Get With The Guidelines is associated with improved patient outcomes, fewer readmissions and lower mortality rates &#8211; a win for health care systems, families, and communities.&rdquo;</p>
<p>Northern Regional Hospital also received the American Heart Association&rsquo;s Target: StrokeSM Honor Roll Elite award. To qualify for this recognition, hospitals must meet specific criteria that reduce the time between an eligible patient&rsquo;s arrival at the hospital and treatment with the clot-buster alteplase.</p>
<p>In addition, Northern Regional Hospital also received the American Heart Association&rsquo;s Target: Type 2 Diabetes Honor Roll award. Target: Type 2 Diabetes aims to ensure patients with Type 2 diabetes, who might be at higher risk for complications, receive the most up-to-date, evidence-based care when hospitalized due to stroke.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/111197/childrens-center-offers-culinary-camp" title="Children&#8217;s Center offers culinary camp" style="color:black">Children&#8217;s Center offers culinary camp</a></h1>

            <a href="https://www.mtairynews.com/news/111197/childrens-center-offers-culinary-camp" title="Children&#8217;s Center offers culinary camp">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/07/128660371_web1_apron-photo.jpg" alt="Children&amp;#8217;s Center offers culinary camp">
            </a>
   <p class="entry-meta">July 03, 2022</p>
   <p>DOBSON &#8211; The Children&rsquo;s Center of Northwest North Carolina recently partnered with Surry County Schools to launch a collaborative Summer Culinary Camp at Surry Central High School in the school system&rsquo;s new state-of-the-art culinary lab. </p>
<p>Monday, June 20 was the official kick-off date, running from 8:30 a.m. until 3 p.m. each day, through Jan. 23. Sixteen students ranging from 8 years old to 18 years old were able to take part, with funding for the camp provided by Vaya Health, Partners Health Management, and the Children&rsquo;s Center of Northwest North Carolina.</p>
<p>&ldquo;We are thankful for the collaboration and partnership with the Department of Juvenile Justice and Delinquency Prevention, Vaya Health, Partners Health Management and Surry County Schools for making this happen and giving children an opportunity to learn and explore culinary skills, &rdquo; said Robin Testerman Beeson, executive director of the children&rsquo;s center.</p>
<p>Campers learned how to prepare a variety of meals, starting from scratch. They also learned proper food safety and sanitation requirements, food preparation skills, basic knife skills, how to read a recipe, and how to use kitchen equipment and tools.</p>
<p>&ldquo;When presented with the opportunity to provide a fun learning experience to our youth, my first thought was, &lsquo;I would like something that all youth could participate and learn from regardless of their physical or academic limitations,&rsquo;&rdquo; said says Gayle Alston, N.C. Department of Juvenile Justice and Delinquency Prevention chief court counselor, District 17. &ldquo;The culinary program provides a necessary skill that can also be fun. I presented the idea to Robin Testerman&#8230;.Robin took the idea and did a perfect job of creating the vision. Our hope is that these youth learned a necessary life skill and that the program provided them with a memorable summer experience.&rdquo;</p>
<p>The camp was led by Sabrina Wilmoth, along with help from Teacher Assistant Janel Kidd and Student Teachers Joanna Arroyo and Tyler Smeltzer. The menus consisted of Mexican, American, Italian cuisines, and cupcake creativity. Upon successful completion of the Culinary Arts Camp students earned a souvenir apron, chef hat, journal, teen cookbook, and a game.</p>
<p>&ldquo;Partners Health Management is honored to support the efforts of the Children&rsquo;s Center of Northwest North Carolina in providing this unique opportunity to youth in Surry County. The Summer Culinary Camp is an innovative approach to better health that teaches teens food safety and how to prepare meals&rdquo;, said Jeff Eads, Partners regional director.</p>
<p>&ldquo;Through our initiatives focused on child and family welfare, we have learned that youth want something more meaningful than just recreational programs,&rdquo; said Donald Reuss, VP Behavioral Health and I/DD Network Operations. &ldquo;They are seeking opportunities for skill building and job training. Vaya is proud to partner with the Children&rsquo;s Center of Northwest North Carolina and DJJ District 17 to offer a culinary program that teaches valuable life skills that can be used in daily life.&rdquo;</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/111193/budbreak-proceeds-of-17000-to-aid-local-causes" title="Budbreak proceeds of $17,000 to aid local causes" style="color:black">Budbreak proceeds of $17,000 to aid local causes</a></h1>

            <a href="https://www.mtairynews.com/news/111193/budbreak-proceeds-of-17000-to-aid-local-causes" title="Budbreak proceeds of $17,000 to aid local causes">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/07/128660765_web1_Budbreak-thiss.jpg" alt="Budbreak proceeds of $17,000 to aid local causes">
            </a>
   <p class="entry-meta">July 03, 2022</p>
   <p>Budbreak is undergoing leadership changes, but the annual springtime celebration of the region&rsquo;s wine and beer industries continues to uncork thousands of dollars for local charities. </p>
<p>The latest tally of proceeds from the downtown Mount Airy event featuring various vendors &mdash; last held in early May &mdash; is $17,000, it was announced during a Rotary Club of Mount Airy meeting this week.</p>
<p>Budbreak, which marked its 12th year in 2022, is spearheaded by the club. It traditionally receives a facsimile check for total profits reaped from Budbreak ticket sales and other revenue sources, which it then distributes to various community organizations.</p>
<p>Unlike the most-flavorful of wines, Tuesday afternoon&rsquo;s occasion was bittersweet, however, with mention made of longtime Festival Director Bob Meinecke turning over the reigns to fellow Rotarian Sue Brownfield. She will now guide the Budbreak Wine and Craft Beer Festival, next scheduled for May 6, 2023.</p>
<p>&ldquo;It&rsquo;s been an incredible run,&rdquo; Meinecke said of his 12 years as top organizer for the annual, well-attended gathering. It includes around 20 wine and craft beer vendors offering tastings and sales of their wares in a closed section of North Main Street on a Saturday afternoon.</p>
<p>Live music and dancing also is a part of the event that promotes those growing industries.</p>
<p>During Meinecke&rsquo;s tenure, around $200,000 has been raised to aid the causes of local charitable groups in keeping with the official Rotary mission of community betterment under the motto &ldquo;service above self.&rdquo;</p>
<p>In addition to those organizations, members of the Mount Airy group mirror Rotary&rsquo;s international mission in supporting efforts to battle hunger, along with literacy, polio and other programs.</p>
<p>Brownfield did not have an updated list of beneficiaries for this year&rsquo;s Budbreak proceeds, but said it basically includes usual recipients such as the Shepherd&rsquo;s House homeless shelter, Salvation Army, Surry Medical Ministries free clinic, United Fund of Surry and others.</p>
<p>One new recipient for this year involves Ukrainian relief in light of Russia&rsquo;s invasion of that country, based on previous reports.</p>
<p>Meinecke indicated that he believes the management of the Budbreak Wine and Craft Beer Festival is in good hands going forward.</p>
<p>&ldquo;And I thank you all for participating, with many more years of success,&rdquo; Meinecke told fellow Rotarians.</p>
<p><strong>New group leader</strong></p>
<p>This week&rsquo;s Rotary Club of Mount Airy meeting also marked the passing of a baton in another way, with Dr. Phillip Brown being installed as the new president of the organization for the coming year.</p>
<p>This was done with the help of a visiting Rotary official, Mark Brandon from Yadkin County.</p>
<p>Brown is replacing Tonda Phillips, who served as president with particular distinction, it was mentioned during the meeting.</p>
<p>Phillips took an active role leading Rotary efforts in support of drug prevention; the Camp Raven Knob scouting facility, which included rappelling from a tower there to highlight its programs; the restoration of the historic Satterfield House; international programs on a local scale; and building its membership ranks.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/111181/pilot-mountain-tapped-for-nc-main-street-program" title="Pilot Mountain tapped for NC Main Street program" style="color:black">Pilot Mountain tapped for NC Main Street program</a></h1>
   <p class="entry-meta">July 03, 2022</p>
   <p>For several years, Pilot Mountain officials have tried to gain entry into the North Carolina Main Street program, only to be stymied at every attempt.</p>
<p>So the town decided to set up its own Main Street program, aimed at not only finding ways to make the town look better, but to attract new people, and businesses, to the town.</p>
<p>The effort worked. Pilot Mountain has seen the number of businesses on Main Street and ancillary roads grew significantly, and visitors from across the region and state travel to the town to visit those business and to take part in nearly two dozen weekend fairs and festivals it holds every year.</p>
<p>Last week, town officials learned because of its success, the aforementioned North Carolina Main Street program has now accepted Pilot Mountain into its program.</p>
<p>Operated under the state&rsquo;s Department of Commerce, the Main Street Program accepted four towns last week &mdash; in addition to Pilot Mountain, the program took in Manteo, Murphy, and Pittsboro.</p>
<p>Mayor Evan Cockerham said the program will be valuable to Pilot Mountain on several levels.</p>
<p>&rdquo;It will allow us to access new grant opportunities for downtown,&rdquo; he said. &ldquo;We can now have logistical support, design support for our work&#8230;through the Department of Commerce. Beyond that, it&rsquo;s a little bit of validation of the work we&rsquo;ve put in to revitalize our Main Street.&rdquo;</p>
<p>Pilot officials had tried on several occasions to be accepted into the state Main Street program, to no avail.</p>
<p>&ldquo;In 2017, that&rsquo;s when we decided to launch our own Main Street program at the local level&#8230;We decided if change is going to come, it&rsquo;s going to come from right here in Pilot Mountain.&rdquo;</p>
<p>That involved hiring Jenny Kindy as Main Street Coordinator and Christy Wright as events coordinator, gathering a cadre of volunteers and then going about finding ways to grow business and tourism to the town.</p>
<p>&rdquo;We&rsquo;ve had dozens more businesses open since 2017,&rdquo; he said. The number of events in the town grew from nine &mdash; dominated by Mayfest and the Pilot Mountain Hot Nights and Hot Cars cruise-in series. Now, the mayor said Pilot Mountain has 20 events taking up nearly half the year&rsquo;s weekends.</p>
<p>Not only is the town often filled during those events, but he said with the growth in business, there are an ample number of shoppers in Pilot Mountain during most weekdays, allowing businesses to survive on more than weekend traffic.</p>
<p>Cockerham said many of those coming to town are from Winston-Salem, Clemmons, Statesville, and as far away as Raleigh and the Research Triangle of the state.</p>
<p>Up to this point, the mayor said the local Main Street program has been operating on a town contribution of about $100,000, &ldquo;Which is not very much in the grand scheme of things, but our staff does a really good job,&rdquo; he said, adding they work to maximize the value of every dollar. He also credited a cast of volunteers who make the town&rsquo;s events run well, and on a break-even or slightly profitable basis.</p>
<p>He said Rep. Kyle Hall was able to secure some engineering planning funding from the General Assembly, so the town already has a streetscape plan in place. Now, he said the town can apply for grant money from the Main Street program to make that a reality.</p>
<p>&ldquo;You&rsquo;ll see improvements like wider sidewalks, decorative lighting, an overall update for downtown, more of a destination, not just for cars, but for people.&rdquo;</p>
<p>Cockerham did caution folks should not expect too much too fast. &ldquo;There&rsquo;s a lot of preparation and coordination with our business owners,&rdquo; so that work downtown won&rsquo;t interrupt their business operations. He said townsfolk might see the beginnings of that work in the next calendar year.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/111212/pilot-cruisers-get-early-start-on-fourth" title="Pilot cruisers get early start on Fourth" style="color:black">Pilot cruisers get early start on Fourth</a></h1>

            <a href="https://www.mtairynews.com/news/111212/pilot-cruisers-get-early-start-on-fourth" title="Pilot cruisers get early start on Fourth">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/07/128666309_web1_Pilot-Cruise-this-1.jpg" alt="Pilot cruisers get early start on Fourth">
            </a>
   <p class="entry-meta">July 02, 2022</p>
   <p>PILOT MOUNTAIN &mdash; There&rsquo;s something uniquely American about the car culture that fits perfectly with patriotism, along with freedom of the open road and otherwise, which appropriately was on display during the Independence Day weekend in Pilot Mountain.</p>
<p>Some of the finest examples of automotive excellence ever to come out of Detroit filled the downtown area Saturday afternoon and evening for the July edition of the Hot Nights, Hot Cars cruise-in series.</p>
<p>Conducted on the first Saturday of each month from June through October, the latest event coincided with the July 4 celebration just two days later &mdash; which seemed to give it an extra boost of horsepower from a national pride standpoint.</p>
<p>Along with shining up the sparkling chrome and paint jobs of vintage, muscle and other unique vehicles showcasing automaking history, some of those attending Saturday&rsquo;s cruise-in proudly displayed U.S. flags or donned red, white and blue attire.</p>
<p>The spirit exhibited, partly fueled by nostalgia, was hard to ignore at the gathering that has been revving up the town for nearly 20 years now.</p>
<p>&ldquo;I think it takes us back to the America I grew up in,&rdquo; said Bob Wilson of Bassett, Virginia, who was attending the Hot Nights, Hot Cars cruise-in for the first time.</p>
<p>&ldquo;I grew up around muscle cars like this,&rdquo; Wilson, who was born in the early 1950s, added while standing near a 1960s-era Ford Mustang with a glistening black paint job.</p>
<p>&ldquo;It takes you back to a kinder, gentler nation,&rdquo; he said of the aura created in the small Surry County town via the Hot Nights, Hot Cars spectacle.</p>
<p>Two other words, &ldquo;Hot Day,&rdquo; easily could have been spliced onto that equation Saturday as temperatures hovered near the 90-degree mark.</p>
<p>Yet that &mdash; and a few random raindrops &mdash; did not keep crowds from filling downtown Pilot Mountain, with every square inch of both its main drag and side streets seemingly occupied by machines with power plants measured in cubic inches.</p>
<p>Sidewalks on both sides of West Main Street were all but impassable at times, with folks strolling by to view cars parallel-parked all along the way. Others, meanwhile, sat in lawn chairs lining walls of downtown businesses watching cool rides cruise through under an open-street format &mdash; mostly bumper to bumper &mdash; accompanied by the exhilarating roar of engines.</p>
<p>Later Saturday, a beach music group, The Entertainers, was scheduled to perform from the town bandstand.</p>
<p>Another highlight was the awarding of Classic Ride of the Month honors to a participating vehicle exhibitor.</p>
<p>Each cruise-in begins at 3 p.m. and lasts until 9:30 p.m., with admission free.</p>
<p>The next one is scheduled for Aug. 6.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/111178/police-reports-590" title="Police reports" style="color:black">Police reports</a></h1>
   <p class="entry-meta">July 02, 2022</p>
   <p>&#8226; Her alleged hitting of a city officer this week has landed a local woman behind bars, according to Mount Airy Police Department reports.</p>
<p>Marissa Lynn Hensley, 52, of 129 Good News Lane, was encountered late Monday afternoon by department members investigating an intoxicated person at a residence on Taylor Street. During the course of that she struck Officer A.R. Tilley under her left eye with a closed fist, arrest records state.</p>
<p>This led to Hensley being taken into custody on a charge of assault on a government official and held in the Surry County Jail under a $5,000 secured bond. She is facing an Aug. 19 appearance in District Court.</p>
<p>&#8226; Jesse James Outlaw, 29, of 168 Key Road in Siloam, was arrested Monday afternoon at the local probation office on State Street and jailed without privilege of bond.</p>
<p>Warrants for charges of assault on a female and misdemeanor larceny had been filed against Outlaw through the Surry County Sheriff&rsquo;s Office on May 13. He was jailed without bond due to the domestic nature of the assault case and is scheduled to be in District Court on July 8.</p>
<p>&#8226; Jennifer Rose Aguilar, 33, of 1844 Westfield Road, was incarcerated without privilege of bond Monday for allegedly violating a domestic violence protective order. This occurred after Aguilar was encountered by police at that location and found to be in violation, with no other details listed.</p>
<p>She also was charged with possession of drug paraphernalia, listed as a glass smoking device with burned white residue. The case is set for the July 11 session of Surry District Court.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/111177/w-l-a-trucking-honored-by-music-center" title="W.L.A. Trucking honored by music center" style="color:black">W.L.A. Trucking honored by music center</a></h1>
   <p class="entry-meta">July 02, 2022</p>
   <p>GALAX, Va &mdash; As part of the Blue Ridge Parkway Foundation&rsquo;s 25th anniversary celebrations, the nonprofit honored seven members of its community of stewards at a ceremony on June 18, at the Blue Ridge Music Center. Among those honored was a Mount Airy business &mdash; W.L.A. Trucking.</p>
<p>The firm earned the Corporate Champion Award for the company&rsquo;s support of the music center. The business, owned by Bobby and Debbie Post, has sponsored the summer concert series since 2018, and contributes to specialprojects, including the replacement of aging speakers and other equipment in the amphitheater. Bobby Post accepted the award on behalf of the company.</p>
<p>&ldquo;Our 25th anniversary is really a celebration of the people who bring our mission to life through their contributions to the national park they love,&rdquo; said Carolyn Ward, CEO of the foundation during the ceremony. &ldquo;We are fortunate to count these honorees as members of our community of stewards.&rdquo;</p>
<p>Ian Jordan was honored with the Youth Ambassador award for his contributions to Kids in Parks, a program of the foundation. Over the past five years, Jordan has visited more than 80 of the program&rsquo;s TRACK Trail locations, and logged more than 100 miles hiking. He has become a Junior Ranger in 118 national parks and in every North Carolina State Park. He also helped Kids in Parks design, test, and implement a new smartphone-based Junior Ranger activity, creating an opportunity for children across the country to learn about the natural, historical, and cultural resources found in national parks.</p>
<p>Radio station 88.5 WFDD received the Media Partner Award for its work to spread the word about the venue&rsquo;s musical programs throughout its 29 county-listening area, including northwest North Carolina and southwest Virginia. The partnership has furthered the center&rsquo;s mission to celebrate the music and musicians of the mountains. Morning Edition host Neal Charnoff accepted the award.</p>
<p>The Yadkin Arts Council was honored with the Partnership Award. In addition to being a longtime sponsor of the summer concert series, the Yadkin Arts Council has collaborated with the music center to present the Sounds of the Mountains concert series each January when the national park venue is closed. This series is hosted by the Yadkin Arts Council at The Willingham Theater in the Yadkin Cultural Arts Center. The partnership has yielded 20 concerts showcasing bluegrass, old-time, gospel, and Americana groups. Yadkin Arts Council board president John Willingham accepted the award.</p>
<p>The musicians who volunteer their time and talents for the daily Midday Mountain Music sessions were honored with the Volunteer Service Award. What started as two musicians &mdash; Willard Gayheart and Bobby Patterson &mdash; playing tunes for Music Center visitors on Thursday afternoons, blossomed into the Midday Mountain Music sessions offered free for visitors each day. This amounts to about 800 hours of music, and as a group accounts for more than 3,000 volunteer hours during the season. Amy Boucher accepted the award for the Midday Mountain Musicians.</p>
<p>Long-time volunteer Aubrey Arrington&rsquo;s numerous contributions to the music center and Blue Ridge Parkway include providing educational programs, training new seasonal rangers, leading hikes, organizing volunteer clean-up days, performing trail and facility maintenance, and more. For his support, Arrington was honored with the Blue Ridge Music Center Champion Award.</p>
<p>The National Council for the Traditional Arts was recognized with the Visionary Award for the organization&rsquo;s work to establish the Music Center, founding the annual concert series that continues today, and opening the Roots of American Music exhibit in 2011.</p>
<p>First Citizens Bank is the premier sponsor of the Foundation&rsquo;s 25th anniversary celebrations.</p>
<p>The Blue Ridge Parkway Foundation is the nonprofit fundraising partner for the Blue Ridge Parkway. The organization provides support for initiatives along the 469-mile route, including historical and cultural preservation, environmental protection, visitor amenities, and education and outreach. The Foundation&rsquo;s work includes programming at the Blue Ridge Music Center, and the award-winning, nationwide Kids in Parks program.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/111324/parkway-bucks-trickle-surrys-way" title="Parkway bucks trickle Surry&#8217;s way" style="color:black">Parkway bucks trickle Surry&#8217;s way</a></h1>

            <a href="https://www.mtairynews.com/news/111324/parkway-bucks-trickle-surrys-way" title="Parkway bucks trickle Surry&#8217;s way">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/07/128665836_web1_Puckett-Cabin-this-340x509.jpg" alt="Parkway bucks trickle Surry&amp;#8217;s way">
            </a>
   <p class="entry-meta">July 02, 2022</p>
   <p>Contrary to popular belief, the theory of trickle-down economics actually does work when it comes to benefits Surry County is reaping from a scenic highway meandering over nearby peaks. </p>
<p>A new report from the National Park Service, which oversees the Blue Ridge Parkway, shows that in 2021, 15.9 million visitors spent an estimated $1.3 billion in local gateway regions scattered along its path.</p>
<p>Originating as a public works project of the 1930s, the Parkway&rsquo;s designed landscape was always intended to bring economic stimulation to neighboring communities.</p>
<p>That certainly includes Mount Airy and Surry County, where construction actually began on the scenic highway in 1935 at a spot near Lowgap adjacent to a key Parkway attraction, Cumberland Knob.</p>
<p>Meanwhile, Mount Airy is a 14-mile, 20-minute jaunt down the mountain from the Parkway&rsquo;s exit at U.S. 52 in Fancy Gap, Virginia, with many travelers invariably finding their way here for ample lodging, dining, retail and other opportunities.</p>
<p>&ldquo;Mount Airy and Surry County benefit as being a gateway region from the traffic on the Parkway,&rdquo; Executive Director Jessica Roberts of the Mount Airy Tourism Development Authority agreed.</p>
<p>&ldquo;And our area has been proactive to make travelers aware how close the Parkway is to our area and various attractions we offer.&rdquo;</p>
<p>The latest financial-impact figures for communities near its path emerged from a peer-reviewed visitor spending analysis conducted by economists at the National Park Service and the U.S. Geological Survey.</p>
<p>Their report shows that the estimated $1.3 billion spent in gateway regions while visitors are touring the Blue Ridge Parkway supported 17,900 jobs in those localities and had a cumulative benefit to their economies of $1.7 billion.</p>
<p>&ldquo;We have benefited from various sizes of car groups, families, couples and others who are traveling up and down the Parkway that come into our area, stay overnight and visit our downtowns,&rdquo; Roberts advised regarding Surry County as a whole.</p>
<p>&ldquo;The Blue Ridge Parkway supports economic development and recovery along the rural communities in and around America&rsquo;s most-scenic drive,&rdquo; the local tourism official added.</p>
<p>And this is an occurrence year in and year out, according to Roberts.</p>
<p>&ldquo;Travelers from near and far visit the Blue Ridge Parkway annually and impact Mount Airy, Surry County and the surrounding region.&rdquo;</p>
<p>This reflects a winning combination of outdoor recreation opportunities from hiking trails to scenic drives on the Parkway itself and the varied experiences also found in Blue Ridge Parkway communities of North Carolina and Virginia.</p>
<p>That formula has continued to attract millions of visitors each year despite the coronavirus, with the Parkway remaining a source of strength through the COVID-19 crisis.</p>
<p>&ldquo;As our country moves through the varied impacts resulting from the pandemic, we are grateful that the Parkway continues to serve as a touchstone, reconnecting people with inspiring places of deep significance, while also supporting economic resiliency and vitality for local communities moving forward,&rdquo; Parkway Superintendent Tracy Swartout said in a statement.</p>
<p>For generations, the Parkway has drawn legions of visitors &ldquo;who enjoy both the natural beauty and cultural heritage of our region, while contributing positively to the economy in our surrounding communities,&rdquo; Swartout emphasized.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/111170/flurry-of-first-day-filings-unfolds" title="Flurry of first-day filings unfolds" style="color:black">Flurry of first-day filings unfolds</a></h1>
   <p class="entry-meta">July 01, 2022</p>
   <p>DOBSON &mdash; The first day of the candidates&rsquo; filing period for an upcoming election usually prompts activity, which occurred Friday when seekers of municipal offices across the county wasted no time tossing their hats into the ring.</p>
<p>By around 3:30 p.m., three people had done so at the Surry Board of Elections Office in the county seat, with another 90 minutes to go before the close of business.</p>
<p>Nine different elected positions are at stake this year in Dobson, Pilot Mountain and Elkin, for which candidates have a two-week window to make their intentions officially known.</p>
<p><strong>Dobson mayor files</strong></p>
<p>Among the early &ldquo;customers&rdquo; at the elections office Friday was Dobson Mayor Ricky Draughn, who had announced his intentions to be there as soon as filing began at noon. The period closes at the same time on July 15.</p>
<p>Draughn, 68, of South Main Street, is seeking his sixth four-year term in Dobson, where he wants to continue progress on infrastructure improvements undertaken and basically maintain the town as a pleasant place to live and visit.</p>
<p>The main focus at present is finishing an upgrade of the municipality&rsquo;s water plant. Then Dobson officials want to upgrade its sewer capacity, given that reliable utilities are important to both businesses and residents.</p>
<p>&ldquo;I still think we have a whole lot to do,&rdquo; Draughn added, with paving projects for local streets and other improvements on tap.</p>
<p>Yet the veteran town official seems pretty satisfied with what Dobson has to offer presently in terms of services and a generally good quality of life.</p>
<p>&ldquo;And we do it all on way less money than other people do,&rdquo; Draughn said of municipal governments elsewhere.</p>
<p>It&rsquo;s not always a bed of roses, he acknowledged, mentioning as an example a recent controversy involving plans for subsidized apartments in town which some residents believed would be market-rate instead.</p>
<p>&ldquo;All some ever hear is what we need and what you&rsquo;re not doing right over here,&rdquo; the mayor said of juggling the sometimes-competing interests in a small town.</p>
<p>Yet Draughn seems to have no problem making himself readily available for citizens to contact when problems or questions arise, saying he believes this is part of one&rsquo;s role as a public servant.</p>
<p><strong>Pilot mayor running again</strong></p>
<p>Evan Cockerham, the mayor of Pilot Mountain, also announced his intentions to file for a second four-year term as Friday approached and subsequently did so that day along with Draughn.</p>
<p>&ldquo;Absolutely,&rdquo; said Cockerham, 36, a resident of Lynchburg Road who also served on the Pilot Mountain Board of Commissioners for two years before being elected mayor in 2018.</p>
<p>Similar to the outlook in Dobson, issues in Pilot are all about the basics, in Cockerham&rsquo;s view. Meeting infrastructure needs, getting the municipality&rsquo;s finances in order and pursuing economic-development opportunities are in the mix of ongoing activities.</p>
<p>One such effort occurred this week with an announcement that Pilot Mountain is joining the state Main Street Program of the N.C. Department of Commerce. This will allow the town to tap into expertise to keep its downtown area vital going forward, a movement that has been under way in Mount Airy for about a decade.</p>
<p>Among other chief goals are proceeding with an initiative involving Mount Airy supplying water to Pilot Mountain under a special agreement between the two, and the paving of all streets on the town system.</p>
<p>&ldquo;And I&rsquo;m just saying I want to stay around to be part of it,&rdquo; the incumbent mayor said. &ldquo;I just want to see all these things through.&rdquo;</p>
<p>Another Pilot Mountain office holder, Commissioner Scott Needham, also filed Friday for his second term on the town board. Needham is 36 and lives on South Depot Street.</p>
<p>The seat now held by Commissioner Donna M. Kiger additionally is part of this year&rsquo;s election process.</p>
<p>In Dobson, two town commissioner slots presently occupied by J. Wayne Atkins and John Lawson are affected in addition to the mayoral post.</p>
<p>Three board seats in Elkin now held by Jeffrey Eidson, Cicely McCulloch and William Gwyn also are involved.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/111155/city-woman-charged-in-fireworks-theft" title="City woman charged in fireworks theft" style="color:black">City woman charged in fireworks theft</a></h1>
   <p class="entry-meta">July 01, 2022</p>
   <p>A crime of a distinctly seasonal nature has occurred in Mount Airy, where a woman was charged this week with stealing fireworks worth hundreds of dollars, according to city police.</p>
<p>The theft occurred Monday in the parking lot of Forrest Oaks Shopping Center on Rockford Street. A temporary fireworks business has been set up there under a tent offering products in anticipation of the July 4 holiday, similar to others that operate in the area at this time of year.</p>
<p>Listed as stolen were a package of Phantom Awestruck Fireworks and one containing Phantom Ultimate Fireworks. The two were valued altogether at $340.</p>
<p>Through an investigation by Mount Airy police, Rusty Leigh Queen, 45, of 215 Katie Lane, soon was identified as the suspect in the case.</p>
<p>Queen was encountered at her residence later Monday and arrested on charges of larceny and possession of stolen goods. She was released on a $500 unsecured bond to appear in Surry District Court on July 11. The charges were reported by the Mount Airy Police Department Thursday.</p>
<p>The fireworks were recovered intact and returned to the business with no restitution owed, police records state.</p>
<p>Phantom Fireworks Eastern Region, LLC, based in Youngstown, Ohio, is listed as the victim of the larceny, which was reported by a local employee of Phantom Fireworks, Daniel Layne of Bray Ford Road, Dobson.</p>
<p>The company sells its products from stands in a number of states similar to the operation in Mount Airy.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/111145/young-audience-series-begins-saturday" title="Young Audience Series begins Saturday" style="color:black">Young Audience Series begins Saturday</a></h1>

            <a href="https://www.mtairynews.com/news/111145/young-audience-series-begins-saturday" title="Young Audience Series begins Saturday">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/06/128660214_web1_B-Dazzle-Productions-512x509.jpg" alt="Young Audience Series begins Saturday">
            </a>
   <p class="entry-meta">June 30, 2022</p>
   <p>The Surry Arts Council Young Audience Series will begin this weekend with a Dance Party by Blanton Youell&rsquo;s B-Dazzle Production.</p>
<p>The Dance Party will take place on Saturday at 10:30 a.m. at the Blackmon Amphitheatre andwill include music, bubbles, and lots of fun for everyone.</p>
<p>The Young Audience Series is a free interactive series of shows for children of all ages. The shows will take place at the Blackmon Amphitheatre on Saturdays at 10:30 a.m. from July 2 to August 6.</p>
<p>Upcoming shows include Saturday, July 9 &ldquo;Stories That Sing&rdquo; with Emily and Bruce Burgess, July 16 and July 23 &ldquo;Storytime with Papa Pantalone&rdquo; by Mark Donnell, July 30 Zumbini with Chrissy by Christina Kinzer, and August 6 a Dance Party with Blanton Youell.</p>
<p>Stories That Sing will provide a fun-filled, interactive morning of musical mischief hosted by the Burgess Family featuring sing-a-long books, visits from puppet characters, and an instrument petting zoo.</p>
<p>Storytime with Papa Pantalone will feature Mark Donnell&rsquo;s interactive retelling of Little Red Riding Hood and Hansel and Gretel in &ldquo;The Most Famous Adventure of Little Red Riding Hood&rdquo; and &ldquo;Hansel and Gretel, A Woodland Tale or &lsquo;How Do We Get Out of Here?&rsquo;&rdquo;</p>
<p>Zumbini with Chrissy features songs, activities, special instruments, and more, all in the name of movement.</p>
<p>For additional information, contact Marianna Juliana at 336-786-7998 or marianna@surryarts.org</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/111139/local-marine-corps-league-has-new-officers" title="Local Marine Corps League has new officers" style="color:black">Local Marine Corps League has new officers</a></h1>

            <a href="https://www.mtairynews.com/news/111139/local-marine-corps-league-has-new-officers" title="Local Marine Corps League has new officers">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/06/128652684_web1_Marines-thiss.jpg" alt="Local Marine Corps League has new officers">
            </a>
   <p class="entry-meta">June 30, 2022</p>
   <p>New leadership has been announced for a local veterans organization that plays an active role in the community.</p>
<p>The fresh slate of officers for Surry County Detachment 1322 of the Marine Corps League was elected during a recent meeting of the group.</p>
<p>They include Michael Russell, senior vice commandant; David Gigante, judge advocate; Todd Abbott, commandant; and Travis Yelton, junior vice commandant.</p>
<p>The Marine Corps League, whose motto is &ldquo;Same Team New Mission,&rdquo; is the only congressionally chartered Marine Corps-related veterans organization in the United States.</p>
<p>Its charter was approved by the 75th U.S. Congress and signed by President Franklin D. Roosevelt on Aug. 4, 1937.</p>
<p>The mission of the Marine Corps League includes promoting the interests and preserving the traditions of that branch of service; strengthening the fraternity of Marines and their families; and fostering the ideals of Americanism and patriotic volunteerism.</p>
<p>It is through that latter goal that Surry County Detachment 1322 of the Marine Corps League has most made its presence known locally by long spearheading the annual Toys for Tots campaign that helps children in need have a better Christmas.</p>
<p>In 2019, before the coronavirus brought some disruption to that effort, more than 1,300 kids were served through the distribution of 8,200-plus new unwrapped toys.</p>
<p>Even at the height of the pandemic in 2020, the local group was still able to collect or buy almost 4,900 toys.</p>
<p>Surry County Detachment 1322 also has helped spread Christmas cheer to older folks in the community, including at the Twelve Oaks assisted-living facility, and participated in Veterans Day observances.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/111138/chamber-golf-tourney-coming-up-2" title="Chamber golf tourney coming up" style="color:black">Chamber golf tourney coming up</a></h1>
   <p class="entry-meta">June 30, 2022</p>
   <p>The Greater Mount Airy Chamber of Commerce will host is 21st Annual Chairman&rsquo;s Cup Golf Tournament on Thursday July 7, noon, at Cross Creek Country Club. Player slots and sponsorships are still available for the event.</p>
<p>The chamber&rsquo;s annual golf tournament will feature a best ball/captains choice format, a shotgun start at noon, box lunches, beverages, door prizes, awards to the top players and more. Proceeds from the golf event will go to support the programs and services of the Greater Mount Airy Chamber of Commerce.</p>
<p>The Chamber wishes to thank the major event sponsors. They are:</p>
<p>&#8226; Eagle Level: Kelly Office Solutions, Wayne Farms, Surry Communications</p>
<p>&#8226; Birdie Level: Leonard Truck Accessories</p>
<p>&#8226; Gift Sponsor: Northern Regional Hospital, Chatham Nursing and Rehab</p>
<p>&#8226; Par Sponsor: Surry Community College, Hugh Chatham Memorial Hospital</p>
<p>&#8226; Beverage Cart: Coldwell Banker Advantage, Mountain Valley Hospice</p>
<p>&#8226; Photo Sponsor: Dr. John Gravitte, DDS</p>
<p>&#8226; Award Sponsors: Scenic Motors, Shelton Vineyards</p>
<p>&#8226; Beverage Sponsor: Coca Cola, Round Peak Vineyards</p>
<p>Player slots are still open but selling fast. Several event sponsor packages are open and priced to fit different budgets. Interested players or sponsors should contact Jordon Edwards, director of events at the chamber via email: jordon@mtairyncchamber.org</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/111135/roundtable-looks-at-housing-challenges" title="Roundtable looks at housing challenges" style="color:black">Roundtable looks at housing challenges</a></h1>

            <a href="https://www.mtairynews.com/news/111135/roundtable-looks-at-housing-challenges" title="Roundtable looks at housing challenges">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/06/128648059_web1_Roundtable.jpg" alt="Roundtable looks at housing challenges">
            </a>
   <p class="entry-meta">June 30, 2022</p>
   <p>At the Moore House in Mount Airy last week a group met to discuss housing challenges facing the area. Facilitated by Melissa Hiatt and the United Fund of Surry, the housing roundtable brought together stakeholders from local non-profit groups to hold a dialogue on what are the strengths and weaknesses of the community as they relate to housing.</p>
<p>Gathering a disparate set of voices that represent areas of need within the community, Hiatt said conversations on housing challenges began in earnest months ago. At their last meeting they spoke generally about what types of services were provided by non-governmental groups, as well as municipal and county organizations.</p>
<p>She said of those early talks, &ldquo;It was so broad, we didn&rsquo;t know where to go because in that conversation we started with the fact that we are having problems keeping folks in Habitat homes, then we talked about we don&rsquo;t have enough space to put domestic violence victims to hide them.&rdquo;</p>
<p>With needs that show the diverse scope and nuanced nature of housing problems &mdash; there is no one solution. In recent discussions with the economic development office, she said that housing has been a hot topic of conversation, &ldquo;top three&rdquo; among current issues that were discussed.</p>
<p>Hiatt advised the group&rsquo;s purpose was to set a road map for Todd Tucker and the team at the economic development office. In July, Tucker will meet with a housing consultant about the situation in Surry County so that a study may be conducted; notes from the housing roundtable will help guide that study.</p>
<p>Housing issues may be found across the county, &ldquo;We know we have lots of housing problems. That led me to do what you asked me to do, and I found county commissioner,&rdquo; Hiatt said referring to Commissioner Mark Marion seated across the table.</p>
<p>After the needs were better identified by the small group she can invite in the municipalities to the conversation. Until such a time as all parties could join, she was concerned only having a representative from Mount Airy or Elkin, for example, would be a disservice to the other local governments. &ldquo;We don&rsquo;t want this to be about one specific group, it needs to be a broad purview.&rdquo;</p>
<p>The group discussed areas of opportunity to determine what issues are best addressed by the member organizations of the United Fund of Surry. Not all issues would fall to non-profits; she mentioned housing at Ridgecrest as an area that would fall under the medical community sphere of influence. Her point being, &ldquo;There have to be multiple leaders on this. When we have this list of needs and priorities, we can then take off the things that are not ours and send the rest on.&rdquo;</p>
<p>Needs for the area were identified as a lack of market value housing, a homeless shelter option for men; options for domestic violence victims; public transportation; waiting lists for housing; &lsquo;screen outs&rsquo; such as having a criminal record that hinder finding housing; cost of materials for the construction of new shelters or transitional housing; and a need for more education.</p>
<p>Karl Singletary of New Hope New Beginnings repeated more than once that many in the public see issues of homelessness and substance abuse only as shortcomings in moral character. &ldquo;That&rsquo;s one of the big challenges to the community, is the education because some people are just now recognizing substance abuse as a mental illness. If you can&rsquo;t treat the mental illness and substance abuse at the same time, you are wasting your time.&rdquo;</p>
<p>The group identified among the greatest strengths of the community to be the strong involvement of a wide array of non-profit groups. Also, they cited the creation of the office of substance abuse recovery and the hiring of drug czar Mark Willis to manage its efforts. Programs such as Ride the Road to Recovery and the Prevention All Stars have received notice locally as well as from the Substance Abuse and Mental Health Services Administration.</p>
<p>One resource that Hiatt is excited to tap are the myriad of faith-based groups which have been speaking to her recently. Among their congregants are found a need for assistance, but members of the faith community have told her they need help to determine how best to help those in need. One said, &ldquo;We don&rsquo;t know how to help. Sometimes we feel we might be a hindrance.&rdquo;</p>
<p>&ldquo;They don&rsquo;t feel qualified to answer questions because they don&rsquo;t have the answers,&rdquo; she said. &ldquo;Or they worry they are keeping the cycle going&rdquo; by helping.</p>
<p>For some, there does need to be a change in mindset. &ldquo;I try to teach people it is never a handout &#8211; it is always a hand up. These folks have self-respect too and we need to help grow that. We have all been in a situation that we had to recognize we had to do better. It comes from the way someone has treated you, good or bad, or someone who has helped you that gives you that sense of pride that says, &lsquo;I can do this.&rsquo; Our hand ups are what need to do that.&rdquo;</p>
<p>&ldquo;Our avenues of hope or help are not always faith-based, some are scientific based,&rdquo; she went on to explain why some faith groups may shy away from aid. &ldquo;These groups need to hear that we give everyone the opportunity for the approach they want. I am happy they are at least asking the questions.&rdquo;</p>
<p>&ldquo;You have to save them before they can be saved,&rdquo; Commissioner Marion added in showing that there is a place for faith to enter the conversation.</p>
<p>Singletary reminded that twelve-step groups such as Alcoholics Anonymous and Narcotics Anonymous are spiritual programs, &ldquo;God is all over there. What matters is a person &mdash; a human being &mdash; with choices. Just because they may not believe does not mean that they don&rsquo;t have a right to recovery.&rdquo;</p>
<p>There is no reason to send anyone away from the table who may wish to help, so Hiatt and the housing roundtable will continue bringing in more community and faith leaders to have honest discussions. Marion said the truth may not make everyone happy, but Marlin Yoder said of the need for honest discourse, &ldquo;The truth may set us free.&rdquo;</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/111132/police-reports-589" title="Police reports" style="color:black">Police reports</a></h1>
   <p class="entry-meta">June 29, 2022</p>
   <p>&#8226; A Mount Airy woman has become the victim of a scam related to checks, according to city police reports. </p>
<p>The incident occurred last Friday, involving fraudulent checks being created by an unknown suspect in order &ldquo;to take advantage of&rdquo; Monica Jean Snelling, an incident record states. It does not elaborate on how the scam transpired or list Snelling&rsquo;s address. The crime occurred at a home on Price Street, with no monetary loss given.</p>
<p>&#8226; Bobby Durelle Robinson, 40, of 401 Hadley St., was jailed on an assault charge in the wake of a June 23 incident at the Marshall Street residence of Jeffery Lee Frost, where Robinson allegedly punched Frost in the face with a closed fist. The victim was found to have signs of the assault during a police investigation.</p>
<p>Robinson was held in the Surry County Jail under a $500 secured bond and slated for a July 11 appearance in District Court.</p>
<p>&#8226; A local auto dealership has been victimized by a crime that involved the obtaining of property by false pretense which was reported on June 22.</p>
<p>It concerned an unknown suspect using fraudulent personal information to obtain a vehicle at Simmons Nissan, identified as a 2019 Honda CR-V LX station wagon valued at $34,204. It was recovered, with the case still under investigation.</p>
<p>&#8226; An undisclosed sum of money and other property with a total value of $450 were discovered stolen at Northern Family Medicine on North Pointe Boulevard on June 18, which involved the multi-colored handbag of Kizzie Blanche Waddell of Greystone Lane being taken from a locker room.</p>
<p>The loss also included an Apple SE smartphone, gray in color; a Fitbit fitness tracker; and a Toyota Avalon car key.</p>
<p>&#8226; Angel Noel Tate, 31, of 873 Brim Road, was charged with second-degree trespassing on June 17 after being encountered by an officer at a residence on Granite Road, from which she had been banned by police in February 2020.</p>
<p>Tate was released on a $500 unsecured bond to appear in Surry District Court on July 18.</p>
<p>&#8226; Jennifer Diane Draughn, 32, of 445 Culbert St., was jailed without privilege of bond on June 17 on a warrant for an assault charge that had been filed the same day with no other details provided.</p>
<p>Draughn is facing a July 18 appearance in District Court.</p>
</article>

</div><div style="max-width:600px;" class="entry-content">
<article>
<hr />

   <h1 class="entry-title"><a href="https://www.mtairynews.com/news/111125/stokes-county-land-of-roads-rivers-and-its-own-mountain-range" title="Stokes County, land of roads, rivers, and it&#8217;s own mountain range" style="color:black">Stokes County, land of roads, rivers, and it&#8217;s own mountain range</a></h1>

            <a href="https://www.mtairynews.com/news/111125/stokes-county-land-of-roads-rivers-and-its-own-mountain-range" title="Stokes County, land of roads, rivers, and it&#8217;s own mountain range">
			                           <img src="https://s24476.pcdn.co/wp-content/uploads/2022/06/128622082_web1_HARO-waterfall-by-Jane-PC-509x509.jpg" alt="Stokes County, land of roads, rivers, and it&amp;#8217;s own mountain range">
            </a>
   <p class="entry-meta">June 29, 2022</p>
   <p><strong>Stokes County</strong></p>
<p><strong>Zipline Canopy Tour</strong></p>
<p>Open since 2007, Carolina Ziplines Canopy Tour offers a unique day of outdoor recreation sailing through the sky. It was the first zipline business to open in North Carolina. After multiple visits to Costa Rica, Robert and Joanna Nickell caught the vision for Carolina Ziplines Canopy Tour. Conception to completion was eight months of ducking vines, climbing large trees and hauling heavy cables through the forest. In 2010 Keith and Barbara Bollman brought with them their 12 children and 18 grandchildren to liven things up a bit.</p>
<p>Carolina Ziplines is located on a truly unique place. It was the active farm and homestead of R.J. Reynolds great-grandfather Joshua Cox (1731-1821). Joshua Cox was a trainer of the local Patriot Militia in the Revolutionary War and was instrumental in establishing freedom for North Carolina from the British. To learn more, visit https://www.carolinaziplines.com/ or call 336-972-7656 to make a reservation.</p>
<p><strong>Sauratown Mountains Scenic Byway</strong></p>
<p>The Sauratown Mountains Scenic Byway bends for 82 miles through the gently rolling rural landscapes that surround the ancient Sauratown Mountains. Sometimes referred to as &ldquo;the mountains away from the mountains,&rdquo; the Sauratowns are an isolated range with peaks that rise abruptly above the surrounding Piedmont to over 2,500 feet.</p>
<p>The route, which takes about two hours to drive, basically links Hanging Rock State Park with Pilot Mountain State Park. There&rsquo;s another part that stretches along N.C. Highway 89 from Danbury to Bannertown in Surry County and a spur on into Mount Airy.</p>
<p>The Hanging Rock Scenic Byway&rsquo;s southern end is in the Mount Olive community, where Highway 66 and Denny Road intersect. Driving north, you would bear right into Flat Shoals Road and then turn left on Mountain Road. After four miles, turn left on N.C. 8/89 and continue through the town. At this point you have a choice of turning left onto Hanging Rock State Park Road and continuing back to the starting point via Moores Spring Road and Highway 66. Or keep going on N.C. Highway 89 for about 25 miles to Shelton Town community east of Mount Airy in Surry County, where the byway currently ends.</p>
<p><strong>Payne Road</strong></p>
<p>It&rsquo;s safe to say Payne Road is the only roadway in Stokes County that has its own Facebook page.</p>
<p>There are lots of stories and versions of stories, few based in fact. But who doesn&rsquo;t get excited by a scary ghost story?</p>
<p>If you grew up in the southern half of Stokes County, or Rural Hall just over the county line, you know all the stories. They don&rsquo;t need to be re-hashed here, but all involve murder, violence and creepy experiences. A quick Google search of &ldquo;Legend of Payne Road&rdquo; will give you all you care to read and more. Or visit said Facebook page.</p>
<p>No doubt if you were in high school in the area at some point you and your friends went for a drive to see what was what.</p>
<p>The first bit of factual information is that Payne Road is actually Edwards Road. There is actually a Payne Road in the area, but it&rsquo;s not sure how this confusion originated. Perhaps the original Payne Road residents petitioned to change the name to deter adventure-seekers.</p>
<p>The only other gruesome story that is factual is that a man named Milus Frank Edwards, who owned land in a bend of Edwards road, blew himself up with a stick of dynamite in 1955. His house burned down in 1991 thanks to vandals.</p>
<p>The &ldquo;haunted bridge&rdquo; is also no more, as it was replaced by an ordinary culvert.</p>
<p><strong>Trail Dome</strong></p>
<p>The Mountains-to-Sea State Trail is a long-distance trail for hiking and backpacking, that traverses North Carolina from the Great Smoky Mountains to the Outer Banks. The trail&rsquo;s western endpoint is at Clingman&rsquo;s Dome, where it connects to the Appalachian Trail in the Great Smoky Mountains National Park. The trail stretches for 1,175 miles and is part of the State Park system.</p>
<p>In Stokes County it cuts right across the middle of the map, from Pinnacle in the west to Hanging Rock State Park. In the Hartman community it dips south, down through Walnut Cove and skirting the southwestern tip of Belews Lake. Mostly the trail follows the roadways of Stokes County, with a few exceptions where it is a hiking trail, from Volunteer around the Col. Jack Martin Rock House to Torys Den. Then there&rsquo;s another trail loop around to N.C. Highway 66.</p>
<p>For more information, visit https://mountainstoseatrail.org/get-involved/become-a-member/.</p>
<p><strong>Hillbilly Hideaway</strong></p>
<p>When you visit the Hillbilly Hideaway Restaurant in rural Stokes County, you will be urged to relax in a rustic atmosphere as family-sized bowls of country-style food are brought to your table. You might ask for more of the crispy fried chicken, the salty country ham or the buttery hoecake and cornbread. If it is Saturday, you can mosey on down the hill to the music hall to take in some live country music from 6-9 p.m. or over to the gift antique shop to see what goodies await your purchase.</p>
<p>The owner, Rosanna Bray Jarvis, will typically be onsite to welcome you and make sure you enjoy the Southern hospitality her restaurant is famous for. The hospitable atmosphere has not changed since Rosanna&rsquo;s parents, Sam and Louise Bray, opened the Hillbilly Hideaway in 1978. Even though Sam and Louise are gone now &#8211; she passed away in 2014 and he in 2016 &#8211; their daughter sticks to their original plan for guests. &ldquo;I want them to feel like they&rsquo;re coming to my house, like they&rsquo;re at home, like they&rsquo;re at Grandma&rsquo;s,&rdquo; Rosanna explains with her big smile. &ldquo;They can have all they want, and we&rsquo;ll keep bringing it to them.&rdquo;</p>
<p>Located at 4375 Pine Hall Road in Walnut Cove, it is open only on weekends: Friday from 4-9 p.m., Saturday from 3-9 p.m., Sunday from 8-11 a.m. for breakfast and 11 a.m. to 8 p.m. for lunch and dinner. Reservations for groups of 15 or more are available but not required. The biggest day of their year is Mother&rsquo;s Day, but Rosanna notes that on normal weekends, there is little to no wait before guests are seated.</p>
<p><strong>Hanging Rock</strong></p>
<p>Hanging Rock State Park&rsquo;s total visitation for 2021 was a whopping 900,702, breaking the record set the year before, which was 867,911 guests. Hanging Rock &ldquo;ticks all the boxes&rdquo; among all the amenities that one might want a state park to offer. Constructed in the 1930s by the Civilian Conservation Corps, Hanging Rock covers 9,011-acres and offers sheer cliffs and peaks of bare rock, quiet forests and cascading waterfalls, with views of the Piedmont that stretch for miles.</p>
<p>More than 20 miles of trails are available in the park. In addition to those that lead to Hanging Rock itself, other trails in the park lead to other peaks and rock walls with spectacular views. Two picnic areas are available for lunch before the trail or grilling afterward; there are 60 tables total. One is at the main Hanging Rock trailhead and the other is near the 12-acre lake with boathouse and swimming area. Rowboats and canoes are for rent during the summer (private boats are not allowed), plus there are 15 miles of biking trails, camping and cabins for rent. The main park website is https://www.ncparks.gov/hanging-rock-state-park/home.</p>
<p><strong>Great Wagon Road</strong></p>
<p>The Great Wagon Road was the main North-South artery, and was the main route of transportation from North to South into the Blue Ridge area of the Piedmont for settlers. This road is thought to have touched far southeast Patrick County in Virginia where Patrick and Henry counties come together along the North Mayo River. The Great Wagon Road came into North Carolina at Stokes County, forded the Dan River at Upper Sauratown at Walnut Cove and then continued to Wachovia in what was then Forsyth County which later became Bethabara.</p>
<p>You can roughly follow the path of the Great Wagon Road in modern Stokes County: in the north, Amostown Road to Sandy Ridge, then N.C. Highway 704 to Highway 772. At present-day Dodgetown, there was a fork in the path. Some wagons branched southwest here to ford the Dan River, possibly following Dodgetown Road past Dillard Road, then down Glidewell Lane to a ford and then over Bumpy Hollow Road and Stewart Road to N.C 89 to reach Meadows, Danbury, or Walnut Cove. Wagons also could follow Dodgetown Road and NC-1698 (Davis Chapel Church Road), crossing Davis ford (now a bridge) to reach Meadows, Danbury, or Walnut Cove.</p>
<p>It is possible that the original Moravian settlers forded the Dan River here in 1753 and then traveled south to present-day Walnut Cove, but this road doesn&rsquo;t appear on the Wachovia map of 1767. On the Wachovia maps of 1770 and 1771 it runs directly from Salem to the Dan River ford here, crossing Town Creek at Walnut Cove.</p>
<p>Continuing south on Highway 772 to short distances on Hickory Fork Road, Willard Road, Saura Farm Road, Tuttle Road to U.S. 311 at Oldtown Road. Then Brook Cove Road to N.C. Highway 8 through Germanton to the junction with N.C. 65.</p>
<p><strong>Foothills Farm Festival</strong></p>
<p>A newcomer among Stokes County&rsquo;s many outdoor events, the Foothills Farm Festival is held on the Knight&rsquo;s farm in Lawsonville in early October and features old-time farm equipment. &ldquo;The Festival is our family&rsquo;s way of preserving Stoke County&rsquo;s rural agriculture heritage for generations to come,&rdquo; said Robert Knight. &ldquo;We demonstrate local farming techniques from years ago as well as modern-day agriculture. The event allows children and adults to have a hands-on learning experience that they will never forget.&rdquo;</p>
<p><strong>Farm Fest Along the Sunflower Trail</strong></p>
<p>Held in September, the trail starts in Francisco and meanders across the northern part of Stokes County. Marked with sunflower signs, the trail provides a look back at farm life and equipment from the &ldquo;good ol&rsquo; days&rdquo; as well as state-of-the-art agricultural practices, arts and crafts, baked goods, yard sales, and craft beer. It includes local businesses such as Midsummer Brewing, the Big Creek Lodge at Luna&rsquo;s Trail Farm, and the Kordick Family Farm.</p>
<p><strong>KingFest</strong></p>
<p>Each October, King&rsquo;s Central Park comes alive with its annual KingFest. The event, hosted by the King Chamber of Commerce, celebrated its 30th year in 2019. Music, food, crafts, demonstrations, animals and games line both sides of the park. KingFest offers two stages of music as well as many arts and craft vendors and kids&rsquo; activities. Music for the day ranges from local rock and bluegrass favorites to old-time gospel music. The festival also has its own traveling train, the KingFest Express.</p>
<p><strong>Stokes Stomp</strong></p>
<p>For more than four decades the annual Stokes Stomp Festival on the Dan has kicked off the fall in Danbury&rsquo;s Moratock Park. Locals and visitors from surrounding counties flock to the event held on the banks of the Dan River to enjoy music, dance talent, local marching bands, games, crafts and food. The festival brings big crowds to the park every year and offers two stages of bluegrass and folk music. The fun kicks off with a parade through downtown Danbury and ends at the park. Organized each year by the Stokes County Arts Council, the festival also offers artisans from throughout the region a chance to display and sell their work.</p>
<p><strong>Reach the Peaks</strong></p>
<p>Reach the Peaks sees hundreds participate in the annual event, which is considered the premier single-day hiking challenge in the state. Reach the Peaks offers a strenuous 10 mile trail route testing participants to summit the five major peaks of Hanging Rock State Park, including Moore&rsquo;s Knob, House Rock, Cook&rsquo;s Wall, Wolf Rock and Hanging Rock. (There&rsquo;s also a 5-mile option that summits Moore&rsquo;s Knob.) Reach the Peaks has grown its participation base to expand beyond the county because of its challenge.</p>
<p><strong>Soup in a Bowl</strong></p>
<p>Stokes County Arts Council shows off its best attributes of culinary, visual, performance and volunteerism each November at the annual Stokes Soup in a Bowl at Hanging Rock State Park. For $25 per person, attendees choose their own handcrafted soup bowl, soup, beverage and dessert, with all proceeds benefiting the food ministries of East Stokes Outreach, King Outreach and Northern Stokes Food Pantry.</p>
<p><strong>Meet Me on Main</strong></p>
<p>Another King Chamber-sponsored event, Meet Me on Main is a spring Saturday celebration where the streets are closed off and vendors, kids activities and musicians take over the downtown area. &ldquo;We are showcasing our membership and then also invite other vendors to come and set up as well,&rdquo; King Chamber&rsquo;s Cathy Loveday said. &ldquo;The event also promotes the downtown businesses, many of whom stay open into the evening.&rdquo; This year&rsquo;s event added a 5K downtown run.</p>
<p><strong>Polar Plunge</strong></p>
<p>This growing event features hundreds of costume-clad thrill seekers to brave the cold waters of Hanging Rock Lake on New Year&rsquo;s Day. And that group always draws a big crowd on onlookers. Arts Council Director Eddy McGee has also been a participant every year. &ldquo;It&rsquo;s awesome and exhilarating,&rdquo; he said. &ldquo;The build up to it, the anticipation was really something. When we were standing on the beach counting down I remember thinking to myself &lsquo;I am fixing to run into this lake.&rsquo; It was great to be in the moment and then the next thing you know your feet are moving and you are running into the lake and then just.. cold. It is hard to describe.For me it was exhilarating, refreshing and cold, but something different. It was not nearly as bad as I had made it out to be.&rdquo;</p>
<p><strong>Stokes County Agricultural Fair</strong></p>
<p>And while not technically a festival, the American Legion&rsquo;s annual county fair in mid-September is certainly a big party, and remains on of the best county fairs in the region. The 2022 fair will be the 71th annual.</p>
<p><strong>Parades</strong></p>
<p>The parade season kicks off in September in Danbury with the annual Stokes Stomp Parade. That event winds through historic Danbury crossing the Dan River to end at Moratock Park and serves as the official kick off for the annual Stokes Stomp music festival. Then in early December King and Walnut Cove ring in the Christmas season in style with lengthy parades highlighting all of the area businesses and community organizations. Both of those parades are run by the local Masons and provide the entertainment and, for the kids, tons of candy.</p>
<p><strong>Stokes Arts Council</strong></p>
<p>Nestled in the small town of Danbury is a big-time art house. The Stokes Arts Council offers many of the creative amenities of larger cities in this quiet, out-of-the way rural community. The council offers a place for artists to work, show off their art through gallery shows, is home to the Three Sisters stage where plays, musicals and concerts are put on, and so much more. A quick drive to Danbury can give you an opportunity to enjoy all of this.</p>
<p><strong>Roads</strong></p>
<p>That might sound a little generic, but sometimes an attraction can be a simply, winding country road. Or a whole network of them. That is what you can find in Stokes County, where most of the highways and lands are narrow and winding and simply fun to drive. There are not many sections of straight roadway in Stokes County.</p>
<p>If you&rsquo;re looking for a fun Sunday afternoon drive, or a sojourn into the country to get away from city life for a bit, then just drive the country lanes of Stokes. Along the way you&rsquo;ll see the freshly plowed fields in the spring, the wet grass from summer showers, the hay bales during the harvest; ridges and mountains covered in lush green throughout spring and summer, then bursting with color in the autumn; and more. .</p>
<p><strong>The Dan River</strong></p>
<p>The winding Dan River offers a variety of outdoor activities to visitors of Stokes County ranging from excellent fishing to tubing, kayaking and canoeing possibilities. It winds more than 50 miles through Stokes County offering visitors and locals alike an abundance of options. &ldquo;The Dan,&rdquo; said professional fishing guide Kyle Hoover, &ldquo;is clear and clean from one end of Stokes County to the other. You can catch fine fish anywhere.&rdquo; Popular fish found in the Dan include Trout, Redbreast Sunfish, Largemouth and Smallmouth Bass, Bluegill and Suckers.</p>
<p>And while the river is a paradise for fishermen seeking pristine mountain waters, it is also big draw for those hoping to just spend a lazy day floating on the water. A number of local business in Danbury offer tubing trips down the Dan providing a tube and shuttle service to return you to your car after a relaxing afternoon. Tubing season runs from late-May through Labor Day weekend. Rental of a tube and access to shuttle services cost about $10 and the average float lasts for about two hours.</p>
<p>For the more adventurous types a couple of businesses, like the Dan River Company, also provide kayak and canoe rentals. Rapids on the river are gentle (Class 1 and below), so you can run the shallow white water for thrills without spills.</p>
<p>Check the river conditions by checking both the weather forecast for Zip Code 27046 as well as the volume of flow as reported by a USGS gaging station at the Highway 704 bridge near Francisco (http://waterdata.usgs.gov/nwis/uv?02068500).</p>
</article>

</div></div></ul><div class="alm-paging">Pages: <span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593">1</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/2">2</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/3">3</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/4">4</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/5">5</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/6">6</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/7">7</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/8">8</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/9">9</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/10">10</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/11">11</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/12">12</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/13">13</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/14">14</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/15">15</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/16">16</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/17">17</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/18">18</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/19">19</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/20">20</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/21">21</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/22">22</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/23">23</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/24">24</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/25">25</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/26">26</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/27">27</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/28">28</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/29">29</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/30">30</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/31">31</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/32">32</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/33">33</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/34">34</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/35">35</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/36">36</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/37">37</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/38">38</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/39">39</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/40">40</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/41">41</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/42">42</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/43">43</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/44">44</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/45">45</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/46">46</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/47">47</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/48">48</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/49">49</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/50">50</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/51">51</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/52">52</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/53">53</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/54">54</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/55">55</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/56">56</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/57">57</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/58">58</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/59">59</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/60">60</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/61">61</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/62">62</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/63">63</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/64">64</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/65">65</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/66">66</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/67">67</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/68">68</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/69">69</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/70">70</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/71">71</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/72">72</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/73">73</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/74">74</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/75">75</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/76">76</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/77">77</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/78">78</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/79">79</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/80">80</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/81">81</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/82">82</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/83">83</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/84">84</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/85">85</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/86">86</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/87">87</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/88">88</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/89">89</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/90">90</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/91">91</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/92">92</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/93">93</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/94">94</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/95">95</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/96">96</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/97">97</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/98">98</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/99">99</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/100">100</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/101">101</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/102">102</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/103">103</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/104">104</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/105">105</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/106">106</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/107">107</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/108">108</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/109">109</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/110">110</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/111">111</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/112">112</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/113">113</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/114">114</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/115">115</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/116">116</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/117">117</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/118">118</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/119">119</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/120">120</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/121">121</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/122">122</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/123">123</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/124">124</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/125">125</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/126">126</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/127">127</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/128">128</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/129">129</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/130">130</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/131">131</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/132">132</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/133">133</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/134">134</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/135">135</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/136">136</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/137">137</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/138">138</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/139">139</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/140">140</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/141">141</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/142">142</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/143">143</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/144">144</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/145">145</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/146">146</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/147">147</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/148">148</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/149">149</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/150">150</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/151">151</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/152">152</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/153">153</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/154">154</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/155">155</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/156">156</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/157">157</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/158">158</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/159">159</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/160">160</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/161">161</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/162">162</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/163">163</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/164">164</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/165">165</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/166">166</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/167">167</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/168">168</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/169">169</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/170">170</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/171">171</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/172">172</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/173">173</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/174">174</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/175">175</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/176">176</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/177">177</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/178">178</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/179">179</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/180">180</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/181">181</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/182">182</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/183">183</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/184">184</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/185">185</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/186">186</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/187">187</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/188">188</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/189">189</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/190">190</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/191">191</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/192">192</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/193">193</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/194">194</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/195">195</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/196">196</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/197">197</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/198">198</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/199">199</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/200">200</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/201">201</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/202">202</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/203">203</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/204">204</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/205">205</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/206">206</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/207">207</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/208">208</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/209">209</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/210">210</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/211">211</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/212">212</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/213">213</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/214">214</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/215">215</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/216">216</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/217">217</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/218">218</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/219">219</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/220">220</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/221">221</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/222">222</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/223">223</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/224">224</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/225">225</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/226">226</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/227">227</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/228">228</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/229">229</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/230">230</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/231">231</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/232">232</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/233">233</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/234">234</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/235">235</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/236">236</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/237">237</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/238">238</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/239">239</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/240">240</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/241">241</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/242">242</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/243">243</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/244">244</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/245">245</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/246">246</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/247">247</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/248">248</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/249">249</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/250">250</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/251">251</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/252">252</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/253">253</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/254">254</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/255">255</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/256">256</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/257">257</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/258">258</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/259">259</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/260">260</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/261">261</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/262">262</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/263">263</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/264">264</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/265">265</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/266">266</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/267">267</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/268">268</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/269">269</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/270">270</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/271">271</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/272">272</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/273">273</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/274">274</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/275">275</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/276">276</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/277">277</a></span><span class="page"><a href="https://www.mtairynews.com/news/111473/police-reports-593/page/278">278</a></span></div></noscript><div class="alm-btn-wrap" style="visibility: hidden;"><button class="alm-load-more-btn more " rel="next" type="button">Next Article</button></div></div>	
		</div>

		 		<aside class="mh-widget-col-1 mh-sidebar" itemscope="itemscope" itemtype="http://schema.org/WPSideBar"><div id="custom_html-13" class="widget_text mh-widget widget_custom_html"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Weather</span></h4><div class="textwidget custom-html-widget"><div style="width: 300px;"><iframe style="display: block;" src="https://cdnres.willyweather.com/widget/loadView.html?id=100630" width="300" height="228" frameborder="0" scrolling="no"></iframe><a style="height: 20px;position: relative;margin: -20px 0 0 0;text-indent: -9999em;display: block;z-index: 1" href="https://mtairynews.com/weather" rel="nofollow">mount airy weekly forecast</a></div>

<ins data-revive-zoneid="10" data-revive-id="7704ed944ed7863d36a61d5fccf7693e"></ins>
</div></div><div id="custom_html-31" class="widget_text mh-widget widget_custom_html"><div class="textwidget custom-html-widget"><p>
<ins data-revive-zoneid="123" data-revive-id="7704ed944ed7863d36a61d5fccf7693e"></ins>

</p><p>
<ins data-revive-zoneid="124" data-revive-id="7704ed944ed7863d36a61d5fccf7693e"></ins>

</p><p>
<ins data-revive-zoneid="125" data-revive-id="7704ed944ed7863d36a61d5fccf7693e"></ins>

</p><p>
<ins data-revive-zoneid="126" data-revive-id="7704ed944ed7863d36a61d5fccf7693e"></ins>

</p></div></div><div id="custom_html-2" class="widget_text mh-widget widget_custom_html"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Advertisement</span></h4><div class="textwidget custom-html-widget"><!---<ins data-revive-zoneid="1" data-revive-id="7704ed944ed7863d36a61d5fccf7693e"></ins>--->
</div></div><div id="custom_html-39" class="widget_text mh-widget widget_custom_html"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Video</span></h4><div class="textwidget custom-html-widget"><ins data-revive-zoneid="152" data-revive-id="7704ed944ed7863d36a61d5fccf7693e"></ins>
<script async src="//adamsads.midtc.com/www/delivery/asyncjs.php"></script></div></div><div id="custom_html-4" class="widget_text mh-widget widget_custom_html"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Advertisement</span></h4><div class="textwidget custom-html-widget"><!---<ins data-revive-zoneid="2" data-revive-id="7704ed944ed7863d36a61d5fccf7693e"></ins>--->
</div></div><div id="custom_html-15" class="widget_text mh-widget widget_custom_html"><div class="textwidget custom-html-widget"><ins data-revive-zoneid="97" data-revive-id="7704ed944ed7863d36a61d5fccf7693e"></ins>
</div></div><div id="custom_html-17" class="widget_text mh-widget widget_custom_html"><div class="textwidget custom-html-widget"><ins data-revive-zoneid="112" data-revive-id="7704ed944ed7863d36a61d5fccf7693e"></ins>
</div></div><div id="custom_html-6" class="widget_text mh-widget widget_custom_html"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Advertisement</span></h4><div class="textwidget custom-html-widget"><!---<ins data-revive-zoneid="3" data-revive-id="7704ed944ed7863d36a61d5fccf7693e"></ins>--->
</div></div><div id="custom_html-24" class="widget_text mh-widget widget_custom_html"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Poll</span></h4><div class="textwidget custom-html-widget"><script type="text/javascript" src="https://www.civicscience.com/widget/jspoll/?elt=130efe3f-8872-9e24-3d0a-f08413db6479&amp;tgtid=0ea95aa6-abf0-e1a4-91f4-4a6b1d2e6b5e"></script>
<div id="130efe3f-8872-9e24-3d0a-f08413db6479"></div></div></div><div id="custom_html-40" class="widget_text mh-widget widget_custom_html"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Recipe of the Day</span></h4><div class="textwidget custom-html-widget"><!-- APG TN/NC/VA; Recipe Of The Day -->

<div id="ahm-rotd" class="ahm-rotd" style="display: inline-block; vertical-align: top;max-width:365px;width: calc( 100% - 310px ); min-width: 300px;"></div><div style="display: inline-block; margin: 0 auto; width: calc(100% - 375px); min-width: 300px;"><div style="margin: 0 auto; vertical-align: top;height: 250px; width: 300px; background: #666;width: 300px; min-height: 50px;" id="_snup-rtdx-ldgr1"></div></div>

<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':

new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],

j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=

'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);

})(window,document,'script','dataLayer','GTM-ML7VZQM');</script>
</div></div><div id="custom_html-8" class="widget_text mh-widget widget_custom_html"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Advertisement</span></h4><div class="textwidget custom-html-widget"><!---<ins data-revive-zoneid="4" data-revive-id="7704ed944ed7863d36a61d5fccf7693e"></ins>---></div></div>	</aside>

	</div>
    </div>
<footer class="mh-footer" itemscope="itemscope" itemtype="http://schema.org/WPFooter">
<div class="mh-container mh-container-inner mh-footer-widgets mh-row clearfix">
<div class="mh-col-1-2 mh-widget-col-2 mh-footer-2-cols  mh-footer-area mh-footer-1">
<div id="media_image-2" class="mh-footer-widget widget_media_image"><a href="https://mtairynews.com"><img width="300" height="29" src="https://s24476.pcdn.co/wp-content/uploads/2018/09/mtairynews-300x29.png" class="image wp-image-65276  attachment-medium size-medium" alt="" style="max-width: 100%; height: auto;" srcset="https://s24476.pcdn.co/wp-content/uploads/2018/09/mtairynews-300x29.png 300w, https://s24476.pcdn.co/wp-content/uploads/2018/09/mtairynews.png 374w" sizes="(max-width: 300px) 100vw, 300px" /></a></div></div>
<div class="mh-col-1-2 mh-widget-col-2 mh-footer-2-cols  mh-footer-area mh-footer-4">
<div id="custom_html-27" class="widget_text mh-footer-widget widget_custom_html"><h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner">Contact</span></h6><div class="textwidget custom-html-widget"><b>Phone:</b><br>
336-786-4141<br>
<b>Fax:</b><br>
336-789-2816<br>
<b>Address:</b><br>
319 N. Renfro Street,<br> 
Mount Airy NC, 27030</div></div><div id="custom_html-36" class="widget_text mh-footer-widget widget_custom_html"><div class="textwidget custom-html-widget"><script src="//adamsads.midtc.com/www/delivery/asyncjs.php"></script></div></div></div>
</div>
</footer>
	<div class="mh-footer-nav-mobile"></div>
	<nav class="mh-navigation mh-footer-nav" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
		<div class="mh-container mh-container-inner clearfix">
			<div class="menu-footer-container"><ul id="menu-footer" class="menu"><li id="menu-item-77700" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-77700"><a href="https://www.mtairynews.com/terms-of-use">Terms Of Use</a></li>
<li id="menu-item-87777" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87777"><a href="https://www.mtairynews.com/cookie-policy-us">Cookie Policy (US)</a></li>
<li id="menu-item-87778" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-87778"><a href="https://www.mtairynews.com/privacy-statement-us">Privacy statement (US)</a></li>
<li id="menu-item-87779" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87779"><a href="https://www.mtairynews.com/disclaimer">Disclaimer</a></li>
</ul></div>		</div>
	</nav>
<div class="mh-copyright-wrap">
	<div class="mh-container mh-container-inner clearfix">
		<p class="mh-copyright">
			&copy; 2018 The Mount Airy News		</p>
	</div>
</div>
<a href="#" class="mh-back-to-top"><i class="fa fa-chevron-up"></i></a>
</div><!-- .mh-container-outer -->
<!-- Google Tag Manager -->
	<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
	new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
	j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
	'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
	})(window,document,'script','dataLayer','GTM-WCB7NXP');</script>
	<!-- End Google Tag Manager --><script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"mtairynews"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s24476.pcdn.co/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.22'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.22"},"disqusIdentifier":"111473 https:\/\/www.mtairynews.com\/news\/111473\/police-reports-593","disqusShortname":"mtairynews","disqusTitle":"Police reports","disqusUrl":"https:\/\/www.mtairynews.com\/news\/111473\/police-reports-593","postId":"111473"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s24476.pcdn.co/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.22'></script>
<script type='text/javascript' src='https://s24476.pcdn.co/wp-includes/js/comment-reply.min.js?ver=5.3.12'></script>
<script type='text/javascript' src='https://s24476.pcdn.co/wp-includes/js/hoverIntent.min.js?ver=1.8.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var megamenu = {"timeout":"300","interval":"100"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s24476.pcdn.co/wp-content/plugins/megamenu/js/maxmegamenu.js?ver=2.9.7'></script>
<script type='text/javascript' src='https://s24476.pcdn.co/wp-includes/js/wp-embed.min.js?ver=5.3.12'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var alm_localize = {"ajaxurl":"https:\/\/www.mtairynews.com\/wp-admin\/admin-ajax.php","alm_nonce":"5355f6c1aa","rest_api":"https:\/\/www.mtairynews.com\/wp-json\/","rest_nonce":"0fe7ef5ff4","pluginurl":"https:\/\/www.mtairynews.com\/wp-content\/plugins\/ajax-load-more","speed":"200","ga_debug":"false","results_text":"Viewing {post_count} of {total_posts} results.","no_results_text":"No results found.","alm_debug":"","a11y_focus":"1","site_title":"Mt. Airy News","site_tagline":"Mount Airy News, Obituaries, Classifieds, and Sports"};
var ajax_load_more_vars = {"id":"ajax-load-more"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s24476.pcdn.co/wp-content/plugins/ajax-load-more/core/dist/js/ajax-load-more.min.js?ver=5.5.3'></script>
<script type='text/javascript' src='https://s24476.pcdn.co/wp-content/plugins/ajax-load-more-seo/js/alm-seo.min.js?ver=1.9.3'></script>
</body>
</html>